Perte de la passerelle

Le
Sylvain Sauvage
’jour,

Sur une Sarge presque passée en Etch (elle a conservé son
noyau 2.4.27 pour cause de matériel récalcitrant), connectée
à une Livebox, la route default / la gateway / la passerelle
disparaît (je n’ai pas réussi à déterminer quan=
d, je suis à
350 km de là…).
Ça arrive que l’on soit en dhcp ou en static.

Une idée de ce qui pourrait se passer ?

(Très peu de logiciels installés, c’est un routeurÂ=
 : dnsmasq,
clamav, squid, squidguard, p3scan, clamsmtp, un ssh (pas en 22)…
Je ne vois pas trop lequel pourrait intervenir.)

--
Sylvain Sauvage
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Serge Cavailles
Le #9683841
Le lundi 21 avril 2008 17:37, Sylvain Sauvage a écrit :
’jour,


'lut,


Sur une Sarge presque passée en Etch (elle a conservé son
noyau 2.4.27 pour cause de matériel récalcitrant), connectà ©e
à une Livebox, la route default / la gateway / la passerelle
disparaît (je n’ai pas réussi à déterminer qu and, je suis à
350 km de là…).
Ça arrive que l’on soit en dhcp ou en static.

Une idée de ce qui pourrait se passer ?



L'activation/désactivation des interfaces modifie généraleme nt la table de
routage. Un interface ppp ou wlan qui s'active/désactive?

2 cts
--
Serge



(Très peu de logiciels installés, c’est un routeur  : dnsmasq,
clamav, squid, squidguard, p3scan, clamsmtp, un ssh (pas en 22)…
Je ne vois pas trop lequel pourrait intervenir.)


Sylvain Sauvage
Le #9683821
Serge Cavailles, lundi 21 avril 2008, 18:51:52 CEST

Le lundi 21 avril 2008 17:37, Sylvain Sauvage a écrit :
> ’jour,
'lut,

>
> Sur une Sarge presque passée en Etch (elle a conservé son
> noyau 2.4.27 pour cause de matériel récalcitrant), connectà ©e
> à une Livebox, la route default / la gateway / la passerelle
> disparaît (je n’ai pas réussi à déterminer quand, je suis à
> 350 km de là…).
> Ça arrive que l’on soit en dhcp ou en static.
>
> Une idée de ce qui pourrait se passer ?

L'activation/désactivation des interfaces modifie générale ment la table de
routage. Un interface ppp ou wlan qui s'active/désactive?



La machine a 4 cartes ethernet, 3 en static (c’est elle le
routeur), et une pour la Livebox (en dhcp ou en static, j’ai
testé les deux). La Livebox n’est là que depuis 8 jours  ; avant,
c’était un Speedtouch en pppoe mais j’ai purgé/co mmenté toutes
les références au ppp.
Tout ça est un peu vieux pour ma mémoire défaillante, mais
j’ai revérifié :
— pas de script spécial ppp dans init.d ;
— le ppp est^W était géré comme les autres interfa ces dans le
fichier /etc/network/interfaces :
#auto dsl-provider
#iface dsl-provider inet ppp
# provider dsl-provider
# please do not modify the following line
# pre-up /sbin/ifconfig eth2 up # line maintained by pppoeconf

J’ai oublié un truc ?

2 cts



Purée, c’est cher !
On m’avait dit « GNU/Linux, c’est gratuit.  Â» :o)

--
Sylvain Sauvage
Serge Cavailles
Le #9683791
Le lundi 21 avril 2008 19:41, Sylvain Sauvage a écrit :
Serge Cavailles, lundi 21 avril 2008, 18:51:52 CEST
> L'activation/désactivation des interfaces modifie généra lement la table
> de routage. Un interface ppp ou wlan qui s'active/désactive?

La machine a 4 cartes ethernet, 3 en static (c’est elle le
routeur), et une pour la Livebox (en dhcp ou en static, j’ai
testé les deux). La Livebox n’est là que depuis 8 jours  ; avant,
c’était un Speedtouch en pppoe mais j’ai purgé/ commenté toutes
les références au ppp.



J'en déduis que tu es passé du modem en bridge à la LB en ro uteur...

Tout ça est un peu vieux pour ma mémoire défaillante, ma is
j’ai revérifié :
— pas de script spécial ppp dans init.d ;



... et donc que tu pourrais supprimer les paquets ppp, pppoe et pppoeconf
pour laisser apt nettoyer tout ça.

— le ppp est^W était géré comme les autres inter faces dans le
fichier /etc/network/interfaces :
#auto dsl-provider
#iface dsl-provider inet ppp
# provider dsl-provider
# please do not modify the following line
# pre-up /sbin/ifconfig eth2 up # line maintained by pppoeconf

J’ai oublié un truc ?



Je ne sais pas :P

Comment/ou est déclarée la passerelle pour l'interface vers la LB (eth2 ?)
Pas de traces de down/up d'interfaces dans le syslog?
Quelles autres routes déclarées sur cette machine?


> 2 cts

Purée, c’est cher !
On m’avait dit « GNU/Linux, c’est gratuit.  Â» :o)



Voui, mais pas le "support" :D
Sylvain Sauvage
Le #9683771
Serge Cavailles, lundi 21 avril 2008, 20:43:58 CEST

Le lundi 21 avril 2008 19:41, Sylvain Sauvage a écrit :
> Serge Cavailles, lundi 21 avril 2008, 18:51:52 CEST
> > L'activation/désactivation des interfaces modifie géné ralement la table
> > de routage. Un interface ppp ou wlan qui s'active/désactive?
>
> La machine a 4 cartes ethernet, 3 en static (c’est elle le
> routeur), et une pour la Livebox (en dhcp ou en static, j’ai
> testé les deux). La Livebox n’est là que depuis 8 jou rs ; avant,
> c’était un Speedtouch en pppoe mais j’ai purgà ©/commenté toutes
> les références au ppp.

J'en déduis que tu es passé du modem en bridge à la LB en routeur...



Yep. Je l’ai faite courte.

> Tout ça est un peu vieux pour ma mémoire défaillante, mais
> j’ai revérifié :
> — pas de script spécial ppp dans init.d ;

... et donc que tu pourrais supprimer les paquets ppp, pppoe et pppoeconf
pour laisser apt nettoyer tout ça.



Ben, en fait, si ça continue (et ça semble continuer) on va
sûrement repasser au modem qui marche et virer la Livebox qui
foire. Donc je gardais tout ça sous le coude (J’ai appris à  
conserver en commentaire les anciennes configurations qui
marchent :o)

Pour la faire plus longue, j’ai d’autres pépins avec cette
s#@$! de Livebox :
— le routeur m’envoie un courriel à chaque reconnexion (dans le
if-up.d du ppp avant, un test toutes les 5 min maintenant)
pour me permettre le ssh ;
— depuis la Livebox : ça fonctionnait après redà ©marrage de la LB
mais le ssh est impossible après qu’elle s’est recon nectée (et
elle se reconnecte souvent la nuit (entre 5 et 20 fois !)) ;
— un reboot de la LB et ça repartait ;
— ce matin, le reboot n’a rien fait, et, par télé phone et
unitapiste¹ interposé, j’ai vu que la gateway avait dis paru.
D’où passage en IP statique, avec re-perte de la gw.

¹ unitapiste : personne qui tape avec un seul doigt, l’au tre
index faisant partie de la main qui tient le téléphone…

Là (21h20), j’ai reçu un courriel du routeur pour me fa ire
part du changement d’IP de la LB. Et impossible de ssh-iser…
Rectification (22h01, je tape pas vite :o>), j’ai reçu
plusieurs courriels (4) et la dernière adresse fonctionne…

Mais tous les pépins ne sont pas dus qu’à la gw, pour d eux
raisons :
1. si la gw tombe, pas de courriel sortant possible puisque
plus de route vers l’extérieur, or j’ai des courriel s et le
ssh qui ne fonctionne plus (en général, parce que le dernier
en date fonctionne) ;
2. pour « voir », j’ai fait le sauvage (normal :o) et j’ai mis
une tâche cron "route add default gw 192.168.9.1" toutes les
5 min. Non mais :oP

Mais bon, même en étant toute pourrie, je ne vois pas comment
la LB pourrait enlever la passerelle de mon routeur. D’où le f ait
que je l’ai faite courte dans le premier message : la LB ne
devrait pas intervenir dans l’équation pour ce problème l à.

> — le ppp est^W était géré comme les autres int erfaces dans le
> fichier /etc/network/interfaces :
> #auto dsl-provider
> #iface dsl-provider inet ppp
> # provider dsl-provider
> # please do not modify the following line
> # pre-up /sbin/ifconfig eth2 up # line maintained by pppoeconf
>
> J’ai oublié un truc ?

Je ne sais pas :P

Comment/ou est déclarée la passerelle pour l'interface vers la LB (eth2 ?)



Cette semaine : dhcp. À partir de cet après-midi : st atic.

Pas de traces de down/up d'interfaces dans le syslog?



Non. Rien.
Je n’ai pas ifplugd ou un truc du genre, donc le fait de
débrancher-rebrancher un câble c’est multi-spire : ça ne
réveille pas le noyau…

Quelles autres routes déclarées sur cette machine?



Juste celles des quatre cartes/réseaux :

Table de routage IP du noyau
Destination Passerelle Genmask Indic Metric Ref Use Ifa ce
192.168.2.0 0.0.0.0 255.255.255.0 U 0 0 0 eth3
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
192.168.9.0 0.0.0.0 255.255.255.0 U 0 0 0 eth2
0.0.0.0 192.168.9.1 0.0.0.0 UG 0 0 0 eth2

(J’ai mis la LB en 192.168.9.0 parce j’avais déjà   pris le .1.0
et que toutes les règles iptables sont faites avec .[0123].0, ça
faisait moins de changements à faire.)

Fichier interfaces :

# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.1.254
netmask 255.255.255.0

auto eth1
iface eth1 inet static
address 192.168.0.254
netmask 255.255.255.0

auto eth2
iface eth2 inet static
address 192.168.9.99
netmask 255.255.255.0
gateway 191.168.9.1
dns-nameservers 80.10.246.2 80.10.246.129

auto eth3
iface eth3 inet static
address 192.168.2.254
netmask 255.255.255.0

La Livebox est sur eth2. Chaque autre eth a son sous-réseau.

Pour tout dire, c’est un réseau pour une école (chouett e,
profitons des vacances pour que ça foire), avec un sous-réseau
pour l’école, un pour le secrétariat de la mairie, un pou r le
secrétariat du syndicat des écoles. Le routeur fait « c ontrôle
parental » et scan de virus smtp et pop3 en proxy transparent
(#!$ d’utilisateurs qui ne mettent pas à jour leurs anti-virus ).
C’est du bricolage (PC de récup) qui a tenu 3 ans sans pà ©pin.

Bon, le routeur va bientôt être remplacé par un WRT54GL ( ça
permettra aux instits de se la péter en wifi en restant
sécurisés) : ce n’est pas évident de maint enir un PC avec 4
cartes réseaux (faut déjà un PC de récup. qui peut les contenir,
et, non, une carte à 4 ports ethernet à 300 $ n’est pas
envisageable). On n’aura plus besoin que d’un PC avec une s eule
carte pour les filtres squidguard et clamav, plus facile à
maintenir.
Mais ça me turlupine quand même cette histoire de passerelle⠀¦

> > 2 cts
>
> Purée, c’est cher !
> On m’avait dit « GNU/Linux, c’est gratuit.  » :o)

Voui, mais pas le "support" :D



Mais il tient tout seul, sur une table d’écolier…

Merci beaucoup de ton aide, je me sens moins seul et ça donne
des pistes.

--
Sylvain Sauvage
Serge Cavailles
Le #9683751
Re,

Hmmm... pas trop d'idées :/

Le lundi 21 avril 2008 22:25, Sylvain Sauvage a écrit :

Mais tous les pépins ne sont pas dus qu’à la gw, pour deux
raisons :
1. si la gw tombe, pas de courriel sortant possible puisque
plus de route vers l’extérieur, or j’ai des courri els et le
ssh qui ne fonctionne plus (en général, parce que le dernier
en date fonctionne) ;



Des micro-coupures de secteur auxquelles la LB serait sensible?
J'entends souvent se plaindre des alims des F...box, je ne sais ce qu'il en
est des LB. (j'ai toujours un speedtouch ;) )


> Pas de traces de down/up d'interfaces dans le syslog?

Non. Rien.
Je n’ai pas ifplugd ou un truc du genre,



Moi non plus...

donc le fait de
débrancher-rebrancher un câble c’est multi-spire : ça ne
réveille pas le noyau…



... cependant, et à moins d'avoir modifié le loglevel, l'activa tion /
désactivation d'un interface eth m'a toujours donné dans le syslo g des
lignes du genre:
hatchill:~# grep eth /var/log/syslog
Apr 21 19:35:16 hatchill kernel: eth2: link up, 100Mbps, full-duplex, lpa
0x41E1
Apr 21 20:32:35 hatchill kernel: eth2: link down




[routes et fichier interfaces]
Ça m'a l'air tout bon.


Mais ça me turlupine quand même cette histoire de passerelle …



Tu peux peut-être tenter de remettre la box en bridge?


> > > 2 cts
> >
> > Purée, c’est cher !
> > On m’avait dit « GNU/Linux, c’est gratuit . » :o)
>
> Voui, mais pas le "support" :D

Mais il tient tout seul, sur une table d’écolier…



J'ai beau chercher, j'ai pas compris. :/
Mais je n'ai pas de TV, ceci expliquant peut-être cela. :)


Merci beaucoup de ton aide, je me sens moins seul et ça donne
des pistes.



2 riens :D
Tiens nous au courant si tu as du nouveau.

--
Serge
Sylvain Sauvage
Le #9683741
Serge Cavailles, mardi 22 avril 2008, 00:16:54 CEST

Re,

Hmmm... pas trop d'idées :/



Vi hein… En plus, ce n’est même pas imputable au noy au
puisqu’il n’a pas changé en 3 ans.

Le lundi 21 avril 2008 22:25, Sylvain Sauvage a écrit :
[…]
Des micro-coupures de secteur auxquelles la LB serait sensible?



Sur onduleur depuis 6 mois (car, effectivement, les
micro-coupures, c’est chianf).

> donc le fait de
> débrancher-rebrancher un câble c’est multi-spire  : ça ne
> réveille pas le noyau…

... cependant, et à moins d'avoir modifié le loglevel, l'activa tion /
désactivation d'un interface eth m'a toujours donné dans le sys log des
lignes du genre:
> hatchill:~# grep eth /var/log/syslog
> Apr 21 19:35:16 hatchill kernel: eth2: link up, 100Mbps, full-duplex, l pa
> 0x41E1
> Apr 21 20:32:35 hatchill kernel: eth2: link down



J’ai aussi ces lignes si je débranche/rebranche un câbl e. Ce
que je voulais dire avec le « multi-spire », c’ est qu’une partie
du noyau voit les déconnexions et les logue mais que l’autre
partie, en gros la pile réseau, s’en fout : l’int erface est
configurée en statique, qu’il y ait ou non un câble avec des
trucs qui passent ou pas, il continue de ronfler.
En tout cas pas de ces messages aux moments des plantages ou
des reconnexions.

> Mais ça me turlupine quand même cette histoire de passerell e…

Tu peux peut-être tenter de remettre la box en bridge?



Vu les possibilités de configuration de la Livebox (genre
pare-feu « minimum », « moyen »⠀¦, pas de bail dhcp fixe, etc.),
le Speedtouch est aussi bien et il est testé et approuvé, lui.
Ce n’était que moi et la Livebox ne serait jamais venue⠀¦

> > Voui, mais pas le "support" :D
>
> Mais il tient tout seul, sur une table d’écolier…

J'ai beau chercher, j'ai pas compris. :/
Mais je n'ai pas de TV, ceci expliquant peut-être cela. :)



Pour le « multi-spire », il faut avoir eu la tél é il y a, euh,
quoi, 20-25 ans ? (putain, on vieillit !)
Ici, c’est juste du français : « support  : n.m. truc sur
lequel on pose » et le routeur est sur une table, dans une
école… :oD

Bon, allez, dodo, on verra demain s’il tient…

--
Sylvain Sauvage
Serge Cavailles
Le #9683721
Le mardi 22 avril 2008 00:52, Sylvain Sauvage a écrit :
Serge Cavailles, mardi 22 avril 2008, 00:16:54 CEST
> Des micro-coupures de secteur auxquelles la LB serait sensible?

Sur onduleur depuis 6 mois (car, effectivement, les
micro-coupures, c’est chianf).



Bon. Si on admet que les batteries sont bonnes, ça nous fait une piste de
moins.

> lignes du genre:
> > hatchill:~# grep eth /var/log/syslog
> > Apr 21 19:35:16 hatchill kernel: eth2: link up, 100Mbps, full-duplex,
> > lpa 0x41E1
> > Apr 21 20:32:35 hatchill kernel: eth2: link down

J’ai aussi ces lignes si je débranche/rebranche un câ ble. Ce
que je voulais dire avec le « multi-spire », c†™est qu’une partie
du noyau voit les déconnexions et les logue mais que l’autre
partie, en gros la pile réseau, s’en fout : l’i nterface est
configurée en statique, qu’il y ait ou non un câble ave c des
trucs qui passent ou pas, il continue de ronfler.



Effectivement. Tu as raison.

En tout cas pas de ces messages aux moments des plantages ou
des reconnexions.



Mauvaise piste. Changer piste. ;)


> > Mais ça me turlupine quand même cette histoire de passere lle…
>
> Tu peux peut-être tenter de remettre la box en bridge?

Vu les possibilités de configuration de la Livebox (genre
pare-feu « minimum », « moyen » …, pas de bail dhcp fixe, etc.),
le Speedtouch est aussi bien et il est testé et approuvé, lui.



Je crois avoir compris que le speedtouch avant était en bridge.
Passer la box en bridge est le meilleur moyen de s'affranchir de ses
limitations puisque c'est le PC derrière qui assure dans ce cas la lia ison
pppoe. Pas d'IP à attribuer à la box, et filtrage + NAT à ef fectuer sur le
PC qui se retrouve avec l'IP publique.

Ceci étant, si le Speedtouch était en routeur, il y a eu comme mo dif avec la
LB uniquement le passage en IP statique, et encore, pour essais suite à  
l'apparition du problème. Ce qui tendrait [aussi] à mettre en cau se la box.

Ce n’était que moi et la Livebox ne serait jamais venue⠀¦


Mauvais box. Virer box. Mais dans l'esprit de beaucoup de gens, la box c'es t
mieux. Alors faut souvent faire avec.


> > > Voui, mais pas le "support" :D
> >
> > Mais il tient tout seul, sur une table d’écolier†¦
>
> J'ai beau chercher, j'ai pas compris. :/
> Mais je n'ai pas de TV, ceci expliquant peut-être cela. :)

Pour le « multi-spire », il faut avoir eu la tà ©lé il y a, euh,
quoi, 20-25 ans ? (putain, on vieillit !)



Oui - m'en souviens. On pouvait faire sa nuit sans réveiller l'autre. :D

Ici, c’est juste du français : « support  : n.m. truc sur
lequel on pose » et le routeur est sur une table, dans une
école… :oD



Pfff... suis c...

Bon, allez, dodo, on verra demain s’il tient…



yes
@+
--
Serge
Yves Rutschle
Le #9683711
On Mon, Apr 21, 2008 at 10:25:43PM +0200, Sylvain Sauvage wrote:
La Livebox est sur eth2. Chaque autre eth a son sous-réseau.



Quel type de carte réseau et quel driver?

Y.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
pascatgm
Le #9683701
Serge Cavailles a écrit :
Le mardi 22 avril 2008 00:52, Sylvain Sauvage a écrit :

Serge Cavailles, mardi 22 avril 2008, 00:16:54 CEST

Des micro-coupures de secteur auxquelles la LB serait sensible?



Sur onduleur depuis 6 mois (car, effectivement, les
micro-coupures, c’est chianf).




Bon. Si on admet que les batteries sont bonnes, ça nous fait une piste de
moins.


lignes du genre:

hatchill:~# grep eth /var/log/syslog
Apr 21 19:35:16 hatchill kernel: eth2: link up, 100Mbps, full-duplex,
lpa 0x41E1
Apr 21 20:32:35 hatchill kernel: eth2: link down





J’ai aussi ces lignes si je débranche/rebranche un câble. Ce
que je voulais dire avec le « multi-spire », c’est qu’une partie
du noyau voit les déconnexions et les logue mais que l’autre
partie, en gros la pile réseau, s’en fout : l’interface est
configurée en statique, qu’il y ait ou non un câble avec des
trucs qui passent ou pas, il continue de ronfler.




Effectivement. Tu as raison.


En tout cas pas de ces messages aux moments des plantages ou
des reconnexions.




Mauvaise piste. Changer piste. ;)



Mais ça me turlupine quand même cette histoire de passerelle…









Je dis peut-être une bêtise...
Heureux possesseur d'une LB j'ai eu un problème similaire il y a quelque
temps...
Multiples déconnexions/re-connexions avec perte (aléatoire) de la
passerelle.
Après un appel hilarant à la hotline et leur réponse loufoque
("Attention nous allons procéder à la ré-initialisation de la pile
réseau de votre Windows"...Leur incompréhension totale "quoi ?....Vous
n'avez pas Windows ??..." et mon exaspération croissante) on a fini par
trouver un problème sur la ligne (chez moi---> pour ma pomme) résolu par
l'intervention d'un technicien France-Telecom^W Orange ...et quelques
dizaines d'euros...
Mes deux centimes à moi aussi...
P.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sylvain Sauvage
Le #9683681
Yves Rutschle, mardi 22 avril 2008, 07:59:43 CEST

On Mon, Apr 21, 2008 at 10:25:43PM +0200, Sylvain Sauvage wrote:
> La Livebox est sur eth2. Chaque autre eth a son sous-réseau.

Quel type de carte réseau et quel driver?



Realtek 8139C, 8139too, pour les 4. Toutes les mêmes.
Fonctionnelles depuis 3 ans.

Noyau 2.4.27-2-i386 (depuis le 30 nov. 2005), qui doit être
la dernière version Sarge avant la sortie de Etch.

--
Sylvain Sauvage
Publicité
Poster une réponse
Anonyme