perte réseau sous ubuntu 10.04 LTS

Le
bertrand
Bonjour,

Je perds ma connexion réseau régulièrement au bout d'une semaine de
fonctionnement(à peu près), sans action particulière de ma part.
j'éteins alors mon PC et au bout d'une durée variable (de quelques
heures à plusieurs jours) ça re-fonctionne (mais le plus souvent
plusieurs jours).

je suis derrière un modem/routeur, os ubuntu 10.04 LTS (et les autres PC
fonctionnent sans pb : 2 Windows en eth0 et 1 Ubuntu 12.04 en wlan, 1
PS3 wlan).

Je sèche, et un coup de main serait le bien venu pour continuer mes
recherches (voire pour trouver la cause ;).

merci par avance pour vos idées.


Pour info, quand c'est HS:


> bertrand@bertrand-ubuntu:~$ cat /etc/network/interfaces
> auto lo
> iface lo inet loopback
>

> bertrand@bertrand-ubuntu:~$ ifconfig
> eth0 Link encap:Ethernet HWaddr 90:fb:a6:49:a2:0d
> adr inet6: fe80::92fb:a6ff:fe49:a20d/64 Scope:Lien
> UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
> Packets reçus:2847 erreurs:0 :0 overruns:0 frame:0
> TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
> collisions:0 lg file transmission:1000
> Octets reçus:408293 (408.2 KB) Octets transmis:468 (468.0 B)
> Mémoire:f7dc0000-f7de0000
>
> lo Link encap:Boucle locale
> inet adr:127.0.0.1 Masque:255.0.0.0
> adr inet6: ::1/128 Scope:Hôte
> UP LOOPBACK RUNNING MTU:16436 Metric:1
> Packets reçus:5548 erreurs:0 :0 overruns:0 frame:0
> TX packets:5548 errors:0 dropped:0 overruns:0 carrier:0
> collisions:0 lg file transmission:0
> Octets reçus:818742 (818.7 KB) Octets transmis:818742 (818.7 KB)


ou

> bertrand@bertrand-ubuntu:~$ ifconfig
> eth0 Link encap:Ethernet HWaddr 90:fb:a6:49:a2:0d
> adr inet6: fe80::92fb:a6ff:fe49:a20d/64 Scope:Lien
> UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
> Packets reçus:381 erreurs:0 :0 overruns:0 frame:0
> TX packets:56 errors:0 dropped:0 overruns:0 carrier:0
> collisions:0 lg file transmission:1000
> Octets reçus:49521 (49.5 KB) Octets transmis:15370 (15.3 KB)
> Mémoire:f7dc0000-f7de0000
>
> eth0:avahi Link encap:Ethernet HWaddr 90:fb:a6:49:a2:0d
> inet adr:169.254.6.236 Bcast:169.254.255.255 Masque:255.255.0.0
> UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
> Mémoire:f7dc0000-f7de0000
>
> lo Link encap:Boucle locale
> inet adr:127.0.0.1 Masque:255.0.0.0
> adr inet6: ::1/128 Scope:Hôte
> UP LOOPBACK RUNNING MTU:16436 Metric:1
> Packets reçus:26 erreurs:0 :0 overruns:0 frame:0
> TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
> collisions:0 lg file transmission:0
> Octets reçus:1608 (1.6 KB) Octets transmis:1608 (1.6 KB)
>
> wlan0 Link encap:Ethernet HWaddr 70:1a:04:ef:61:e7
> adr inet6: fe80::721a:4ff:feef:61e7/64 Scope:Lien
> UP BROADCAST MULTICAST MTU:1500 Metric:1
> Packets reçus:2586 erreurs:0 :0 overruns:0 frame:0
> TX packets:61 errors:0 dropped:0 overruns:0 carrier:0
> collisions:0 lg file transmission:1000
> Octets reçus:418616 (418.6 KB) Octets transmis:0 (0.0 B)
> Interruption:16


et quand ça marche :

> bertrand@bertrand-ubuntu:~$ ifconfig
> eth0 Link encap:Ethernet HWaddr 90:fb:a6:49:a2:0d
> inet adr:192.168.0.7 Bcast:192.168.0.255 Masque:255.255.255.0
> adr inet6: fe80::92fb:a6ff:fe49:a20d/64 Scope:Lien
> UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
> Packets reçus:14223 erreurs:0 :0 overruns:0 frame:0
> TX packets:8838 errors:0 dropped:0 overruns:0 carrier:0
> collisions:0 lg file transmission:1000
> Octets reçus:17968667 (17.9 MB) Octets transmis:918350 (918.3 KB)
> Mémoire:f7dc0000-f7de0000
>
> lo Link encap:Boucle locale
> inet adr:127.0.0.1 Masque:255.0.0.0
> adr inet6: ::1/128 Scope:Hôte
> UP LOOPBACK RUNNING MTU:16436 Metric:1
> Packets reçus:4542 erreurs:0 :0 overruns:0 frame:0
> TX packets:4542 errors:0 dropped:0 overruns:0 carrier:0
> collisions:0 lg file transmission:0
> Octets reçus:720521 (720.5 KB) Octets transmis:720521 (720.5 KB)
>
> wlan0 Link encap:Ethernet HWaddr 70:1a:04:ef:61:e7
> adr inet6: fe80::721a:4ff:feef:61e7/64 Scope:Lien
> UP BROADCAST MULTICAST MTU:1500 Metric:1
> Packets reçus:13974 erreurs:0 :0 overruns:0 frame:0
> TX packets:1502 errors:0 dropped:0 overruns:0 carrier:0
> collisions:0 lg file transmission:1000
> Octets reçus:2525426 (2.5 MB) Octets transmis:0 (0.0 B)
> Interruption:16
>

> bertrand@bertrand-ubuntu:~$ cat /etc/network/interfaces
> auto lo
> iface lo inet loopback
>
> auto eth0
> iface eth0 inet dhcp

Je vois bien une différence entre les 2, mais d'où ça vientpas trop.

--
Bertrand
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe Weill
Le #24629891
Le 10/07/2012 18:30, bertrand a écrit :
Bonjour,

Je perds ma connexion réseau régulièrement au bout d'une semaine de fonctionnement(à peu près), sans
action particulière de ma part. j'éteins alors mon PC et au bout d'une durée variable (de quelques
heures à plusieurs jours) ça re-fonctionne (mais le plus souvent plusieurs jours).

je suis derrière un modem/routeur, os ubuntu 10.04 LTS (et les autres PC fonctionnent sans pb : 2
Windows en eth0 et 1 Ubuntu 12.04 en wlan, 1 PS3 wlan).

Je sèche, et un coup de main serait le bien venu pour continuer mes recherches (voire pour trouver
la cause ;).

merci par avance pour vos idées.


Pour info, quand c'est HS:


:~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback




:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 90:fb:a6:49:a2:0d
adr inet6: fe80::92fb:a6ff:fe49:a20d/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Packets reçus:2847 erreurs:0 :0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:408293 (408.2 KB) Octets transmis:468 (468.0 B)
Mémoire:f7dc0000-f7de0000

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
Packets reçus:5548 erreurs:0 :0 overruns:0 frame:0
TX packets:5548 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
Octets reçus:818742 (818.7 KB) Octets transmis:818742 (818.7 KB)




ou

:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 90:fb:a6:49:a2:0d
adr inet6: fe80::92fb:a6ff:fe49:a20d/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Packets reçus:381 erreurs:0 :0 overruns:0 frame:0
TX packets:56 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:49521 (49.5 KB) Octets transmis:15370 (15.3 KB)
Mémoire:f7dc0000-f7de0000

eth0:avahi Link encap:Ethernet HWaddr 90:fb:a6:49:a2:0d
inet adr:169.254.6.236 Bcast:169.254.255.255 Masque:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Mémoire:f7dc0000-f7de0000

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
Packets reçus:26 erreurs:0 :0 overruns:0 frame:0
TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
Octets reçus:1608 (1.6 KB) Octets transmis:1608 (1.6 KB)

wlan0 Link encap:Ethernet HWaddr 70:1a:04:ef:61:e7
adr inet6: fe80::721a:4ff:feef:61e7/64 Scope:Lien
UP BROADCAST MULTICAST MTU:1500 Metric:1
Packets reçus:2586 erreurs:0 :0 overruns:0 frame:0
TX packets:61 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:418616 (418.6 KB) Octets transmis:0 (0.0 B)
Interruption:16




et quand ça marche :

:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 90:fb:a6:49:a2:0d
inet adr:192.168.0.7 Bcast:192.168.0.255 Masque:255.255.255.0
adr inet6: fe80::92fb:a6ff:fe49:a20d/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Packets reçus:14223 erreurs:0 :0 overruns:0 frame:0
TX packets:8838 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:17968667 (17.9 MB) Octets transmis:918350 (918.3 KB)
Mémoire:f7dc0000-f7de0000

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
Packets reçus:4542 erreurs:0 :0 overruns:0 frame:0
TX packets:4542 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
Octets reçus:720521 (720.5 KB) Octets transmis:720521 (720.5 KB)

wlan0 Link encap:Ethernet HWaddr 70:1a:04:ef:61:e7
adr inet6: fe80::721a:4ff:feef:61e7/64 Scope:Lien
UP BROADCAST MULTICAST MTU:1500 Metric:1
Packets reçus:13974 erreurs:0 :0 overruns:0 frame:0
TX packets:1502 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:2525426 (2.5 MB) Octets transmis:0 (0.0 B)
Interruption:16




:~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp



Je vois bien une différence entre les 2, mais d'où ça vient...pas trop.




rechercher du coté du serveur dhcp c'est lui qui doit etre fautif
bertrand
Le #24630021
Le 10/07/2012 19:27, Philippe Weill a écrit :


Je vois bien une différence entre les 2, mais d'où ça vient...pas trop.




rechercher du coté du serveur dhcp c'est lui qui doit etre fautif



C'est mon routeur Netgear qui fait office de serveur DHCP. son IP (en
dur c'est 192.168.0.1 avec un mask 255.255.255.0
et il sert les IP de 192.168.0.2 à 192.168.0.254

Je ne peux pas changer grand chose, et les autres machines n'ont pas de
problème particulier (4 machines connectés en ce moment, toutes en eth0)

192.168.0.2 PC W$
192.168.0.4 PC W$
192.168.0.7 PC Linux
192.168.0.13 PC W$

B.
Pascal Hambourg
Le #24630791
Salut,

bertrand a écrit :
Le 10/07/2012 19:27, Philippe Weill a écrit :

Je vois bien une différence entre les 2, mais d'où ça vient...pas trop.



rechercher du coté du serveur dhcp c'est lui qui doit etre fautif





Ou bien le client DHCP de la machine, ou bien la liaison entre les deux,
ou bien...

C'est mon routeur Netgear qui fait office de serveur DHCP. son IP (en
dur c'est 192.168.0.1 avec un mask 255.255.255.0
et il sert les IP de 192.168.0.2 à 192.168.0.254

Je ne peux pas changer grand chose,



Si : tu peux passer l'interface en configuration statique.
bertrand
Le #24638221
Le 11/07/2012 01:09, Pascal Hambourg a écrit :
Salut,

bertrand a écrit :
Le 10/07/2012 19:27, Philippe Weill a écrit :

Je vois bien une différence entre les 2, mais d'où ça vient...pas trop.



rechercher du coté du serveur dhcp c'est lui qui doit etre fautif





Ou bien le client DHCP de la machine, ou bien la liaison entre les deux,
ou bien...

C'est mon routeur Netgear qui fait office de serveur DHCP. son IP (en
dur c'est 192.168.0.1 avec un mask 255.255.255.0
et il sert les IP de 192.168.0.2 à 192.168.0.254

Je ne peux pas changer grand chose,



Si : tu peux passer l'interface en configuration statique.



Merci,
je vais essayer ça : je viens de passer en IP fixe pour ma machine et
j'attends pour voir si ça marche.

(ça ne me donne pas la raison pour laquelle, à intervalle presque
régulier, je perd le réseau)

A+, la suite la semaine prochaine, ou la suivante...
B.
Publicité
Poster une réponse
Anonyme