Pertes valeurs sous formulaire avec formulaire non renseigné manuellement

Le
yann77
Bonjour,

J'ai créé un formulaire qui contient un sous-formulaire dans lequel je
rentre des données.

Mon formulaire principal contient des champs qui se remplissent soit
automatiquement ou manuellement.

Lorsque je ne rentre aucune valeur sur le formulaire et que j'en
rentre dans mon sous-formulaire, je ne peux pas passer à
l'enregistrement suivant (créer un nouvel enregistrement) dans mon
formulaire principal:
ce qui me fait perdre les données entrées dans mon sous-formulaire.

J'espère avoir été clair dans mon explication.

Merci d'avance.

Yann
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
3stone
Le #19414801
Salut,

yann77 wrote:
Bonjour,

J'ai créé un formulaire qui contient un sous-formulaire dans lequel je
rentre des données.

Mon formulaire principal contient des champs qui se remplissent soit
automatiquement ou manuellement.

Lorsque je ne rentre aucune valeur sur le formulaire et que j'en
rentre dans mon sous-formulaire, je ne peux pas passer à
l'enregistrement suivant (créer un nouvel enregistrement) dans mon
formulaire principal:
ce qui me fait perdre les données entrées dans mon sous-formulaire.

J'espère avoir été clair dans mon explication.




Il faudrait (re)voir ton schema relationel...

En principe, le formulaire principal contient "les parents" et le
sous-formulaire contiendra "les enfants".

Il est donc naturel que tu ne puisse saisir des "enfants" puisque
tu ne peux les lier à aucun "parent".

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
Publicité
Poster une réponse
Anonyme