petit probleme sur un code vba

Le
stephprod
Bonjour,

Voci mon code qui marche très bien qui met certaines cellules en majuscule
après modification..

Mon problème est que si la formule que contient une des cellule est modifiée
alors il m'efface cette formule..
avez vous une solution

Private Sub Worksheet_Change(ByVal Target As Range)


If Not
Intersect(Range("e49,h38,G20,g21,i21,d29,f35,f36,f37,h36,h37,h40,h42,g55,g58,i58,g61,f63,g64,i64,g80,g81,g82,e83,g87,g88,i88,g92,g93,i93"),
Target) Is Nothing And Target.Count = 1 Then
If Target = "" Then Exit Sub
Application.EnableEvents = False
If Target <> "" Then
Application.EnableEvents = False
Target = UCase(Target)
Application.EnableEvents = True
End If
End If
End Sub

2eme probleme

=SI(DO="Propriétaire";adr_prop;SI(DO="Notaire";adresse_notaire;SI(DO="Acquéreur";adr_acq;SI(DO="Agence";agence_adr;SI(DO="Cabinet
immobilier";RECHERCHEV(I78;Feuil1!A1:D25;2);SI(DO="Représentant
légal";RECHERCHEV(I78;Feuil1!A50:D95;2);""))))))

voici une formule contenu dans une cellule je voudrais la mettre en vba est
ce possible?

merci d'avance
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
stephprod
Le #5227011
bon personne a une solution????


"stephprod" 47de5380$0$866$
Bonjour,

Voci mon code qui marche très bien qui met certaines cellules en majuscule
après modification..

Mon problème est que si la formule que contient une des cellule est
modifiée alors il m'efface cette formule..
avez vous une solution...

Private Sub Worksheet_Change(ByVal Target As Range)


If Not
Intersect(Range("e49,h38,G20,g21,i21,d29,f35,f36,f37,h36,h37,h40,h42,g55,g58,i58,g61,f63,g64,i64,g80,g81,g82,e83,g87,g88,i88,g92,g93,i93"),
Target) Is Nothing And Target.Count = 1 Then
If Target = "" Then Exit Sub
Application.EnableEvents = False
If Target <> "" Then
Application.EnableEvents = False
Target = UCase(Target)
Application.EnableEvents = True
End If
End If
End Sub

2eme probleme

=SI(DO="Propriétaire";adr_prop;SI(DO="Notaire";adresse_notaire;SI(DO="Acquéreur";adr_acq;SI(DO="Agence";agence_adr;SI(DO="Cabinet
immobilier";RECHERCHEV(I78;Feuil1!A1:D25;2);SI(DO="Représentant
légal";RECHERCHEV(I78;Feuil1!A50:D95;2);""))))))

voici une formule contenu dans une cellule je voudrais la mettre en vba
est ce possible?

merci d'avance



Gaston
Le #5226501
Bonjour stephprod,

Pour ton premier probleme:
Ça met en majuscules ta réponse avec "Target = Ucase(Target)"
Met le Majuscule dans ta formule; en B1: = Majuscule(A1),
et tu n'auras pas besoin de faire de macro.
Si cela a pu t'aider.
Bye
Gaston

"stephprod" wrote:

bon personne a une solution????


"stephprod" 47de5380$0$866$
Bonjour,

Voci mon code qui marche très bien qui met certaines cellules en majuscule
après modification..

Mon problème est que si la formule que contient une des cellule est
modifiée alors il m'efface cette formule..
avez vous une solution...

Private Sub Worksheet_Change(ByVal Target As Range)


If Not
Intersect(Range("e49,h38,G20,g21,i21,d29,f35,f36,f37,h36,h37,h40,h42,g55,g58,i58,g61,f63,g64,i64,g80,g81,g82,e83,g87,g88,i88,g92,g93,i93"),
Target) Is Nothing And Target.Count = 1 Then
If Target = "" Then Exit Sub
Application.EnableEvents = False
If Target <> "" Then
Application.EnableEvents = False
Target = UCase(Target)
Application.EnableEvents = True
End If
End If
End Sub

2eme probleme

=SI(DO="Propriétaire";adr_prop;SI(DO="Notaire";adresse_notaire;SI(DO="Acquéreur";adr_acq;SI(DO="Agence";agence_adr;SI(DO="Cabinet
immobilier";RECHERCHEV(I78;Feuil1!A1:D25;2);SI(DO="Représentant
légal";RECHERCHEV(I78;Feuil1!A50:D95;2);""))))))

voici une formule contenu dans une cellule je voudrais la mettre en vba
est ce possible?

merci d'avance








Publicité
Poster une réponse
Anonyme