Petite aide sur une formule

Le
Marc
Bonjour à tous et toutes

J'ai un petit tableur tout simple qui fonctionne pour rechercher des
données dans un tableau ( tableau de 4 colonnes et 13 lignes (N35/R47)
existant . J'ai voulu rajouter une ligne au tableau donc passer à 14
lignes (N35/R48)
La formule fonctionnant avec 13 lignes est :
=SI(OU(E20=N35:N47);INDIRECT(ADRESSE(EQUIV(E20;N35:N47;0)+34;EQUIV(E23;
{"E";"X"};0)+16));SI((E21="MS");RECHERCHEV(E24;J64:L107;3;FAUX);0))

Je pensais que changer dans la formule N35:N47 par N35:N48, me
suffisait , mais cela ne fonctionne pas.
Merci de votre aide

Marc
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichD
Le #24196221
Bonjour,

Tenter de corriger une formule sans autre indication n'est pas évident.

Essaie ceci :
Validation matricielle : Maj + Ctrl + Enter
=SI(E20=N35:N48;INDIRECT(ADRESSE(EQUIV(E20;N35:N48;0)+34;EQUIV(E23;{"E";"X"};0)+16));SI((E21="MS");RECHERCHEV(E24;J64:L107;3;FAUX);0))



MichD
------------------------------------------
"Marc" a écrit dans le message de groupe de discussion :


Bonjour à tous et toutes

J'ai un petit tableur tout simple qui fonctionne pour rechercher des
données dans un tableau ( tableau de 4 colonnes et 13 lignes (N35/R47)
existant . J'ai voulu rajouter une ligne au tableau donc passer à 14
lignes (N35/R48)
La formule fonctionnant avec 13 lignes est :
=SI(OU(E20=N35:N47);INDIRECT(ADRESSE(EQUIV(E20;N35:N47;0)+34;EQUIV(E23;
{"E";"X"};0)+16));SI((E21="MS");RECHERCHEV(E24;J64:L107;3;FAUX);0))

Je pensais que changer dans la formule N35:N47 par N35:N48, me
suffisait , mais cela ne fonctionne pas.
Merci de votre aide

Marc
Jacquouille
Le #24197711
Bonjour
Quand cela merdouille trop, j'essaie d'insérer une ligne DANS le tableau.
Excel, pas con, me modifie les formules. Reste alors soit recopier les
lignes du bas, soit retrier les données.
Bonne chance

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"MichD" a écrit dans le message de groupe de discussion :
jfpqjq$kcb$

Bonjour,

Tenter de corriger une formule sans autre indication n'est pas évident.

Essaie ceci :
Validation matricielle : Maj + Ctrl + Enter
=SI(E20=N35:N48;INDIRECT(ADRESSE(EQUIV(E20;N35:N48;0)+34;EQUIV(E23;{"E";"X"};0)+16));SI((E21="MS");RECHERCHEV(E24;J64:L107;3;FAUX);0))



MichD
------------------------------------------
"Marc" a écrit dans le message de groupe de discussion :


Bonjour à tous et toutes

J'ai un petit tableur tout simple qui fonctionne pour rechercher des
données dans un tableau ( tableau de 4 colonnes et 13 lignes (N35/R47)
existant . J'ai voulu rajouter une ligne au tableau donc passer à 14
lignes (N35/R48)
La formule fonctionnant avec 13 lignes est :
=SI(OU(E20=N35:N47);INDIRECT(ADRESSE(EQUIV(E20;N35:N47;0)+34;EQUIV(E23;
{"E";"X"};0)+16));SI((E21="MS");RECHERCHEV(E24;J64:L107;3;FAUX);0))

Je pensais que changer dans la formule N35:N47 par N35:N48, me
suffisait , mais cela ne fonctionne pas.
Merci de votre aide

Marc
Marc
Le #24199351
On 26 jan, 13:35, "Jacquouille"
Bonjour
Quand cela merdouille trop, j'essaie d'insérer une ligne DANS le tablea u.
Excel, pas con, me modifie les formules.  Reste alors soit recopier les
lignes du bas, soit retrier les données.
Bonne chance

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"MichD"  a écrit dans le message de groupe de discussion :
jfpqjq$

Bonjour,

Tenter de corriger une formule sans autre indication n'est pas évident.

Essaie ceci :
Validation matricielle : Maj + Ctrl + Enter
=SI(E20=N35:N48;INDIRECT(ADRESSE(EQUIV(E20;N35:N48;0)+34;EQUIV(E23;{" E";"X"};0)+16));SI((E21="MS");RECHERCHEV(E24;J64:L107;3;FAUX);0))

MichD
------------------------------------------
"Marc"  a écrit dans le message de groupe de discussion :


Bonjour à tous et toutes

J'ai un petit tableur tout simple qui fonctionne pour rechercher des
données dans un tableau ( tableau de 4 colonnes et 13 lignes (N35/R47)
existant . J'ai voulu rajouter une ligne au tableau donc passer à 14
lignes (N35/R48)
La formule fonctionnant avec 13 lignes est :
=SI(OU(E20=N35:N47);INDIRECT(ADRESSE(EQUIV(E20;N35:N47;0)+34;EQUIV(E2 3;
{"E";"X"};0)+16));SI((E21="MS");RECHERCHEV(E24;J64:L107;3;FAUX);0))

Je pensais que changer dans la formule N35:N47 par N35:N48,  me
suffisait  , mais cela ne fonctionne pas.
Merci de votre aide

Marc



Merci pour vos réponses. J'ai opté pour la solution de changer une
donnée obsolète dans le tableau et cela fonctionne.
Merci encore.
Publicité
Poster une réponse
Anonyme