php4 et php5 double instance

Le
dodger_web
Bonjour,

Je cherche à installer un serveur apache 1.3 avec php4 et php5 en même
temps (via 2 instances apache différentes).

Le problème que je me pose, est qu'il existe un conflit entre
libapache-mod-php5 et libapache-mod-php4, donc impossible d'installer
les deux en même temps.

Suis je obligé de passer par la compilation de php pour l'une de deux
verisons, ou existe t'il un moyen via dpkg ?

Merci d'avance


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Yves F. Barbier
Le #9580231
dodger_web wrote:
Bonjour,



salut

Je cherche à installer un serveur apache 1.3 avec php4 et php5 en mê me
temps (via 2 instances apache différentes).

Le problème que je me pose, est qu'il existe un conflit entre
libapache-mod-php5 et libapache-mod-php4, donc impossible d'installer
les deux en même temps.

Suis je obligé de passer par la compilation de php pour l'une de deux
verisons, ou existe t'il un moyen via dpkg ?



loin d'être spécialiste web, je dirais (au moins compliqué, mais pa s moins
lourd) 1 system & 1 machine virtuelle (vmware | virtualbox), ou 2 MV.
evidemment, c'est lourdingue :(

Sinon, du fait que les packages sont en conflit, installer une des versio ns
packagée, et l'autre manuellement (tar.gz, dans /usr/local/...), puis j eter
un neunoeil là:

http://www.gentoo.org/proj/en/php/php4-php5-configuration.xml

Merci d'avance



atta: y'a sûrement des gens bcp plus calés qui vont te donner une ré ponse
plus pro/simple ;-)

--
QOTD:
"The only real difference between men and women is that men are
crabby all month long."
dodger_web
Le #9580221
Jean-Yves F. Barbier a écrit :
dodger_web wrote:
Bonjour,



salut

Je cherche à installer un serveur apache 1.3 avec php4 et php5 en
même temps (via 2 instances apache différentes).

Le problème que je me pose, est qu'il existe un conflit entre
libapache-mod-php5 et libapache-mod-php4, donc impossible d'installer
les deux en même temps.

Suis je obligé de passer par la compilation de php pour l'une de deux
verisons, ou existe t'il un moyen via dpkg ?



loin d'être spécialiste web, je dirais (au moins compliqué, mais pas
moins
lourd) 1 system & 1 machine virtuelle (vmware | virtualbox), ou 2 MV.
evidemment, c'est lourdingue :(


Pas envisageable en prod à moins de gros moyens.

Sinon, du fait que les packages sont en conflit, installer une des
versions
packagée, et l'autre manuellement (tar.gz, dans /usr/local/...), puis
jeter
un neunoeil là:

http://www.gentoo.org/proj/en/php/php4-php5-configuration.xml



C'est justement ce que je veux éviter :-)
Je cherche une technique debian de faire cela, sinon je me rabattrais
sur ca.
Merci d'avance



atta: y'a sûrement des gens bcp plus calés qui vont te donner une réponse
plus pro/simple ;-)






--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jean-Yves F. Barbier
Le #9580201
IMHO s'il-y-a un conflit, c'est parce que certains fichiers ont le même
nom et le même emplacement (tu peux vérifier en chargeant les 2 et en
les parcourant avec mc, par exemple).

donc, ne reste plus que la solt manuelle

dodger_web wrote:
Jean-Yves F. Barbier a écrit :
dodger_web wrote:
Bonjour,



salut

Je cherche à installer un serveur apache 1.3 avec php4 et php5 en
même temps (via 2 instances apache différentes).

Le problème que je me pose, est qu'il existe un conflit entre
libapache-mod-php5 et libapache-mod-php4, donc impossible d'installer
les deux en même temps.

Suis je obligé de passer par la compilation de php pour l'une de de ux
verisons, ou existe t'il un moyen via dpkg ?



loin d'être spécialiste web, je dirais (au moins compliqué, mais pas
moins
lourd) 1 system & 1 machine virtuelle (vmware | virtualbox), ou 2 MV.
evidemment, c'est lourdingue :(


Pas envisageable en prod à moins de gros moyens.

Sinon, du fait que les packages sont en conflit, installer une des
versions
packagée, et l'autre manuellement (tar.gz, dans /usr/local/...), pui s
jeter
un neunoeil là:

http://www.gentoo.org/proj/en/php/php4-php5-configuration.xml



C'est justement ce que je veux éviter :-)
Je cherche une technique debian de faire cela, sinon je me rabattrais
sur ca.
Merci d'avance



atta: y'a sûrement des gens bcp plus calés qui vont te donner une réponse
plus pro/simple ;-)









--
The reason Roman Catholics are allowed to use the rhythm method of birth
control is that it doesn't work.
Sylvain Sauvage
Le #9580171
Jean-Yves F. Barbier, lundi 9 juillet 2007, 16:33:42 CEST

IMHO s'il-y-a un conflit, c'est parce que certains fichiers ont le mà ªme
nom et le même emplacement (tu peux vérifier en chargeant les 2 et en
les parcourant avec mc, par exemple).

donc, ne reste plus que la solt manuelle



Ou un chroot : installation minimale avec debootstrap (moins
lourd qu’une machine virtuelle et plus efficace dans ce cas).

--
Sylvain Sauvage
Publicité
Poster une réponse
Anonyme