Piece jointe non telechargee dans Mail

Le
olivier.marti
Bonjour,

J'ai un mail avec 3 pièces jointes : 2 fichiers Microsoft Word (.doc) et
une carte de carnet d'adresse (.vcf). Les deux .docs apparaissent avec
une icône bizarre,signalant que la pièce joint n'est pas téléchagée. Si
je le met sur le disque, quelque soit la méthode (Glisser-déposer, "Tout
télécharger", etc ), ils sont vides dans Word.

Voir http://omarti.free.fr/Public/Images/PieceJointeManquante.png

Ceci avec Mail d'Apple, en IMAP.

Mais si je lit mon mail sur le même serveur de mail par l'interface web
(Squirrel Mail), les pièces jointes sont bien là, complètes, et Word les
lis sans problème.

J'ai essayé de reconstruire la boîte d'entrée dans Mail, sans succès.

Il se passe quoi, comment faire pour que Mail charge les pièces jointes
correctement ?

Config : Mac OS X 10.7.2

Une idée ?

Olivier
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
g4fleurot
Le #24088351
Olivier Marti
Il se passe quoi, comment faire pour que Mail charge les pièces jointes
correctement ?



As-tu essayé de faire un clic droit sur une vignette et
"Afficher depuis son emplacement",
ou "Coup d'½il sur la pièce jointe" ?

Dans les deux cas, elle devrait s'afficher, si elle n'est pas corrompue.
(je viens de faire l'essai avec un fichier Word)

--
Gérard FLEUROT
Patrick Stadelmann
Le #24088461
In article (Olivier Marti) wrote:

Une idée ?



Certains serveurs, en particulier MS Exchange, reconstruisent les
messages IMAP à la volée pour le client. Ca m'est déjà arriver de
constater des erreurs (par exemple, séparateur MIME déclaré dans
l'entête différent de celui utiliser dans le corps du message) avec
certains logiciels, typiquement ceux qui ne téléchargent pas tout le
message d'un coup (Entourage par exemple n'avait jamais le moindre
problème) mais qui se renseignent d'abord sur la structure (genre
Thunderbird).

Tu peux essayer de copier le message dans un dossier Mail local, ou dans
un autre dossier sur le serveur.

Patrick
--
Patrick Stadelmann
olivier.marti
Le #24088571
Patrick Stadelmann
In article (Olivier Marti) wrote:

> Une idée ?

Certains serveurs, en particulier MS Exchange, reconstruisent les
messages IMAP à la volée pour le client. Ca m'est déjà arriver de
constater des erreurs (par exemple, séparateur MIME déclaré dans
l'entête différent de celui utiliser dans le corps du message) avec
certains logiciels, typiquement ceux qui ne téléchargent pas tout le
message d'un coup (Entourage par exemple n'avait jamais le moindre
problème) mais qui se renseignent d'abord sur la structure (genre
Thunderbird).



Le serveur de mail est un 'vrai' serveur IMAP, pas Exchange : Cyrus
v2.3.7-Invoca-RPM-2.3.7-12.el5_7.2, sur un Linux.

Si je relève avec Thunderbird, ça marche. C'est vraiment Mail qui merde.


Tu peux essayer de copier le message dans un dossier Mail local, ou dans
un autre dossier sur le serveur.



Idée intéressante. Mais ça ne marche pas mieux.

Groumph ... !

Olivier
olivier.marti
Le #24088561
Fleuger
Olivier Marti
> Il se passe quoi, comment faire pour que Mail charge les pièces jointes
> correctement ?

As-tu essayé de faire un clic droit sur une vignette et
"Afficher depuis son emplacement",
ou "Coup d'½il sur la pièce jointe" ?




Case blanche, qui affiche "Téléchargement de la pièce jointe", mais rien
ne se passe.


Dans les deux cas, elle devrait s'afficher, si elle n'est pas corrompue.
(je viens de faire l'essai avec un fichier Word)



Olivier
g4fleurot
Le #24088601
Olivier Marti
Case blanche, qui affiche "Téléchargement de la pièce jointe", mais rien
ne se passe.



Et si tu demandes directement "Ouvrir" où "Ouvrir avec..." avec le clic
droit ?
Est-ce que c'est pareil avec des .JPG ?
J'ai Word en 14.1.4.

Dans Préférences > Générales, le dossier de téléchargement est-il bien
spécifié ?

Tu peux peut-être aussi essayer de récupérer un fichier de prefs dans
une sauvegarde d'avant Lion ? (en sauvegardant celui qui est présent au
préalable).

--
Gérard FLEUROT
Patrick Stadelmann
Le #24088931
In article (Olivier Marti) wrote:

Patrick Stadelmann
>
> Tu peux essayer de copier le message dans un dossier Mail local, ou dans
> un autre dossier sur le serveur.

Idée intéressante. Mais ça ne marche pas mieux.



Tu peux essayer de comparer les sources du mail récupéré avec Mail et
Thunderbird pour voir ce qui cloche.

Patrick
--
Patrick Stadelmann
olivier.marti
Le #24089331
Fleuger
Olivier Marti
> Case blanche, qui affiche "Téléchargement de la pièce jointe", mais rien
> ne se passe.

Et si tu demandes directement "Ouvrir" où "Ouvrir avec..." avec le clic
droit ?



Rien de mieux.

Est-ce que c'est pareil avec des .JPG ?
J'ai Word en 14.1.4.



Ce problème m'arrive de temps en temps, et c'est toujours avec des
fichiers Word.

Dans Préférences > Générales, le dossier de téléchargement est-il bien
spécifié ?



Oui, pas de problème. De façon générale ça marche. C'est juste une fois
de temps en temps.


Tu peux peut-être aussi essayer de récupérer un fichier de prefs dans
une sauvegarde d'avant Lion ? (en sauvegardant celui qui est présent au
préalable).



J'ai pu récupérer le fichier par ailleurs, pas de soucis. J'aimerais
juste comprendre, et trouver que ça ne se reproduise pas.

Olivier
olivier.marti
Le #24089321
Patrick Stadelmann
In article (Olivier Marti) wrote:

> Patrick Stadelmann >
> >
> > Tu peux essayer de copier le message dans un dossier Mail local, ou dans
> > un autre dossier sur le serveur.
>
> Idée intéressante. Mais ça ne marche pas mieux.

Tu peux essayer de comparer les sources du mail récupéré avec Mail et
Thunderbird pour voir ce qui cloche.




Aucune différence :

:12:36-~/Desktop:cmp Message_Mail.eml
Message_Thunderbird.eml
:12:57-~/Desktop:

C'est vraiment Mail qui merde...

Olivier
Patrick Stadelmann
Le #24090491
In article (Olivier Marti) wrote:

C'est vraiment Mail qui merde...



Essaye avec sous un compte utilisateur différent, et si le problème
persiste, fait un rapport de bug à Apple en joignant le message si cela
est possible, ou du moins sa structure s'il continent des information
confidentielles.

Patrick
--
Patrick Stadelmann
olivier.marti
Le #24091021
Patrick Stadelmann
In article (Olivier Marti) wrote:

> C'est vraiment Mail qui merde...

Essaye avec sous un compte utilisateur différent,



Et le problème persiste :-(

Je l'ai fait sur un compte nouvellement créé pour ça.

et si le problème
persiste, fait un rapport de bug à Apple en joignant le message si cela
est possible, ou du moins sa structure s'il continent des information
confidentielles.



La ça ne va pas être possible ! Rien que le nom des pièces jointes va
être considéré comme confidentiel :-(

Je n'ai plus qu'à attendre que ça se reproduise avec un message plus
anodin.

Merci de toutes tes pistes

Olivier
Publicité
Poster une réponse
Anonyme