pinning lenny/squeeze ne marche pas

Le
Gauthier
Bonjour à tous,

J'utilise une Debian Lenny mais je souhaite exceptionnelement y
installer un paquet dont la version souhaitée figure dans testing,
gscan2pdf.

J'ai lu un texte d'explication bien fait sur la manière de mélanger
ainsi des paquets: http://www.bxlug.be/articles/194
«Mélanger Testing et Unstable»

Je modifie mon /etc/apt/sources.list ainsi:

deb http://ftp.be.debian.org/debian/ lenny main non-free contrib
deb http://ftp.be.debian.org/debian/ squeeze main non-free contrib

deb http://security.debian.org/ lenny/updates main non-free
deb http://security.debian.org/ squeeze/updates main non-free

deb http://volatile.debian.org/debian-volatile lenny/volatile main

deb ftp://mirrors.powersource.cx/pub/debian-multimedia/ stable main

Je crée /etc/apt/preferences:

Package: *
Pin: release a=lenny
Pin-Priority: 990

Package: *
Pin: release a=squeeze
Pin-Priority: 99


À la suite de quoi, je fais un apt-get update, et tout se passe bien.

Avant d'installer un paquet, je fait un test sur un paquet quelconque:

# apt-cache policy joe
joe:
Installé : (aucun)
Candidat : 3.7-1
Table de version :
3.7-1 0
500 http://ftp.be.debian.org squeeze/main Packages
100 /var/lib/dpkg/status
3.5-2 0
500 http://ftp.be.debian.org lenny/main Packages

:(

J'en conclue que mes préférences ne sont pas prises en considération,
puisque la priorité est à 500 pour les deux versions.

Je pourrais à la limite préciser pour chaque installation la branche que
je souhaite avec l'option -t lenny mais comme je ne souhaite
qu'exceptionnelement installer un paquet provenant de testing, c'est
embêtant. Donc je crée /etc/apt/apt.conf

APT::Default-Release "lenny";

et ça ne change absolument rien. re :(

Pour couronner le tout, je fais le test pour gscan2pdf:

# apt-cache policy gscan2pdf
gscan2pdf:
Installé : (aucun)
Candidat : 0.9.25-1
Table de version :
0.9.25-1 0
500 http://ftp.be.debian.org lenny/main Packages

et je ne retrouve même pas la version figurant dans testing, alors
qu'elle existe bien: http://packages.debian.org/squeeze/gscan2pdf

Bref, c'est le désastre, si quelqu'un pouvait m'éclairer

Merci d'avance
--
Gauthier <gvdmoort at skynet.be>

Le hasard, c'est différent de la chance parce que souvent ça merde.
(Brèves de comptoir - J-M Gourio)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
David Prévot
Le #20617681
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Gauthier a écrit :
Bonjour à tous,



Bonjour,

[...]

Je crée /etc/apt/preferences:

Package: *
Pin: release a=lenny
Pin-Priority: 990



Ne fonctionnera pas sous Lenny :

$ man apt_preferences
La ligne Archive:
nomme l´archive à laquelle appartiennent tous les paquets
situés dans les répertoires. Par exemple, la ligne Archive:
stable indique que tous les paquets dans les répertoires
situés sous le répertoire parent du fichier Release
appartiennent à l´archive stable. Indiquer cette valeur dans
le fichier des préférences demanderait cette ligne :

Pin: release a=stable

Bref, renseigner stable et non lenny [testing et non squeeze].

« Suivre l´évolution d´une version par son nom de code » n'a été ajouté
que récemment.

Amicalement

David

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAksK9cYACgkQ18/WetbTC/ruVQCfZ3u7s8+NhCveE4ebCzH/uva8
OlUAnAiFAYi5nfTNgT7pV6FWjmq2o4oL
=U/LA
-----END PGP SIGNATURE-----

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme