plus de gestion d'

Le
Christophe PEREZ
Bonjour,

Sous gentoo, subitement, sans doute à cause d'une manip de ma part mais
je ne sais pas laquelle, mais pas suite à une mise à jour puisque ce PC
n'en avait pas eu depuis plusieurs jours, la gestion d'énergie a disparu
de Kde.
Pourtant, polkit et upowerd tournent, le module kde powerdevil est bien
chargé, dbus est joignable :
# ps axfu | grep polkit
polkitd 1714 0.0 0.4 519508 13360 ? Sl 01:28 0:00 /usr/lib/
polkit-1/polkitd --no-debug
kevin 2656 0.0 0.7 288808 24328 ? Sl 01:32 0:00 /usr/
lib64/kde4/libexec/polkit-kde-authentication-agent-1

# ps axfu | grep power
root 2125 0.0 0.1 198084 5652 ? Sl 01:29 0:00 /usr/lib/
upower/upowerd

$ qdbus --system
:1.0
org.freedesktop.ConsoleKit
:1.1
:1.10
:1.14
:1.2
org.freedesktop.PolicyKit1
:1.28
:1.31
:1.32
:1.35
:1.38
:1.39
:1.40
:1.41
:1.43
:1.8
org.freedesktop.UDisks2
:1.9
org.freedesktop.UPower
org.freedesktop.DBus

$ qdbus org.kde.kded /kded loadedModules | grep powerdevil
powerdevil

Par contre :
$ upower -d
Daemon:
daemon-version: 0.9.23
can-suspend: no
can-hibernate: no
on-battery: no
on-low-battery: no
lid-is-closed: no
lid-is-present: no
is-docked: no
déjà ça me surprend fortement.

Evidemment :
$ qdbus org.kde.kded /org/freedesktop/PowerManagement CanSuspend
false

$ dbus-send --system --print-reply --dest="org.freedesktop.UPower" /org/
freedesktop/UPower org.freedesktop.UPower.Suspend
Error org.freedesktop.UPower.GeneralError: No kernel support

Je ne vois pas le rapport avec le noyau, il est là depuis le 27 Décembre
2014, et le PC a rebooté X fois depuis.

# uname -a
Linux medion 3.17.7-gentoo #1 SMP Sat Dec 27 22:10:45 AST 2014 x86_64
Intel(R) Core(TM)2 Quad CPU Q8200 @ 2.33GHz GenuineIntel GNU/Linux

Pour info :
$ ck-list-sessions
Session11:
unix-user = '507'
realname = 'Kévin ******'
seat = 'Seat1'
session-type = ''
active = TRUE
x11-display = ':0'
x11-display-device = '/dev/tty5'
display-device = ''
remote-host-name = ''
is-local = TRUE
on-since = '2015-01-11T06:43:11.740776Z'

Si quelqu'un s'y connait un peu en la matière Ah oui, j'oubliais, j'ai
déjà ré-installé (recompilé) tous les packages qui pourraient être
incriminés (sauf oubli) : dbus dbus-glib polkit consolekit powerdevil pm-
utils upower-pm-utils
J'ai déjà fermé la session en mode tel que je ré-ouvre sans conserver
l'état de la session actuelle, j'ai déjà arrêté puis relancé le processus
de gestion d'énergie dans le panneau de Kde, et j'ai déjà rebooté le PC
plusieurs fois, au cas où.
J'avoue que je ne sais plus quoi tenter, à part demander de l'aide à
droite et à gauche (forums gentoo et ici).

Merci de m'avoir lu, et pour l'aide que vous m'apporterez.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Christophe PEREZ
Le #26333486
Le Sun, 11 Jan 2015 16:14:09 +0000, Christophe PEREZ a écrit :

subitement, sans doute à cause d'une manip de ma part



C'était bien ça, uniquement ma faute. Une commande mal placée dans un
script de /etc/pm/config.d/ qui a tout désactivé.
Désolé pour le bruit.
Publicité
Poster une réponse
Anonyme