Pourquoi des videos vertes?

Le
Tanguy Briançon
Bonjour

Je suis sous Kubuntu (12.04). Les vidéos Youtube s'affichent
avec des couleurs vertes. Les vidéos normales marchent bien (a
priori je suis avec les drivers proprio nvidia).
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jp willm
Le #24751752
Hello,

Le 03/09/2012 16:47, Tanguy Briançon a écrit :
Je suis sous Kubuntu (12.04). Les vidéos Youtube s'affichent
avec des couleurs vertes. Les vidéos normales marchent bien (a
priori je suis avec les drivers proprio nvidia).



J'avais mes vidéos en négatif il fut un temps et j'avais résolu le
problème à l'aide de gstreamer-properties.

Ci après mes notes à ce sujet :

Si les vidéos s'affichent en négatif dans Totem :

Alt+ F2 >
gstreamer-properties >
onglet "Video" >
Plugin = X Window System (sans Xv)

Clic sur test pour voir le résultat

Si les vidéos s'affichent en négatif dans Kaffeine :

Settings (Paramètres) >
video >
Options de débutant >
driver (pilote vidéo à utiliser) = xshm




Voir éventuellement :
http://ubuntuforums.org/showpost.php?pQ52874&postcount=6

Qui dit ceci :


Sergey Burnevsky wrote on 2008-05-01: #6

I was able to SOLVE the problem on my system. Playing movie in Totem
(which was playing in inverse colors) I opened Edit->Options, tab Video
and changed value of the last slider, Hue. Video plays in correct colors
if slider is set to min or max values, inverse colors are shown if
slider is in middle position. One note, initially the hue level (or at
least the slider) was set in leftmost position, I just had to move it.


Et cela :


Re: Negative colors
Hey!

Just letting you know I have discovered another work-around that doesn't
require you to manually set the hue every time you open a video

To implement the workaround, do the following:

Open gstreamer-properties (alt+f2, enter gstreamer-properties)
Change to the video tab
Change the default output plugin to "custom"
Place the following command in the bottom box: videobalance hue=-1
! autovideosink
Close the box and enjoy your now correct colour

--
jp willm
http://perso.orange.fr/willms/index.html
Sergio
Le #24751742
Le Mon, 03 Sep 2012 16:47:07 +0200, Tanguy Briançon a écrit :

Je suis sous Kubuntu (12.04). Les vidéos Youtube s'affichent avec des
couleurs vertes. Les vidéos normales marchent bien (a priori je suis
avec les drivers proprio nvidia).



- Voir ce topic :
http://forum.ubuntu-fr.org/viewtopic.php?id†4831

- Si ça ne marche pas, essaye de régler Youtube pour qu'il utilise HTML 5
plutôt que Flash :
http://www.youtube.com/html5
Nicolas George
Le #24751762
jp willm , dans le message
Plugin = X Window System (sans Xv)



Très mauvaise idée : c'est lent (mise à l'échelle et conversion d'espace de
couleurs faite par le processeur -- avec les processeurs actuels, ce n'est
pas dramatique évidemment) et surtout ça ne permet pas la synchronisation
avec le rafraîchissement de l'écran, donc tearing abominable.
jp willm
Le #24752012
Le 03/09/2012 17:35, Nicolas George a écrit :

Très mauvaise idée : c'est lent (mise à l'échelle et conversion d'espace de
couleurs faite par le processeur -- avec les processeurs actuels, ce n'est
pas dramatique évidemment) et surtout ça ne permet pas la synchronisation
avec le rafraîchissement de l'écran, donc tearing abominable.




Ok. Merci.

Faute de grives...

--
jp willm
http://perso.orange.fr/willms/index.html
jp willm
Le #24752002
Le 03/09/2012 17:21, Sergio a écrit :

- Voir ce topic :
http://forum.ubuntu-fr.org/viewtopic.php?id†4831

- Si ça ne marche pas, essaye de régler Youtube pour qu'il utilise HTML 5
plutôt que Flash :
http://www.youtube.com/html5




Merci pour cette solution plus propre que j'ai notée :o)

--
jp willm
http://perso.orange.fr/willms/index.html
olive
Le #24754342
Sergio écrivait :

- Si ça ne marche pas, essaye de régler Youtube pour qu'il utilise HTML 5
plutôt que Flash :
http://www.youtube.com/html5



Je viens de tester, c'est impeccable. Pour ma culture, quelles sont les
fonctionalités qui manquent au html 5 pour remplacer complètement flash
?



--
Olivier -- "On est comme tous les artistes, on croit à notre produit."
-+-groupe Début de Soirée-+-
Tanguy Briançon
Le #24755032
On 03/09/2012 17:21, Sergio wrote:
Le Mon, 03 Sep 2012 16:47:07 +0200, Tanguy Briançon a écrit :

Je suis sous Kubuntu (12.04). Les vidéos Youtube s'affichent avec des
couleurs vertes. Les vidéos normales marchent bien (a priori je suis
avec les drivers proprio nvidia).



- Voir ce topic :
http://forum.ubuntu-fr.org/viewtopic.php?id†4831

- Si ça ne marche pas, essaye de régler Youtube pour qu'il utilise HTML 5
plutôt que Flash :
http://www.youtube.com/html5



Merci j'ai résolu le problème.
Publicité
Poster une réponse
Anonyme