prob ugrade php4--> php5

Le
Aux Saveurs Gourmandes
Apres un long moment sans faire evoluer mon serveur je decide de le
mettre a jour et surtout d'installer php5.
Donc apt get install php5 libapache-mod-php5 comme conseillé sur le web
(enfin le site que j'ai consulté pour cela)
depuis
les pages .php de mon serveur ne sont plus interpretées mais bien
envoyées tel quelles a telecharger.
j'ai essayer de vire php5 libapache-mod-php5 et reinstaller
libapache-mod-php4
mais cela ne change rien (je restarte apache apres chaque manip bien
entendu)
Comment revenir a une config qui marche ? (ce serait deja pas mal
apache 1.1.3
php 4.4.8 (je crois)

Guy

ma config:
ultimate:~# dpkg -l |grep php
ii gallery
1.5.4-3 a web-based photo album written
in php
ii libapache-mod-php4
4.4.4-8+etch4 server-side, HTML-embedded
scripting languag
ii libphp-adodb
4.93a-1.1 The 'adodb' database
abstraction layer for p
ii php-doc
20061001-1 Documentation for PHP4 and PHP5
ii php-gtk
4.3.1-2 php4-gtk lib for applications
develop
ii php4
4.4.4-8+etch4 server-side, HTML-embedded
scripting languag
ii php4-cgi
4.4.4-8+etch4 server-side, HTML-embedded
scripting languag
ii php4-cli
4.4.4-8+etch4 command-line interpreter for
the php4 script
ii php4-common
4.4.4-8+etch4 Common files for packages built
from the php
ii php4-gd
4.4.4-8+etch4 GD module for php4
ii php4-ldap
4.4.4-8+etch4 LDAP module for php4
ii php4-mysql
4.4.4-8+etch4 MySQL module for php4
ii php4-sqlite
1.0.2-12+b1 PHP4 bindings to SQLite, a
file-based SQL en
ii phpdoc
20061001-1 Transition package for PHP4 and
PHP5 documen
rc phpldapadmin
0.9.5-3 web based interface for
administering LDAP s
ii phpmyadmin
2.9.1.1-6 Administrate MySQL over the WWW
ii phpsysinfo
2.5.1-6 PHP based host information

ultimate:~# dpkg -l |grep apache
ii apache
1.3.34-4.1 versatile, high-performance
HTTP server
ii apache-common
1.3.34-4.1 support files for all Apache
webservers
ii apache-utils
1.3.33-8 utility programs for webservers
(transitiona
ii apache2-mpm-prefork
2.2.3-4+etch3 Traditional model for Apache
HTTPD 2.1
ii apache2-utils
2.2.3-4+etch3 utility programs for webservers
ii apache2.2-common
2.2.3-4+etch3 Next generation, scalable,
extendable web se
ii libapache-mod-php4
4.4.4-8+etch4 server-side, HTML-embedded
scripting languag
ii webmin-apache
1.200-1 apache control module for webmin
ultimate:~#


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Michel OLTRA
Le #9643521
Bonjour,


Le mardi 22 janvier 2008, Aux Saveurs Gourmandes a écrit...


les pages .php de mon serveur ne sont plus interpretées mais bien
envoyées tel quelles a telecharger....



Il doit manquer quelque chose dans le
/etc/apache2/mods-available/php5.conf ??
Quelque chose (une extension) dans la directive AddType ?

--
jm

A.E.L. Sarl (R.C.S CASTRES 490843240)
http://www.spidboutic.fr



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jean-Michel Caricand
Le #9643501
Le mardi 22 janvier 2008 15:58, Aux Saveurs Gourmandes a écrit :
Apres un long moment sans faire evoluer mon serveur je decide de le
mettre a jour et surtout d'installer php5.
Donc apt get install php5 libapache-mod-php5 comme conseillé sur le web
(enfin le site que j'ai consulté pour cela)
depuis
les pages .php de mon serveur ne sont plus interpretées mais bien
envoyées tel quelles a telecharger....
j'ai essayer de vire php5 libapache-mod-php5 et reinstaller
libapache-mod-php4
mais cela ne change rien (je restarte apache apres chaque manip bien
entendu)
Comment revenir a une config qui marche ? (ce serait deja pas mal
apache 1.1.3
php 4.4.8 (je crois)

Guy

ma config:
ultimate:~# dpkg -l |grep php
ii gallery
1.5.4-3 a web-based photo album written
in php
ii libapache-mod-php4
4.4.4-8+etch4 server-side, HTML-embedded
scripting languag
ii libphp-adodb
4.93a-1.1 The 'adodb' database
abstraction layer for p
ii php-doc
20061001-1 Documentation for PHP4 and PHP5
ii php-gtk
4.3.1-2 php4-gtk lib for applications
develop
ii php4
4.4.4-8+etch4 server-side, HTML-embedded
scripting languag
ii php4-cgi
4.4.4-8+etch4 server-side, HTML-embedded
scripting languag
ii php4-cli
4.4.4-8+etch4 command-line interpreter for
the php4 script
ii php4-common
4.4.4-8+etch4 Common files for packages built
from the php
ii php4-gd
4.4.4-8+etch4 GD module for php4
ii php4-ldap
4.4.4-8+etch4 LDAP module for php4
ii php4-mysql
4.4.4-8+etch4 MySQL module for php4
ii php4-sqlite
1.0.2-12+b1 PHP4 bindings to SQLite, a
file-based SQL en
ii phpdoc
20061001-1 Transition package for PHP4 and
PHP5 documen
rc phpldapadmin
0.9.5-3 web based interface for
administering LDAP s
ii phpmyadmin
2.9.1.1-6 Administrate MySQL over the WWW
ii phpsysinfo
2.5.1-6 PHP based host information

ultimate:~# dpkg -l |grep apache
ii apache
1.3.34-4.1 versatile, high-performance
HTTP server
ii apache-common
1.3.34-4.1 support files for all Apache
webservers
ii apache-utils
1.3.33-8 utility programs for webservers
(transitiona
ii apache2-mpm-prefork
2.2.3-4+etch3 Traditional model for Apache
HTTPD 2.1
ii apache2-utils
2.2.3-4+etch3 utility programs for webservers
ii apache2.2-common
2.2.3-4+etch3 Next generation, scalable,
extendable web se
ii libapache-mod-php4
4.4.4-8+etch4 server-side, HTML-embedded
scripting languag
ii webmin-apache
1.200-1 apache control module for webmin
ultimate:~#



Bonjour,

Ce problème m'est arrivé il n'y a pas longtemps. J'ai utilisé une sol ution
radicale pour ne pas me prendre la tête (et perdre trop de temps) :

- Suppression de tout les PHP avec l'option --purge
- Réinstallation de PHP5 et de tous les modules associés

C'est un peu bourrin mais bon, ça a marché :)

--
Jean-Michel Caricand
Tél: 03.81.66.20.63
E-mail:

Equipe systèmes
Laboratoire d'Informatique de l'Université de Franche-Comté
16, route de Gray - 25030 BESANÇON CEDEX
Publicité
Poster une réponse
Anonyme