probl

Le
Emmanuel Florac
J'essaie d'utiliser G'MIC ( http://gmic.sourceforge.net/ ) mais
impossible de rien en tirer ( Slack 13 32 bits ).

J'ai compilé fftw à la mimine, et installé, pas de problème. Ensuite
j'essaie le plugin précompilé du site : que dalle, pas grave je me dis
que je vais le compiler moi-même.

Donc je compile, impec, et ça marche pas. Il n'est pas listé dans les
plugins de GIMP. Pourtant tout semble correct :

$ arch
i686
$ ls -l .gimp-2.4/plug-ins/
total 2384
-rwxr-xr-x 1 emmanuel users 2381816 2010-02-16 18:43 gmic_gimp*
-rwxr-xr-x 1 emmanuel users 29812 2007-11-16 17:20 resynth*
-rwxr-xr-x 1 emmanuel users 24468 2007-10-29 15:13 variable-blur*
lrwxrwxrwx 1 emmanuel users 14 2009-05-20 19:44 xsane -> /usr/bin/xsane*
$ file .gimp-2.4/plug-ins/gmic_gimp
.gimp-2.4/plug-ins/gmic_gimp: ELF 32-bit LSB executable, Intel 80386,
version 1 (SYSV), dynamically linked (uses shared libs), stripped
$ ldd .gimp-2.4/plug-ins/gmic_gimp | grep -i "not found"
$ .gimp-2.4/plug-ins/gmic_gimp
.gimp-2.4/plug-ins/gmic_gimp is a GIMP plug-in and must be run by GIMP to
be used

Les autres plugins que j'ai installé manuellement marchent très bien,
eux Sur le forum le problème semble récurrent mais à chaque fois lié à
une erreur stupide (fichier non exécutable, mauvaise archi.). Dans mon
cas je ne comprends vraiment pas.


--
Quidquid latine dictum sit, altum sonatur
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Emmanuel Florac
Le #21211171
Le Tue, 16 Feb 2010 20:44:13 +0000, Emmanuel Florac a écrit:


Les autres plugins que j'ai installé manuellement marchent très bien,
eux... Sur le forum le problème semble récurrent mais à chaque fois lié
à une erreur stupide (fichier non exécutable, mauvaise archi....). Dans
mon cas je ne comprends vraiment pas.





J'ai trouvé : cet idiot de GIMP n'utilise que le dossier .gimp-2.x
correspondant à sa version, MAIS lors de la mise à jour il recopie les
plugins de l'ancienne version! Ceci explique que les plugins "customs"
que j'avais compilé pour la 2.4 fonctionnent : ils ont été recopiés
dans .gimp-2.6/plug-ins! recopié bien salement avec ça, parce que le lien
symbolique vers /usr/bin/xsane est carrément remplacé par le binaire de
xsane... bref... Il faut mettre dans .gimp-2.6 si on utilise GIMP 2.6
(j'avais même pas fait gaffe à la version...)

--
Quis, quid, ubi, quibus auxiliis, cur, quomodo, quando
jp willm
Le #21213251
Emmanuel Florac a écrit :


J'ai trouvé : cet idiot de GIMP n'utilise que le dossier .gimp-2.x
correspondant à sa version, MAIS lors de la mise à jour il recopie les
plugins de l'ancienne version!



Merci pour ce rappel (ajouter les plugin dans le .gimp-ma.version et les
infos utiles !

jp willm

--
http://perso.orange.fr/willms/index.html
Publicité
Poster une réponse
Anonyme