Probl

Le
La Bete des Vosges (Francis Chartier)
Bonjour

Soit deux macpros, un sous 10.6.8 (à l'origine installé en 10.6.3),
l'autre plus ancien en 10.5 passé récemment en 10.6.3 puis 10.6.8.

Sur les deux sont installés les mêmes files d'impression avec les mêmes
révisions de drivers (il s'agit des mêmes périphériques d'impression en
réseau)

Sur le premier, pas de souci, tout baigne.

Sur le second, problèmes d'impression suite à la mise à jour en Snow
Leopard : certaines fonctionnalités des drivers sont inaccessibles, ou
sans effet, certaines fenêtres de configuration ne s'affichent, pas, etc.

Pas de message d'erreur dans les logs, pas de problème à l'installation,
les permissions du volume sont ok.

J'ai purgé (réinitialisé) la configuration des préférences système pour
l'impression et tout réinstallé de zéro en partant des mêmes dmg que sur
l'autre macpro : même problème.

Pour info mais je ne pense pas que ça soit significatif, il s'agit du
Command Workstation 5.2 livré avec les RIP Fiery, d'une file d'impression
concernant une flasheuse ECRM SS36 (pas de driver, juste un PPD attaché à
une file RAW publiée sur un serveur CUPS), d'une file d'impression pour
une Epson Stylus Pro 7700, et des files d'impression pour un RIP Delta
8.0 Heidelberg pilotant un CTP.
La seule qui fonctionne correctement c'est la file d'une HP CP1525cn.

Dans la mesure où tout continue à fonctionner normalement sur les autres
postes (le premier mac pro, un G4 et 2 PC), le problème vient bien du
macpro mis à jour, mais je sèche vu l'absence d'erreur dans les logs.

Si quelqu'un a une idée sur quoi faire (hormis réinstaller tout le
système) ?

--
La Bête des Vosges
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacques Perrocheau
Le #23822111
In article "La Bete des Vosges (Francis Chartier)" wrote:

Bonjour

Soit deux macpros, un sous 10.6.8 (à l'origine installé en 10.6.3),
l'autre plus ancien en 10.5 passé récemment en 10.6.3 puis 10.6.8.

Sur les deux sont installés les mêmes files d'impression avec les mêmes
révisions de drivers (il s'agit des mêmes périphériques d'impression en
réseau)



Quel modèle d'imprimante ? type de pilotage, (Postscript,.. GutenPrint
version ? (GimPrint),...) ?

OK voir plus bas.

Sur le premier, pas de souci, tout baigne.

Sur le second, problèmes d'impression suite à la mise à jour en Snow
Leopard : certaines fonctionnalités des drivers sont inaccessibles, ou
sans effet, certaines fenêtres de configuration ne s'affichent, pas, etc.



Peux-tu être plus précis ?


Pas de message d'erreur dans les logs, pas de problème à l'installation,
les permissions du volume sont ok.

J'ai purgé (réinitialisé) la configuration des préférences système pour
l'impression et tout réinstallé de zéro en partant des mêmes dmg que sur
l'autre macpro : même problème.



C'est à dire, effacé les anciens services d'impression créés sous Mac OS
X 10.5.x et refait tout à neuf ?

Pour info mais je ne pense pas que ça soit significatif, il s'agit du
Command Workstation 5.2 livré avec les RIP Fiery, d'une file d'impression
concernant une flasheuse ECRM SS36 (pas de driver, juste un PPD attaché à
une file RAW publiée sur un serveur CUPS),



Est-ce que tu peux vérifier la version de GutenPrint qui tourne
effectivement ?


une Epson Stylus Pro 7700, et des files d'impression pour un RIP Delta
8.0 Heidelberg pilotant un CTP.



Il n'y aurait pas un pb 32 bit versus 64 bits pour des fonctionnalités
annexes de ces grosses machines, fonctionnalités contenues dans un
plug-in annexe (à chercher dans "/Library/Printers"), genre fichier
résiduel de l'ancienne installation sous Mac OS X 10.5 et qui ne serait
pas nettoyé par l'installateur plus récent.

On a le cas ici d'un copieur-imprimante Toshiba pour lequel il a fallu
attendre longtemps une mise à jour du pilotage pour un fonctionnement
complet sous Mac OS X 10.6.x.

La seule qui fonctionne correctement c'est la file d'une HP CP1525cn.



Sans doute parce que cette imprimante a un pilotage revu et corrigé pour
Mac OS X 10.6.x par Apple et à ma connaissance pas de fonctions
exotiques pris en charge dans un plug-in.

Dans la mesure où tout continue à fonctionner normalement sur les autres
postes (le premier mac pro, un G4 et 2 PC), le problème vient bien du
macpro mis à jour, mais je sèche vu l'absence d'erreur dans les logs.

Si quelqu'un a une idée sur quoi faire (hormis réinstaller tout le
système...) ?



--
Jacques PERROCHEAU
CNRS UMR 6226
Université de Rennes 1, Campus de Beaulieu, 35042 RENNES Cedex, France
La Bete des Vosges (Francis Chartier)
Le #23822571
Le Tue, 04 Oct 2011 18:42:42 +0200, Jacques Perrocheau a écrit :

Sur le second, problèmes d'impression suite à la mise à jour en Snow
Leopard : certaines fonctionnalités des drivers sont inaccessibles, ou
sans effet, certaines fenêtres de configuration ne s'affichent, pas,
etc.



Peux-tu être plus précis ?



Oui, mais je crains qu'on se perde dans des détails inutiles si vous
n'avez pas le même soft, mais bon.
.
Par exemple dans les réglages d'impression du Fiery (installé avec le
Command Workstation 5.2), le bouton libellé "Personnalisation Imprimante"
qui permet de choisir le type de réglages avancés accessibles n'affiche
aucune fenêtre. Normalement ça ouvre une fenêtre permettant d'accèder à
une trentaine de réglages genre "type de papiers, contrôle des encrages,
gestion des bacs, détection de la couleur du papier, etc).

Si je lance le client Fiery j'ai accès à tous ces réglages directement
sur le RIP, c'est a priori la partie driver sur le Mac qui déconne, comme
si un plugin ou une bibliothèque nécessaire ne se charge pas, ou est
manquant.


J'ai purgé (réinitialisé) la configuration des préférences système pour
l'impression et tout réinstallé de zéro en partant des mêmes dmg que
sur l'autre macpro : même problème.



C'est à dire, effacé les anciens services d'impression créés sous Mac OS
X 10.5.x et refait tout à neuf ?



Préférences système, Imprimantes, bouton droit dans la liste
"réinitialiser le système d'impression".
Ca efface toutes les imprimantes configurées.
J'ai ensuite tout réinstallé.


Pour info mais je ne pense pas que ça soit significatif, il s'agit du
Command Workstation 5.2 livré avec les RIP Fiery, d'une file
d'impression concernant une flasheuse ECRM SS36 (pas de driver, juste
un PPD attaché à une file RAW publiée sur un serveur CUPS),



Est-ce que tu peux vérifier la version de GutenPrint qui tourne
effectivement ?



Je ferai ça demain, mais il me semble avoir justement vérifié que j'avais
bien les mêmes versions. Je revérifierai.

une Epson Stylus Pro 7700, et des files d'impression pour un RIP Delta
8.0 Heidelberg pilotant un CTP.



Il n'y aurait pas un pb 32 bit versus 64 bits pour des fonctionnalités
annexes de ces grosses machines, fonctionnalités contenues dans un
plug-in annexe (à chercher dans "/Library/Printers"), genre fichier
résiduel de l'ancienne installation sous Mac OS X 10.5 et qui ne serait
pas nettoyé par l'installateur plus récent.



Possible, mais justement le nouveau MacPro tourne en 64 bits (8Go de ram)
alors que l'ancien qui pose problème est en 32 bits de mémoire (4 Go).
Si c'était un problème du à des drivers 32 bists ça serait plutôt sur le
nouveau je pense, non ?

Bon, je vais faire du ménage sous terminal et tester en recopiant les
librairies du nouveau, pour voir si je pète tout ou si ça va mieux. :)


On a le cas ici d'un copieur-imprimante Toshiba pour lequel il a fallu
attendre longtemps une mise à jour du pilotage pour un fonctionnement
complet sous Mac OS X 10.6.x.




Bon, second round d'observation demain, merci des suggestions.



--
La Bête des Vosges
xavier
Le #23822851
La Bete des Vosges (Francis Chartier) wrote:

Préférences système, Imprimantes, bouton droit dans la liste
"réinitialiser le système d'impression".
Ca efface toutes les imprimantes configurées.
J'ai ensuite tout réinstallé.



Je n'ose pas te le proposer, c'est mal vu ici, mais Onyx a une commande
pour réinitialiser *tout CUPS*

--
XAv
In your pomp and all your glory you're a poorer man than me,
as you lick the boots of death born out of fear.
(Jethro Tull)
La Bete des Vosges (Francis Chartier)
Le #23822841
Le Tue, 04 Oct 2011 19:56:15 +0200, Xavier a écrit :

Je n'ose pas te le proposer, c'est mal vu ici, mais Onyx a une commande
pour réinitialiser *tout CUPS*



Ah ben j'ai pourtant passé Onyx, mais j'ai raté ça. Merci du tuyau, je
regarderai demain.

--
La Bête des Vosges
Jacques Perrocheau
Le #23826311
In article "La Bete des Vosges (Francis Chartier)" wrote:

> Il n'y aurait pas un pb 32 bit versus 64 bits pour des fonctionnalités
> annexes de ces grosses machines, fonctionnalités contenues dans un
> plug-in annexe (à chercher dans "/Library/Printers"), genre fichier
> résiduel de l'ancienne installation sous Mac OS X 10.5 et qui ne serait
> pas nettoyé par l'installateur plus récent.

Possible, mais justement le nouveau MacPro tourne en 64 bits (8Go de ram)
alors que l'ancien qui pose problème est en 32 bits de mémoire (4 Go).



AMHA La quantité de RAM ne présume pas le démarrage en mode 64 ou 32
bits du noyau si le hardware supporte le 64 bits. (?)


Si c'était un problème du à des drivers 32 bists ça serait plutôt sur le
nouveau je pense, non ?



Ou l'inverse si le nouvel installateur de l'imprimante n'a que la
version 64 bits des plug-ins (surprenant, mais...) alors que cette
machine démarre le noyau en 32 bits.


Bon, je vais faire du ménage sous terminal et tester en recopiant les
librairies du nouveau, pour voir si je pète tout ou si ça va mieux. :)



--
Jacques PERROCHEAU
CNRS UMR 6226
Université de Rennes 1, Campus de Beaulieu, 35042 RENNES Cedex, France
Publicité
Poster une réponse
Anonyme