Problème AHCI

Le
Xavier Couture
Sous Windows 7 (carte mère Gigabyte P55-UD4) j'ai remarqué que l'AHCI
n'était pas mis dans le Bios. A la place c'est IDE. J'ai donc mis l'AHCI
pour 3 options : Sata, e-Sata et G-Sata. Impossible alors de démarrer
windows et l'utilitaire de résolution de problème ne trouve rien. J'ai eu la
chance après le 3ème ou 4ème redémarrage de pouvoir retourner dans le bios
et j'ai donc tout remis en IDE.
D'où quelques questions : l'AHCI est-il indispensable pour la commande Trim
des SSD sous windows 7 (j'ai un SSD à contrôleur Indilinx)? L'absence du
AHCI pourrait-il expliquer mes problèmes de plantage au retour d'une veille
prolongée? Comment doit-on configurer le bios à cet égard?

Merci
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
tintheo
Le #21312531
Hello,

non l'AHCI n'est pas indispensable pour la commande "TRIM" l'IDE fait aussi
bien l'affaire, par contre pour bénéficier du "TRIM" il est actuellement
indispensable de conserver sur le contrôleur disque les drivers natifs de
Microsoft à l'install de win 7, les drivers INTEL pour contrôleurs disque ne
sont à ce jour (et à ma connaissance) pas encore compatible "TRIM"

Il est par ailleurs normal que si tu as fait ton install de win 7 en mode
"IDE" et que après coup tu bascules en AHCI tu ais des BSOD, là aussi tu
peux modifier après coup mais moyennant certaines manip dans le registre...
Tu trouveras sur google => "IDE vers AHCI"

Selon la marque et le Firmware de ton SSD tu peux avoir un léger avantage à
être en AHCI en tout cas je dirais oui avec un contrôleur "Indilinx
Barefoot" et dernier firmware à jour, mais là je ne peux t'en dire plus ne
connaissant pas ton matériel...


Cordialement, tintheo

"Xavier Couture" discussion : 4b8f4e5c$0$17861$
Sous Windows 7 (carte mère Gigabyte P55-UD4) j'ai remarqué que l'AHCI
n'était pas mis dans le Bios. A la place c'est IDE. J'ai donc mis l'AHCI
pour 3 options : Sata, e-Sata et G-Sata. Impossible alors de démarrer
windows et l'utilitaire de résolution de problème ne trouve rien. J'ai eu
la chance après le 3ème ou 4ème redémarrage de pouvoir retourner dans le
bios et j'ai donc tout remis en IDE.
D'où quelques questions : l'AHCI est-il indispensable pour la commande
Trim des SSD sous windows 7 (j'ai un SSD à contrôleur Indilinx)? L'absence
du AHCI pourrait-il expliquer mes problèmes de plantage au retour d'une
veille prolongée? Comment doit-on configurer le bios à cet égard?

Merci
Robin des Bois
Le #21312661
L_O,

tintheo a exposé le 04/03/2010 :

non l'AHCI n'est pas indispensable pour la commande "TRIM" l'IDE fait aussi
bien l'affaire, par contre pour bénéficier du "TRIM" il est actuellement
indispensable de conserver sur le contrôleur disque les drivers natifs de
Microsoft à l'install de win 7, les drivers INTEL pour contrôleurs disque ne
sont à ce jour (et à ma connaissance) pas encore compatible "TRIM"



Ca sert à quoi avec des disques SATA?
C'est une question que je me pose depuis longtemps.
Mes disques SATA sont configurés en IDE dans le bios, mais j'ai
d'autres options dont le fameux AHCI...
Merci.

--
Cordialement à tous, @+ et grand V
Robin des Bois, Adventurer

http://philippecharreire.fr/
Xavier Couture
Le #21312771
Hello,

non l'AHCI n'est pas indispensable pour la commande "TRIM" l'IDE fait
aussi bien l'affaire, par contre pour bénéficier du "TRIM" il est
actuellement indispensable de conserver sur le contrôleur disque les
drivers natifs de Microsoft à l'install de win 7, les drivers INTEL pour
contrôleurs disque ne sont à ce jour (et à ma connaissance) pas encore
compatible "TRIM"




Et comment savoir si ce sont bien les drivers natifs? A priori c'est le cas
vu que j'ai rien changé à ce niveau.

Il est par ailleurs normal que si tu as fait ton install de win 7 en mode
"IDE" et que après coup tu bascules en AHCI tu ais des BSOD, là aussi tu
peux modifier après coup mais moyennant certaines manip dans le
registre... Tu trouveras sur google => "IDE vers AHCI"




Je crois que c'est aussi une question de version du bios. Il faudrait
peut-être que je le flashe.

Selon la marque et le Firmware de ton SSD tu peux avoir un léger avantage
à être en AHCI en tout cas je dirais oui avec un contrôleur "Indilinx
Barefoot" et dernier firmware à jour, mais là je ne peux t'en dire plus ne
connaissant pas ton matériel...



Mon SSD c'est un G.skill falcon 128 Go, version 1.

Merci en tout cas pour toutes ces infos.
tintheo
Le #21315141
Hello,

Le mode AHCI permet d'exploiter les fonctionnalités de l'interface SATA, le
NCQ (Native Command Queuing) ou encore le Hot Plug...

Avec le NCQ, le disque dur peut recevoir plus d'une requête entrées/sorties
à la fois et décider le meilleur ordre pour effectuer les opérations. Cela
réduit la quantité de recherches inutiles des têtes de lecture, et entraîne
une amélioration des performances ainsi qu'une usure légèrement moindre du
disque.

Le Hot Plug, permet de brancher et de débrancher à chaud un disque dur SATA.

les gains apportés par le mode AHCI sont bien présents. Le taux de transfert
lors du chargement des applications ou du démarrage de Windows peut
progresser de 10 à 20% ( source: TTHardware)

Cordialement, tintheo

"Robin des Bois" de discussion : 4b8fa35d$0$15816$
L_O,

tintheo a exposé le 04/03/2010 :

non l'AHCI n'est pas indispensable pour la commande "TRIM" l'IDE fait
aussi bien l'affaire, par contre pour bénéficier du "TRIM" il est
actuellement indispensable de conserver sur le contrôleur disque les
drivers natifs de Microsoft à l'install de win 7, les drivers INTEL pour
contrôleurs disque ne sont à ce jour (et à ma connaissance) pas encore
compatible "TRIM"



Ca sert à quoi avec des disques SATA?
C'est une question que je me pose depuis longtemps.
Mes disques SATA sont configurés en IDE dans le bios, mais j'ai d'autres
options dont le fameux AHCI...
Merci.

--
Cordialement à tous, @+ et grand V
Robin des Bois, Adventurer

http://philippecharreire.fr/


tintheo
Le #21315131
"Xavier Couture" discussion : 4b8fa662$0$17882$

Et comment savoir si ce sont bien les drivers natifs? A priori c'est le
cas vu que j'ai rien changé à ce niveau.




oui, très certainement: si tu as toi même procéder à l'install de win 7 et
que tu n'as pas mis à jour tes drivers contrôleurs Intel avec par exemple
ceux présent sur le cd de ta carte mère, alors tu as bien les drivers natifs
Microsoft.

Ou alors, tu n'as pas procéder toi même à l'install de win 7, donc pour le
savoir:

clic droit sur "Ordinateur"=> propriétés=> gestionnaire de
périphériques=>Lecteurs de disques=> propriétés de ton disque=> onglet
Pilote=> fournisseur du pilote, si le fournisseur est Microsoft, alors tu as
les drivers natifs de Win 7 ( cette solution est préconisée pour bénéficier
des avantages du TRIM ), et dans le cas où le "Fournisseur du pilote est
Intel, et bien les drivers spécifiques à ton contrôleur et actuellement non
compatible avec la fonction TRIM, ont été installés...

Je crois que c'est aussi une question de version du bios. Il faudrait
peut-être que je le flashe.



Pas nécessairement, car d'après ton 1er post, tu as le choix entre l'IDE et
l'AHCI dans ton bios...




Mon SSD c'est un G.skill falcon 128 Go, version 1.



Je te suggère de de vérifier la version de ton firmware et d'aller faire 1
tour ici => http://gskill.us/forum/showthread.php?t‚0 , afin de vérifier
si tu es à jour de ce côté...


Merci en tout cas pour toutes ces infos.




De rien ;)


Cordialement, tintheo
Robin des Bois
Le #21315281
tintheo avait soumis l'idée :

les gains apportés par le mode AHCI sont bien présents. Le taux de transfert
lors du chargement des applications ou du démarrage de Windows peut
progresser de 10 à 20% ( source: TTHardware)



Merci beaucoup, je vais voir demain si je peux repasser en AHCI sans
problèmes.

--
Cordialement à tous, @+ et grand V
Robin des Bois, Adventurer

http://philippecharreire.fr/
Robin des Bois
Le #21315791
tintheo a formulé ce jeudi :

les gains apportés par le mode AHCI sont bien présents. Le taux de transfert
lors du chargement des applications ou du démarrage de Windows peut
progresser de 10 à 20% ( source: TTHardware)



Impossible à installer chez moi, CM Asus PLD2, XP Pro.
1- impossible d'installer le driver depuis XP:

Drver AHCI_IATA89CD.exe

(votre système ne le suporte pas????????????????????,,) ce que je ne
comprends pas puisque je n'ai que des disques durs SATA installés, et
aucun en raid.
2- si modif depuis le bios sans avoir changé le driver, alors écran
bleu au démarrage de XP.

--
Cordialement à tous, @+ et grand V
Robin des Bois, Adventurer

http://philippecharreire.fr/
Xavier Couture
Le #21316891
clic droit sur "Ordinateur"=> propriétés=> gestionnaire de
périphériques=>Lecteurs de disques=> propriétés de ton disque=> onglet
Pilote=> fournisseur du pilote, si le fournisseur est Microsoft, alors tu
as les drivers natifs de Win 7 ( cette solution est préconisée pour
bénéficier des avantages du TRIM ), et dans le cas où le "Fournisseur du
pilote est Intel, et bien les drivers spécifiques à ton contrôleur et
actuellement non compatible avec la fonction TRIM, ont été installés...



C'est bon! Mais ils sont pas récents les pilotes Microsoft de mes disques :
2006!

Pas nécessairement, car d'après ton 1er post, tu as le choix entre l'IDE


et
l'AHCI dans ton bios...

Mon SSD c'est un G.skill falcon 128 Go, version 1.



Je te suggère de de vérifier la version de ton firmware et d'aller faire 1
tour ici => http://gskill.us/forum/showthread.php?t‚0 , afin de vérifier
si tu es à jour de ce côté...



J'avais évité jusqu'à maintenant parce qu'à lire certains témoignages c'est
encore plus dangereux de mettre à jour le firmware d'un SSD que de flasher
un bios.
tintheo
Le #21317031
"Robin des Bois" de discussion : 4b8ff617$0$15827$

Impossible à installer chez moi, CM Asus PLD2, XP Pro.
1- impossible d'installer le driver depuis XP:

Drver AHCI_IATA89CD.exe

(votre système ne le suporte pas????????????????????,,) ce que je ne
comprends pas puisque je n'ai que des disques durs SATA installés, et
aucun en raid.
2- si modif depuis le bios sans avoir changé le driver, alors écran bleu
au démarrage de XP.



bonsoir,

oui, c'est normal, si tu es sur XP installé en mode "compatible IDE" c'est 1
choix que tu as fais en indiquant au système ( bios) un fonctionnement
"standard" donc pour modifier le mode standard (compatible) au mode
spécifique (AHCI) cela impose une toute autre procédure qu'une "simple"
install du driver directement depuis l'OS, donc 2 solutions: ( différente
selon l'OS: vista possible depuis une clé USB, et win 7 avec 1 "simple modif
du registre)

Alors, au choix:

1- tu réinstalles win XP, dans le bios de la carte mère tu actives le mode
AHCI, tu colles les drivers contrôleurs AHCI de ta carte mère sur 1
disquette, et au moment où win te demande si tu veux installer des drivers
spécifiques tu appuies sur la touche "F6" et le système installera tes
drivers AHCI depuis la disquette, puis continuera l'install...

2- autre méthode qui évite une réinstall, je l'ai déjà utilisé et cela
fonctionne, tu suis la méthode décrite ici =>
http://www.tt-hardware.com/test/hardware/passer-en-ahci-vraiment-la-galere

voilà, bon courage...

cordialement, tintheo
tintheo
Le #21317161
Bonsoir,

oui, je comprends ta crainte, mais regardes bien sur le forum de support de
G.skill la procédure, et demande conseil auprès de leur support...

les différentes upgrades de firmware sont justifiées par la correction de
bugs et l'amélioration de la compatibilité du support du TRIM spécifiquement
(je suppose) avec win 7, donc je suppose aussi ( j'espère) que le flashage
ne remet pas à zéro ton SDD, mais dans le doute 1ère chose à faire 1 backup
!

Personnellement, mes flashages de SSD ( OCZ) se sont toujours bien déroulés,
bien respecter par contre certains points: pour effectuer l'opération le
bios doit être en mode "IDE" et le SSD connecté sur le port sata 0 de ta
carte mère.


P.S: un bon moyen simple de vérifier si le trim fonctionne est de contrôler
si les débits en écritures sont stables dans le temps, c'est à dire qu'ils
ne diminuent pas avec le temps.

Pour savoir si tu as le trim activé sous win7, tu passes en lignes de
commandes (démarrer=>exécuter=> "cmd" puis tu tapes:

"fsutil behavior query DisableDeleteNotify"


DisableDeleteNotify = 1 ( le TRIM est desactivé)
DisableDeleteNotify = 0 (le TRIM est activé)

Voilà, bon courage

cordialement, tintheo


Mon SSD c'est un G.skill falcon 128 Go, version 1.



Je te suggère de de vérifier la version de ton firmware et d'aller faire
1 tour ici => http://gskill.us/forum/showthread.php?t‚0 , afin de
vérifier si tu es à jour de ce côté...



J'avais évité jusqu'à maintenant parce qu'à lire certains témoignages
c'est encore plus dangereux de mettre à jour le firmware d'un SSD que de
flasher un bios.


Publicité
Poster une réponse
Anonyme