Problème avec du 32 bits

Le
Philippe Delavalade
Bonjour la liste.

J'utilisais autrefois le logiciel mupad ; j'en ai une vieille version (une
dizaine d'années je pense). C'était écrit en 32 bits.

Je ne me souviens plus de quand je l'ai utilisé pour la dernière fois mais
aujourd'hui ça ne fonctionne pas ; je suis sous debian testing avec le
noyau 3.12-1-amd64 (et j'imagine que le problème vient de là, enfin les 64
bits).

Lorsque je lance mupad j'obtiens une erreur 127

/usr/local/mupad/share/bin/mupad: 102: exec:
/usr/local/mupad/linux/bin/mupad:
not found

Or cet exécutable est bien à l'endroit cherché.

En fait /usr/local/mupad/share/bin/mupad est un script dont la ligne 102
est la suivante :

exec $MuPAD_BIN/mupad -l $MuPAD_LIB -m $MuPAD_MOD -h $MuPAD_HELP "$@"

Les variables d'environnement sont correctes mais un 'file -s' sur ce
fameux /usr/local/mupad/linux/bin/mupad
me répond :

mupad: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV),
dynamically linked (uses shared libs), for GNU/Linux 2.0.30, stripped

J'ai le même genre de réponses avec les éléments de
/usr/local/mupad/linux/lib

Il me semble pourtant avoir fait tourner mupad depuis que je suis passé en
64 bits mais je ne peux pas l'affirmer.

Je crois me souvenir avoir eu ce genre de souci avec un autre programme et
que j'avais résolu ça en installant un paquet qui devait avoir un nom du
genre ia32-quelquechose mais il n'est plus sur ma machine et je ne le
retrouve pas avec apt-cache.

Merci d'avance pour toute aide.

--
Ph. Delavalade

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20140128164230.GA10883@magellan
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
aishen
Le #25959532
ia32lib
Le 28/01/2014 17:42, Philippe Delavalade a écrit :
Bonjour la liste.

J'utilisais autrefois le logiciel mupad ; j'en ai une vieille version (une
dizaine d'années je pense). C'était écrit en 32 bits.

Je ne me souviens plus de quand je l'ai utilisé pour la dernière fois mais
aujourd'hui ça ne fonctionne pas ; je suis sous debian testing avec le
noyau 3.12-1-amd64 (et j'imagine que le problème vient de là, enfin les 64
bits).

Lorsque je lance mupad j'obtiens une erreur 127

/usr/local/mupad/share/bin/mupad: 102: exec:
/usr/local/mupad/linux/bin/mupad:
not found

Or cet exécutable est bien à l'endroit cherché.

En fait /usr/local/mupad/share/bin/mupad est un script dont la ligne 102
est la suivante :

exec $MuPAD_BIN/mupad -l $MuPAD_LIB -m $MuPAD_MOD -h $MuPAD_HELP "$@"

Les variables d'environnement sont correctes mais un 'file -s' sur ce
fameux /usr/local/mupad/linux/bin/mupad
me répond :

mupad: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV),
dynamically linked (uses shared libs), for GNU/Linux 2.0.30, stripped

J'ai le même genre de réponses avec les éléments de
/usr/local/mupad/linux/lib

Il me semble pourtant avoir fait tourner mupad depuis que je suis passé en
64 bits mais je ne peux pas l'affirmer.

Je crois me souvenir avoir eu ce genre de souci avec un autre programme et
que j'avais résolu ça en installant un paquet qui devait avoir un nom du
genre ia32-quelquechose mais il n'est plus sur ma machine et je ne le
retrouve pas avec apt-cache.

Merci d'avance pour toute aide.




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
aishen
Le #25959602
mupad fonctionne bien sur trusty 64 bits je viens de l'essayer : version
4.0.6 c'est matlab qui l'a repris.
Le 28/01/2014 18:23, aishen a écrit :
ia32lib
Le 28/01/2014 17:42, Philippe Delavalade a écrit :
Bonjour la liste.

J'utilisais autrefois le logiciel mupad ; j'en ai une vieille version
(une
dizaine d'années je pense). C'était écrit en 32 bits.

Je ne me souviens plus de quand je l'ai utilisé pour la dernière fois
mais
aujourd'hui ça ne fonctionne pas ; je suis sous debian testing avec le
noyau 3.12-1-amd64 (et j'imagine que le problème vient de là, enfin
les 64
bits).

Lorsque je lance mupad j'obtiens une erreur 127

/usr/local/mupad/share/bin/mupad: 102: exec:
/usr/local/mupad/linux/bin/mupad:
not found

Or cet exécutable est bien à l'endroit cherché.

En fait /usr/local/mupad/share/bin/mupad est un script dont la ligne 102
est la suivante :

exec $MuPAD_BIN/mupad -l $MuPAD_LIB -m $MuPAD_MOD -h $MuPAD_HELP "$@"

Les variables d'environnement sont correctes mais un 'file -s' sur ce
fameux /usr/local/mupad/linux/bin/mupad
me répond :

mupad: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV),
dynamically linked (uses shared libs), for GNU/Linux 2.0.30, stripped

J'ai le même genre de réponses avec les éléments de
/usr/local/mupad/linux/lib

Il me semble pourtant avoir fait tourner mupad depuis que je suis
passé en
64 bits mais je ne peux pas l'affirmer.

Je crois me souvenir avoir eu ce genre de souci avec un autre
programme et
que j'avais résolu ça en installant un paquet qui devait avoir un nom du
genre ia32-quelquechose mais il n'est plus sur ma machine et je ne le
retrouve pas avec apt-cache.

Merci d'avance pour toute aide.







--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Guy Roussin
Le #25959592
Bonsoir,

Vérifie que le multiarch avec i386 est bien installé ...
https://wiki.debian.org/Multiarch/HOWTO

Guy

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Philippe Delavalade
Le #25960052
Le mardi 28 janvier à 18:29, aishen a écrit :
mupad fonctionne bien sur trusty 64 bits je viens de l'essayer :
version 4.0.6 c'est matlab qui l'a repris.



Moi j'ai la 3.11 qui date :-) Je verrai ça demain.

Merci.

--
Ph. Delavalade

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Philippe Delavalade
Le #25960032
Le mardi 28 janvier à 18:39, Guy Roussin a écrit :
Bonsoir,

Vérifie que le multiarch avec i386 est bien installé ...
https://wiki.debian.org/Multiarch/HOWTO



Je pense que c'est bon mais demain je vérifierai de façon approfondie.

Merci.

--
Ph. Delavalade

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Philippe Delavalade
Le #25960042
Le mardi 28 janvier à 18:23, aishen a écrit :
ia32lib



Ça ne se fait plus en testing ; j'avais bien sûr commencé par là.

Le 28/01/2014 17:42, Philippe Delavalade a écrit :
>Bonjour la liste.
>
>J'utilisais autrefois le logiciel mupad ; j'en ai une vieille version (une
>dizaine d'années je pense). C'était écrit en 32 bits.
>
>Je ne me souviens plus de quand je l'ai utilisé pour la dernière fois mais
>aujourd'hui ça ne fonctionne pas ; je suis sous debian testing avec le
>noyau 3.12-1-amd64 (et j'imagine que le problème vient de là, enfin les 64
>bits).
>
>Lorsque je lance mupad j'obtiens une erreur 127
>
>/usr/local/mupad/share/bin/mupad: 102: exec:
>/usr/local/mupad/linux/bin/mupad:
>not found
>
>Or cet exécutable est bien à l'endroit cherché.
>
>En fait /usr/local/mupad/share/bin/mupad est un script dont la ligne 102
>est la suivante :
>
>exec $MuPAD_BIN/mupad -l $MuPAD_LIB -m $MuPAD_MOD -h $MuPAD_HELP "$@"
>
>Les variables d'environnement sont correctes mais un 'file -s' sur ce
>fameux /usr/local/mupad/linux/bin/mupad
>me répond :
>
>mupad: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV),
>dynamically linked (uses shared libs), for GNU/Linux 2.0.30, stripped
>
>J'ai le même genre de réponses avec les éléments de
>/usr/local/mupad/linux/lib
>
>Il me semble pourtant avoir fait tourner mupad depuis que je suis passé en
>64 bits mais je ne peux pas l'affirmer.
>
>Je crois me souvenir avoir eu ce genre de souci avec un autre programme et
>que j'avais résolu ça en installant un paquet qui devait avoir un nom du
>genre ia32-quelquechose mais il n'est plus sur ma machine et je ne le
>retrouve pas avec apt-cache.
>
>Merci d'avance pour toute aide.
>

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/




--
Ph. Delavalade

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Philippe Delavalade
Le #25961142
Le mardi 28 janvier à 18:29, aishen a écrit :
mupad fonctionne bien sur trusty 64 bits je viens de l'essayer :
version 4.0.6 c'est matlab qui l'a repris.



J'ai cherché sur gogol mais rien trouvé de gratuit ou de libre :-) Ma
vieille version était gratuite.

Si vous en savez plus, je suis évidemment preneur.

Cordialement.

--
Ph. Delavalade

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Philippe Delavalade
Le #25961132
Le mardi 28 janvier à 18:39, Guy Roussin a écrit :
Bonsoir,

Vérifie que le multiarch avec i386 est bien installé ...
https://wiki.debian.org/Multiarch/HOWTO



Je viens de jeter un œil à ce « howto » mais si j'ai bien compris, ça ne
concerne que les paquets .deb et mupad était en tarball.

Cordialement.

--
Ph. Delavalade

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Lorenzo Bernardi
Le #25961232
On 01/29/2014 03:50 PM, Philippe Delavalade wrote:
Le mardi 28 janvier à 18:39, Guy Roussin a écrit :
Bonsoir,

Vérifie que le multiarch avec i386 est bien installé ...
https://wiki.debian.org/Multiarch/HOWTO


Je viens de jeter un œil à ce « howto » mais si j'ai bien compris, ça ne
concerne que les paquets .deb et mupad était en tarball.


oui mais je pense qu'il faut quand meme passer en multiarch. J'avais eu
un probleme incomprehensible de ce genre et ca c'est resolu en
installant le paquet lsb. Le truc surprenant c'est le nombre de paquets
associes a celui la.

mes 2cents

L.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Philippe Delavalade
Le #25961212
Le mercredi 29 janvier à 16:31, Lorenzo Bernardi a écrit :
On 01/29/2014 03:50 PM, Philippe Delavalade wrote:
>Le mardi 28 janvier à 18:39, Guy Roussin a écrit :
>>Bonsoir,
>>
>>Vérifie que le multiarch avec i386 est bien installé ...
>>https://wiki.debian.org/Multiarch/HOWTO
>Je viens de jeter un œil à ce « howto » mais si j'ai bien compris, ça ne
>concerne que les paquets .deb et mupad était en tarball.
oui mais je pense qu'il faut quand meme passer en multiarch. J'avais
eu un probleme incomprehensible de ce genre et ca c'est resolu en
installant le paquet lsb. Le truc surprenant c'est le nombre de
paquets associes a celui la.



Je viens de faire ça et maintenant ça refonctionne !
Avant 'avis rajouté l'architecture i386.

Grand merci. Je suis bien heureux de retrouver ce mupad que je préfère à
maxima (qui aurait fait l'affaire malgré tout).

--
Ph. Delavalade

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme