Probleme avec macro

Le
Sim
Bonjour a tous ,

J'ai la macro suivante :

Sub desactiver()
Cells(ActiveCell.Row, 1).Select
ActiveCell.Offset(0, 9).Cut Destination:¬tiveCell.Offset(0, 69)
Range(ActiveCell.Offset(0, 6), ActiveCell.Offset(0,
6)).EntireRow.Font.Strikethrough = True
end sub

Si j'execute la macro suivante une fois sa prend environ 1 sec si je la
lance un autre fois 2 sec un autre 3 sec etc et sa devient de plus
en plus long avant d'executer la macro.

Pour regler le probleme je doit fermer mon excel et le reallumer ce qui
n'est pas vraiment pratique

Quelqu'un aurait une iddée pk sa me fait ce probleme :(

Si je l'execute pas a pas c'est la ActiveCell.Offset(0, 9).Cut
Destination:¬tiveCell.Offset(0, 69) que sa dure un éterniter !!!

Merci a tous pour votre aide.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ninbihan
Le #4467241
Bonsoir,

J'ai essayé cela ne se produit pas chez moi, néanmoins, essaie cela
Sub desactiver()
Cells(ActiveCell.Row, 1).Offset(0, 9).Cut Destination:¬tiveCell.Offset(0,
69)
ActiveCell.EntireRow.Font.Strikethrough = True
End Sub



"Sim"
Bonjour a tous ,

J'ai la macro suivante :

Sub desactiver()
Cells(ActiveCell.Row, 1).Select
ActiveCell.Offset(0, 9).Cut Destination:¬tiveCell.Offset(0, 69)
Range(ActiveCell.Offset(0, 6), ActiveCell.Offset(0,
6)).EntireRow.Font.Strikethrough = True
end sub

Si j'execute la macro suivante une fois sa prend environ 1 sec ... si je
la lance un autre fois 2 sec ... un autre 3 sec etc ... et sa devient de
plus en plus long avant d'executer la macro.

Pour regler le probleme je doit fermer mon excel et le reallumer ce qui
n'est pas vraiment pratique

Quelqu'un aurait une iddée pk sa me fait ce probleme :(

Si je l'execute pas a pas c'est la ActiveCell.Offset(0, 9).Cut
Destination:¬tiveCell.Offset(0, 69) que sa dure un éterniter !!!

Merci a tous pour votre aide.




Publicité
Poster une réponse
Anonyme