Problème avec la sytaxe nom de champ

Le
flomen
Bonjour,
J'ai récupérer une base Access avec des tables dont le nom des champs
comportent des blancs. exemple
If AV![N° tel domicile] <> "" Then Debug.Print "Test"
Quand j'execute le code vba, j'ai une erreur qui me dit que le champ
n'existe pas dans la collection.
Qu'elle est la sytaxe d'écriure à respecter pour ce type de champ?
Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
3stone
Le #6361551
Salut,

"flomen"
| J'ai récupérer une base Access avec des tables dont le nom des champs
| comportent des blancs.


Tu veux dire que des champs sont vides ou non renseignés ? ;-)



| exemple
| If AV![N° tel domicile] <> "" Then Debug.Print "Test"
| Quand j'execute le code vba, j'ai une erreur qui me dit que le champ
| n'existe pas dans la collection.
| Qu'elle est la sytaxe d'écriure à respecter pour ce type de champ?

Tu as placé ce code à quel endroit ?

"AV" c'est la table ? dans le formulaire, on ne s'occupe pas de la table,
mais de la source du formulaire...

If isnull( Me![N° tel domicile] ) then Debug.Print "rien"

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
flomen
Le #6361531
Merci
Effectivement c'est bien comme ça qu'il faut l'érire, j'était un peu
fatiqué, merci pour la rapidité de ta réponse
Cependant, j'ai une autre question, depuis un certain temps je n'arrive pas
à poser de question dans ce forum, je clic sur Question et il ne se passe
rien !, je suis obligé de passer par le site :
http://officesystemaccess.seneque.net/
puis sur forum et là ça marche
As-tu une idée ?


Salut,

"flomen"
| J'ai récupérer une base Access avec des tables dont le nom des champs
| comportent des blancs.


Tu veux dire que des champs sont vides ou non renseignés ? ;-)



| exemple
| If AV![N° tel domicile] <> "" Then Debug.Print "Test"
| Quand j'execute le code vba, j'ai une erreur qui me dit que le champ
| n'existe pas dans la collection.
| Qu'elle est la sytaxe d'écriure à respecter pour ce type de champ?

Tu as placé ce code à quel endroit ?

"AV" c'est la table ? dans le formulaire, on ne s'occupe pas de la table,
mais de la source du formulaire...

If isnull( Me![N° tel domicile] ) then Debug.Print "rien"

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)




3stone
Le #6361501
Salut "flomen",

"flomen"
[...]
| Cependant, j'ai une autre question, depuis un certain temps je n'arrive pas
| à poser de question dans ce forum, je clic sur Question et il ne se passe
| rien !, je suis obligé de passer par le site :
| http://officesystemaccess.seneque.net/
| puis sur forum et là ça marche
| As-tu une idée ?

Etant donné que MS veux faire basculer tout le monde sur des forum web,
ils ont (entre autre) coupé l'entrée par CDO vers les newsgroups...

Tu devrais utiliser un "lecteur de news" pour lire les newsgroups.
C'est le jour et la nuit par rapport à une entrée web !!!

Comme lecteur de news, tu peux utiliser

- Outlook Express (qui fait les deux en fait - émail et news ;-)
- MesNews qui est excellent http://www.mesnews.net/

Pour venir ici avec OE (Outlook Express), il suffit d'aller à cette page
http://www.mpfa.info/articles.php?lng=fr&pg=5 et de cliquer sur
le lien "connecter immédiatement" pour arriver directement sur les
serveurs MS et le NG Access ;-))

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
Docteur Jekyll
Le #6348951
Merci à tous, mais c'était bien une faute de nom de mon sf.

Maintenant j'ai un autre problème.
VraiFaux([sf.form.[champ estnull;o;sf.form.champ)

Ca ne marche pas.
*
Merci

"3stone"
Salut "flomen",

"flomen"
[...]
| Cependant, j'ai une autre question, depuis un certain temps je n'arrive
pas
| à poser de question dans ce forum, je clic sur Question et il ne se
passe
| rien !, je suis obligé de passer par le site :
| http://officesystemaccess.seneque.net/
| puis sur forum et là ça marche
| As-tu une idée ?

Etant donné que MS veux faire basculer tout le monde sur des forum web,
ils ont (entre autre) coupé l'entrée par CDO vers les newsgroups...

Tu devrais utiliser un "lecteur de news" pour lire les newsgroups.
C'est le jour et la nuit par rapport à une entrée web !!!

Comme lecteur de news, tu peux utiliser

- Outlook Express (qui fait les deux en fait - émail et news ;-)
- MesNews qui est excellent http://www.mesnews.net/

Pour venir ici avec OE (Outlook Express), il suffit d'aller à cette page
http://www.mpfa.info/articles.php?lng=fr&pg=5 et de cliquer sur
le lien "connecter immédiatement" pour arriver directement sur les
serveurs MS et le NG Access ;-))

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)






3stone
Le #6348911
Salut,

"Docteur Jekyll"
| Maintenant j'ai un autre problème.
| VraiFaux([sf.form.[champ estnull;o;sf.form.champ)


Nouvelle question, nouveau fil ;-)


Peut-être...

iif ( isnull(sf.Form.ChampX) ; 0 ; sf.Form.ChampX )

à condition que le sf possède un recordset (sf pas "vide")

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
Publicité
Poster une réponse
Anonyme