Probleme avec VirtualBox

Le
Nicolas BERNE
Bonjour à tous,

Depuis que j'ai installé la nouvelle version de VirtualBox (2.2.0) sous
ma slack 12.2 en utilisant les packages virtualbox-ose-2.2.0-i686-1dav
et virtualbox-ose-qt4-2.2.0-i686-1dav de www.slacky.eu, j'obtiens le
message suivant :
Échec de création de la nouvelle session.
Code retourné : NS_ERROR_FACTORY_NOT_REGISTERED (0x80040154).

Par contre, sous root, aucun problème.
J'ai googolisé et tout ce que j'ai pu trouver ne m'a pas du tout aidé.
Mon utilisateur est bien dans le groupe vboxusers.
ls -l /dev/vboxdrv ->
crw-rw- 1 root vboxusers 10, 57 2009-04-10 12:42 /dev/vboxdrv

ls -l /usr/lib/virtualbox/VirtualBox ->
-r-s--x--x 1 root root 18308 2009-04-09 10:21 /usr/lib/virtualbox/VirtualBox

/tmp/.vbox-nico-ipc/ possède les bons droits (et meme si je l'efface, il
est recréé comme il faut).

Evidemment, si je repasse en 2.1.4 (avec les packages de www.slacky.eu),
ça roule

Bref, je ne vois pas ce qui cloche.

A+

--
DROIT AU BLASPHEME
http://minilien.com/?mtqAszLMyi
http://www.ulb.ac.be/cal/laiciteAZ/blaspheme.html
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
gaia
Le #19105421
salut
la 2.2.0 sort juste en released . tu l'as install via netpkg ou tu l'as
compilé . slack l'a déja packagé! n'y a t'il pas un simple probleme de
dependance ?

j'avais eu ce genre de soucis sous Fedora et cela etait due au faite que
j'avais un paquet qui n'avait pas été mis à jour . malheureusement je ne
me rappelle plus de son nom .
Robert LEFEVRE
Le #19105991
Nicolas BERNE a écrit :
Bonjour à tous,

Depuis que j'ai installé la nouvelle version de VirtualBox (2.2.0) sous
ma slack 12.2 en utilisant les packages virtualbox-ose-2.2.0-i686-1dav
et virtualbox-ose-qt4-2.2.0-i686-1dav de www.slacky.eu, j'obtiens le
message suivant :
Échec de création de la nouvelle session.
Code retourné : NS_ERROR_FACTORY_NOT_REGISTERED (0x80040154).

Par contre, sous root, aucun problème.
J'ai googolisé et tout ce que j'ai pu trouver ne m'a pas du tout aidé.
Mon utilisateur est bien dans le groupe vboxusers.
ls -l /dev/vboxdrv ->
crw-rw---- 1 root vboxusers 10, 57 2009-04-10 12:42 /dev/vboxdrv

ls -l /usr/lib/virtualbox/VirtualBox ->
-r-s--x--x 1 root root 18308 2009-04-09 10:21 /usr/lib/virtualbox/VirtualBox

/tmp/.vbox-nico-ipc/ possède les bons droits (et meme si je l'efface, il
est recréé comme il faut).

Evidemment, si je repasse en 2.1.4 (avec les packages de www.slacky.eu),
ça roule...

Bref, je ne vois pas ce qui cloche.

A+



Ajouter un utilisateur au groupe vboxusers, avec la commande "sudo
adduser $LOGNAME vboxusers" ?
Nicolas BERNE
Le #19105981
Thus Spoke gaia
salut
la 2.2.0 sort juste en released . tu l'as install via netpkg ou tu l'as
compilé . slack l'a déja packagé! n'y a t'il pas un simple probleme de
dependance ?


Comme je l'ai indiqué dans mon poste initial, j'ai utilisé les packages
de www.slacky.eu (via leur utilitaire slackyd).
D'ailleurs, d'après leur forum, je ne suis pas le seul à qui ça arrive :
http://www.slacky.eu/forum/viewtopic.php?p$0047
(bon, c'est en italien mais un coup de translate.google...)

j'avais eu ce genre de soucis sous Fedora et cela etait due au faite que
j'avais un paquet qui n'avait pas été mis à jour . malheureusement je ne
me rappelle plus de son nom .


Bon, en attendant une solution à mon pb, j'utilise VirtualBox en tant
que root (je sais, c'est MAAAAAL.)

A+

--
DROIT AU BLASPHEME
http://minilien.com/?mtqAszLMyi
http://www.ulb.ac.be/cal/laiciteAZ/blaspheme.html
Nicolas BERNE
Le #19105971
Thus Spoke Robert LEFEVRE
Nicolas BERNE a écrit :
> Bonjour à tous,
>
> Mon utilisateur est bien dans le groupe vboxusers.
>
> A+
>
Ajouter un utilisateur au groupe vboxusers, avec la commande "sudo
adduser $LOGNAME vboxusers" ?


Dejà fait.
D'ailleurs, je n'ai jamais eu le moindre pb avec VirtualBox jusqu'à
cette version 2.2.0.

A+

--
DROIT AU BLASPHEME
http://minilien.com/?mtqAszLMyi
http://www.ulb.ac.be/cal/laiciteAZ/blaspheme.html
Nicolas BERNE
Le #19108661
Thus Spoke Nicolas BERNE
Bonjour à tous,

Depuis que j'ai installé la nouvelle version de VirtualBox (2.2.0) sous
ma slack 12.2 en utilisant les packages virtualbox-ose-2.2.0-i686-1dav
et virtualbox-ose-qt4-2.2.0-i686-1dav de www.slacky.eu, j'obtiens le
message suivant :
Échec de création de la nouvelle session.
Code retourné : NS_ERROR_FACTORY_NOT_REGISTERED (0x80040154).


Trouvé une solution qui marche ici :
http://forums.virtualbox.org/viewtopic.php?f&t090#
Le dernier message indique ce qu'il faut faire :
find /usr/lib/virtualbox -maxdepth 1 -name '*.so' -exec ln -s {} /usr/lib/virtualbox/components/ ;

Et ça roule.

Voila, voila.

A+

--
DROIT AU BLASPHEME
http://minilien.com/?mtqAszLMyi
http://www.ulb.ac.be/cal/laiciteAZ/blaspheme.html
Publicité
Poster une réponse
Anonyme