Problème build-dep et vlc

Le
Vincent MAUGE
=_Part_16582_23962999.1221684814427
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Bonsoir,

je cherche à compiler vlc 0.9.2 depuis les sources sur ma debian etch. En
suivant leur wiki, il propose la commande apt-get build-dep vlc pour
récupérer les dépendances nécessaires à la compilation. Mais quan=
d je lance
cette commande j'ai l'erreur suivante :

Reading package lists Done
Building dependency tree Done
E: Build-Depends dependency for vlc cannot be satisfied because no availabl=
e
versions of package debhelper can satisfy version requirements

Je n'utilise normalement que des paquets de etch.

D'où vient le problème ?

J'ai vérifié le paquet debhelper est bien installé sur ma machine.


Vincent

=_Part_16582_23962999.1221684814427
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

<div dir="ltr">Bonsoir,<br><br>je cherche à compiler vlc 0.9.2 depuis l=
es sources sur ma debian etch. En suivant leur wiki, il propose la commande=
apt-get build-dep vlc pour récupérer les dépendances nécessaires =
à la compilation. Mais quand je lance cette commande j&#39;ai l&#39;erreu=
r suivante :<br>
<br>Reading package lists Done<br>Building dependency tree Done<br>E:=
Build-Depends dependency for vlc cannot be satisfied because no available =
versions of package debhelper can satisfy version requirements<br><br>Je n&=
#39;utilise normalement que des paquets de etch.<br>
<br>D&#39;où vient le problème ?<br><br>J&#39;ai vérifié le paquet =
debhelper est bien installé sur ma machine.<br><br><br>Vincent<br></div>

=_Part_16582_23962999.1221684814427--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Gilles Mocellin
Le #17258161
On Wed, Sep 17, 2008 at 10:53:34PM +0200, Vincent MAUGE wrote:
Bonsoir,

je cherche à compiler vlc 0.9.2 depuis les sources sur ma debian etch. En
suivant leur wiki, il propose la commande apt-get build-dep vlc pour
récupérer les dépendances nécessaires à la compilation. Mais quand je lance
cette commande j'ai l'erreur suivante :

Reading package lists... Done
Building dependency tree... Done
E: Build-Depends dependency for vlc cannot be satisfied because no available
versions of package debhelper can satisfy version requirements

Je n'utilise normalement que des paquets de etch.



Et oui, mais pas pour le paquet source, sinon, ça ne serait pas la verion 0.9.2 !
Tu dois avoir une ligne deb-src dans /etc/apt/source.list qui pointe sur la version unstable.

Le paquet unstable dépend, pour sa construction, de paquet de unstable...

Là, tu entres dans les joies du backport.
- soit tu recompiles pour etch debhelper d'unstable. Et peut-être que ça entrainera d'autres dépendances...
- soit tu compile vlc à partir des sources, sans utiliser les outils debian...

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Vincent MAUGE
Le #17258541
------=_Part_17182_682545.1221687561187
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Le 17 septembre 2008 23:30, Gilles Mocellin écrit :

On Wed, Sep 17, 2008 at 10:53:34PM +0200, Vincent MAUGE wrote:
> Bonsoir,
>
> je cherche à compiler vlc 0.9.2 depuis les sources sur ma debian etch . En
> suivant leur wiki, il propose la commande apt-get build-dep vlc pour
> récupérer les dépendances nécessaires à la compilation. Mais quand je
lance
> cette commande j'ai l'erreur suivante :
>
> Reading package lists... Done
> Building dependency tree... Done
> E: Build-Depends dependency for vlc cannot be satisfied because no
available
> versions of package debhelper can satisfy version requirements
>
> Je n'utilise normalement que des paquets de etch.

Et oui, mais pas pour le paquet source, sinon, ça ne serait pas la veri on
0.9.2 !
Tu dois avoir une ligne deb-src dans /etc/apt/source.list qui pointe sur la
version unstable.

Le paquet unstable dépend, pour sa construction, de paquet de unstable. ..

Là, tu entres dans les joies du backport.
- soit tu recompiles pour etch debhelper d'unstable. Et peut-être que ça
entrainera d'autres dépendances...
- soit tu compile vlc à partir des sources, sans utiliser les outils
debian...




La version de etch est la 0.8.6. Je veux justement compiler la 0.9.2 a
partir des source mais je pensais que build-dep me faciliteraient le
téléchargement les dépendances pour la compilation (Et ainsi éviter de
lancer ./configure, regarder les erreurs et télécharger le packages
correspondant jusqu'à qu'il n'y ai plus d'erreur)
Donc que fait exactement la commande apt-get buid-dep <un_nom_de_package> ?


Vincent

------=_Part_17182_682545.1221687561187
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

<div class="Ih2E3d">On Wed, Sep 17, 2008 at 10:53:34PM +0200, Vincent MAU GE wrote:<br>
&gt; Bonsoir,<br>
&gt;<br>
&gt; je cherche à compiler vlc 0.9.2 depuis les sources sur ma debian etc h. En<br>
&gt; suivant leur wiki, il propose la commande apt-get build-dep vlc pour<b r>
&gt; récupérer les dépendances nécessaires à la compilation. Mais quand je lance<br>
&gt; cette commande j&#39;ai l&#39;erreur suivante :<br>
&gt;<br>
&gt; Reading package lists... Done<br>
&gt; Building dependency tree... Done<br>
&gt; E: Build-Depends dependency for vlc cannot be satisfied because no ava ilable<br>
&gt; versions of package debhelper can satisfy version requirements<br>
&gt;<br>
&gt; Je n&#39;utilise normalement que des paquets de etch.<br>
<br>
Tu dois avoir une ligne deb-src dans /etc/apt/source.list qui pointe sur la version unstable.<br>
<br>
Le paquet unstable dépend, pour sa construction, de paquet de unstable... <br>
<br>
Là, tu entres dans les joies du backport.<br>
- soit tu recompiles pour etch debhelper d&#39;unstable. Et peut-être que ça entrainera d&#39;autres dépendances...<br>
- soit tu compile vlc à partir des sources, sans utiliser les outils debi an...<br>
Donc que fait exactement la commande apt-get buid-dep &lt;un_nom_de_package &gt; ?<br><br><br>Vincent <br></div>

------=_Part_17182_682545.1221687561187--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Gilles Mocellin
Le #17258531
On Wed, Sep 17, 2008 at 11:39:21PM +0200, Vincent MAUGE wrote:
Le 17 septembre 2008 23:30, Gilles Mocellin écrit :

> On Wed, Sep 17, 2008 at 10:53:34PM +0200, Vincent MAUGE wrote:
> > Bonsoir,
> >
> > je cherche à compiler vlc 0.9.2 depuis les sources sur ma debian etch. En
> > suivant leur wiki, il propose la commande apt-get build-dep vlc pour
> > récupérer les dépendances nécessaires à la compilation. Mais quand je
> lance


[...]

> Et oui, mais pas pour le paquet source, sinon, ça ne serait pas la verion
> 0.9.2 !
> Tu dois avoir une ligne deb-src dans /etc/apt/source.list qui pointe sur la
> version unstable.
>
> Le paquet unstable dépend, pour sa construction, de paquet de unstable...
>
> Là, tu entres dans les joies du backport.
> - soit tu recompiles pour etch debhelper d'unstable. Et peut-être que ça
> entrainera d'autres dépendances...
> - soit tu compile vlc à partir des sources, sans utiliser les outils
> debian...
>

La version de etch est la 0.8.6. Je veux justement compiler la 0.9.2 a
partir des source mais je pensais que build-dep me faciliteraient le
téléchargement les dépendances pour la compilation (Et ainsi éviter de
lancer ./configure, regarder les erreurs et télécharger le packages
correspondant jusqu'à qu'il n'y ai plus d'erreur)
Donc que fait exactement la commande apt-get buid-dep <un_nom_de_package> ?



La plupart du temps, ça se passe bien en faisant comme ça.
Les prolèmes arrivent quand il y a des changements importants dans les fonctionnalités utilisées dans les paquets dépendants, mais aussi, et c'est le cas ici, quand les outils Debian évoluent. (Cf Debian policy).

Je ne sais pas si tu as essayer de faire marcher firefox 3 sur Etch, mais on a là aussi des problèmes pas facils à résoudre avec les librairies GTK.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Vincent MAUGE
Le #17258521
------=_Part_17521_14989695.1221688708599
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Le 17 septembre 2008 23:57, Gilles Mocellin écrit :

On Wed, Sep 17, 2008 at 11:39:21PM +0200, Vincent MAUGE wrote:
> Le 17 septembre 2008 23:30, Gilles Mocellin > écrit :
>
> > On Wed, Sep 17, 2008 at 10:53:34PM +0200, Vincent MAUGE wrote:
> > > Bonsoir,
> > >
> > > je cherche à compiler vlc 0.9.2 depuis les sources sur ma debian
etch. En
> > > suivant leur wiki, il propose la commande apt-get build-dep vlc pou r
> > > récupérer les dépendances nécessaires à la compilation. M ais quand je
> > lance
[...]

> > Et oui, mais pas pour le paquet source, sinon, ça ne serait pas la
verion
> > 0.9.2 !
> > Tu dois avoir une ligne deb-src dans /etc/apt/source.list qui pointe
sur la
> > version unstable.
> >
> > Le paquet unstable dépend, pour sa construction, de paquet de
unstable...
> >
> > Là, tu entres dans les joies du backport.
> > - soit tu recompiles pour etch debhelper d'unstable. Et peut-être q ue
ça
> > entrainera d'autres dépendances...
> > - soit tu compile vlc à partir des sources, sans utiliser les outil s
> > debian...
> >
>
> La version de etch est la 0.8.6. Je veux justement compiler la 0.9.2 a
> partir des source mais je pensais que build-dep me faciliteraient le
> téléchargement les dépendances pour la compilation (Et ainsi év iter de
> lancer ./configure, regarder les erreurs et télécharger le packages
> correspondant jusqu'à qu'il n'y ai plus d'erreur)
> Donc que fait exactement la commande apt-get buid-dep <un_nom_de_packag e>
?

La plupart du temps, ça se passe bien en faisant comme ça.
Les prolèmes arrivent quand il y a des changements importants dans les
fonctionnalités utilisées dans les paquets dépendants, mais aussi, et c'est
le cas ici, quand les outils Debian évoluent. (Cf Debian policy).





Le problème dans mon cas c'est que apt-get build ne fait rien et sort en
erreur. Au delà de mon problème de vlc, j'aimerai comprendre d'où vie nt le
problème : mon source liste, un bug dans la définition du paquet ... ?



Je ne sais pas si tu as essayer de faire marcher firefox 3 sur Etch, mais
on a là aussi des problèmes pas facils à résoudre avec les librai ries GTK.

Je me doute bien que les versions des mibs d'une version précédente p euvent


ne pas satisfaire la version courante

------=_Part_17521_14989695.1221688708599
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

<div class="Ih2E3d">On Wed, Sep 17, 2008 at 11:39:21PM +0200, Vincent MAU GE wrote:<br>
&gt; Le 17 septembre 2008 23:30, Gilles Mocellin &lt; &gt; écrit :<br>
&gt;<br>
&gt; &gt; On Wed, Sep 17, 2008 at 10:53:34PM +0200, Vincent MAUGE wrote:<br >
&gt; &gt; &gt; Bonsoir,<br>
&gt; &gt; &gt;<br>
&gt; &gt; &gt; je cherche à compiler vlc 0.9.2 depuis les sources sur ma debian etch. En<br>
&gt; &gt; &gt; suivant leur wiki, il propose la commande apt-get build-dep vlc pour<br>
&gt; &gt; &gt; récupérer les dépendances nécessaires à la compila tion. Mais quand je<br>
&gt; &gt; lance<br>
<div class="Ih2E3d"><br>
&gt; &gt; Et oui, mais pas pour le paquet source, sinon, ça ne serait pas la verion<br>
&gt; &gt; 0.9.2 !<br>
&gt; &gt; Tu dois avoir une ligne deb-src dans /etc/apt/source.list qui poi nte sur la<br>
&gt; &gt; version unstable.<br>
&gt; &gt;<br>
&gt; &gt; Le paquet unstable dépend, pour sa construction, de paquet de u nstable...<br>
&gt; &gt;<br>
&gt; &gt; Là, tu entres dans les joies du backport.<br>
&gt; &gt; - soit tu recompiles pour etch debhelper d&#39;unstable. Et peut- être que ça<br>
&gt; &gt; entrainera d&#39;autres dépendances...<br>
&gt; &gt; - soit tu compile vlc à partir des sources, sans utiliser les o utils<br>
&gt; &gt; debian...<br>
&gt; &gt;<br>
&gt;<br>
&gt; La version de etch est la &gt; partir des source mais je pensais que build-dep me faciliteraient le<b r>
&gt; téléchargement les dépendances pour la compilation (Et ainsi é viter de<br>
&gt; lancer ./configure, regarder les erreurs et télécharger le package s<br>
&gt; correspondant jusqu&#39;à qu&#39;il n&#39;y ai plus d&#39;erreur)<br >
&gt; Donc que fait exactement la commande apt-get buid-dep &lt;un_nom_de_pa ckage&gt; ?<br>
<br>
Les prolèmes arrivent quand il y a des changements importants dans les fo nctionnalités utilisées dans les paquets dépendants, mais aussi, et c &#39;est le cas ici, quand les outils Debian évoluent. (Cf Debian policy) .<br>

</blockquote><br><br>Le problème dans mon cas c&#39;est que apt-get build ne fait rien et sort
en erreur. Au delà de mon problème de vlc, j&#39;aimerai comprendre d&# 39;où
vient le problème : mon source liste, un bug dans la définition du
paquet ... ? Je ne sais pas si tu as essayer de faire marcher firefox 3 sur Etch, mais o n a là aussi des problèmes pas facils à résoudre avec les librairie s GTK.<br>
<div><div></div><div class="Wj3C7c"><br>
</div></div></blockquote></div>Je me doute bien que les versions des mibs d &#39;une version précédente peuvent ne pas satisfaire la version couran te<br></div>

------=_Part_17521_14989695.1221688708599--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Bruno Muller
Le #17260521
--=-CAFKuV4Ux5WutGD68HIz
Content-Type: text/plain; charset=ISO-8859-15
Content-Transfer-Encoding: quoted-printable

Hello,


Le mercredi 17 septembre 2008 à 23:58 +0200, Vincent MAUGE a écrit :

Le problème dans mon cas c'est que apt-get build ne fait rien et sort
en erreur. Au delà de mon problème de vlc, j'aimerai comprendre d'o ù
vient le problème : mon source liste, un bug dans la définition du
paquet ... ?



Pour simplifier, "apt-get build-dep vlc" installe les paquets indiqués
sur la ligne Build-Depends par la commande "apt-cache showsrc vlc".

Et je te parie que la version de debhelper demandée pour construire vlc
est supérieure à celle dispo dans etch.
Et c'est pour cela que apt-get build-dep ne fait rien.

Bruno

--
C'EST LA NATURE...
Crr
O : Cui ?
M : Salaud ! Il ne pouvait même pas voler !!
P : Sélection naturelle ! Un oiseau qui ne peut pas voler mérite-t-il d e
vivre ?

--=-CAFKuV4Ux5WutGD68HIz
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: Ceci est une partie de message
=?ISO-8859-1?Q?numériquement?= =?ISO-8859-1?Q?_signée?
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEABECAAYFAkjSCwkACgkQuJD2bkb8m5vbwQCfccuI9phjVHxCSa3VrzbDIa/I
NGAAn3mDyHwRfQZ8AUZ3A+mm06xb1g2d
=xwYY
-----END PGP SIGNATURE-----

--=-CAFKuV4Ux5WutGD68HIz--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Vincent MAUGE
Le #17266911
------=_Part_481_17165511.1221763100375
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Le 18 septembre 2008 10:02, Bruno Muller
Hello,


Le mercredi 17 septembre 2008 à 23:58 +0200, Vincent MAUGE a écrit :

> Le problème dans mon cas c'est que apt-get build ne fait rien et sort
> en erreur. Au delà de mon problème de vlc, j'aimerai comprendre d'o ù
> vient le problème : mon source liste, un bug dans la définition du
> paquet ... ?

Pour simplifier, "apt-get build-dep vlc" installe les paquets indiqués
sur la ligne Build-Depends par la commande "apt-cache showsrc vlc".

Et je te parie que la version de debhelper demandée pour construire vlc
est supérieure à celle dispo dans etch.
Et c'est pour cela que apt-get build-dep ne fait rien.




Merci de cette réponse très clair. J'ai donc exécuté la commande ap t-cache
showsrc vlc et celle-ci affiche les informations pour plusieurs paquets
(normal mon source.list contient les repository de etch, lenny sid et gér er
par des priorités) . J'ai l'impression donc que apt-get build-dep regarde un
peut tous les paquets dispo au lieu de prendre les infos du paquets
installable sur mon système. Il y a une option pour forcer la version ?

Vincent

------=_Part_481_17165511.1221763100375
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Hello,<br>
<br>
<br>
Le mercredi 17 septembre 2008 à 23:58 +0200, Vincent MAUGE a écrit :<br >
<div class="Ih2E3d"><br>
&gt; Le problème dans mon cas c&#39;est que apt-get build ne fait rien et sort<br>
&gt; en erreur. Au delà de mon problème de vlc, j&#39;aimerai comprendr e d&#39;où<br>
&gt; vient le problème : mon source liste, un bug dans la définition du <br>
&gt; paquet ... ?<br>
<br>
</div>Pour simplifier, &quot;apt-get build-dep vlc&quot; installe les paque ts indiqués<br>
sur la ligne Build-Depends par la commande &quot;apt-cache showsrc vlc&quot ;.<br>
<br>
Et je te parie que la version de debhelper demandée pour construire vlc<b r>
est supérieure à celle dispo dans etch.<br>
Et c&#39;est pour cela que apt-get build-dep ne fait rien.<br>
<br>Vincent<br></div></div><br></div>

------=_Part_481_17165511.1221763100375--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Gilles Mocellin
Le #17267431
On Thu, Sep 18, 2008 at 08:38:20PM +0200, Vincent MAUGE wrote:
[...]

Merci de cette réponse très clair. J'ai donc exécuté la commande apt-cache
showsrc vlc et celle-ci affiche les informations pour plusieurs paquets
(normal mon source.list contient les repository de etch, lenny sid et gérer
par des priorités) . J'ai l'impression donc que apt-get build-dep regarde un
peut tous les paquets dispo au lieu de prendre les infos du paquets
installable sur mon système. Il y a une option pour forcer la version ?



Normalement, l'option -t permet de spécifier la release.
Mais, du coup, ça prendra les dépendances du paquet vlc de etch, et tu ne pourras pas le compiler avec dpkg-buildpackage.
Théoriquement, il dira que la version de debhelper n'est pas assez récente.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Vincent MAUGE
Le #17268211
------=_Part_2956_27362560.1221770968028
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Le 18 septembre 2008 21:19, Gilles Mocellin écrit :

On Thu, Sep 18, 2008 at 08:38:20PM +0200, Vincent MAUGE wrote:
[...]
>
> Merci de cette réponse très clair. J'ai donc exécuté la command e
apt-cache
> showsrc vlc et celle-ci affiche les informations pour plusieurs paquets
> (normal mon source.list contient les repository de etch, lenny sid et
gérer
> par des priorités) . J'ai l'impression donc que apt-get build-dep reg arde
un
> peut tous les paquets dispo au lieu de prendre les infos du paquets
> installable sur mon système. Il y a une option pour forcer la version ?

Normalement, l'option -t permet de spécifier la release.
Mais, du coup, ça prendra les dépendances du paquet vlc de etch, et t u ne
pourras pas le compiler avec dpkg-buildpackage.
Théoriquement, il dira que la version de debhelper n'est pas assez ré cente.




C'est ce que j'avais essayer mais ça ne marchais pas. J'ai compris qu'il
faut mettre -t stable et non -t etch.

Merci à tous pour votre aide je comprends maintenant mieux certaines opti ons
d'apt-get et apt-cache.

Pour en revenir à mon problème de départ le but n'était pas de cons truire un
package mais juste de compiler le binaire. J'attendrai la prochaine version
de Debian pour peut-être avoir la nouvelle version de vlc dans les packag es
officiels même si malheuresement après avoir discuter avec les dévelo ppeurs
officiels il semble que le freeze soit trop avancer pour inclure cette
nouvelle version. (Même problème avec la future ubuntu d'ailleurs)

Vincent

------=_Part_2956_27362560.1221770968028
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

On Thu, Sep 18, 2008 at 08:38:20PM +0200, Vincent MAUGE wrote:<br>
[...]<br>
<div class="Ih2E3d">&gt;<br>
&gt; Merci de cette réponse très clair. J&#39;ai donc exécuté la co mmande apt-cache<br>
&gt; showsrc vlc et celle-ci affiche les informations pour plusieurs paquet s<br>
&gt; (normal mon source.list contient les repository de etch, lenny sid et gérer<br>
&gt; par des priorités) . J&#39;ai l&#39;impression donc que apt-get buil d-dep regarde un<br>
&gt; peut tous les paquets dispo au lieu de prendre les infos du paquets<br >
&gt; installable sur mon système. Il y a une option pour forcer la versio n ?<br>
<br>
Mais, du coup, ça prendra les dépendances du paquet vlc de etch, et tu ne pourras pas le compiler avec dpkg-buildpackage.<br>
Théoriquement, il dira que la version de debhelper n&#39;est pas assez r écente.<br>
<br>Vincent<br></div></div><br></div>

------=_Part_2956_27362560.1221770968028--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme