Problème de caractère sous KDE

Le
Damelo
Bonsoir,
Depuis que mon système est passé en squeeze, les polices de caractères
sont illisibles dans les menus et titres de fenêtre KDE, ainsi que dans
les programmes natif, comme le centre de config de KDE, par exemple.

Ce n'est pas un problème de taille, comme on peut le voir sur google un
peu partout, mais plutôt des signes bizarre à la place des caractères.

Par contre, icewacel ou autres fonctionnent parfaitement. Les applis à
problèmes n'en pose plus si elles sont lancé en root.
J'ai bien tenter de réinstaller KDE et X ( par purge et install ) ou
bien d'installer un max de fonts mais rien n'y fait.

Je ne sais plus trop par ou chercher, une idée?

DamElo

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Guillaume Caron
Le #20549491
--=-Ntmxal5epiB6tGp/kBSP
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: 8bit

Hello,

C'est peut-être une histoire de paramètres : le fait de réinstaller KDE
en purgeant les fichiers ne touche pas à tes paramètes locaux.

Du coup, tu peux essayer de mettre de côté ton dossier de paramètres de
KDE ~/.kde et relancer une session. Tu auras les paramètres par défaut
et ça résoudra peut-être ton problème.

Cordialement,
--
Guillaume

Le vendredi 13 novembre 2009 à 18:10 +0100, Damelo a écrit :

Bonsoir,
Depuis que mon système est passé en squeeze, les polices de caractères
sont illisibles dans les menus et titres de fenêtre KDE, ainsi que dans
les programmes natif, comme le centre de config de KDE, par exemple.

Ce n'est pas un problème de taille, comme on peut le voir sur google un
peu partout, mais plutôt des signes bizarre à la place des caractères.

Par contre, icewacel ou autres fonctionnent parfaitement. Les applis à
problèmes n'en pose plus si elles sont lancé en root.
J'ai bien tenter de réinstaller KDE et X ( par purge et install ) ou
bien d'installer un max de fonts mais rien n'y fait.

Je ne sais plus trop par ou chercher, une idée?

DamElo






--=-Ntmxal5epiB6tGp/kBSP
Content-Type: text/html; charset="utf-8"
Content-Transfer-Encoding: 7bit

<HTML>
<HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; CHARSET=UTF-8">
</HEAD>
<BODY>
Hello,<BR>
<BR>
C'est peut-&#234;tre une histoire de param&#232;tres : le fait de r&#233;installer KDE en purgeant les fichiers ne touche pas &#224; tes param&#232;tes locaux.<BR>
<BR>
Du coup, tu peux essayer de mettre de c&#244;t&#233; ton dossier de param&#232;tres de KDE ~/.kde et relancer une session. Tu auras les param&#232;tres par d&#233;faut et &#231;a r&#233;soudra peut-&#234;tre ton probl&#232;me.<BR>
<TABLE CELLSPACING="0" CELLPADDING="0" WIDTH="100%">
<TR>
<TD>
<BR>
Cordialement,<BR>
--<BR>
Guillaume <BR>
<BR>
</TD>
</TR>
</TABLE>
Le vendredi 13 novembre 2009 &#224; 18:10 +0100, Damelo a &#233;crit&nbsp;:
<BLOCKQUOTE TYPE=CITE>
<PRE>
Bonsoir,
Depuis que mon syst&#232;me est pass&#233; en squeeze, les polices de caract&#232;res
sont illisibles dans les menus et titres de fen&#234;tre KDE, ainsi que dans
les programmes natif, comme le centre de config de KDE, par exemple.

Ce n'est pas un probl&#232;me de taille, comme on peut le voir sur google un
peu partout, mais plut&#244;t des signes bizarre &#224; la place des caract&#232;res.

Par contre, icewacel ou autres fonctionnent parfaitement. Les applis &#224;
probl&#232;mes n'en pose plus si elles sont lanc&#233; en root.
J'ai bien tenter de r&#233;installer KDE et X ( par purge et install ) ou
bien d'installer un max de fonts mais rien n'y fait.

Je ne sais plus trop par ou chercher, une id&#233;e?

DamElo

</PRE>
</BLOCKQUOTE>
<BR>
</BODY>
</HTML>

--=-Ntmxal5epiB6tGp/kBSP--



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Damelo
Le #20549581
Guillaume Caron a écrit :

Bonne idée, mais déjà testé, sans succès.
J'ai réessayer à tout hazard, mais non.
Merci.


Hello,

C'est peut-être une histoire de paramètres : le fait de réinstaller KDE
en purgeant les fichiers ne touche pas à tes paramètes locaux.

Du coup, tu peux essayer de mettre de côté ton dossier de paramètres de
KDE ~/.kde et relancer une session. Tu auras les paramètres par défaut
et ça résoudra peut-être ton problème.

Cordialement,
--
Guillaume

Le vendredi 13 novembre 2009 à 18:10 +0100, Damelo a écrit :

Bonsoir,
Depuis que mon système est passé en squeeze, les polices de caractères
sont illisibles dans les menus et titres de fenêtre KDE, ainsi que dans
les programmes natif, comme le centre de config de KDE, par exemple.

Ce n'est pas un problème de taille, comme on peut le voir sur google un
peu partout, mais plutôt des signes bizarre à la place des caractères.

Par contre, icewacel ou autres fonctionnent parfaitement. Les applis à
problèmes n'en pose plus si elles sont lancé en root.
J'ai bien tenter de réinstaller KDE et X ( par purge et install ) ou
bien d'installer un max de fonts mais rien n'y fait.

Je ne sais plus trop par ou chercher, une idée?

DamElo









--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
claude poupelier
Le #20551511
J'ai eu un problème qui ressemblait un peu au tien: seuls les menu et
titres utilisateurs étaient touchés,apparaissant en anglais. Tout était OK sous root.

Sébastien NOBILI m'a conseillé: << Étant donné
que seul le compte utilisateur est impacté, il y a de fortes chances
que ça se trouve dans ~/.bashrc ou dans ~/.profile. Il doit y avoir
dans un de ces fichiers un export de la variable LANG, personnellement
je le retirerais simplement, la locale utilisée redeviendrait la locale
système.>>

Effectivement mes locales différaient entre user et root.

Dans le fichier ~/.profile j'ai remplacé
LANG=fr_FR
par
LANG=fr_FR.UTF-8
Du coup tout est rentré dans l'ordre. Les en tête de barre de menu des
fenêtres sont revenues en français.


Le vendredi 13 novembre 2009 à 18:10 +0100, Damelo a écrit :
les polices de caractères sont illisibles dans les menus et titres de fenêtre KDE, ainsi que dans
les programmes natif, comme le centre de config de KDE, par exemple.




Par contre, icewacel ou autres fonctionnent parfaitement. Les applis à
problèmes n'en pose plus si elles sont lancé en root.



Si ça peut te servir

Claude



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Damelo
Le #20551981
claude poupelier a écrit :
J'ai eu un problème qui ressemblait un peu au tien: seuls les menu et
titres utilisateurs étaient touchés,apparaissant en anglais. Tout était OK sous root.

Sébastien NOBILI m'a conseillé: << Étant donné
que seul le compte utilisateur est impacté, il y a de fortes chances
que ça se trouve dans ~/.bashrc ou dans ~/.profile. Il doit y avoir
dans un de ces fichiers un export de la variable LANG, personnellement
je le retirerais simplement, la locale utilisée redeviendrait la locale
système.>>


...
J'ai essayé de commenter les variables dans mon .bashrc mais celà n'a
rien changer à mon problème.
Je pense que mon souci est différent, car ce n'est pas un problème de
langue, on dirait plutôt que KDE ne reconnait pas la police de caractère
et affiche n'importe quoi à la place. Encore plus fort, je copie un
paquet de sigle correspondant à un nom de fichier dans krusader et quant
je le colle dans une console, c'est les bon caractère!!!
Je pense que c'est lié à la config de KDE pour l'utilisateur.
Merci.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Thierry Chatelet
Le #20551991
On Saturday 14 November 2009 05:57:23 Damelo wrote:
claude poupelier a écrit :
...
J'ai essayé de commenter les variables dans mon .bashrc mais celà   n'a
rien changer à mon problème.
Je pense que mon souci est différent, car ce n'est pas un problà ¨me de
langue, on dirait plutôt que KDE ne reconnait pas la police de carac tère
et affiche n'importe quoi à la place. Encore plus fort, je copie un
paquet de sigle correspondant à un nom de fichier dans krusader et q uant
je le colle dans une console, c'est les bon caractère!!!
Je pense que c'est lié à la config de KDE pour l'utilisateur.
Merci.



As-tu essayé de créer un nouvel utilisateur pour voir si il avait le même
problème?
Thierry

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Charles Plessy
Le #20558181
Le Fri, Nov 13, 2009 at 06:10:03PM +0100, Damelo a écrit :

Depuis que mon système est passé en squeeze, les polices de caractères
sont illisibles dans les menus et titres de fenêtre KDE, ainsi que dans
les programmes natif, comme le centre de config de KDE, par exemple.



Pareil ici. On dirait un problème d'anti-crénelage. En visitant www.debian.org
avec Konqueror, je me suis apperçu que les titres apparaissaient correctement.
Comme ils sont dans une taille plus grande, j'ai essayé d'agrandir les polices
en général dans le menu « view » : tous les textes s'affichent alors
correctement.

N'utilisant jamais KDE, j'ai du mal à aller plus loin dans la chasse au bug…

Bon dimanche,

--
Charles Plessy
Tsurumi, Kanagawa, Japan

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Damelo
Le #20566591
Guillaume Caron a écrit :
Hello,

C'est peut-être une histoire de paramètres : le fait de réinstaller KDE
en purgeant les fichiers ne touche pas à tes paramètes locaux.

Du coup, tu peux essayer de mettre de côté ton dossier de paramètres de
KDE ~/.kde et relancer une session. Tu auras les paramètres par défaut
et ça résoudra peut-être ton problème.

Cordialement,
--
Guillaume

Le vendredi 13 novembre 2009 à 18:10 +0100, Damelo a écrit :

Bonsoir,
Depuis que mon système est passé en squeeze, les polices de caractères
sont illisibles dans les menus et titres de fenêtre KDE, ainsi que dans
les programmes natif, comme le centre de config de KDE, par exemple.

Ce n'est pas un problème de taille, comme on peut le voir sur google un
peu partout, mais plutôt des signes bizarre à la place des caractères.

Par contre, icewacel ou autres fonctionnent parfaitement. Les applis à
problèmes n'en pose plus si elles sont lancé en root.
J'ai bien tenter de réinstaller KDE et X ( par purge et install ) ou
bien d'installer un max de fonts mais rien n'y fait.

Je ne sais plus trop par ou chercher, une idée?

DamElo








Bonsoir,
tu avais raison, seulement, je n'avait déplacer que le contenu de mon
~/.kde, et il falait aussi effectuer la manip sur /var/tmp/kdecache-user.
Et là, magie! Mes polices de caractères sont revenu!

Merci pour votre aide.

DamElo

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme