probleme config apache2 zope pour le cgi awstats

Le
petit fabien
=_Part_88397_14293458.1182599797681
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Bonjour,

j'ai un probleme pour acceder au script awstats.pl dans l'url
http://www.monserveur.com/cgi-bin/awstats.pl
quand je tape cette url, zope me signale ceci :

"Site Error

An error was encountered while publishing this resource.

Resource not found
Sorry, the requested resource does not exist.

Check the URL and try again.

Resource: cgi-bin GET"

je vous mets les parties concernées de mon httpd.conf :

ServerRoot /etc/apache2

LoadModule proxy_module /usr/lib/apache2/modules/mod_proxy.so
LoadModule proxy_ftp_module /usr/lib/apache2/modules/mod_proxy_ftp.so
LoadModule proxy_http_module /usr/lib/apache2/modules/mod_proxy_http.so
LoadModule proxy_connect_module
/usr/lib/apache2/modules/mod_proxy_connect.so
LoadModule authn_alias_module /usr/lib/apache2/modules/mod_authn_alias.so
LoadModule vhost_alias_module /usr/lib/apache2/modules/mod_vhost_alias.so
LoadModule cgid_module /usr/lib/apache2/modules/mod_cgid.so

User www-data
Group www-data

DocumentRoot /var/www/

<Directory />
Options SymLinksIfOwnerMatch
AllowOverride None
</Directory>

<Directory /var/www>

#
# This may also be "None", "All", or any combination of "Indexes",
# "Includes", "FollowSymLinks", "ExecCGI", or "MultiViews".
#
# Note that "MultiViews" must be named *explicitly* "Options All"
# doesn't give it to you.
#
Options Indexes Includes FollowSymLinks MultiViews

#
# This controls which options the .htaccess files in directories can
# override. Can also be "All", or any combination of "Options", "FileInfo",
# "AuthConfig", and "Limit"
#
AllowOverride All

#
# Controls who can get stuff from this server.
#
Order allow,deny
Allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/

#
# "/usr/lib/cgi-bin" could be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
#
#
<Directory /usr/lib/cgi-bin>
AllowOverride None
Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteRule ^/stats(.*) /cgi-bin/awstats.pl$1
RewriteRule ^/(.*)
http://localhost:9673/VirtualHostBase/http/www.monserveur:80/VirtualHostRoo=
t/$1
</IfModule>

# <Directory proxy:*>
# Order deny,allow
# Deny from all
# Allow from all
# </Directory>

"je ne connais pas cette directive, je l'ai donc commentée"

# Les ProxyPass

ProxyRequests Off
ProxyPass /
http://localhost:9673/VirtualHostBase/http/wwww.monserveur.com:80/VirtualHo=
stRoot/

ProxyPassReverse /
http://localhost:9673/VirtualHostBase/http/www.monserveur.com:80/VirtualHos=
tRoot/

=
--

la page d'accueil, quand je tape http://www.monserveur.com, s'affiche mais
sans les images
alors que si je fais http://localhost:9673/ sur le serveur , 9673 étant l=
e
port d'écoute de zope, la page d'accueil s'affiche correctement avec les
images.
J'ai mis un virtual host monster dans la racine de la ZMI.


J'ai oublié ou mal écrit quelque chose dans mon httpd.conf ?
Pourquoi les images ne s'affichent t elles pas ?

je suis connecté en ethernet avec une live box, je suis en testing etch.

Merci d'avance pour vos réponses.

=_Part_88397_14293458.1182599797681
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Bonjour,<br><br>j&#39;ai un probleme pour acceder au script awstats.pl dans=
l&#39;url <br><a href="http://www.monserveur.com/cgi-bin/awstats.pl">htt=
p://www.monserveur.com/cgi-bin/awstats.pl</a><br>quand je tape cette url, z=
ope me signale ceci :
<br><br>&quot;Site Error<br><br>An error was encountered while publishing t=
his resource.<br><br>Resource not found<br>Sorry, the requested resource do=
es not exist.<br><br>Check the URL and try again.<br><br>Resource: cgi-bin =
GET&quot;
<br><br>je vous mets les parties concernées de mon httpd.conf :<br><br>Se=
rverRoot /etc/apache2<br><br>LoadModule proxy_module /usr/lib/apache2/modul=
es/mod_proxy.so <br>LoadModule proxy_ftp_module /usr/lib/apache2/modules/mo=
d_proxy_ftp.so
<br>LoadModule proxy_http_module /usr/lib/apache2/modules/mod_proxy_http.so=
<br>LoadModule proxy_connect_module /usr/lib/apache2/modules/mod_proxy_conn=
ect.so<br>LoadModule authn_alias_module /usr/lib/apache2/modules/mod_authn_=
alias.so
<br>LoadModule vhost_alias_module /usr/lib/apache2/modules/mod_vhost_alias.=
so<br>LoadModule cgid_module /usr/lib/apache2/modules/mod_cgid.so<br><br>Us=
er www-data<br>Group www-data<br><br>DocumentRoot /var/www/<br><br>&lt;Dire=
ctory /&gt;
<br>&nbsp;&nbsp;&nbsp; Options SymLinksIfOwnerMatch<br>&nbsp;&nbsp;&nbsp; A=
llowOverride None<br>&lt;/Directory&gt;<br><br>&lt;Directory /var/www&gt;<b=
r><br>#<br># This may also be &quot;None&quot;, &quot;All&quot;, or any com=
bination of &quot;Indexes&quot;,
<br># &quot;Includes&quot;, &quot;FollowSymLinks&quot;, &quot;ExecCGI&quot;=
, or &quot;MultiViews&quot;.<br>#<br># Note that &quot;MultiViews&quot; mus=
t be named *explicitly* &quot;Options All&quot;<br># doesn&#39;t give i=
t to you.
<br>#<br>&nbsp;&nbsp;&nbsp; Options Indexes Includes FollowSymLinks MultiVi=
ews <br><br>#<br># This controls which options the .htaccess files in direc=
tories can<br># override. Can also be &quot;All&quot;, or any combination o=
f &quot;Options&quot;, &quot;FileInfo&quot;,
<br># &quot;AuthConfig&quot;, and &quot;Limit&quot;<br>#<br>&nbsp;&nbsp;&nb=
sp; AllowOverride All<br><br>#<br># Controls who can get stuff from this se=
rver.<br>#<br>&nbsp;&nbsp;&nbsp; Order allow,deny<br>&nbsp;&nbsp;&nbsp; All=
ow from all<br>&lt;/Directory&gt;<br><br>
ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/<br><br>#<br># &quot;/usr/lib/cgi-bi=
n&quot; could be changed to whatever your ScriptAliased<br># CGI directory =
exists, if you have that configured.<br>#<br>#<br>&lt;Directory /usr/lib/cg=
i-bin&gt;
<br>&nbsp;&nbsp;&nbsp; AllowOverride None<br>&nbsp;&nbsp;&nbsp; Options Exe=
cCGI&nbsp; -MultiViews +SymLinksIfOwnerMatch&nbsp;&nbsp;&nbsp; &nbsp;<br>&n=
bsp;&nbsp;&nbsp; Order allow,deny<br>&nbsp;&nbsp;&nbsp; Allow from all<br>&=
lt;/Directory&gt;<br><br>&lt;IfModule mod_rewrite.c&gt;<br>RewriteEngine On=
<br>RewriteRule ^/stats(.*) /cgi-bin/awstats.pl$1
<br>RewriteRule ^/(.*) <a href="http://localhost:9673/VirtualHostBase/htt=
p/www.monserveur:80/VirtualHostRoot/$1">http://localhost:9673/VirtualHostBa=
se/http/www.monserveur:80/VirtualHostRoot/$1</a> <br>&lt;/IfModule&gt;<br>
<br>#&nbsp;&nbsp;&nbsp; &lt;Directory proxy:*&gt;<br>#&nbsp;&nbsp;&nbsp;&nb=
sp;&nbsp;&nbsp;&nbsp; Order deny,allow<br>#&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&n=
bsp;&nbsp; Deny from all<br>#&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; All=
ow from all<br>#&nbsp;&nbsp;&nbsp; &lt;/Directory&gt;<br><br>&quot;je ne co=
nnais pas cette directive, je l&#39;ai donc commentée&quot;
<br><br># Les ProxyPass<br><br>ProxyRequests Off<br>ProxyPass / <a href="=
http://localhost:9673/VirtualHostBase/http/wwww.monserveur.com:80/VirtualHo=
stRoot/">http://localhost:9673/VirtualHostBase/http/wwww.monserveur.com:80/=
VirtualHostRoot/
</a>&nbsp; &nbsp;<br>ProxyPassReverse / <a href="http://localhost:9673/Vi=
rtualHostBase/http/www.monserveur.com:80/VirtualHostRoot/">http://localhost=
:9673/VirtualHostBase/http/www.monserveur.com:80/VirtualHostRoot/</a><br><b=
r>-=
-
<br><br>la page d&#39;accueil, quand je tape <a href="http://www.monserve=
ur.com">http://www.monserveur.com</a>, s&#39;affiche mais sans les images <=
br>alors que si je fais <a href="http://localhost:9673/">http://localhost=
:9673/
</a> sur le serveur , 9673 étant le port d&#39;écoute de zope, la page =
d&#39;accueil s&#39;affiche correctement avec les images.<br>J&#39;ai mis u=
n virtual host monster dans la racine de la ZMI.<br><br><br>J&#39;ai oubli=
é ou mal écrit quelque chose dans mon
httpd.conf ?<br>Pourquoi les images ne s&#39;affichent t elles pas ?<br><br=
>je suis connecté en ethernet avec une live box, je suis en testing etch.=
<br><br>Merci d&#39;avance pour vos réponses.<br><br><br><br><br><br><br>
<br><br><br><br><br><br><br><br><br><br><br><br><br><br><br>

=_Part_88397_14293458.1182599797681--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
petit fabien
Le #9784181
------=_Part_88457_29182280.1182600611566
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Excusez moi, j'ai mal recopié cette ligne, le probleme reste là.

On 6/23/07, Ludovic Desfontaines

Pas sûr que ce soit ça, mais, il y a un petit souci dans ton fichier.
Tu as mis 4 "w" sur l'instruction ProxyPass /
Erreur de recopie ou bel et bien erreur ?

> # Les ProxyPass
>
> ProxyRequests Off
> ProxyPass /
>
http://localhost:9673/VirtualHostBase/http/wwww.monserveur.com:80/Virtual HostRoot/
^^^^^
>
> ProxyPassReverse /
>
http://localhost:9673/VirtualHostBase/http/www.monserveur.com:80/VirtualH ostRoot/

Bon courage

Ludovic





------=_Part_88457_29182280.1182600611566
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

<div>&nbsp;</div>
<div>&nbsp;</div>
http://localhost:9673/VirtualHostBase/http/wwww.monserveur.com:80/VirtualHo stRoot/ http://localhost:9673/VirtualHostBase/http/www.monserveur.com:80/VirtualHos tRoot/</a><br><br>Bon courage<br><br>Ludovic<br><br></blockquote></div><br>

------=_Part_88457_29182280.1182600611566--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme