Probleme CSV

Le
BZP
Bonjour,

Mon probleme est un peu transverse alors nh'ésitez pas a me signaler
que je suis pas sur le bon NG :)

Voila j'ai un serveur Aweb A (apache1.4/redhat) et j'ai migré vers un
serveur B (apache2/gentoo) .

A l'heure actuelle et a des fins de test les deux serveurs sont
opérationels.
J'ai sur le serveur A un fichier CSV (avec un ; pour séparateur) que
j'ouvre dans IE et qui m'ouvre automatiquement Excel dans IE et
m'affiche mon document bien afficher en plusieur colone (la séparation
est ok).
Quand j'ouvre le même fichier (qui n'a pas été modifié) sur le serv=
eur
B et bien ca m'affiche le texte en brut dans la page. Si je modifie le
type mime et que je dis que csv c'est Excel il m'ouvre bien excel mais
tout s'affiche que dans une colonne

Si quelqu'un a une piste je suis preneur.

--
BZP
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
newsreader
Le #1877648
Bonjour,

Mon probleme est un peu transverse alors nh'ésitez pas a me signaler
que je suis pas sur le bon NG :)

Voila j'ai un serveur Aweb A (apache1.4/redhat) et j'ai migré vers un
serveur B (apache2/gentoo) .

A l'heure actuelle et a des fins de test les deux serveurs sont
opérationels.
J'ai sur le serveur A un fichier CSV (avec un ; pour séparateur) que
j'ouvre dans IE et qui m'ouvre automatiquement Excel dans IE et
m'affiche mon document bien afficher en plusieur colone (la séparation
est ok).
Quand j'ouvre le même fichier (qui n'a pas été modifié) sur le serveur
B et bien ca m'affiche le texte en brut dans la page. Si je modifie le
type mime et que je dis que csv c'est Excel il m'ouvre bien excel mais
tout s'affiche que dans une colonne...

Si quelqu'un a une piste je suis preneur.




Des pistes de recherche :

Ces fichiers sont ouverts depuis la même machine cliente avec le même
navigateur avec le même Excel ?

Si non, essayer d'accéder au fichier sur le serveur B avec les mêmes
clients utilisés pour le fichier du serveur A. Si alors le fichier s'ouvre
comme sur le serveur A, alors s'orienter sur la conf d'Excel.

Si oui, voir peut-être du côté de la conf des apache, module mod_mime
et/ou fichier magic et/ou fichier mime.types


Lolotte
--
(enlever pasdespam pour répondre)
http://www.dansmongrenier.com/ : les pages du manuel, les newsgroups,
recherche whois, les codes postaux, des jeux et plein d'autres bêtises...

Arol
Le #1877607
"BZP" a écrit dans le message de news:
Si je modifie le
type mime et que je dis que csv c'est Excel il m'ouvre bien excel mais
tout s'affiche que dans une colonne...


C'est problème aussi vieux que excel.
Pour résoudre ce problème, faut sauver le fichier, puis l'ouvrir avec excel.
Ouvrir par forcément en double clickant dessus, mais peut être en faisant un
"ouvrir fichier" sous excel.
Si ça marche toujours pas, dans excel, faut utiliser la fonction "importer"
et la vous précisez que le séparateur de colonnes est ";".

Bref, le problème vient aussi bien du serveur web que de excel.

Fabien LE LEZ
Le #1877549
On 14 Mar 2007 03:31:44 -0700, "BZP"
Quand j'ouvre le même fichier (qui n'a pas été modifié) sur le serveur
B et bien ca m'affiche le texte en brut dans la page.


Envoie la même requête sur les deux serveurs (avec wget ou netcat) et
regarde la différence entre les deux réponses.

wget --save-headers -Oserveur1 http://serveur1/fichier.csv
wget --save-headers -Oserveur2 http://serveur2/fichier.csv

BZP
Le #1879443
Le probleme a l'air de venir du charset. Quand mon fichier CSV est en
ascii il s'ouvre tout comme il faut, lorsqu'il est en unicode il
présente le probleme ci dessus.
Le changement d'OS a-t-il fait la conversion ?

On 14 mar, 17:19, Fabien LE LEZ
On 14 Mar 2007 03:31:44 -0700, "BZP"
Quand j'ouvre le même fichier (qui n'a pas été modifié) sur le s erveur
B et bien ca m'affiche le texte en brut dans la page.


Envoie la même requête sur les deux serveurs (avec wget ou netcat) et
regarde la différence entre les deux réponses.

wget --save-headers -Oserveur1http://serveur1/fichier.csv
wget --save-headers -Oserveur2http://serveur2/fichier.csv



Fabien LE LEZ
Le #1879437
On 15 Mar 2007 01:50:33 -0700, "BZP"
Le probleme


Ça a peut-être un rapport avec le fait que tu écris à l'envers ?
Cf
http://www.usenet-fr.net/fr.usenet.reponses/usenet/repondre-sur-usenet.html

BZP
Le #1879412
On 15 mar, 11:32, Fabien LE LEZ
On 15 Mar 2007 01:50:33 -0700, "BZP"
Le probleme


Ça a peut-être un rapport avec le fait que tu écris à l'envers ?
Cfhttp://www.usenet-fr.net/fr.usenet.reponses/usenet/repondre-sur-usene...


C'est à dire ?


Publicité
Poster une réponse
Anonyme