problème de doublon dans un classement

Le
Thierry976
bonjour,
après avoir épluché de nombreux posts je ne trouve pas de réponse à mon
problème alors je me lance.
Voilà je voudrais supprimer les doublons dans un classement (fonction
"rang"). Pour ce faire il me faudrait une formule qui prenne en compte
d'abord les données d'une colonne (1er classement) et, en cas d'égalité,
celles d'une deuxième colonne. je suppose qu'il faut utiliser une
conditionnelle avec plusieurs conditions mais je n'arrive pas à l'écrire
correctement en intégrant la fonction "rang".
Quelqu'un peut il aider un esprit peu scientifique?
Merci d'avance.
Thierry
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #4741711
Bonjour Thierry,
Peux tu préciser un peu ce qui pour toi, dans ce contexte est un doublon ?
Pourquoi prendre en compte 1 deuxième colonne ?
Sinon, pour extraire une liste sans doublon, tu peux te tourner vers le
filtre élaboré de : Données / Filtrer
--
http://www.excelabo.net/mpfe/connexion.php
Avec plaisir
Philippe.R
"Thierry976" news:
bonjour,
après avoir épluché de nombreux posts je ne trouve pas de réponse à mon
problème alors je me lance.
Voilà je voudrais supprimer les doublons dans un classement (fonction
"rang"). Pour ce faire il me faudrait une formule qui prenne en compte
d'abord les données d'une colonne (1er classement) et, en cas d'égalité,
celles d'une deuxième colonne. je suppose qu'il faut utiliser une
conditionnelle avec plusieurs conditions mais je n'arrive pas à l'écrire
correctement en intégrant la fonction "rang".
Quelqu'un peut il aider un esprit peu scientifique?
Merci d'avance.
Thierry


Filochard
Le #4741591
..0 Pour ce faire il me faudrait une formule qui prenne en compte d'abord les
données d'une colonne (1er classement) et, en cas d'égalité, celles d'une
deuxième colonne


Un exemple : en A2:A20 des noms, en B2:B20 des valeurs numériques (1° critère
pour le classement) et en C2:C20 d'autres valeurs numériques (utilisation si
égalité sur le 1° critère)
En D2 et recopie ==> vers D20 :
=SOMMEPROD((B2+C2/100<$B$2:$B$20+$C$2:$C$20/100)*1)+1

http://cjoint.com/?jxqZMaf7Ep

Thierry976
Le #4741531
Merci à toi Filochard pour ta formule. Elle fonctionne à merveille.
Thierry
"Filochard" news:uym3CFf$
..0 Pour ce faire il me faudrait une formule qui prenne en compte d'abord
les données d'une colonne (1er classement) et, en cas d'égalité, celles
d'une deuxième colonne


Un exemple : en A2:A20 des noms, en B2:B20 des valeurs numériques (1°
critère pour le classement) et en C2:C20 d'autres valeurs numériques
(utilisation si égalité sur le 1° critère)
En D2 et recopie ==> vers D20 :
=SOMMEPROD((B2+C2/100<$B$2:$B$20+$C$2:$C$20/100)*1)+1

http://cjoint.com/?jxqZMaf7Ep




Publicité
Poster une réponse
Anonyme