probleme d'execution de scripts perl

Le
l3w0rM
Bonjour la liste

Depuis quelques semaines j'ai un petit problème pour faire exécuter les
scripts perl :

le script ne s'exécute pas lorsque je fait ./monscript.pl par contre il
s'exécute bien quand quand je fais perl monscript.pl

echo $PATH me donne bien : /usr/bin/

je suis en SID et je pense que le problème est apparu apres une mise à
jour ..

une idée merci

philippe


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
l3w0rM
Le #21188531
Le 13/02/2010 10:13, Vincent Morlot a écrit :
Bonjour,

le début du fichier de script contient bien la ligne
#!/usr/bin/perl



oui j ai
droit d'éxécution du fichier r?xr?xr??



oui en rx pour u / g / o

merci
quelques idées ....


Le Saturday 13 February 2010 � 08:14, l3w0rM �crivait:

Bonjour la liste

Depuis quelques semaines j'ai un petit problème pour faire exécuter les
scripts perl :

le script ne s'exécute pas lorsque je fait ./monscript.pl par contre il
s'exécute bien quand quand je fais perl monscript.pl

echo $PATH me donne bien : /usr/bin/

je suis en SID et je pense que le problème est apparu apres une mise à
jour .....

une idée merci

philippe


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS










--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
moi-meme
Le #21188521
Le Sat, 13 Feb 2010 08:20:02 +0100, l3w0rM a écrit :

Depuis quelques semaines j'ai un petit problème pour faire exécuter les
scripts perl :

le script ne s'exécute pas lorsque je fait ./monscript.pl par contre il
s'exécute bien quand quand je fais perl monscript.pl

echo $PATH me donne bien : /usr/bin/

je suis en SID et je pense que le problème est apparu apres une mise à
jour .....



et que donne
which perl ?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
l3w0rM
Le #21188721
Le 13/02/2010 10:36, moi-meme a écrit :
Le Sat, 13 Feb 2010 08:20:02 +0100, l3w0rM a écrit :


Depuis quelques semaines j'ai un petit problème pour faire exécuter les
scripts perl :

le script ne s'exécute pas lorsque je fait ./monscript.pl par contre il
s'exécute bien quand quand je fais perl monscript.pl

echo $PATH me donne bien : /usr/bin/

je suis en SID et je pense que le problème est apparu apres une mise à
jour .....



et que donne
which perl ?



classic : /usr/bin/perl





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
fra-duf-no-spam
Le #21188801
Le 14653ième jour après Epoch,
l3w0rM écrivait une question HS sans mettre le tag [HS] ^^:

Bonjour la liste

Depuis quelques semaines j'ai un petit problème pour faire exéc uter
les scripts perl :



Tous les scripts?

le script ne s'exécute pas lorsque je fait ./monscript.pl



C'est à dire? Tu as un message d'erreur, il ne fait rien, il affiche un
sapin de noël ?

il s'exécute bien quand quand je fais perl monscript.pl



Une intuition comme ça: Des caractères de contrôle (genre en registrés
sous DOS) dans la ligne #! ?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Nicolas KOWALSKI
Le #21188851
l3w0rM
Bonjour la liste



Bonjour,

le script ne s'exécute pas lorsque je fait ./monscript.pl par contre
il s'exécute bien quand quand je fais perl monscript.pl



Est-ce que ce script est bien marqué comme executable au niveau des
droits unix ?

--
Nicolas

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Nicolas KOWALSKI
Le #21189801
l3w0rM
Le 13/02/2010 11:49, Nicolas KOWALSKI a écrit :
l3w0rM
le script ne s'exécute pas lorsque je fait ./monscript.pl par contre
il s'exécute bien quand quand je fais perl monscript.pl



Est-ce que ce script est bien marqué comme executable au niveau des
droits unix ?



oui et il fonctionnait il y a plusieurs semaines



Ok.

Quel est le message d'erreur qui apparait lorsque tu le lances ?

--
Nicolas

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
l3w0rM
Le #21189811
Le 13/02/2010 11:49, Nicolas KOWALSKI a écrit :
l3w0rM

Bonjour la liste



Bonjour,


le script ne s'exécute pas lorsque je fait ./monscript.pl par contre
il s'exécute bien quand quand je fais perl monscript.pl



Est-ce que ce script est bien marqué comme executable au niveau des
droits unix ?



oui et il fonctionnait il y a plusieurs semaines
merci



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
moi-meme
Le #21190511
Le Sat, 13 Feb 2010 08:20:02 +0100, l3w0rM a écrit :

je suis en SID et je pense que le problème est apparu apres une mise à
jour .....



le problème ne vient pas de là ?

Moi frileux je suis sous Lenny.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
François Boisson
Le #21191201
> >> le script ne s'exécute pas lorsque je fait ./monscript.pl par contre
>> il s'exécute bien quand quand je fais perl monscript.pl
>>
> Est-ce que ce script est bien marqué comme executable au niveau des
> droits unix ?
>
oui et il fonctionnait il y a plusieurs semaines
merci



perl est bien là où l'entête du fichier l'indique (/usr/bin/perl)?
La partition est bien montée en éxécutable possible?

François Boisson

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
l3w0rM
Le #21191401
Le 13/02/2010 17:46, François Boisson a écrit :

le script ne s'exécute pas lorsque je fait ./monscript.pl par contre
il s'exécute bien quand quand je fais perl monscript.pl




Est-ce que ce script est bien marqué comme executable au niveau des
droits unix ?




oui et il fonctionnait il y a plusieurs semaines
merci




perl est bien là où l'entête du fichier l'indique (/usr/bin/perl)?



oui
La partition est bien montée en éxécutable possible?



oui
François Boisson




merci de ton aide



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme