probleme de formule avec indirect

Le
sleg
BOnjour,

j'utilise cette formule pour des calclul :
=NB.SI(INDIRECT("'\chemin accesom_fichier.XLS!$e:$e");A2)

et j'aimerais remplacer le nom du fichier par le contenue d'une
cellule d'un autre onglets comment puis je faire cela ?

et dans le meme style j'aimerais ouvrir par macro 2 fichiers dont le
chemin serais contenue dans la macro et le nom du fichier dans un
onglet.


merci de votre aide.
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Misange
Le #22149391
Bonjour

indirect te permet d'utiliser une chaine de caractère comme adresse,
que cette adresse soit tapée en dur en une seule fois comme ton
"'\chemin accesnom_fichier.XLS!$e:$e"
ou de faire toutes les concaténations que tu veux dans cette chaine comme
=INDIRECT("'[!"&A1&"]"&A2&"'!"&A3)
en mettant en A1 A2 A3
monclasseur.xls
mafeuille
$G$10 par exemple

Misange migrateuse
http://www.excelabo.net


sleg a écrit :
BOnjour,

j'utilise cette formule pour des calclul :
=NB.SI(INDIRECT("'\chemin accesnom_fichier.XLS!$e:$e");A2)

et j'aimerais remplacer le nom du fichier par le contenue d'une
cellule d'un autre onglets comment puis je faire cela ?

et dans le meme style j'aimerais ouvrir par macro 2 fichiers dont le
chemin serais contenue dans la macro et le nom du fichier dans un
onglet.


merci de votre aide.
sleg
Le #22149871
merci mais j'obtiens un REF alors que mes fichiers sont bien ouvert ??

je ne comprends pas




On 21 mai, 13:20, Misange
Bonjour

indirect te permet  d'utiliser une chaine de caractère comme adresse,
que cette adresse soit tapée en dur en une seule fois comme ton
"'\chemin accesnom_fichier.XLS!$e:$e"
ou de faire toutes les concaténations que tu veux dans cette chaine com me
=INDIRECT("'[!"&A1&"]"&A2&"'!"&A3)
en mettant en A1 A2 A3
monclasseur.xls
mafeuille
$G$10 par exemple

Misange migrateusehttp://www.excelabo.net

sleg a écrit :



> BOnjour,

> j'utilise cette formule pour des calclul :
> =NB.SI(INDIRECT("'\chemin accesnom_fichier.XLS!$e:$e");A2)

> et j'aimerais remplacer le nom du fichier par le contenue d'une
> cellule d'un autre onglets comment puis je faire cela ?

> et dans le meme style j'aimerais ouvrir par macro 2 fichiers dont le
> chemin serais contenue dans la macro et le nom du fichier dans un
> onglet.

> merci de votre aide.- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -
sleg
Le #22150061
ok c bon il ma manquais un " me reste juste a integrer le nom de la
feuille


grand merci a toi

On 21 mai, 14:54, sleg
merci mais j'obtiens un REF alors que mes fichiers sont bien ouvert ??

je ne comprends pas

On 21 mai, 13:20, Misange


> Bonjour

> indirect te permet  d'utiliser une chaine de caractère comme adress e,
> que cette adresse soit tapée en dur en une seule fois comme ton
> "'\chemin accesnom_fichier.XLS!$e:$e"
> ou de faire toutes les concaténations que tu veux dans cette chaine c omme
> =INDIRECT("'[!"&A1&"]"&A2&"'!"&A3)
> en mettant en A1 A2 A3
> monclasseur.xls
> mafeuille
> $G$10 par exemple

> Misange migrateusehttp://www.excelabo.net

> sleg a écrit :

> > BOnjour,

> > j'utilise cette formule pour des calclul :
> > =NB.SI(INDIRECT("'\chemin accesnom_fichier.XLS!$e:$e");A2)

> > et j'aimerais remplacer le nom du fichier par le contenue d'une
> > cellule d'un autre onglets comment puis je faire cela ?

> > et dans le meme style j'aimerais ouvrir par macro 2 fichiers dont le
> > chemin serais contenue dans la macro et le nom du fichier dans un
> > onglet.

> > merci de votre aide.- Masquer le texte des messages précédents -

> - Afficher le texte des messages précédents -- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -
Publicité
Poster une réponse
Anonyme