problème de formule

Le
joseph84
Bonjour tout le monde,

J'ai la formule suivante:

=si(D2="O"),"GO","Stop"

le problème que j'ai c'est que la valeur logique on la retrouve dans
la colonne D en forme de "O"

je ne sais pas comment modifier ma formule pour qu'elle prend compte
des doubles quotes

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #23777351
bonjour Joseph,


=SI(D2="""O""";"GO";"Stop")
ou
=SI(D2="""O""","GO","Stop")

--
isabelle



Le 2011-09-20 13:51, joseph84 a écrit :
Bonjour tout le monde,

J'ai la formule suivante:

=si(D2="O"),"GO","Stop"

le problème que j'ai c'est que la valeur logique on la retrouve dans
la colonne D en forme de "O"

je ne sais pas comment modifier ma formule pour qu'elle prend compte
des doubles quotes

Merci
joseph84
Le #23777401
Merci

mais sa me donne toujours une erreur
:(
MichD
Le #23777461
Bonjour,

Exemple : Si la cellule D1 contient "0" avec les guillemets
la formule d'Isabelle est correcte : =SI(D1="""O""";"GO";"Stop")

Attention, le séparateur d'argument ";" peut aussi être la virgule selon
la valeur définie dans le panneau de configuration.

Si tu as toujours un problème, dis-nous ce que tu as exactement dans la cellule D1.



MichD
------------------------------------------
"joseph84" a écrit dans le message de groupe de discussion :


Merci

mais sa me donne toujours une erreur
:(
joseph84
Le #23777451
voila ma formule au complet:
=SI(OU(D2="Paris",D2="Marseille",D2="Lyon",D2="Lille"),"France",S I(OU(D2="Londre",D2="Bern",D2="Berlin",D2="Madrid",D2="TOTEM"),"E urope",SI(OU(D2="Europe",D2="afrique",D2="Amerique",D2=""Asie""),"R ésident","")))

L'erreur est ""Asie""

parce que dans la cellule on peut on trouve "Asie" avec les doubles
quotes
Charles
Le #23777551
Bonsoir Joseph,


Remplace simplement les virgules par un point virgule et supprime le double
guillemet pour Asie.

J'ai testé, cela fonctionne parfaitement.

Bonne soirée

Charles


"joseph84" news:
voila ma formule au complet:
=SI(OU(D2="Paris",D2="Marseille",D2="Lyon",D2="Lille"),"France",SI(OU(D2="Londre",D2="Bern",D2="Berlin",D2="Madrid",D2="TOTEM"),"Europe",SI(OU(D2="Europe",D2="afrique",D2="Amerique",D2=""Asie""),"Résident","")))

L'erreur est ""Asie""

parce que dans la cellule on peut on trouve "Asie" avec les doubles
quotes
joseph84
Le #23777661
J'ai trouver la solution:

=SI(OU(D2="Paris",D2="Marseille",D2="Lyon",D2="Lille"),"France",S I(OU(D2="L­
ondre",D2="Bern",D2="Berlin",D2="Madrid",D2="TOTEM"),"Europe",SI(OU (D2="Eur­
ope",D2="afrique",D2="Amerique",D2="""Asie"""),"Résident","")))

il faut mettre trois doubles quotes

Merci, bonne fin de soirree :-)
Publicité
Poster une réponse
Anonyme