Probleme de lecture avec un GSM Nokia 6300 via port USB

Le
Nicolas BERNE
Bonjour à tous,

J'ai un Nokia 6300 avec une microSD.
Je n'ai aucun pb lorsque j'accede à la microSD via un lecteur de cartes USB.
Par contre, lorsque j'essaye d'y acceder directement via le GSM en le
branchant via son port USB, les pbs apparaissent.
Tout d'abort, lors du branchement, je choisis "Stockage de données"
depuis le GSM.
Là, tout est bien reconnu :
melkor kernel: usb 1-2: new full speed USB device using ohci_hcd and address 2
melkor kernel: usb 1-2: configuration #1 chosen from 1 choice
melkor kernel: scsi3 : SCSI emulation for USB Mass Storage devices
melkor kernel: usb-storage: device found at 2
melkor kernel: usb-storage: waiting for device to settle before scanning
melkor kernel: scsi 3:0:0:0: Direct-Access Nokia Nokia 6300 0000 PQ: 0 ANSI: 4
melkor kernel: SCSI device sdb: 3920897 512-byte hdwr sectors (2007 MB)
melkor kernel: sdb: Write Protect is off
melkor kernel: sdb: Mode Sense: 03 00 00 00
melkor kernel: sdb: assuming drive cache: write through
melkor kernel: SCSI device sdb: 3920897 512-byte hdwr sectors (2007 MB)
melkor kernel: sdb: Write Protect is off
melkor kernel: sdb: Mode Sense: 03 00 00 00
melkor kernel: sdb: assuming drive cache: write through
melkor kernel: sdb:
melkor kernel: sd 3:0:0:0: Attached scsi removable disk sdb
melkor kernel: usb-storage: device scan complete

Si je fais un "badblocks /dev/sdb", aucune erreur (mais, le debit ne
depasse pas 1Mo/s, alors qu'il est de 8-10Mo/s lorsque je passe par le
lecteur de cartes).

Les pbs arrivent lorsque je monte la "partition" et que j'essaye de lire
des données de la carte (je monte avec un bete "mount -t vfat /dev/sdb
/mnt/Nokia").
A peine, le premier fichier lu, bloquage et impossible d'avoir access à la
carte. Le message suivant apparait alors dans les logs :
melkor kernel: usb 1-2: reset full speed USB device using ohci_hcd and address 2
Et je dois débrancher le GSM pour pouvoir demonter la partition

Par contre, sous WindowsXP (meme en emulation via Vmware), aucun pb
(aussi bien avec le mode "Stockage de données" - le GSM est vu comme une
simple clé USB - ou en "mode Nokia" - en utilisant le logiciel de Nokia
PC Suite).

Bon, le pb n'est pas vital, vu que je peux quand meme utiliser la carte
via un lecteur de cartes mais il reste tout de meme etrange
Donc, si quelqu'un a une idée

A+

--
En ce moment, j'écoute "Loin au Nord"
De "Belenos"
Tiré de leur album "Spicilège"
http://www.last.fm/user/nicolinux/
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas BERNE
Le #1887952
Thus Spoke Nicolas BERNE
Bonjour à tous,

J'ai un Nokia 6300 avec une microSD.
<SNIP>


Oops...
J'ai oublié de préciser que je suis sous Slack 11.0 avec un noyau
2.6.21.1.

A+

--
En ce moment, j'écoute "Chant D'automne"
De "Belenos"
Tiré de leur album "Spicilège"
http://www.last.fm/user/nicolinux/

sansflotusspam
Le #1887949
Nicolas BERNE a commis :

Bonjour à tous,

J'ai un Nokia 6300 avec une microSD.
Je n'ai aucun pb lorsque j'accede à la microSD via un lecteur de
cartes USB. Par contre, lorsque j'essaye d'y acceder directement via
le GSM en le branchant via son port USB, les pbs apparaissent.
Tout d'abort, lors du branchement, je choisis "Stockage de données"
depuis le GSM.
Là, tout est bien reconnu :
melkor kernel: usb 1-2: new full speed USB device using ohci_hcd and
address 2 melkor kernel: usb 1-2: configuration #1 chosen from 1
choice melkor kernel: scsi3 : SCSI emulation for USB Mass Storage
devices melkor kernel: usb-storage: device found at 2
melkor kernel: usb-storage: waiting for device to settle before
scanning
melkor kernel: scsi 3:0:0:0: Direct-Access Nokia Nokia 6300
0000 PQ: 0 ANSI: 4 melkor kernel: SCSI device sdb: 3920897 512-byte
hdwr sectors (2007 MB) melkor kernel: sdb: Write Protect is off
melkor kernel: sdb: Mode Sense: 03 00 00 00
melkor kernel: sdb: assuming drive cache: write through
melkor kernel: SCSI device sdb: 3920897 512-byte hdwr sectors (2007
MB) melkor kernel: sdb: Write Protect is off
melkor kernel: sdb: Mode Sense: 03 00 00 00
melkor kernel: sdb: assuming drive cache: write through
melkor kernel: sdb:
melkor kernel: sd 3:0:0:0: Attached scsi removable disk sdb
melkor kernel: usb-storage: device scan complete

Si je fais un "badblocks /dev/sdb", aucune erreur (mais, le debit ne
depasse pas 1Mo/s, alors qu'il est de 8-10Mo/s lorsque je passe par le
lecteur de cartes).

Les pbs arrivent lorsque je monte la "partition" et que j'essaye de
lire des données de la carte (je monte avec un bete "mount -t vfat
/dev/sdb /mnt/Nokia").


ah ! /dev/sdb, c'est le périphérique bloc au travers duquel est vu le
volume ; il faudrait peut'être cibler la partition, /dev/sdb1 s'il n'y
en a qu'une, par exemple, ou /dev/sdb5 si la carte a été partitionnée
en étendue par win$ ou similaire.
le mieux serait de lancer (en root) un fdisk /dev/sdb pour voir la table
des partitions, et de paramétrer /etc/fstab en fonction.


A peine, le premier fichier lu, bloquage et impossible d'avoir access
à la carte. Le message suivant apparait alors dans les logs :
melkor kernel: usb 1-2: reset full speed USB device using ohci_hcd and
address 2 Et je dois débrancher le GSM pour pouvoir demonter la
partition...

Par contre, sous WindowsXP (meme en emulation via Vmware), aucun pb
(aussi bien avec le mode "Stockage de données" - le GSM est vu comme
une simple clé USB - ou en "mode Nokia" - en utilisant le logiciel de
Nokia PC Suite).

Bon, le pb n'est pas vital, vu que je peux quand meme utiliser la
carte via un lecteur de cartes mais il reste tout de meme etrange...
Donc, si quelqu'un a une idée...

A+



Nicolas BERNE
Le #1887947
Thus Spoke sansflotusspam
Si je fais un "badblocks /dev/sdb", aucune erreur (mais, le debit ne
depasse pas 1Mo/s, alors qu'il est de 8-10Mo/s lorsque je passe par le
lecteur de cartes).

Les pbs arrivent lorsque je monte la "partition" et que j'essaye de
lire des données de la carte (je monte avec un bete "mount -t vfat
/dev/sdb /mnt/Nokia").


ah ! /dev/sdb, c'est le périphérique bloc au travers duquel est vu le
volume ; il faudrait peut'être cibler la partition, /dev/sdb1 s'il n'y
en a qu'une, par exemple, ou /dev/sdb5 si la carte a été partitionnée
en étendue par win$ ou similaire.
le mieux serait de lancer (en root) un fdisk /dev/sdb pour voir la table
des partitions, et de paramétrer /etc/fstab en fonction.
Salut,


Il s'agit bien de /dev/sdb (et non de /dev/sdb1 ou /dev/sdb5).
En fait, la partition vfat est directement sur /dev/sdb (c'est
classique, ça le fait également pour certaines clés et certains lecteurs
mp3).
Et ce n'est pas ça qui pose pb, vu que lorsque je monte la microSD via
le lecteur de cartes (toujours avec un bete "mount -t vfat /dev/sdb
/mnt/SD"), il n'y a aucun pb d'acces.

A+

--
En ce moment, j'écoute "Priez Encore"
De "Belenos"
Tiré de leur album "L'Ancien Temps - Notre Amour Eternel"
http://www.last.fm/user/nicolinux/


Luc.Habert.00__arjf
Le #1887946
Nicolas BERNE :

Si je fais un "badblocks /dev/sdb", aucune erreur (mais, le debit ne
depasse pas 1Mo/s, alors qu'il est de 8-10Mo/s lorsque je passe par le
lecteur de cartes).


Il est reconnu en tant qu'USB 1 :

melkor kernel: usb 1-2: new full speed USB device using ohci_hcd and address 2


, sinon ça parlerait d'ehci_hcd. Je ne sais si c'est un bug ou juste une
limitation du téléphone.

Les pbs arrivent lorsque je monte la "partition" et que j'essaye de lire
des données de la carte (je monte avec un bete "mount -t vfat /dev/sdb
/mnt/Nokia").
A peine, le premier fichier lu, bloquage et impossible d'avoir access à la
carte. Le message suivant apparait alors dans les logs :
melkor kernel: usb 1-2: reset full speed USB device using ohci_hcd and address 2
Et je dois débrancher le GSM pour pouvoir demonter la partition...

Par contre, sous WindowsXP (meme en emulation via Vmware), aucun pb


Certains périphériques ne sont pas complètement conformes à la spec USB mass
storage : ils supportent juste le sous-ensemble utilisé par le driver de
windows. Il est censé y avoir du bugware dans le driver du noyau pour
traiter ces cas particuliers, mais il faut avoir la chance de tomber sur un
cas traité. Tu es peut-être dans un cas de pas de bol. Ça pourrait valoir le
coup de faire un bug report.

Nicolas BERNE
Le #1887945
Thus Spoke Luc Habert
Nicolas BERNE :

Si je fais un "badblocks /dev/sdb", aucune erreur (mais, le debit ne
depasse pas 1Mo/s, alors qu'il est de 8-10Mo/s lorsque je passe par le
lecteur de cartes).


Il est reconnu en tant qu'USB 1 :

melkor kernel: usb 1-2: new full speed USB device using ohci_hcd and address 2


, sinon ça parlerait d'ehci_hcd. Je ne sais si c'est un bug ou juste une
limitation du téléphone.
Effectivement.

Je pense que ça vient du GSM car sous Windows, c'est aussi en USB1 avec
des débits du meme ordre.

Les pbs arrivent lorsque je monte la "partition" et que j'essaye de lire
des données de la carte (je monte avec un bete "mount -t vfat /dev/sdb
/mnt/Nokia").
A peine, le premier fichier lu, bloquage et impossible d'avoir access à la
carte. Le message suivant apparait alors dans les logs :
melkor kernel: usb 1-2: reset full speed USB device using ohci_hcd and address 2
Et je dois débrancher le GSM pour pouvoir demonter la partition...

Par contre, sous WindowsXP (meme en emulation via Vmware), aucun pb


Certains périphériques ne sont pas complètement conformes à la spec USB mass
storage : ils supportent juste le sous-ensemble utilisé par le driver de
windows. Il est censé y avoir du bugware dans le driver du noyau pour
traiter ces cas particuliers, mais il faut avoir la chance de tomber sur un
cas traité. Tu es peut-être dans un cas de pas de bol. Ça pourrait valoir le
coup de faire un bug report.
Bon, vu la différence de débit (facteur 10) entre l'utilisation de la

carte via le GSM et via le lecteur de carte, je ne vais pas trop
insisté.
Sinon, concernant le bug report, ça se passe comment ?

A+

--
En ce moment, j'écoute "Tristesse"
De "Belenos"
Tiré de leur album "L'Ancien Temps - Triste Pensée"
http://www.last.fm/user/nicolinux/


noone
Le #1887936
On Fri, 11 May 2007 17:35:48 +0400, Nicolas BERNE wrote:

Bonjour à tous,

J'ai un Nokia 6300 avec une microSD.
Je n'ai aucun pb lorsque j'accede à la microSD via un lecteur de cartes USB.
Par contre, lorsque j'essaye d'y acceder directement via le GSM en le
branchant via son port USB, les pbs apparaissent.
Tout d'abort, lors du branchement, je choisis "Stockage de données"


on est pas sensé le protocole obex ?

Nicolas BERNE
Le #1887935
Thus Spoke
On Fri, 11 May 2007 17:35:48 +0400, Nicolas BERNE wrote:

Bonjour à tous,

J'ai un Nokia 6300 avec une microSD.
Je n'ai aucun pb lorsque j'accede à la microSD via un lecteur de cartes USB.
Par contre, lorsque j'essaye d'y acceder directement via le GSM en le
branchant via son port USB, les pbs apparaissent.
Tout d'abort, lors du branchement, je choisis "Stockage de données"


on est pas sensé le protocole obex ?


Salut,

Si je ne m'abuse, le protocole obex est utilisé lorsqu'on passe par
l'infrarouge ou le bluetooth (à ce propos, je n'ai pas encore réussi à
me connecter à un GSM via le bluetooth... Si quelqu'un a des infos.)

Dans le cas qui m'interesse, le GSM (lorsqu'on utilise le mode "Stockage
de données") est vu comme un clé USB et utilise par conséquent le "mass
storage". Mais apparement, c'est un peu foireux du côté de mon GSM et ça
plante...

A+

--
En ce moment, j'écoute "Vrede"
De "Månegarm"
Tiré de leur album "Dödsfärd"
http://www.last.fm/user/nicolinux/


Publicité
Poster une réponse
Anonyme