Problème de librairies

Le
François Boisson
Le problème est le suivant:

Deux sarge, l'une installée ce jour, l'autre il y a un an en gros. Sur chacune
maple7 et les mêmes paquets. Sur l'une xmaple7 fonctionne, pas sur l'autre.

Sur la première (qui marche):

$ ldd /usr/local/maple7/bin.IBM_INTEL_LINUX/libmaple.so
libc.so.6 => /lib/libc.so.6 (0x40301000)
libm.so.6 => /lib/libm.so.6 (0x40434000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)

Sur la seconde
$ ldd /usr/local/maple7/bin.IBM_INTEL_LINUX/libmaple.so
libc.so.6 => /lib/tls/libc.so.6 (0xa7bb3000)
libm.so.6 => /lib/tls/libm.so.6 (0xa7b90000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x75555000)

L'erreur est
/usr/local/maple7/bin.IBM_INTEL_LINUX/mserver: relocation
error: /usr/local/maple7/bin.IBM_INTEL_LINUX/libmaple.so: symbol errno,
version GLIBC_2.0 not defined in file libc.so.6 with link time reference

J'ai essayé les choses suivantes:

* Installation du même paquet libc6 via dpkg-repack): echec
* /lib en entête de ld.so.conf et ldconfig: echec
* suppression de /lib/tls/libc-2.3.2.so et /lib/tls/libm-2.3.2.so, xmaple7 se
met à marcher parfaitement MAIS un simple ls plante.
* Utilisation de LD_LIBRARY_PATH en écrivant
LD_LIBRARY_PATH=/lib/:$LD_LIBRARY_PATH
export LD_LIBRARY_PATH
echec.
* Rajout dans le script de lancement de
LD_PRELOAD="/lib/libc-2.3.2.so /lib/libm-2.3.2.so"
export LD_PRELOAD
> Noël, Mazeltov, Youkaïdi, bref chouette!

Cependant pourquoi diable cette différence entre les deux sarges (pures): J'ai
recopié le même ld.so.conf, Et pourquoi cette méprise sur la bonne librairie
à charger.
Je n'ai rien vu d'opportun dans la doc de ld-linux excepté cette variable
LD_PRELOAD, si quelqu'un a des idées.

François Boisson


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
François Boisson
Le #9552811
> L'erreur est
/usr/local/maple7/bin.IBM_INTEL_LINUX/mserver: relocation
error: /usr/local/maple7/bin.IBM_INTEL_LINUX/libmaple.so: symbol errno,
version GLIBC_2.0 not defined in file libc.so.6 with link time reference

J'ai essayé les choses suivantes:

* Installation du même paquet libc6 via dpkg-repack): echec
* /lib en entête de ld.so.conf et ldconfig: echec
* suppression de /lib/tls/libc-2.3.2.so et /lib/tls/libm-2.3.2.so, xmaple7 se
met à marcher parfaitement MAIS un simple ls plante.
* Utilisation de LD_LIBRARY_PATH en écrivant
LD_LIBRARY_PATH=/lib/:$LD_LIBRARY_PATH
export LD_LIBRARY_PATH
echec.
* Rajout dans le script de lancement de
LD_PRELOAD="/lib/libc-2.3.2.so /lib/libm-2.3.2.so"
export LD_PRELOAD


<> ===> Noël, Mazeltov, Youkaïdi, bref chouette!

Cependant pourquoi diable cette différence entre les deux sarges (pures):
J'ai recopié le même ld.so.conf, Et pourquoi cette méprise sur la bonne
librairie à charger.
Je n'ai rien vu d'opportun dans la doc de ld-linux excepté cette variable
LD_PRELOAD, si quelqu'un a des idées.



Je pense avoir une explication: /lib/libc.so.6 est utilisé par défaut avec un
noyau 2.4 et /lib/tls/libc.so.6 avec un noyau 2.6. Cela explique le choix de
ld-linux au moment du chargement du programme. Malheureusement le problème se
repose également avec matlab6 et là, l'astuce du LD_PRELOAD ne fonctionne pas :
(

François Boisson


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme