problème de requête

Le
matthieu
Bonjour à tous,
J'ai créé une requête, j'essaie d'utiliser la syntaxe ANSI-89 pour la
requête et aucun résultat n'est affiché alors qu'il devrait y en avoir. En
effet, dans ma requête, il y a des noms COQUANT, CARLIER, je tape C*. Je
travaille sous windows 2000 le problème ne vient pas de la?
Si quelqu'un sait d'ou vient le problème, ca serait cool de m'aider.
Cordialement.
Matthieu GOURMELON.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
3stone
Le #6282911
Salut;

"matthieu"
| J'ai créé une requête, j'essaie d'utiliser la syntaxe ANSI-89 pour la
| requête et aucun résultat n'est affiché alors qu'il devrait y en avoir. En
| effet, dans ma requête, il y a des noms COQUANT, CARLIER, je tape C*. Je
| travaille sous windows 2000 le problème ne vient pas de la?


Tu écris sûrement "=C*" ce qui est nécessairement faux

Corrige en "Like C*"

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
matthieu
Le #6282901
Non je ne tape pas =C* mais juste C* et ca ne marche pas. Taper Like C* ne
marche pas non plus.
As tu une autre solution?
Merci a+
Matthieu


Salut;

"matthieu"
| J'ai créé une requête, j'essaie d'utiliser la syntaxe ANSI-89 pour la
| requête et aucun résultat n'est affiché alors qu'il devrait y en avoir. En
| effet, dans ma requête, il y a des noms COQUANT, CARLIER, je tape C*. Je
| travaille sous windows 2000 le problème ne vient pas de la?


Tu écris sûrement "=C*" ce qui est nécessairement faux

Corrige en "Like C*"

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)




Jeff
Le #6282891
Salut Matthieu,

Quel est le script exact de ta requête.
Une clause where avec le critère monChamp LIKE "C*" doit marcher sans
problème (ne pas oublier les quotes).

Jeff

"matthieu" news:
Bonjour à tous,
J'ai créé une requête, j'essaie d'utiliser la syntaxe ANSI-89 pour la
requête et aucun résultat n'est affiché alors qu'il devrait y en avoir. En
effet, dans ma requête, il y a des noms COQUANT, CARLIER, je tape C*. Je
travaille sous windows 2000 le problème ne vient pas de la?
Si quelqu'un sait d'ou vient le problème, ca serait cool de m'aider.
Cordialement.
Matthieu GOURMELON.


matthieu
Le #6282731
Bonjour Jeff,

Ma requête est une requêt sélection. J'ai entré les champs sur lesquels je
souhaite faire ma requête sur la ligne Champ, J'ai entré les noms des tables
sur la ligne en dessous.
Sur la ligne OU j'ai entré [Entrez le nom] sous chaque champ et Est Null de
facon a avoir le choix entre taper la valeur dans le champ ou non. Et en
tapant C* dans ma requête lorsque l'on me demande Entrez le nom, le résultats
est nul.
Voila comment j'ai créé ma requête.
Si quelqu'un a une solution merci de se faire connaître.
Matthieu


Salut Matthieu,

Quel est le script exact de ta requête.
Une clause where avec le critère monChamp LIKE "C*" doit marcher sans
problème (ne pas oublier les quotes).

Jeff


Fabien
Le #6282681
Salut Matthieu,

Quel est le script exact de ta requête.
Une clause where avec le critère monChamp LIKE "C*" doit marcher sans
problème (ne pas oublier les quotes).

Jeff

"matthieu" news:
Bonjour à tous,
J'ai créé une requête, j'essaie d'utiliser la syntaxe ANSI-89 pour la
requête et aucun résultat n'est affiché alors qu'il devrait y en avoir. En
effet, dans ma requête, il y a des noms COQUANT, CARLIER, je tape C*. Je
travaille sous windows 2000 le problème ne vient pas de la?
Si quelqu'un sait d'ou vient le problème, ca serait cool de m'aider.
Cordialement.
Matthieu GOURMELON.



Bjr Matthieu

ta chaine Sql = "Select * from TaTable where [TonChamp] like '" &
TonChoix & "*';"
doit te donner le bon résultat
Cf le post de Jeff : Attention aux ' avant et aprés dans la chaine
@+


Fabien
Le #6282661
Bonjour Jeff,

Ma requête est une requêt sélection. J'ai entré les champs sur lesquels je
souhaite faire ma requête sur la ligne Champ, J'ai entré les noms des tables
sur la ligne en dessous.
Sur la ligne OU j'ai entré [Entrez le nom] sous chaque champ et Est Null de
facon a avoir le choix entre taper la valeur dans le champ ou non. Et en
tapant C* dans ma requête lorsque l'on me demande Entrez le nom, le résultats
est nul.
Voila comment j'ai créé ma requête.
Si quelqu'un a une solution merci de se faire connaître.
Matthieu


Salut Matthieu,

Quel est le script exact de ta requête.
Une clause where avec le critère monChamp LIKE "C*" doit marcher sans
problème (ne pas oublier les quotes).

Jeff
Ok c'est plus clair.


Essaie dans la zone critére : comme [entrez le nom ]
ça doit être ok
@+


matthieu
Le #6282591
Merci Fabien tu as trouvé la solution. La prochaine fois que j'ai un problème
j'essayerai d'être clair dès le débuts pour éviter de faire perdre son temps
à tout le monde.
Bonne journée à tous.
Encore merci
Matthieu


Bonjour Jeff,

Ma requête est une requêt sélection. J'ai entré les champs sur lesquels je
souhaite faire ma requête sur la ligne Champ, J'ai entré les noms des tables
sur la ligne en dessous.
Sur la ligne OU j'ai entré [Entrez le nom] sous chaque champ et Est Null de
facon a avoir le choix entre taper la valeur dans le champ ou non. Et en
tapant C* dans ma requête lorsque l'on me demande Entrez le nom, le résultats
est nul.
Voila comment j'ai créé ma requête.
Si quelqu'un a une solution merci de se faire connaître.
Matthieu


Salut Matthieu,

Quel est le script exact de ta requête.
Une clause where avec le critère monChamp LIKE "C*" doit marcher sans
problème (ne pas oublier les quotes).

Jeff
Ok c'est plus clair.


Essaie dans la zone critére : comme [entrez le nom ]
ça doit être ok
@+





Publicité
Poster une réponse
Anonyme