Problème réseau

Le
Euthymenes
Bonjour à tous
Je viens d'installer Vista sur un ordinateur Dell récent que j'avais acheté
expressément avec XP.
Tout fonctionne bien, et même avec une rapidité comparable à XP en faisant
les quelques "optimisations" connues pour leurs effets d'accélération :
suppression du service d'indexation, de Windows defender, du contrôle des
comptes d'utilisateurs,
Bref, tout baigne, sauf un détail qui est apparu dès l'installation initiale
: l'accès aux partitions des autres ordinateurs du réseau local ne marche
qu'en utilisant les adresses IP (fixes dans mon cas), mais pas avec les noms
des ordinateurs.
Les experts du groupe auraient-ils une idée ?
Merci par avance.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Michel Claveau - MVP
Le #20330881
(envoyé via news:\msnews.microsoft.commicrosoft.public.fr.windows.vista.general)

Bonsoir !

Plusieurs pistes :
- Le service NetBios est arrêté.
- Les adresses IP ne sont pas dans le même plan d'adressage.
- Le nom du groupe de travail n'est pas le même sur tous les ordinateurs.

Une solution (presque) "universelle" : remplir le fichiers HOSTS, avec les correspondances IP <==> Nom_machines.

@-salutations
--
MCI
Pierre TORRIS
Le #20331371
Bonjour,

Le +0.81, c'est pour manger les accents et tronquer les titres ?
Anatole22
Le #20331531
"Michel Claveau - MVP" dans le message de news:
(envoyé via
news:\msnews.microsoft.commicrosoft.public.fr.windows.vista.general)

Bonsoir !

Plusieurs pistes :
- Le service NetBios est arrêté.
- Les adresses IP ne sont pas dans le même plan d'adressage.
- Le nom du groupe de travail n'est pas le même sur tous les ordinateurs.

Une solution (presque) "universelle" : remplir le fichiers HOSTS, avec les
correspondances IP <==> Nom_machines.

@-salutations
--
MCI



Merci pour cette réponse rapide !

- Pas de service Netbios dans la liste des services. Mais il n'y a pas non
plus ce service sur un autre ordinateur très similaire, et qui fonctionne.
Peut-être ce service porte-t-il un autre nom que "Netbios" ?
- Adresses IP fixes dans le même plan d'adressage OK : 10.0.0.XX et
255.255.255.0. Les pings et tous les autres adressages fonctionnent. A
l'installation , le masque de sous-réseau était par défaut 255.0.0.0.
Bizarre.
- Nom du groupe de travail = le même (WORKGROUP)

L'addition d'une ligne dans le fichier HOSTS résout effectivement une bonne
partie du problème : l'autre ordinateur du réseau devient accessible par son
nom, comme par son adresse IP.
Dans le fichier SERVICES du même dossier que HOSTS il y a bien 3 lignes
NETBIOS-XX, mais cela ne dit pas si ces 3 services sont actifs ?
Et de toute façon, l'autre ordinateur du réseau ne voit pas par son nom
l'ordinateur dans lequel j'ai modifié HOSTS. Il suffit de lui modifier HOSTS
également.

Mais la fonction "Réséau" de "Démarrer" ne voit toujours pas l'autre
ordinateur. L'ordinateur se voit lui-même, c'est déjà ça, mais pas d'autre
ordinateur dans WORKGROUP. Idem sur l'autre ordinateur du réseau.
L'ordinateur du réseau ne peut pas être mis en cause, car il voyait très
bien l'ordinateur qu'il ne voit plus depuis que celui-ci est passé de XP à
VISTA.
J'ai pourtant fait ce type de basculement XP/VISTA sur d'autres réseaux, et
je n'ai jamais eu de problème.

Cordialement.
Anatole22
Le #20331851
"Anatole22" news:

"Michel Claveau - MVP" dans le message de news:
(envoyé via
news:\msnews.microsoft.commicrosoft.public.fr.windows.vista.general)

Bonsoir !

Plusieurs pistes :
- Le service NetBios est arrêté.
- Les adresses IP ne sont pas dans le même plan d'adressage.
- Le nom du groupe de travail n'est pas le même sur tous les ordinateurs.

Une solution (presque) "universelle" : remplir le fichiers HOSTS, avec
les correspondances IP <==> Nom_machines.

@-salutations
--
MCI



Merci pour cette réponse rapide !

- Pas de service Netbios dans la liste des services. Mais il n'y a pas non
plus ce service sur un autre ordinateur très similaire, et qui fonctionne.
Peut-être ce service porte-t-il un autre nom que "Netbios" ?
- Adresses IP fixes dans le même plan d'adressage OK : 10.0.0.XX et
255.255.255.0. Les pings et tous les autres adressages fonctionnent. A
l'installation , le masque de sous-réseau était par défaut 255.0.0.0.
Bizarre.
- Nom du groupe de travail = le même (WORKGROUP)

L'addition d'une ligne dans le fichier HOSTS résout effectivement une
bonne
partie du problème : l'autre ordinateur du réseau devient accessible par
son
nom, comme par son adresse IP.
Dans le fichier SERVICES du même dossier que HOSTS il y a bien 3 lignes
NETBIOS-XX, mais cela ne dit pas si ces 3 services sont actifs ?
Et de toute façon, l'autre ordinateur du réseau ne voit pas par son nom
l'ordinateur dans lequel j'ai modifié HOSTS. Il suffit de lui modifier
HOSTS
également.

Mais la fonction "Réséau" de "Démarrer" ne voit toujours pas l'autre
ordinateur. L'ordinateur se voit lui-même, c'est déjà ça, mais pas d'autre
ordinateur dans WORKGROUP. Idem sur l'autre ordinateur du réseau.
L'ordinateur du réseau ne peut pas être mis en cause, car il voyait très
bien l'ordinateur qu'il ne voit plus depuis que celui-ci est passé de XP à
VISTA.
J'ai pourtant fait ce type de basculement XP/VISTA sur d'autres réseaux,
et
je n'ai jamais eu de problème.

Cordialement.




Autre constatation :
dans IPCONFIG /ALL
et pour la carte réseau Ethernet concernée, j'ai une ligne "Net bios sur
TCP/IP : activée"
Anatole22
Le #20331951
Plus de détails :

Avec une ligne "10.0.0.13 ORDINATEUR" dans HOSTS, une commande DOS "ping
ORDINATEUR" donne des résultats corrects du type "Réponse de ..." mais avec
une adresse IP longue du type IPv6 et non IPv4.
Alors que j'ai désactivé IPv6 dans les propriétés de la carte Ethernet.

Et une commande "ping localhost" donne des lignes "Réponse de ::1". Bizarre.
Au lieu de 127.0.0.1 qui est d'ailleurs dans le fichier HOSTS.
Anatole22
Le #20332101
Encore moi !!!

C'est bien le protocole IPv4 qui ne fonctionne pas : si je désactive le IPv6
et que je remets le IPv4 dans son état standard (Obtenir automatiquement
tout), plus d'accès réseau du tout !
Comment réparer le IPv4 ?????????
Jean-Claude BELLAMY
Le #20333811
"Anatole22" de discussion :
[...]
- Pas de service Netbios dans la liste des services.



NORMAL !
Vu qu'il ne s'appelle comme çà, mais
"Explorateur d’ordinateurs"
ou (en anglais)
"Browser"
Tient à jour une liste des ordinateurs présents sur le réseau et fournit
cette liste aux ordinateurs désignés comme navigateurs.


Il dépend de DEUX services FONDAMENTAUX (qui doivent eux aussi être
démarrés) :

"Serveur"
en anglais
"LanmanServer"
Prend en charge le partage de fichiers, d’impression et des canaux nommés
via le réseau pour cet ordinateur.


ET
"Station de travail"
en anglais
"LanmanWorkstation"
Crée et maintient des connexions de réseau client à des serveurs distants à
l’aide du protocole SMB.


--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP]
http://www.bellamyjc.org ou http://jc.bellamy.free.fr
Anatole22
Le #20338231
"Jean-Claude BELLAMY" message de news:

"Anatole22" de discussion :
[...]
- Pas de service Netbios dans la liste des services.



NORMAL !
Vu qu'il ne s'appelle comme çà, mais
"Explorateur d’ordinateurs"
ou (en anglais)
"Browser"
Tient à jour une liste des ordinateurs présents sur le réseau et fournit
cette liste aux ordinateurs désignés comme navigateurs.


Il dépend de DEUX services FONDAMENTAUX (qui doivent eux aussi être
démarrés) :

"Serveur"
en anglais
"LanmanServer"
Prend en charge le partage de fichiers, d’impression et des canaux nommés
via le réseau pour cet ordinateur.


ET
"Station de travail"
en anglais
"LanmanWorkstation"
Crée et maintient des connexions de réseau client à des serveurs distants
à l’aide du protocole SMB.


--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP]
http://www.bellamyjc.org ou http://jc.bellamy.free.fr





Merci de cette réponse. Ces 2 services sont l'un et l'autre en cours
d'exécution.
Plus qu'à mettre sur chacun des 2 ordinateurs des raccourcis vers les
partitions de l'autre ordinateur, basés sur l'adresse IP fixe de l'autre
ordinateur.
Ou reprendre à zéro toute l'installation de Vista ..........
Jean-Claude BELLAMY
Le #20338541
"Anatole22" de discussion : uoS$
"Jean-Claude BELLAMY" message de news:
"Anatole22" groupe de discussion :
[...]
- Pas de service Netbios dans la liste des services.



NORMAL !
Vu qu'il ne s'appelle comme çà, mais
"Explorateur d’ordinateurs"
ou (en anglais)
"Browser"
Tient à jour une liste des ordinateurs présents sur le réseau et fournit
cette liste aux ordinateurs désignés comme navigateurs.


Il dépend de DEUX services FONDAMENTAUX (qui doivent eux aussi être
démarrés) :

"Serveur"
en anglais
"LanmanServer"
Prend en charge le partage de fichiers, d’impression et des canaux nommés
via le réseau pour cet ordinateur.


ET
"Station de travail"
en anglais
"LanmanWorkstation"
Crée et maintient des connexions de réseau client à des serveurs distants
à l’aide du protocole SMB.



Merci de cette réponse. Ces 2 services sont l'un et l'autre en cours
d'exécution.



Et le 3ème ?
Celui qui dépend de LanManServer et LanmanWorkstation, à savoir "Browser" ?

Plus qu'à mettre sur chacun des 2 ordinateurs des raccourcis vers les
partitions de l'autre ordinateur, basés sur l'adresse IP fixe de l'autre
ordinateur.



Non, ce n'est pas la bonne solution !
Le "réseau Microsoft" existe, c'est fait pour être utilisé !

On DOIT pouvoir adresser un ordinateur par son nom NETBIOS.
La résolution de nom se fait via une table générée automatiquement par un
ordinateur du réseau qui s'est "élu" comme "master browser" (maître
explorateur), d'où la nécessité d'avoir le service "browser" démarré sur
chaque machine (et donc les services "LanManServer" et "LanmanWorkstation").

Quand on tape la commande
NET START
on doit pouvoir lire :
Les services Windows suivants ont été lancés :
...
Explorateur d’ordinateurs
...
Serveur
...
Station de travail
...

Si l'un d'eux manque, il faut le (re)démarrer :
NET START "Explorateur d’ordinateurs"
NET START "Serveur"
NET START "Station de travail"
(on peut AUSSI utiliser les noms anglais :
NET START Browser
NET START LanManServer
NET START LanmanWorkstation )


Compte tenu que cette exploration peut être assez longue (jusqu'à 72 minutes
ne fonction du réseau!), on peut "accélérer" les choses à l'aide du fichier
%systemroot%system32driversetcLMHOSTS

(et non pas HOSTS, réservé à TCP/IP)
cf. http://www.bellamyjc.org/fr/reseau.html#HOSTS



Ou reprendre à zéro toute l'installation de Vista ..........



Et pourquoi pas alors remplacer les ordinateurs, et changer de domicile ?
!!!!!
N'exagère pas !
On ne change pas de voiture quand le réservoir du lave-glace est vide !

--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP]
http://www.bellamyjc.org ou http://jc.bellamy.free.fr
Anatole22
Le #20339221
"Jean-Claude BELLAMY" message de news:

"Anatole22" groupe de discussion : uoS$
"Jean-Claude BELLAMY" message de news:
"Anatole22" groupe de discussion :
[...]
- Pas de service Netbios dans la liste des services.



NORMAL !
Vu qu'il ne s'appelle comme çà, mais
"Explorateur d’ordinateurs"
ou (en anglais)
"Browser"
Tient à jour une liste des ordinateurs présents sur le réseau et fournit
cette liste aux ordinateurs désignés comme navigateurs.


Il dépend de DEUX services FONDAMENTAUX (qui doivent eux aussi être
démarrés) :

"Serveur"
en anglais
"LanmanServer"
Prend en charge le partage de fichiers, d’impression et des canaux
nommés via le réseau pour cet ordinateur.


ET
"Station de travail"
en anglais
"LanmanWorkstation"
Crée et maintient des connexions de réseau client à des serveurs
distants à l’aide du protocole SMB.



Merci de cette réponse. Ces 2 services sont l'un et l'autre en cours
d'exécution.



Et le 3ème ?
Celui qui dépend de LanManServer et LanmanWorkstation, à savoir "Browser"
?

Plus qu'à mettre sur chacun des 2 ordinateurs des raccourcis vers les
partitions de l'autre ordinateur, basés sur l'adresse IP fixe de l'autre
ordinateur.



Non, ce n'est pas la bonne solution !
Le "réseau Microsoft" existe, c'est fait pour être utilisé !

On DOIT pouvoir adresser un ordinateur par son nom NETBIOS.
La résolution de nom se fait via une table générée automatiquement par un
ordinateur du réseau qui s'est "élu" comme "master browser" (maître
explorateur), d'où la nécessité d'avoir le service "browser" démarré sur
chaque machine (et donc les services "LanManServer" et
"LanmanWorkstation").

Quand on tape la commande
NET START
on doit pouvoir lire :
Les services Windows suivants ont été lancés :
...
Explorateur d’ordinateurs
...
Serveur
...
Station de travail
...

Si l'un d'eux manque, il faut le (re)démarrer :
NET START "Explorateur d’ordinateurs"
NET START "Serveur"
NET START "Station de travail"
(on peut AUSSI utiliser les noms anglais :
NET START Browser
NET START LanManServer
NET START LanmanWorkstation )


Compte tenu que cette exploration peut être assez longue (jusqu'à 72
minutes ne fonction du réseau!), on peut "accélérer" les choses à l'aide
du fichier
%systemroot%system32driversetcLMHOSTS

(et non pas HOSTS, réservé à TCP/IP)
cf. http://www.bellamyjc.org/fr/reseau.html#HOSTS



Ou reprendre à zéro toute l'installation de Vista ..........



Et pourquoi pas alors remplacer les ordinateurs, et changer de domicile ?
!!!!!
N'exagère pas !
On ne change pas de voiture quand le réservoir du lave-glace est vide !



___________________________________________________________________________________________________

Tests effectués :
net start
donne une liste qui contient bien les 3 services
Explorateur d’ordinateurs
Serveur
Station de travail

Par contre dans le dossier qui contient le fichier HOSTS, pas de fichier
LMHOSTS. Seulement un fichier LMHOSTS.SAM qui ne contient que des lignes de
commentaires.

Merci de ton aide (et de ta patience).

PS : le PC concerné est à 700 km de chez moi, mais VNC fonctionne très bien.
Il a juste fallu un peu d'aide locale téléguidée par téléphone pour
installer VISTA + VNC !
Publicité
Poster une réponse
Anonyme