Probleme Samba

Le
at
Bonsoir,

Je ne comprends pas, j'ai partagé un répertoire avec Samba qui est
accessible avec Windows en entrant l'adresse du pc, soit

\192.168.1.13 (dans executer par exemple ou directement dans la barre
d'adresse de l'explorateur)

De cette manière ça fonctionne, je peux parcourir depuis XP le
répertoire partagé.

Par contre, depuis l'explorateur windows, quand je parcours le réseau
et que je clique sur l'icone avec le nom du serveur linux une injure
box me dit \localhost n'est pas accessible, bla bla autorisations
()

J'ai essayé differentes choses mais rien ne marche.

Une idée svp ?

Merci.

ps: le fichier smb.conf

# Samba config file created using SWAT
# from UNKNOWN ()
# Date: 2011/02/25 18:24:49

[global]
workgroup = WINDOWS
server string = Samba Server %v
security = SHARE
encrypt passwords = No
log file = /var/log/samba/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF92 SO_SNDBUF92
printcap name = lpstat
dns proxy = No

[homes]
comment = Home Directories
read only = No
guest ok = Yes

[Media]
path = /mnt
read only = No
guest ok = Yes

[printers]
comment = All Printers
path = /var/spool/samba
create mask = 0700
guest ok = Yes
printable = Yes
print command = lpr-cups -P %p -o raw %s -r
browseable = No

[print$]
path = /var/lib/samba/printers
write list = @adm, root

[pdf-generator]
comment = PDF Generator (only valid users)
path = /var/tmp
printable = Yes
print command = /usr/share/samba/scripts/print-pdf %s ~%u
\\\\%L\\%u %m %I &
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Fabien LE LEZ
Le #23157461
On Fri, 25 Feb 2011 18:25:12 +0100, at
avec le nom du serveur linux une injure
box me dit \localhost n'est pas accessible,



Dans [global], rajoute une ligne :

netbios name = LINUX

(Tu peux remplacer "LINUX" par ce que tu veux.)
xavier
Le #23157501
at
Une idée svp ?



Un problème NetBIOS, à tous les coups.

Tu ne sembles pas avoir configuré WINS, ni le paramètre
netbios name = "ma machine linux" dans smb.conf.

Accéder à un serveur par l'explorateur réseau nécessite une résolution
NetBIOS, soit par la grâce :-} d'un réseau 100% Windows, soit par
l'usage de WINS.

Il y a pas mal d'infos ici : Name Resolution with Samba

--
XAv
In your pomp and all your glory you're a poorer man than me,
as you lick the boots of death born out of fear.
(Jethro Tull)
at
Le #23158831
Merci Fabien et Xavier, c'était bien un problème de netbios name.

Par contre je rencontre un autre problème. Je veux partager une
ressource raccordée sur le port USB, c'est un disque externe avec une
partition en NTFS.

J'arrive à monter le disque avec un

mount -t ntfs-3g /dev/sda1 /mnt -o force

et ensuite je veux la partager avec samba.

Mais impossible d'accéder à la ressource alors qu'un ls /mnt liste bien
les fichiers. Une clef usb formaté en FAT ne pose pas de problème.

Une idée sur le problème ?

Merci.
at
Le #23158821
at a écrit :
Merci Fabien et Xavier, c'était bien un problème de netbios name.

Par contre je rencontre un autre problème. Je veux partager une ressource
raccordée sur le port USB, c'est un disque externe avec une partition en
NTFS.

J'arrive à monter le disque avec un

mount -t ntfs-3g /dev/sda1 /mnt -o force

et ensuite je veux la partager avec samba.

Mais impossible d'accéder à la ressource alors qu'un ls /mnt liste bien les
fichiers. Une clef usb formaté en FAT ne pose pas de problème.

Une idée sur le problème ?

Merci.



Bon en fait j'ai trouvé la réponse en entrant la commande

ntfs-3g /dev/sda1 /mnt

J'ignorai qu'il etait possible de faire un mount sans la commande
mount...

source:
http://webcache.googleusercontent.com/search?qÊche:6H44buJrdYIJ:www.emailsecuritymatters.com/site/blog/best-practices/share-ntfs-usb-hard-drive-vmware-vsphere-esx-4/+samba+usb+ntfs&cd=4&hl=fr&ct=clnk&gl=fr&source=www.google.fr
Publicité
Poster une réponse
Anonyme