Problème sur somme plage variable

Le
Alex
Bonjour à tous,

J'ai un souci avec une addition sur une plage variable et viens
demandé de l'aide pour résoudre ce problème.
Je sais que le debut de ma plage sera toujours "FI2", par contre ma
dernière ligne de la plage est variable, j'ai tenté d'écrire cela :
Selection.FormulaR1C1 = "=SUM(Range("FI2").select:R[-1]C)"
mais cela ne fonctionne.
Quelqu'un aurait il la solution à mon problème ?
Merci par avance de votre aide.
Bien cordialement.
Alex
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #24452841
bonjour Alex,

=SOMME(INDIRECT("FI2:FI"&NBVAL(FI2:FI65536)+1))

--
isabelle



Le 2012-05-04 09:35, Alex a écrit :
Bonjour à tous,

J'ai un souci avec une addition sur une plage variable et viens
demandé de l'aide pour résoudre ce problème.
Je sais que le debut de ma plage sera toujours "FI2", par contre ma
dernière ligne de la plage est variable, j'ai tenté d'écrire cela :
Selection.FormulaR1C1 = "=SUM(Range("FI2").select:R[-1]C)"
mais cela ne fonctionne.
Quelqu'un aurait il la solution à mon problème ?
Merci par avance de votre aide.
Bien cordialement.
Alex
DanielCo
Le #24452831
Bonjour,
A mmoins que tu n'aies besoin de la formule R1C1 :
Selection.Formula = "=SUM(FI2:" & [FI2].End(xlDown).Address(0, 0) & ")"
Cordialement.
Daniel


Bonjour à tous,

J'ai un souci avec une addition sur une plage variable et viens
demandé de l'aide pour résoudre ce problème.
Je sais que le debut de ma plage sera toujours "FI2", par contre ma
dernière ligne de la plage est variable, j'ai tenté d'écrire cela :
Selection.FormulaR1C1 = "=SUM(Range("FI2").select:R[-1]C)"
mais cela ne fonctionne.
Quelqu'un aurait il la solution à mon problème ?
Merci par avance de votre aide.
Bien cordialement.
Alex
Jacquouille
Le #24452941
Bonjour Isabelle

Connais-tu la parade s'il y a une cellule vide? (NBVAL sera différent .....)
Faudrait un truc pour trouver la dernière ligne ....

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"isabelle" a écrit dans le message de groupe de discussion :
jo0mhl$cev$

bonjour Alex,

=SOMME(INDIRECT("FI2:FI"&NBVAL(FI2:FI65536)+1))

--
isabelle



Le 2012-05-04 09:35, Alex a écrit :
Bonjour à tous,

J'ai un souci avec une addition sur une plage variable et viens
demandé de l'aide pour résoudre ce problème.
Je sais que le debut de ma plage sera toujours "FI2", par contre ma
dernière ligne de la plage est variable, j'ai tenté d'écrire cela :
Selection.FormulaR1C1 = "=SUM(Range("FI2").select:R[-1]C)"
mais cela ne fonctionne.
Quelqu'un aurait il la solution à mon problème ?
Merci par avance de votre aide.
Bien cordialement.
Alex
isabelle
Le #24452971
salut mon beau canard,

oui mais il faudra crocher les doigts,

=SOMME(INDIRECT("F2:F"&MAX(SI(F2:F65535<>"";LIGNE(F2:F65535)))))
matricielle (ctrl+maj+enter)

joyeux 700ème

--
isabelle



Le 2012-05-04 09:57, Jacquouille a écrit :
Bonjour Isabelle

Connais-tu la parade s'il y a une cellule vide? (NBVAL sera différent .....)
Faudrait un truc pour trouver la dernière ligne ....

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"isabelle" a écrit dans le message de groupe de discussion : jo0mhl$cev$

bonjour Alex,

=SOMME(INDIRECT("FI2:FI"&NBVAL(FI2:FI65536)+1))

Alex
Le #24453031
Re bonjour à tous,

Oui en effet, il peut y avoir des trous dans la plage.
J'ai testé les différentes propositions, mais cela ne fonctionne pas.
Mon curseur est bien postionné après la dernière cellule de la plage,
et c'est à ce moment la que je souhaite faire mon addition.
Merci encore par avance de votre aide.
Cordialement.
Alex
Alex
Le #24453051
Re :

Pour mon positionnement de mon curseur sur la dernière ligne ou je
souhaites obtenir le résultat.
Je me positionne dans une colonne qui est toujours entierement remplie
(FF) et j'ai écrit cela :
Range("FF1").Select
Selection.End(xlDown).Select
ActiveCell.Offset(1, 0).Range("A1").Select
après je le déplace en mode relatif de trois colonnes sur la droite
afin d'entrer ma formule = somme (FI2 : R-1C)
Encore merci
Alex
Alex
Le #24453151
Re Re :

J'ai tenté aussi en faisant compter les lignes comme suit :
Dim Nbligne As Integer
Dim p As Integer
Nbligne = Range("FF1").CurrentRegion.Rows.Count
p = Nbligne
Selection.Formula = "=SUM(FH2 & ": FH " & p)"

Mais ca marche pas non plus ?
Alex
Alex
Le #24453141
Re :

J'ai tenté également en faisant une variable pour compter les lignes,
j'ai ecrit ceci mais cela ne marche pas non plus :

Dim Nbligne As Integer
Dim p As Integer

Nbligne = Range("FF1").CurrentRegion.Rows.Count
p = Nbligne

Range("FF1").Select
Selection.End(xlDown).Select
ActiveCell.Offset(1, 0).Range("A1").Select
ActiveCell.Offset(0, 2).Range("A1").Select

Selection.Formula = "=SUM(FH2 & ": FH " & p)"

Peut etre est ce plus facile de corriger cela ?
Alex
isabelle
Le #24453261
bonjour Alex,

Dim p As Integer
p = Range("FF" & Rows.Count).End(xlUp).Row
Range("FH" & p + 1).Formula = "=SUM(FH2:FH" & p & ")"

--
isabelle



Le 2012-05-04 10:59, Alex a écrit :
Re :

J'ai tenté également en faisant une variable pour compter les lignes,
j'ai ecrit ceci mais cela ne marche pas non plus :

Dim Nbligne As Integer
Dim p As Integer

Nbligne = Range("FF1").CurrentRegion.Rows.Count
p = Nbligne

Range("FF1").Select
Selection.End(xlDown).Select
ActiveCell.Offset(1, 0).Range("A1").Select
ActiveCell.Offset(0, 2).Range("A1").Select

Selection.Formula = "=SUM(FH2& ": FH "& p)"

Peut etre est ce plus facile de corriger cela ?
Alex
Alex
Le #24453311
Merci Isabelle ca merche super bien
Merci encore, en plus, j'ai pas besoin de me positionner sur la
colonne pour obtenir le calcul
Grand merci et bon week end
Alex
Publicité
Poster une réponse
Anonyme