problème de sshd

Le
Nicolas-MICHEL'_remove_'
Bonjour

J'ai configuré un Mac OS X 10.4.10 client en dhcp
A présent je dois lui mettre une IP fixe.

Quand je mets l'IP fixe, je ne peux plus me connecter en ssh.
Le reste, ARD compris, fonctionne.

le message d'erreur est :
Connection closed by 130.223.212.156

Si je remets l'IP en dhcp, le ssh refonctionne à nouveau.

Je ne trouve rien dans les logs et sshd_config est d'origine.
J'ai renomé /Library/preferences puis rebooté, remis les prefs, même
problème.
J'ai repassé la combo update 10.4.10, pas mieux.

Une idée ?

Mille Merci :)
--
Nicolas
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
patpro ~ Patrick Proniewski
Le #2426661
In article
Nicolas-MICHEL'_remove_'@bluewin.ch (Nicolas MICHEL) wrote:

Bonjour

J'ai configuré un Mac OS X 10.4.10 client en dhcp
A présent je dois lui mettre une IP fixe.

Quand je mets l'IP fixe, je ne peux plus me connecter en ssh.
Le reste, ARD compris, fonctionne.

le message d'erreur est :
Connection closed by 130.223.212.156

Si je remets l'IP en dhcp, le ssh refonctionne à nouveau.

Je ne trouve rien dans les logs et sshd_config est d'origine.
J'ai renomé /Library/preferences puis rebooté, remis les prefs, même
problème.
J'ai repassé la combo update 10.4.10, pas mieux.

Une idée ?


juste pour voir :
sudo ipfw list


patpro

--
http://www.patpro.net/

Nicolas-MICHEL'_remove_'
Le #2426631
patpro ~ Patrick Proniewski
juste pour voir :
sudo ipfw list


J'avais pensé au firewall, mais il n'est pas activé
et j'ai pas installé d'autres système de gesion de ipfw

Il me dit ceci :
65535 allow ip from any to any


Activer ou désactiver le firewall ne change rien.

Merci quand-même :)

--
Nicolas

Nicolas-MICHEL'_remove_'
Le #2426581
Juste pour info, voici le debug mode
(qui ne me dit rien)

$ ssh -vl root toto.isrec.ch
OpenSSH_4.5p1, OpenSSL 0.9.7l 28 Sep 2006
debug1: Reading configuration data /etc/ssh_config
debug1: Connecting to toto.isrec.ch [130.223.212.156] port 22.
debug1: Connection established.
debug1: identity file /Users/toto/.ssh/identity type -1
debug1: identity file /Users/toto/.ssh/id_rsa type -1
debug1: identity file /Users/toto/.ssh/id_dsa type -1
debug1: Remote protocol version 1.99, remote software version
OpenSSH_4.5
debug1: match: OpenSSH_4.5 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.5
debug1: Offering GSSAPI proposal:
[snip]
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: Doing group exchange

debug1: Calling gss_init_sec_context
Connection closed by 130.223.212.156


--
Nicolas
Paul Gaborit
Le #2426551
À (at) Wed, 18 Jul 2007 12:28:37 +0200,
Nicolas-MICHEL'_remove_'@bluewin.ch (Nicolas MICHEL) écrivait (wrote):
Bonjour
J'ai configuré un Mac OS X 10.4.10 client en dhcp
A présent je dois lui mettre une IP fixe.


Quand je mets l'IP fixe, je ne peux plus me connecter en ssh.
Le reste, ARD compris, fonctionne.

le message d'erreur est :
Connection closed by 130.223.212.156

Si je remets l'IP en dhcp, le ssh refonctionne à nouveau.

Je ne trouve rien dans les logs et sshd_config est d'origine.
J'ai renomé /Library/preferences puis rebooté, remis les prefs, même
problème.


Puisque vous parlez de sshd_config, le Mac dont vous parlez est donc
le serveur ssh et vous essayez de vous y connectez en ssh depuis une
autre machine ?

Si c'est bien ça, le fait de changer d'adresse IP peut être la cause
de votre problème (sauf que le message est en général plus clair).
Sur la machine cliente (qui tente de se connecter en ssh vers ce mac),
éditez le fichier known_hosts (généralement dans ~/.ssh/) et supprimez
les lignes correspondant au nom du mac ou à son ancienne adresse IP
(celle qu'il avait en DHCP).


--
Paul Gaborit -

Nicolas-MICHEL'_remove_'
Le #2426521
Paul Gaborit
Si c'est bien ça, le fait de changer d'adresse IP peut être la cause
de votre problème (sauf que le message est en général plus clair).
Sur la machine cliente (qui tente de se connecter en ssh vers ce mac),
éditez le fichier known_hosts (généralement dans ~/.ssh/) et supprimez
les lignes correspondant au nom du mac ou à son ancienne adresse IP
(celle qu'il avait en DHCP).


Ce n'est pas non-plus ça le problème.
Mais ça aurait pu, en effêt.

Finalement j'ai réalisé que depuis un autre client la connexion vers ce
serveur ssh se passe bien.

Et si je supprime mon ticket kerberos sur ma propre machine la connexion
passe bien également.

Lorsque je renouvelle mon ticker krb, en revanche, le problème revient.

Une idée ?
Il doit bien y avoir un cache quelque part ou un truc du genre non ?

Merci d'avance :)


--
Nicolas

Nina Popravka
Le #2426501
On Wed, 18 Jul 2007 14:04:59 +0200,
Nicolas-MICHEL'_remove_'@bluewin.ch (Nicolas MICHEL) wrote:

Et si je supprime mon ticket kerberos sur ma propre machine la connexion
passe bien également.


Quand j'ai des problèmes avec des morceaux de Kerberos dedans, je
pense toujours à un pb de décalage d'heure entre les 2 machines.
--
Nina

Nicolas-MICHEL'_remove_'
Le #2426431
Nina Popravka

Quand j'ai des problèmes avec des morceaux de Kerberos dedans, je
pense toujours à un pb de décalage d'heure entre les 2 machines.


Pas idiot, mais c'est pas ça.

Merci :)
--
Nicolas

Paul Gaborit
Le #2426351
À (at) Wed, 18 Jul 2007 14:04:59 +0200,
Nicolas-MICHEL'_remove_'@bluewin.ch (Nicolas MICHEL) écrivait (wrote):
Et si je supprime mon ticket kerberos sur ma propre machine la connexion
passe bien également.

Lorsque je renouvelle mon ticker krb, en revanche, le problème revient.

Une idée ?
Il doit bien y avoir un cache quelque part ou un truc du genre non ?


C'est donc un problème kerberos et non un problème ssh. Pour en savoir
plus, vous pouvez tenter une connexion 'ssh' ave l'option '-v' (qu'on
peut répetér jusqu'à 2 fois). Mais il y a de grande chance que les
traces ne vous disent rien de plus que "l'authentification kerberos
échoue". Je ne sais pas ce qu'il y a comme outil sous Mac OS X pour
tester kerberos.

--
Paul Gaborit -
laurent.pertois
Le #2426291
Nicolas MICHEL
debug1: Calling gss_init_sec_context


Ca sent des soucis de Kerberos ça.

--
Politically Correct Unix - UTILITIES
The "touch" command has been removed from the standard distribution due
to its inappropriate use by high-level managers.

laurent.pertois
Le #2426281
Nicolas MICHEL
Et si je supprime mon ticket kerberos sur ma propre machine la connexion
passe bien également.

Lorsque je renouvelle mon ticker krb, en revanche, le problème revient.

Une idée ?
Il doit bien y avoir un cache quelque part ou un truc du genre non ?


Et le poste avec lequel tu n'as pas de soucis pour te connecter, il a un
ticket Kerberos ?

Sinon, par défaut il y a tentative de connexion avec authentification
Kerberos et comme ça échoue, il ne va pas plus loin. Mais ça peut aussi
venir d'un soucis d'absence d'entrée dans le DNS ou de d'accès DNS tout
court.

--
Politically Correct Unix - UTILITIES
The "touch" command has been removed from the standard distribution due
to its inappropriate use by high-level managers.

Publicité
Poster une réponse
Anonyme