probleme upgrade sous debian lenny

Le
Thierry B
Bonjour,

Depuis quelques jours, j'ai un problème quand j'essaie d'upgrader ma
debian lenny.

# aptitude update
.
152ko téléchargés en 10s (14,1ko/s)
Lecture des listes de paquets Fait

Current status: 177 mis à jour [+5], 22514 nouveaux [+5].


mais, lors de l'upgrade,

# aptitude safe-upgrade
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances
Lecture des informations d'état Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets Fait
Lecture des descriptions de tâches Fait
Résolution des dépendances
Résolution des dépendances
Résolution des dépendances
Résolution des dépendances
Résolution des dépendances
Résolution des dépendances
Résolution des dépendances
Résolution des dépendances
Résolution des dépendances
Résolution des dépendances
Résolution des dépendances
Résolution des dépendances
Résolution des dépendances
Résolution des dépendances
Résolution des dépendances
Résolution des dépendances
Résolution des dépendances
Les paquets suivants ont des dépendances non satisfaites :
libdiscover2: Est en conflit avec: discover1 mais 1.7.22 est installé.
Est en conflit avec: libdiscover1 mais 1.7.22 est installé.
discover: Est en conflit avec: discover1 mais 1.7.22 est installé.
Est en conflit avec: libdiscover1 mais 1.7.22 est installé.
discover1: Est en conflit avec: discover mais 2.1.2-2 doit être installé.
Est en conflit avec: libdiscover2 mais 2.1.2-2 doit être
installé.


Tiens, je viens juste de faire un test avec apt, et apparemment, cela ne
pose pas de soucis avec lui

# apt-get update puis

# apt-get upgrade
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances
Lecture des informations d'état Fait
Les paquets suivants ont été conservés :
doc-base libcairo2 libcairo2-dev libvte9 totem-mozilla totem-plugins
totem-xine
xbase-clients xfce4-session xfce4-utils xorg xserver-xorg
xserver-xorg-core
xserver-xorg-input-evdev xserver-xorg-input-kbd xserver-xorg-input-mouse
xserver-xorg-input-synaptics xserver-xorg-input-wacom
xserver-xorg-video-apm
xserver-xorg-video-ark xserver-xorg-video-ati xserver-xorg-video-chips
xserver-xorg-video-cirrus xserver-xorg-video-cyrix
xserver-xorg-video-dummy
xserver-xorg-video-fbdev xserver-xorg-video-glint xserver-xorg-video-i128
xserver-xorg-video-i740 xserver-xorg-video-imstt xserver-xorg-video-intel
xserver-xorg-video-mga xserver-xorg-video-neomagic
xserver-xorg-video-newport
xserver-xorg-video-nsc xserver-xorg-video-nv xserver-xorg-video-rendition
xserver-xorg-video-s3 xserver-xorg-video-s3virge
xserver-xorg-video-savage
xserver-xorg-video-siliconmotion xserver-xorg-video-sis
xserver-xorg-video-sisusb
xserver-xorg-video-tdfx xserver-xorg-video-tga xserver-xorg-video-trident
xserver-xorg-video-tseng xserver-xorg-video-v4l xserver-xorg-video-vesa
xserver-xorg-video-vga xserver-xorg-video-via xserver-xorg-video-vmware
xserver-xorg-video-voodoo xutils
Les paquets suivants seront mis à jour :
bsd-mailx compiz compiz-core compiz-dev compiz-fusion-all
compiz-fusion-extras
compiz-fusion-plugins-extra compiz-fusion-plugins-main
compiz-fusion-plugins-unstable
compiz-fusion-plugins-unsupported compiz-gnome compiz-kde compiz-manager
compiz-plugins compizconfig-settings-manager console-common dbus
dbus-x11 emerald
exo-utils fakeroot file fusion-icon htop java-common laptop-detect
libdbus-1-3
libdbus-1-dev libdecoration0 libdecoration0-dev libelfg0
libemeraldengine-dev
libemeraldengine0 libevent1 libexo-0.3-0 libgcrypt11 libgcrypt11-dev
libgsmme1c2a
libkpathsea4 libltdl3 libmagic1 libmysqlclient15off libneon27
libpng12-0 libpng12-dev
libslp1 libspeex1 libtasn1-3 libtasn1-3-dev libthunar-vfs-1-2 libtool
libx86-1
libxine1 libxine1-bin libxine1-console libxine1-ffmpeg libxine1-gnome
libxine1-misc-plugins libxine1-plugins libxine1-x libxvidcore4 mailx
manpages
manpages-fr-extra mysql-common peercast peercast-handlers php-elisp
python-hachoir-core python-hachoir-metadata python-hachoir-parser
python-hachoir-regex
python-hachoir-subfile python-reportlab rdesktop rsync screen
tetex-base tetex-bin
tetex-extra texlive texlive-base texlive-base-bin
texlive-base-bin-doc texlive-common
texlive-doc-base texlive-font-utils texlive-fonts-recommended
texlive-generic-recommended texlive-lang-croatian texlive-lang-cyrillic
texlive-lang-czechslovak texlive-lang-danish texlive-lang-dutch
texlive-lang-finnish
texlive-lang-french texlive-lang-german texlive-lang-greek
texlive-lang-hungarian
texlive-lang-italian texlive-lang-latin texlive-lang-mongolian
texlive-lang-norwegian
texlive-lang-other texlive-lang-polish texlive-lang-portuguese
texlive-lang-spanish
texlive-lang-swedish texlive-lang-vietnamese texlive-latex-base
texlive-latex-recommended texlive-pictures thunar thunar-data
totem-common traceroute
wireshark wireshark-common x11-common xfsprogs xserver-xorg-input-all
xserver-xorg-video-all xserver-xorg-video-i810
123 mis à jour, 0 nouvellement installés, 0 à enlever et 54 non mis à jour.
Il est nécessaire de prendre 110Mo dans les archives.
Après cette opération, 3024ko d'espace disque supplémentaires seront
utilisés.
Souhaitez-vous continuer [O/n] ?

Mais bon, cela m'ennuierait de faire une maj avec apt, du fait que
j'utilise aptitude, depuis que j'ai réinstallé ma debian lenny lol.

Qu'en pensez-vous?

Merci :-)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Louis Giraud
Le #9676141
On Sat, 10 May 2008 14:58:20 +0200
Thierry B
Bonjour,


bonjour,

Depuis quelques jours, j'ai un problème quand j'essaie d'upgrader ma
debian lenny.

# aptitude update
...................
152ko téléchargés en 10s (14,1ko/s)
Lecture des listes de paquets... Fait

Current status: 177 mis à jour [+5], 22514 nouveaux [+5].


mais, lors de l'upgrade,

# aptitude safe-upgrade


peut être essayer full-upgrade au lieu de safe-upgrade : j'utilise
toujours full et je n'ai pas rencontré ce problème ce que le man
aptitude semble confirmer :
safe-upgrade
....

It is sometimes necessary to remove one package in order to
upgrade another; this command is not able to upgrade packages in such
situations. Use the full-upgrade command to upgrade as many packages as
possible.

full-upgrade
Upgrades installed packages to their most recent version,
removing or installing packages as necessary. This command is less
conservative than safe-upgrade and thus more likely to perform unwanted
actions. However, it is capable of upgrading packages that safe-upgrade
cannot upgrade.


--
Cordialement
Jean-Louis Giraud

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Thierry B
Le #9676131
Jean-Louis Giraud a écrit :
On Sat, 10 May 2008 14:58:20 +0200
Thierry B
Bonjour,


bonjour,
Depuis quelques jours, j'ai un problème quand j'essaie d'upgrader ma
debian lenny.

# aptitude update
...................
152ko téléchargés en 10s (14,1ko/s)
Lecture des listes de paquets... Fait

Current status: 177 mis à jour [+5], 22514 nouveaux [+5].


mais, lors de l'upgrade,

# aptitude safe-upgrade


peut être essayer full-upgrade au lieu de safe-upgrade : j'utilise
toujours full et je n'ai pas rencontré ce problème ce que le man
aptitude semble confirmer :
safe-upgrade
....

It is sometimes necessary to remove one package in order to
upgrade another; this command is not able to upgrade packages in such
situations. Use the full-upgrade command to upgrade as many packages as
possible.

full-upgrade
Upgrades installed packages to their most recent version,
removing or installing packages as necessary. This command is less
conservative than safe-upgrade and thus more likely to perform unwanted
actions. However, it is capable of upgrading packages that safe-upgrade
cannot upgrade.





Effectivement,

# aptitude full-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait
Les NOUVEAUX paquets suivants vont être installés :
libfreezethaw-perl{a} libmldbm-perl{a} libpixman-1-0{a}
libpixman-1-dev{a}
libuuid-perl{a} python-profiler{a} x11-apps{a} x11-session-utils{a}
x11-xfs-utils{a} x11-xkb-utils{a}
Les paquets suivants seront ENLEVÉS :
915resolution{a} discover1{u} discover1-data{u} libdiscover1{u}
mdetect{u}
python-xml{u} type-handling{u} xresprobe{u}
Les paquets suivants seront mis à jour :
bsd-mailx compiz compiz-core compiz-dev compiz-fusion-all
compiz-fusion-extras
compiz-fusion-plugins-extra compiz-fusion-plugins-main
compiz-fusion-plugins-unstable compiz-fusion-plugins-unsupported
compiz-gnome
compiz-kde compiz-manager compiz-plugins compizconfig-settings-manager
console-common dbus dbus-x11 doc-base emerald exo-utils fakeroot file
fusion-icon
htop java-common laptop-detect libcairo2 libcairo2-dev libdbus-1-3
libdbus-1-dev
libdecoration0 libdecoration0-dev libelfg0 libemeraldengine-dev
libemeraldengine0
libevent1 libexo-0.3-0 libgcrypt11 libgcrypt11-dev libgsmme1c2a
libkpathsea4
libltdl3 libmagic1 libmysqlclient15off libneon27 libpng12-0
libpng12-dev libslp1
libspeex1 libtasn1-3 libtasn1-3-dev libthunar-vfs-1-2 libtool libvte9
libx86-1
libxine1 libxine1-bin libxine1-console libxine1-ffmpeg libxine1-gnome
libxine1-misc-plugins libxine1-plugins libxine1-x libxvidcore4 mailx
manpages
manpages-fr-extra mysql-common peercast peercast-handlers php-elisp
python-hachoir-core python-hachoir-metadata python-hachoir-parser
python-hachoir-regex python-hachoir-subfile python-reportlab rdesktop
rsync screen
tetex-base tetex-bin tetex-extra texlive texlive-base texlive-base-bin
texlive-base-bin-doc texlive-common texlive-doc-base texlive-font-utils
texlive-fonts-recommended texlive-generic-recommended
texlive-lang-croatian
texlive-lang-cyrillic texlive-lang-czechslovak texlive-lang-danish
texlive-lang-dutch texlive-lang-finnish texlive-lang-french
texlive-lang-german
texlive-lang-greek texlive-lang-hungarian texlive-lang-italian
texlive-lang-latin
texlive-lang-mongolian texlive-lang-norwegian texlive-lang-other
texlive-lang-polish texlive-lang-portuguese texlive-lang-spanish
texlive-lang-swedish texlive-lang-vietnamese texlive-latex-base
texlive-latex-recommended texlive-pictures thunar thunar-data
totem-common
totem-mozilla totem-plugins totem-xine traceroute wireshark
wireshark-common
x11-common xbase-clients xfce4-session xfce4-utils xfsprogs xorg
xserver-xorg
xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-evdev
xserver-xorg-input-kbd xserver-xorg-input-mouse
xserver-xorg-input-synaptics
xserver-xorg-input-wacom xserver-xorg-video-all xserver-xorg-video-apm
xserver-xorg-video-ark xserver-xorg-video-ati xserver-xorg-video-chips
xserver-xorg-video-cirrus xserver-xorg-video-cyrix
xserver-xorg-video-dummy
xserver-xorg-video-fbdev xserver-xorg-video-glint xserver-xorg-video-i128
xserver-xorg-video-i740 xserver-xorg-video-i810 xserver-xorg-video-imstt
xserver-xorg-video-intel xserver-xorg-video-mga
xserver-xorg-video-neomagic
xserver-xorg-video-newport xserver-xorg-video-nsc xserver-xorg-video-nv
xserver-xorg-video-rendition xserver-xorg-video-s3
xserver-xorg-video-s3virge
xserver-xorg-video-savage xserver-xorg-video-siliconmotion
xserver-xorg-video-sis
xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-tga
xserver-xorg-video-trident xserver-xorg-video-tseng
xserver-xorg-video-v4l
xserver-xorg-video-vesa xserver-xorg-video-vga xserver-xorg-video-via
xserver-xorg-video-vmware xserver-xorg-video-voodoo xutils
Les paquets suivants sont RECOMMANDÉS mais ne seront pas installés :
libltdl3-dev texlive-fonts-recommended-doc texlive-latex-base-doc
texlive-latex-recommended-doc texlive-pictures-doc
177 paquets mis à jour, 10 nouvellement installés, 8 à enlever et 0 non
mis à jour.
Il est nécessaire de télécharger 123Mo d'archives. Après dépaquetage,
598ko seront libérés.
Voulez-vous continuer ? [Y/n/?]

mais est-ce prudent finalement, qu'il vire ces paquets? (pqpar exemple,
915resolution, me semblait sympa lol).

Merci :-)



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme