process récalcitrant

Le
Stan
Bonjour,

sur un serveur j'ai des accès en ppp par des modems.
Seulement, je viens de m'apercevoir que les processes pppd n'étaient
pas terminés à la fin
de la connexion, mais pire encore, la commande kill est sans effet sur
eux ( bien qu'ils ne soient pas zombies ).

Non seulement les processes sont visibles sous ps ou top , mais les
interfaces ppp restent également monté ( via ifconfig ).

Une idée du problème et d'éventuelles solution ?

Pour précision, ce serveur est redondant : j'ai déja installé un
serveur de ce genre sous une
RH7.1, je n'ai pas ce comportement; le nouveau serveur tourne sous une
Fedora core 1 et mis à par ce phénomène, tout marche normalement.

Merci.

--
-Stan
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Stan
Le #6856871
On 9 juin, 10:59, Stan
Bonjour,

sur un serveur j'ai des accès en ppp par des modems.
Seulement, je viens de m'apercevoir que les processes pppd n'étaient
pas terminés à la fin
de la connexion, mais pire encore, la commande kill est sans effet sur
eux ( bien qu'ils ne soient pas zombies ).

Non seulement les processes sont visibles sous ps ou top , mais les
interfaces ppp restent également monté ( via ifconfig ).

Une idée du problème et d'éventuelles solution ?

Pour précision, ce serveur est redondant : j'ai déja installé un
serveur de ce genre sous une
RH7.1, je n'ai pas ce comportement; le nouveau serveur tourne sous une
Fedora core 1 et mis à par ce phénomène, tout marche normalement.

Merci.

--
-Stan


En fait, un kill -9 les supprime bien;
il me reste à découvrir pourquoi les processes pppd ne se termine pas
à la fin de la connexion...

--
-Stan

Publicité
Poster une réponse
Anonyme