[Q] SSHkeychain. Ca marche pas chez moi.

Le
blanc
Bonjour à tous.

J'ai voulu tester SSHkeychain. Je l'ai téléchargé, puis installé.
J'ai créé une clef avec ssh-keygen (type DSA)
J'ai mis le fichier id_dsa dans le répertoire .ssh d'une machine
distante "chose" et l'ai renommé en Authorized_keys2 comme indiqué dans
le how-to.
J'ai testé en manuel (dans le Terminal) :
Lancement de ssh, entrée de la passphrase. Ca marche impec : je me
connecte bien sur chose

J'ai ensuite, dans ssh-keychain, ajouté toutes les clés en saisissant la
passphrase (et en cochant la case pour qu'il la mette dans le trousseau)
: il l'a acceptée sans pb.

Puis j'ai essayé de lancer la commande ssh pour me connecter sur chose.
D'abord dans le Terminal, puis dans un xterm de X11. Ca ne marche pas :
ssh me demande la passphrase à chaque fois.

J'ai essayé de changer l'ordre de lancement des différents
protagonistes. Ca ne marche pas mieux.

J'ai cherché un terminal intégré à sshkc ou le moyen de lancer Term à
partir de sshkc. Rien trouvé.

Qu'est-ce que j'ai raté ?

--
JiPaul.
/ /--/--//\ Jean-Paul Blanc
|/| L |\ quelquepart en (somewhere in)
/|| = |||\ FRANCE
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
blanc
Le #2597591
Matt
Pour que loginwindow puisse hériter du socket d'authentification et donc
l'utiliser, il faut relancer ta session ("~/.MacOSX/environment.plist" n'est
lu qu'au démarrage d'une session...)


OK. Ca marche. Merci Matt :-)
--
JiPaul.
/ /--/--//\ Jean-Paul Blanc
|/| L |\ quelquepart en (somewhere in)
/|| = |||\ FRANCE

bonero
Le #21578801
Daniel.C a écrit le 17/04/2010 à 11h07 :
Bonjour.
Merci du retour sur les réponses faites à tes posts. Je suis
toujours
en attente de ton retour sur la réponse faite à ton post du
10/04/2010
13:40:49.
Daniel

Salut tout le monde,

SVP pourriez-vous m’expliquer l’effet de l’argument
AlwaysInsert de la
methode Add sur la collection Listrows d’un objet ListObject ?
Mon code donne le meme resultat que je mette AlwaysInsert= False ou
AlwaysInsert= True.

Voici mon code :

Sub TableAlwaysInsert()

'jai un tableau 6lignes*2colonnes qui contient de valeurs numeriques.
'la 1ere colonne a pour etiquette x, et la 2è colonne a pour etiquette
y.

Worksheets("table").Activate
Dim aFeuil As Worksheet
Set aFeuil = Worksheets("table")

Dim Plage As Range
Set Plage = aFeuil.Range("A11:B16") 'la plage qui contient mon
tableau.

'creation de mon tableau.
aFeuil.ListObjects.Add(xlSrcRange, Plage, , xlYes).Name = "Familia"

Dim T As ListObject: Set T = aFeuil.ListObjects("familia")




' XLigne prend la place de la 1ere ligne.ici alwaysinsert:=True
Dim XLigne As ListRow
Set XLigne = T.ListRows.Add(Position:=1, alwaysinsert:=True)
XLigne.Range.Cells(1, 1).Value = 888: XLigne.Range.Cells(1, 2).Value >
VBA.Rnd + 888

'YLigne prend la place de la 1ere ligne.ici alwaysinsert:úlse
Dim YLigne As ListRow
Set YLigne = T.ListRows.Add(Position:=1, alwaysinsert:úlse) 'prend la
place de la 1ere ligne.
YLigne.Range.Cells(1, 1).Value = 444: YLigne.Range.Cells(1, 2).Value >
VBA.Rnd + 444

'Je ne vois pas l'effet de l'argument alwaysinsert.
'en plus,j'ai remarqué que je n'ai pas "AlwaysInsert" c-a-d
que l'argument
ne se comporte pas comme un mot clef.
End Sub




salut,
je t'avais donné un retour par rapport a ta reponse du 10 avril.c 'etait comment selectionner une colonne entiere(y compris l'etiquette) d 'un tableau excel.
en fait , jai reessayé le meme code et cela a marché.

maintenant mon aide est par rapport à l'utilisation de AlwaysInsert.

merci pour tes reponses.

cordiallement.
Publicité
Poster une réponse
Anonyme