Question pour formulistes...

Le
Francois L
Bonjour tous,

Je cherche, par formule (en VBA, je sais faire mais l'exécution du code
devient vite longue quand le tableau est important), à vérifier dans un
tableau les conditions suivantes :

Le tableau est composé de trois colonnes qui décrivent les relations
fonctionnelles entre divers services d'une entreprise.

Le tableau est comme ce qui suit :
GRH DIR P
GRH IMP E
DIR GRH P
IMP GRH Q
IMP SGE Q

etc.

Les deux premières colonnes sont les services, la troisième le type de
relation.

La formule devrait vérifier si
1 chaque "couple" de services existe bien 2 fois
2 lorsque le couple existe bien 2 fois, le code de la troisième colonne
est bien le même dans les deux cas

Dans l'exemple un code (numérique ou alpha) serait renvoyé
pour le couple GRH-DIR (existe 2 fois et codé de la même manière)
pour le couple GRH-IMP (existe 2 fois mais code différent)
pour le couple IMP-SGE (existe une seule fois)

Avec SOMMEPROD, j'arrive bien à vérifier si les couples existent deux
fois, mais pas à savoir si la troisième condition est remplie. Normal,
je ne suis vraiment pas un bon formuliste !

Merci,

--
François L
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Trirème
Le #5279191
Bonjour François,
Pour ta deuxième formule :
=SOMMEPROD(--(serv1&serv2&relation=LeServ2&LeServ1&LaRelation))

Les plages :
serv1 représente la 1ère plage des services
serv2 représente la 2ème plage des services
relation représente la plage des relations
Les cellules uniques :
LeServ2 représente le 2ème service sur la ligne courante
LeServ1 représente le 1er service sur la ligne courante
LaRelation représente la relation sur la ligne courante

La formule renvoie 1 (ou plus) lorsqu'il y a un couple répondant à tes conditions.
Elle renvoie 0 dans le cas contraire.

Cordialement,
Trirème

Bonjour tous,

Je cherche, par formule (en VBA, je sais faire mais l'exécution du code
devient vite longue quand le tableau est important), à vérifier dans un
tableau les conditions suivantes :

Le tableau est composé de trois colonnes qui décrivent les relations
fonctionnelles entre divers services d'une entreprise.

Le tableau est comme ce qui suit :
GRH DIR P
GRH IMP E
DIR GRH P
IMP GRH Q
IMP SGE Q

etc.

Les deux premières colonnes sont les services, la troisième le type de
relation.

La formule devrait vérifier si
1 chaque "couple" de services existe bien 2 fois
2 lorsque le couple existe bien 2 fois, le code de la troisième colonne
est bien le même dans les deux cas

Dans l'exemple un code (numérique ou alpha) serait renvoyé
pour le couple GRH-DIR (existe 2 fois et codé de la même manière)
pour le couple GRH-IMP (existe 2 fois mais code différent)
pour le couple IMP-SGE (existe une seule fois)

Avec SOMMEPROD, j'arrive bien à vérifier si les couples existent deux
fois, mais pas à savoir si la troisième condition est remplie. Normal,
je ne suis vraiment pas un bon formuliste !

Merci,



Daniel.C
Le #5279181
Bonjour.
Pour la vérification des paires :
=SI(SOMMEPROD(($A$1:$A$5±)*($B$1:$B$5¡))=1;"ok";"nok")
à recopier vers le bas.
Pour la vérification de la 3e colonne :
=SI(SOMMEPROD(($A$1:$A$5±)*($B$1:$B$5¡)*($C$1:$C$5Á))=1;"ok";"nok")
à recopier vers le bas.
Cordialement.
Daniel
"Francois L" de news:
Bonjour tous,

Je cherche, par formule (en VBA, je sais faire mais l'exécution du code
devient vite longue quand le tableau est important), à vérifier dans un
tableau les conditions suivantes :

Le tableau est composé de trois colonnes qui décrivent les relations
fonctionnelles entre divers services d'une entreprise.

Le tableau est comme ce qui suit :
GRH DIR P
GRH IMP E
DIR GRH P
IMP GRH Q
IMP SGE Q

etc.

Les deux premières colonnes sont les services, la troisième le type de
relation.

La formule devrait vérifier si
1 chaque "couple" de services existe bien 2 fois
2 lorsque le couple existe bien 2 fois, le code de la troisième colonne
est bien le même dans les deux cas

Dans l'exemple un code (numérique ou alpha) serait renvoyé
pour le couple GRH-DIR (existe 2 fois et codé de la même manière)
pour le couple GRH-IMP (existe 2 fois mais code différent)
pour le couple IMP-SGE (existe une seule fois)

Avec SOMMEPROD, j'arrive bien à vérifier si les couples existent deux
fois, mais pas à savoir si la troisième condition est remplie. Normal, je
ne suis vraiment pas un bon formuliste !

Merci,

--
François L


Francois L
Le #5279151

Bonjour et merci Trirème,

Ah l'opérateur unaire !

Juste pour le défi, on pourrait distinguer (avec une seule formule) le
cas ou le couple existe mais la relation est différente de celui ou il
n'existe pas ?

--
François L


Bonjour François,
Pour ta deuxième formule :
=SOMMEPROD(--(serv1&serv2&relation=LeServ2&LeServ1&LaRelation))

Les plages :
serv1 représente la 1ère plage des services
serv2 représente la 2ème plage des services
relation représente la plage des relations
Les cellules uniques :
LeServ2 représente le 2ème service sur la ligne courante
LeServ1 représente le 1er service sur la ligne courante
LaRelation représente la relation sur la ligne courante

La formule renvoie 1 (ou plus) lorsqu'il y a un couple répondant à tes
conditions.
Elle renvoie 0 dans le cas contraire.

Cordialement,
Trirème

Bonjour tous,

Je cherche, par formule (en VBA, je sais faire mais l'exécution du
code devient vite longue quand le tableau est important), à vérifier
dans un tableau les conditions suivantes :

Le tableau est composé de trois colonnes qui décrivent les relations
fonctionnelles entre divers services d'une entreprise.

Le tableau est comme ce qui suit :
GRH DIR P
GRH IMP E
DIR GRH P
IMP GRH Q
IMP SGE Q

etc.

Les deux premières colonnes sont les services, la troisième le type de
relation.

La formule devrait vérifier si
1 chaque "couple" de services existe bien 2 fois
2 lorsque le couple existe bien 2 fois, le code de la troisième
colonne est bien le même dans les deux cas

Dans l'exemple un code (numérique ou alpha) serait renvoyé
pour le couple GRH-DIR (existe 2 fois et codé de la même manière)
pour le couple GRH-IMP (existe 2 fois mais code différent)
pour le couple IMP-SGE (existe une seule fois)

Avec SOMMEPROD, j'arrive bien à vérifier si les couples existent deux
fois, mais pas à savoir si la troisième condition est remplie. Normal,
je ne suis vraiment pas un bon formuliste !

Merci,





Francois L
Le #5279141

Bonjour et merci Daniel,

En utilisant les 2 formules j'ai exactement ce dont j'ai besoin.

On aurait pu le faire dans une seule ? (juste pour savoir)

--
François L


Bonjour.
Pour la vérification des paires :
=SI(SOMMEPROD(($A$1:$A$5±)*($B$1:$B$5¡))=1;"ok";"nok")
à recopier vers le bas.
Pour la vérification de la 3e colonne :
=SI(SOMMEPROD(($A$1:$A$5±)*($B$1:$B$5¡)*($C$1:$C$5Á))=1;"ok";"nok")
à recopier vers le bas.
Cordialement.
Daniel
"Francois L" de news:
Bonjour tous,

Je cherche, par formule (en VBA, je sais faire mais l'exécution du code
devient vite longue quand le tableau est important), à vérifier dans un
tableau les conditions suivantes :

Le tableau est composé de trois colonnes qui décrivent les relations
fonctionnelles entre divers services d'une entreprise.

Le tableau est comme ce qui suit :
GRH DIR P
GRH IMP E
DIR GRH P
IMP GRH Q
IMP SGE Q

etc.

Les deux premières colonnes sont les services, la troisième le type de
relation.

La formule devrait vérifier si
1 chaque "couple" de services existe bien 2 fois
2 lorsque le couple existe bien 2 fois, le code de la troisième colonne
est bien le même dans les deux cas

Dans l'exemple un code (numérique ou alpha) serait renvoyé
pour le couple GRH-DIR (existe 2 fois et codé de la même manière)
pour le couple GRH-IMP (existe 2 fois mais code différent)
pour le couple IMP-SGE (existe une seule fois)

Avec SOMMEPROD, j'arrive bien à vérifier si les couples existent deux
fois, mais pas à savoir si la troisième condition est remplie. Normal, je
ne suis vraiment pas un bon formuliste !

Merci,

--
François L






Daniel.C
Le #5279101
=SI(SOMMEPROD(($A$1:$A$5±)*($B$1:$B$5¡)*($C$1:$C$5Á))=1;"tout
ok";SI(SOMMEPROD(($A$1:$A$5±)*($B$1:$B$5¡))=1;"paire seulement
ok";"nok"))
Daniel
"Francois L" de news:

Bonjour et merci Daniel,

En utilisant les 2 formules j'ai exactement ce dont j'ai besoin.

On aurait pu le faire dans une seule ? (juste pour savoir)

--
François L


Bonjour.
Pour la vérification des paires :
=SI(SOMMEPROD(($A$1:$A$5±)*($B$1:$B$5¡))=1;"ok";"nok")
à recopier vers le bas.
Pour la vérification de la 3e colonne :
=SI(SOMMEPROD(($A$1:$A$5±)*($B$1:$B$5¡)*($C$1:$C$5Á))=1;"ok";"nok")
à recopier vers le bas.
Cordialement.
Daniel
"Francois L" message de news:
Bonjour tous,

Je cherche, par formule (en VBA, je sais faire mais l'exécution du code
devient vite longue quand le tableau est important), à vérifier dans un
tableau les conditions suivantes :

Le tableau est composé de trois colonnes qui décrivent les relations
fonctionnelles entre divers services d'une entreprise.

Le tableau est comme ce qui suit :
GRH DIR P
GRH IMP E
DIR GRH P
IMP GRH Q
IMP SGE Q

etc.

Les deux premières colonnes sont les services, la troisième le type de
relation.

La formule devrait vérifier si
1 chaque "couple" de services existe bien 2 fois
2 lorsque le couple existe bien 2 fois, le code de la troisième colonne
est bien le même dans les deux cas

Dans l'exemple un code (numérique ou alpha) serait renvoyé
pour le couple GRH-DIR (existe 2 fois et codé de la même manière)
pour le couple GRH-IMP (existe 2 fois mais code différent)
pour le couple IMP-SGE (existe une seule fois)

Avec SOMMEPROD, j'arrive bien à vérifier si les couples existent deux
fois, mais pas à savoir si la troisième condition est remplie. Normal,
je ne suis vraiment pas un bon formuliste !

Merci,

--
François L







Francois L
Le #5279091

Re Daniel,

Respect et merci,

--
François L


=SI(SOMMEPROD(($A$1:$A$5±)*($B$1:$B$5¡)*($C$1:$C$5Á))=1;"tout
ok";SI(SOMMEPROD(($A$1:$A$5±)*($B$1:$B$5¡))=1;"paire seulement
ok";"nok"))
Daniel
"Francois L" de news:

Bonjour et merci Daniel,

En utilisant les 2 formules j'ai exactement ce dont j'ai besoin.

On aurait pu le faire dans une seule ? (juste pour savoir)

--
François L


Bonjour.
Pour la vérification des paires :
=SI(SOMMEPROD(($A$1:$A$5±)*($B$1:$B$5¡))=1;"ok";"nok")
à recopier vers le bas.
Pour la vérification de la 3e colonne :
=SI(SOMMEPROD(($A$1:$A$5±)*($B$1:$B$5¡)*($C$1:$C$5Á))=1;"ok";"nok")
à recopier vers le bas.
Cordialement.
Daniel
"Francois L" message de news:
Bonjour tous,

Je cherche, par formule (en VBA, je sais faire mais l'exécution du code
devient vite longue quand le tableau est important), à vérifier dans un
tableau les conditions suivantes :

Le tableau est composé de trois colonnes qui décrivent les relations
fonctionnelles entre divers services d'une entreprise.

Le tableau est comme ce qui suit :
GRH DIR P
GRH IMP E
DIR GRH P
IMP GRH Q
IMP SGE Q

etc.

Les deux premières colonnes sont les services, la troisième le type de
relation.

La formule devrait vérifier si
1 chaque "couple" de services existe bien 2 fois
2 lorsque le couple existe bien 2 fois, le code de la troisième colonne
est bien le même dans les deux cas

Dans l'exemple un code (numérique ou alpha) serait renvoyé
pour le couple GRH-DIR (existe 2 fois et codé de la même manière)
pour le couple GRH-IMP (existe 2 fois mais code différent)
pour le couple IMP-SGE (existe une seule fois)

Avec SOMMEPROD, j'arrive bien à vérifier si les couples existent deux
fois, mais pas à savoir si la troisième condition est remplie. Normal,
je ne suis vraiment pas un bon formuliste !

Merci,

--
François L









Publicité
Poster une réponse
Anonyme