Quickcam express

Le
Fabien LUCE
Bonjour à tous,
je suis l'heureux propriétaire d'une quickcam express.
Je suis sous Debian/Testing. Mon noyau: 2.6.22-2-686
Ma carte graphique est une nvidia que j'utilise en twinview car deux
ecrans (celui du portable et de l ecran a cote).
Le driver préconisé pour ma cam est le module qc-usb, compilé et chargé
dans le noyau. Son utilisation est bien confirmée par
*Code:*
lsmod | grep quickcam
quickcam 67300 2
videodev 26656 4 quickcam
usbcore 125096 7
usblp,quickcam,usb_storage,usbhid,ehci_hcd,uhci_hcd


Avant de posté j'ai effectué tout un tas de vérif après moultes recherches:
>>dmesg (apres dé-branchement/branchement webcam)
*Code:*
usb 1-2: new full speed USB device using uhci_hcd and address 13
usb 1-2: configuration #1 chosen from 1 choice
quickcam: QuickCam USB camera found (driver version QuickCam USB 0.6.6
$Date: 2006/11/04 08:38:14 $)
quickcam: Kernel:2.6.22-2-686 bus:1 class:FF subclass:FF vendor:046D
product:0870
quickcam: Sensor HDCS-1020 detected
quickcam: Registered device: /dev/video0


>> Xawtv Scan
*Code:*
This is xawtv-3.95.dfsg.1, running on Linux/i686 (2.6.22-2-686)
looking for available devices
port 325-356
type : Xvideo, image scaler
name : NV17 Video Texture

port 357-388
type : Xvideo, image scaler
name : NV05 Video Blitter

ioctl:
VIDIOC_QUERYCAP(driver="";card="";bus_info="";version=0.0.0;capabilities=0x0
[]): Erreur inconnue 515
/dev/video0: OK [ -device /dev/video0 ]
type : v4l
name : Logitech QuickCam USB
flags: capture




et pour finir d'achever le tout
>> V4l-conf
*Code:*
v4l-conf: using X11 display :0.0
dga: version 2.0
X Error of failed request: XF86DGANoDirectVideoMode
Major opcode of failed request: 137 (XFree86-DGA)
Minor opcode of failed request: 1 (XF86DGAGetVideoLL)
Serial number of failed request: 13
Current serial number in output stream: 13


J'ai essayé d'autres drivers comme gspcamais rien ne
marchecamorama, ekiga, xawtv, amsntotu plante allégrement, par
exemple pour xawtv et sa variante avec nodga

>> Xawtv
*Code:*
This is xawtv-3.95.dfsg.1, running on Linux/i686 (2.6.22-2-686)
xinerama 0: 1680x1050+0+0
xinerama 1: 1440x900+0+0
X Error of failed request: XF86DGANoDirectVideoMode
Major opcode of failed request: 137 (XFree86-DGA)
Minor opcode of failed request: 1 (XF86DGAGetVideoLL)
Serial number of failed request: 13
Current serial number in output stream: 13
v4l-conf had some trouble, trying to continue anyway


Ensuite le désormais légendaire
>> Xawtv -nodga
*Code:*
xinerama 0: 1680x1050+0+0
xinerama 1: 1440x900+0+0
X Error of failed request: XF86DGANoDirectVideoMode
Major opcode of failed request: 137 (XFree86-DGA)
Minor opcode of failed request: 1 (XF86DGAGetVideoLL)
Serial number of failed request: 13
Current serial number in output stream: 13
v4l-conf had some trouble, trying to continue anyway



Je commence à me dire que ca viens du pilote nvidia qui tiens une
embrouille avec le dga j'ai donc aussi essayé le driver libre nv
mais rien de mieux!!

Je commence à saturer et a me dire que faire marcher ma cam ne sera pas
possible sous ma jolie debian!

Si le messie est la ;)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe Merlin
Le #9690051
Bonjour,

Le mercredi 9 avril 2008, Fabien LUCE a écrit :
Bonjour à tous,
je suis l'heureux propriétaire d'une quickcam express.

Je commence à me dire que ca viens du pilote nvidia qui tiens une
embrouille avec le dga... j'ai donc aussi essayé le driver libre nv...
mais rien de mieux!!

Je commence à saturer et a me dire que faire marcher ma cam ne sera pas
possible sous ma jolie debian!

Si le messie est la ;)



Je vois que tu as fait de multiples recherches et essais.
Pourrais tu nous donner le résultat de la commande :
lsusb
A+
Philippe MERLIN
Fabien LUCE
Le #9690041
Philippe Merlin wrote:
Bonjour,

Le mercredi 9 avril 2008, Fabien LUCE a écrit :

Bonjour à tous,
je suis l'heureux propriétaire d'une quickcam express.

Je commence à me dire que ca viens du pilote nvidia qui tiens une
embrouille avec le dga... j'ai donc aussi essayé le driver libre nv...
mais rien de mieux!!

Je commence à saturer et a me dire que faire marcher ma cam ne sera pas
possible sous ma jolie debian!

Si le messie est la ;)




Je vois que tu as fait de multiples recherches et essais.
Pourrais tu nous donner le résultat de la commande :
lsusb
A+
Philippe MERLIN








Si c'est les vendor ID et cam ID que tu regardes, j'ai deja vérifié pour
savoir quel driver il fallait utiliser:
http://www.quickcamteam.net/hcl/linux/logitech-webcams#note_untested

Merci a+

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Fabien LUCE
Le #9689991
Fabien LUCE wrote:
Philippe Merlin wrote:
Bonjour,

Le mercredi 9 avril 2008, Fabien LUCE a écrit :

Bonjour à tous,
je suis l'heureux propriétaire d'une quickcam express.

Je commence à me dire que ca viens du pilote nvidia qui tiens une
embrouille avec le dga... j'ai donc aussi essayé le driver libre nv...
mais rien de mieux!!

Je commence à saturer et a me dire que faire marcher ma cam ne sera pas
possible sous ma jolie debian!

Si le messie est la ;)




Je vois que tu as fait de multiples recherches et essais.
Pourrais tu nous donner le résultat de la commande :
lsusb
A+
Philippe MERLIN








Si c'est les vendor ID et cam ID que tu regardes, j'ai deja vérifié
pour savoir quel driver il fallait utiliser:
http://www.quickcamteam.net/hcl/linux/logitech-webcams#note_untested

Merci a+



Oups pardon j'ai oublié de faire suivre le resultat de lsusb
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 002: ID 1241:1177 Belkin F8E842-DL Mouse
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 006: ID 07ab:fc05 Freecom Technologies
Bus 001 Device 004: ID 0603:00f2 Novatek Microelectronics Corp.
Bus 001 Device 003: ID 046d:0870 Logitech, Inc. QuickCam Express
Bus 001 Device 002: ID 058f:9254 Alcor Micro Corp. Hub
Bus 001 Device 001: ID 0000:0000

Merc i à tous!

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Fabien LUCE
Le #9689981
Philippe Merlin wrote:
Bonjour,

Le mercredi 9 avril 2008, Fabien LUCE a écrit :

Bonjour à tous,
je suis l'heureux propriétaire d'une quickcam express.

Je commence à me dire que ca viens du pilote nvidia qui tiens une
embrouille avec le dga... j'ai donc aussi essayé le driver libre nv...
mais rien de mieux!!

Je commence à saturer et a me dire que faire marcher ma cam ne sera pas
possible sous ma jolie debian!

Si le messie est la ;)




Je vois que tu as fait de multiples recherches et essais.
Pourrais tu nous donner le résultat de la commande :
lsusb
A+
Philippe MERLIN




Sitot dit, sitot fait!

Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 002: ID 1241:1177 Belkin F8E842-DL Mouse
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 006: ID 07ab:fc05 Freecom Technologies
Bus 001 Device 005: ID 043d:0078 Lexmark International, Inc.
Bus 001 Device 004: ID 0603:00f2 Novatek Microelectronics Corp.
Bus 001 Device 003: ID 046d:0870 Logitech, Inc. QuickCam Express
Bus 001 Device 002: ID 058f:9254 Alcor Micro Corp. Hub
Bus 001 Device 001: ID 0000:0000



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Fabien LUCE
Le #9684191
Rebonjour,

bon j'aimerai faire avancer un peu le sujet, surtout que j'ai l
impression apres moultes recherches de ne pas etre le suel à en
"souffrir". Est ce que je vais devoir acheter une autre webcam?
Ca serait un comble...surtout que la cam fonctionne sous ubuntu...

a+

Fabien LUCE wrote:
Philippe Merlin wrote:
Bonjour,

Le mercredi 9 avril 2008, Fabien LUCE a écrit :

Bonjour à tous,
je suis l'heureux propriétaire d'une quickcam express.

Je commence à me dire que ca viens du pilote nvidia qui tiens une
embrouille avec le dga... j'ai donc aussi essayé le driver libre nv...
mais rien de mieux!!

Je commence à saturer et a me dire que faire marcher ma cam ne sera pas
possible sous ma jolie debian!

Si le messie est la ;)




Je vois que tu as fait de multiples recherches et essais.
Pourrais tu nous donner le résultat de la commande :
lsusb
A+
Philippe MERLIN




Sitot dit, sitot fait!

Bus 004 Device 001: ID 0000:0000 Bus 003 Device 001: ID 0000:0000 Bus
002 Device 002: ID 1241:1177 Belkin F8E842-DL Mouse
Bus 002 Device 001: ID 0000:0000 Bus 001 Device 006: ID 07ab:fc05
Freecom Technologies
Bus 001 Device 005: ID 043d:0078 Lexmark International, Inc.
Bus 001 Device 004: ID 0603:00f2 Novatek Microelectronics Corp.
Bus 001 Device 003: ID 046d:0870 Logitech, Inc. QuickCam Express
Bus 001 Device 002: ID 058f:9254 Alcor Micro Corp. Hub
Bus 001 Device 001: ID 0000:0000





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sylvain Sauvage
Le #9684161
Fabien LUCE, samedi 19 avril 2008, 17:39:30 CEST

Rebonjour,



’jour,

bon j'aimerai faire avancer un peu le sujet, surtout que j'ai l
impression apres moultes recherches de ne pas etre le suel à en
"souffrir". Est ce que je vais devoir acheter une autre webcam?
Ca serait un comble...surtout que la cam fonctionne sous ubuntu...



Si elle fonctionne avec Ubuntu, vérifier les messages sous
Ubuntu (dmesg), les versions des pilotes, du noyau…
Ubuntu patche pas mal le noyau (intégration de patches de la
version suivante p.ex.), il faut aller au delà du numéro de
version pour comparer avec le noyau Debian.

Sinon, c’est assez vieux comme modèle/pilote : ça ne bouge pas
trop, (donc/car) ça fonctionne…

J’ai une plus vieille version de la Quickcam Express
(046D:0840) qui fonctionne aussi avec qc-usb, sans trop de
pépins (à part que les canaux RVB sont pris comme BVR, mais
c’est la faute à la caméra…).

--
Sylvain Sauvage
Fabien LUCE
Le #9684011
Oui il faudrait que je reinstalle une ubuntu et que je compare tout
point par point!
J'ai essayé la reinstallation du module qc-usb en version stable, au cas
ou, ca ne marche pas mieux...je pense qu'il s'agit vraiment d'un pb v4l....
En fait je ne sait pas grand chose sur la relation qc-usb et v4l, si
quelqu un peut eclairer ma lanterne...

Merci encore pour votre aide

Sylvain Sauvage wrote:
Fabien LUCE, samedi 19 avril 2008, 17:39:30 CEST

Rebonjour,




’jour,


bon j'aimerai faire avancer un peu le sujet, surtout que j'ai l
impression apres moultes recherches de ne pas etre le suel à en
"souffrir". Est ce que je vais devoir acheter une autre webcam?
Ca serait un comble...surtout que la cam fonctionne sous ubuntu...




Si elle fonctionne avec Ubuntu, vérifier les messages sous
Ubuntu (dmesg), les versions des pilotes, du noyau…
Ubuntu patche pas mal le noyau (intégration de patches de la
version suivante p.ex.), il faut aller au delà du numéro de
version pour comparer avec le noyau Debian.

Sinon, c’est assez vieux comme modèle/pilote : ça ne bouge pas
trop, (donc/car) ça fonctionne…

J’ai une plus vieille version de la Quickcam Express
(046D:0840) qui fonctionne aussi avec qc-usb, sans trop de
pépins (à part que les canaux RVB sont pris comme BVR, mais
c’est la faute à la caméra…).





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Fabien LUCE
Le #9683951
Salut,

merci pour ta reponse, mais cela est couvert par ce que j'ai deja tenté
sur cette webcam.
Je me demande si la version du module v4l que j utilise est pas un peu
buggée!

a+ et merci

Stephane List wrote:
Salut

Il y a un tuto sur comment installer qc-usb sur Debian ici :
http://slist.lilotux.net/linux/webcam/

Et la, une application pour essayer :
http://slist.lilotux.net/linux/qwebcam/index_fr.html

Si ca peut aider...

Steph

Fabien LUCE a écrit :

Oui il faudrait que je reinstalle une ubuntu et que je compare tout
point par point!
J'ai essayé la reinstallation du module qc-usb en version stable, au cas
ou, ca ne marche pas mieux...je pense qu'il s'agit vraiment d'un pb v4l....
En fait je ne sait pas grand chose sur la relation qc-usb et v4l, si
quelqu un peut eclairer ma lanterne...

Merci encore pour votre aide

Sylvain Sauvage wrote:

Fabien LUCE, samedi 19 avril 2008, 17:39:30 CEST


Rebonjour,




’jour,



bon j'aimerai faire avancer un peu le sujet, surtout que j'ai l
impression apres moultes recherches de ne pas etre le suel à en
"souffrir". Est ce que je vais devoir acheter une autre webcam?
Ca serait un comble...surtout que la cam fonctionne sous ubuntu...




Si elle fonctionne avec Ubuntu, vérifier les messages sous
Ubuntu (dmesg), les versions des pilotes, du noyau…
Ubuntu patche pas mal le noyau (intégration de patches de la
version suivante p.ex.), il faut aller au delà du numéro de
version pour comparer avec le noyau Debian.

Sinon, c’est assez vieux comme modèle/pilote : ça ne bouge pas trop,
(donc/car) ça fonctionne…

J’ai une plus vieille version de la Quickcam Express
(046D:0840) qui fonctionne aussi avec qc-usb, sans trop de
pépins (à part que les canaux RVB sont pris comme BVR, mais
c’est la faute à la caméra…).













--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Stephane List
Le #9683941
Salut

Il y a un tuto sur comment installer qc-usb sur Debian ici :
http://slist.lilotux.net/linux/webcam/

Et la, une application pour essayer :
http://slist.lilotux.net/linux/qwebcam/index_fr.html

Si ca peut aider...

Steph

Fabien LUCE a écrit :
Oui il faudrait que je reinstalle une ubuntu et que je compare tout
point par point!
J'ai essayé la reinstallation du module qc-usb en version stable, au cas
ou, ca ne marche pas mieux...je pense qu'il s'agit vraiment d'un pb v4l....
En fait je ne sait pas grand chose sur la relation qc-usb et v4l, si
quelqu un peut eclairer ma lanterne...

Merci encore pour votre aide

Sylvain Sauvage wrote:
Fabien LUCE, samedi 19 avril 2008, 17:39:30 CEST

Rebonjour,




’jour,


bon j'aimerai faire avancer un peu le sujet, surtout que j'ai l
impression apres moultes recherches de ne pas etre le suel à en
"souffrir". Est ce que je vais devoir acheter une autre webcam?
Ca serait un comble...surtout que la cam fonctionne sous ubuntu...




Si elle fonctionne avec Ubuntu, vérifier les messages sous
Ubuntu (dmesg), les versions des pilotes, du noyau…
Ubuntu patche pas mal le noyau (intégration de patches de la
version suivante p.ex.), il faut aller au delà du numéro de
version pour comparer avec le noyau Debian.

Sinon, c’est assez vieux comme modèle/pilote : ça ne bouge pas trop,
(donc/car) ça fonctionne…

J’ai une plus vieille version de la Quickcam Express
(046D:0840) qui fonctionne aussi avec qc-usb, sans trop de
pépins (à part que les canaux RVB sont pris comme BVR, mais
c’est la faute à la caméra…).








--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme