raid, crypt twofish & LVM

Le
franck Dufau
Il s'agit d'un message à parties multiples au format MIME.

=_NextPart_000_0001_01C9B964.11986D00
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

Bonjour,



Je souhaite installer un serveur personnel dont la configuration est la
suivante :



SDA 80 GO}
{ swap 1GO

} raid 0 crypté en twofish puis LVM{

SDB 80 GO}
{ / 150 GO Ext3



SDC 80 GO}

}

SDD 80 GO}

} raid 0 crypté en twofish puis LVM { /data 320 =
GO ext3

SDE 80 GO}

}

SDF 80 GO}



L’installation c’est bien passé jusqu’au moment ou lors de =
l’installation de
grub (en général c’est grub)

Le system m’informe qu’il est impossible d’installer lilo !?!



Je ne peux donc pas installer ni lilo ni grub qui est le loader par =
défaut !
non ?



Bref comment rendre viable cette configuration ?



OU tout simplement…. Suis-je en train de demander l’impossible ???



Cordialement



Franck


=_NextPart_000_0001_01C9B964.11986D00
Content-Type: text/html;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<html xmlns:v="urn:schemas-microsoft-com:vml" =
xmlns:o="urn:schemas-microsoft-com:office:office" =
xmlns:w="urn:schemas-microsoft-com:office:word" =
xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" =
xmlns="http://www.w3.org/TR/REC-html40">

<head>
<meta http-equiv=Content-Type content="text/html; =
charset=iso-8859-1">
<meta name=Generator content="Microsoft Word 12 (filtered medium)">
<style>
<!--
/* Font Definitions */
@font-face
{font-family:"Cambria Math";
panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
{font-family:Calibri;
panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
{margin:0cm;
margin-bottom:.0001pt;
font-size:11.0pt;
font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
{mso-style-priority:99;
color:blue;
text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
{mso-style-priority:99;
color:purple;
text-decoration:underline;}
span.EmailStyle17
{mso-style-type:personal-compose;
font-family:"Calibri","sans-serif";
color:windowtext;}
.MsoChpDefault
{mso-style-type:export-only;}
@page Section1
{size:612.0pt 792.0pt;
margin:70.85pt 70.85pt 70.85pt 70.85pt;}
div.Section1
{page:Section1;}
-->
</style>
<!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
</head>

<body lang=FR link=blue vlink=purple>

<div class=Section1>

<p class=MsoNormal>Bonjour, <o:p></o:p></p>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<p class=MsoNormal>Je souhaite installer un serveur personnel dont la
configuration est la suivante&nbsp;: <o:p></o:p></p>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<p class=MsoNormal>SDA 80 =
GO}                        =
                         =
                    
{ swap 1GO<o:p></o:p></p>

<p class=MsoNormal>                =
     } raid 0 crypté en twofish puis LVM{<o:p></o:p></p>

<p class=MsoNormal>SDB 80 =
GO}                        =
        =
                         =
             {
/ 150 GO Ext3<o:p></o:p></p>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<p class=MsoNormal>SDC 80 GO}<o:p></o:p></p>

<p class=MsoNormal>                =
      }<o:p></o:p></p>

<p class=MsoNormal>SDD 80 GO}<o:p></o:p></p>

<p class=MsoNormal>                =
     } raid 0 crypté en twofish puis LVM { /data
320 GO ext3<o:p></o:p></p>

<p class=MsoNormal>SDE 80 GO}<o:p></o:p></p>

<p class=MsoNormal>                =
     }<o:p></o:p></p>

<p class=MsoNormal>SDF 80 GO}<o:p></o:p></p>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<p class=MsoNormal>L&#8217;installation c&#8217;est bien passé =
jusqu&#8217;au
moment ou lors de l&#8217;installation de grub (en général =
c&#8217;est grub)<o:p></o:p></p>

<p class=MsoNormal>Le system m&#8217;informe qu&#8217;il est =
impossible d&#8217;installer
lilo&nbsp;!?!<o:p></o:p></p>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<p class=MsoNormal>Je ne peux donc pas installer ni lilo ni grub qui =
est le
loader par défaut&nbsp;! non&nbsp;?<o:p></o:p></p>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<p class=MsoNormal>Bref comment rendre viable cette =
configuration&nbsp;?<o:p></o:p></p>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<p class=MsoNormal>OU tout simplement&#8230;. Suis-je en train de =
demander l&#8217;impossible&nbsp;???<o:p></o:p></p>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<p class=MsoNormal>Cordialement<o:p></o:p></p>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<p class=MsoNormal>Franck<o:p></o:p></p>

</div>

</body>

</html>

=_NextPart_000_0001_01C9B964.11986D00--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
François Cerbelle
Le #19089051
franck Dufau a écrit :
Bonjour,
Je souhaite installer un serveur personnel dont la configuration est la
suivante :


[...]
L’installation c’est bien passé jusqu’au moment ou lors de
l’installation de grub (en général c’est grub)
Le system m’informe qu’il est impossible d’installer lilo !?!
Je ne peux donc pas installer ni lilo ni grub qui est le loader par
défaut ! non ?
Bref comment rendre viable cette configuration ?
OU tout simplement…. Suis-je en train de demander l’impossible ???



Théoriquement, l'installateur Debian te propose d'utiliser grub2 à la
place de grub. Mais je crois qu'il ne te le propose pas dans le cas ou
/boot n'est pas sur une partition claire et normale (les tiennes ne sont
pas particulièrement foncées ou anormales, mais raides, chiffrées et
lvmisée). Je n'ai pas essayé aussi loin, mais j'avais constaté ce
comportement sur du simple LVM (sans RAID ni crypt). Il ne doit peut
etre même pas te proposer grub du tout.

Personnellement, j'ai préféré opter pour la simplicité : OK pour aller
jusqu'à mettre le SWAP sur du LVM/CRYPT/RAID, mais je laisse /boot sur
/sda1 (eventuellement mirrorée).

Tout ca pour dire que tu pourrais tenter d'installer manuellement grub2
(paquet grub-pc). Il fonctionne avec des modules (un peu des pilotes)
pour savoir quoi faire avec chaque instruction et une sorte d'initrd.

Je ne comprends pas pourquoi tu ne peux pas installer LILO, son principe
de fonctionnement /devrait/ permettre de démarrer à peu pres n'importe
quoi du moment que tu as le bon noyau avec les bons modules dans ton initrd.

Sinon, il te reste SYSLINUX.

Je ne suis pas certain de t'avoir beaucoup aidé. J'espère juste t'avoir
donné des idées qui te mèneront à la solution

Bonne nuit
Fanfan

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Goldy
Le #19089481
franck Dufau a écrit :
Bonjour,



Je souhaite installer un serveur personnel dont la configuration est la
suivante :



SDA 80
GO}
{ swap 1GO

} raid 0 crypté en twofish puis LVM{

SDB 80 GO}
{ / 150 GO Ext3



SDC 80 GO}

}

SDD 80 GO}

} raid 0 crypté en twofish puis LVM { /data 320 GO ext3

SDE 80 GO}

}

SDF 80 GO}



L’installation c’est bien passé jusqu’au moment ou lors de
l’installation de grub (en général c’est grub)

Le system m’informe qu’il est impossible d’installer lilo !?!



Je ne peux donc pas installer ni lilo ni grub qui est le loader par
défaut ! non ?



Bref comment rendre viable cette configuration ?



OU tout simplement…. Suis-je en train de demander l’impossible ???



Cordialement



Franck




Bonjour,

Personnellement, pour le raid, j'installe lilo sur un clef USB sur
laquelle j'y créé /boot.

Ça fonctionne très bien chez moi, mais ça peut dépendre du matériel,
j'ai un laptop par exemple qui refuse de booter une clé usb si celle-ci
n'est pas en fat32...

Seconde solution, c'est d'ajouter un petit disque dur dédié uniquement à
/boot, voir 2 disques en raid 1, pour la tolérance aux pannes. Possible
probablement avec de toute petit disques flash, ça ne coute rien et
facile à mettre en œuvre.

N'essaie pas d'installer grub sur un raid ou sur du crypté, ça ne marche
pas et ce n'est pas possible.

(message envoyé par erreur sur la boite personnelle)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Sylvain Sauvage
Le #19089521
’soir,

François Cerbelle, jeudi 9 avril 2009, 23:31:20 CEST

franck Dufau a écrit :
> Bonjour,
> Je souhaite installer un serveur personnel dont la configuration est la
> suivante :
[...]



Nonobstant la présentation obscure de ce que tu veux faire, je
ne pige pas du tout l’intérêt de faire du LVM sur du RAID -0…

> L’installation c’est bien passé jusqu’au m oment ou lors de
> l’installation de grub (en général c’est grub)
> Le system m’informe qu’il est impossible d’inst aller lilo !?!
> Je ne peux donc pas installer ni lilo ni grub qui est le loader par
> défaut ! non ?
> Bref comment rendre viable cette configuration ?
> OU tout simplement…. Suis-je en train de demander l’imp ossible ???

Théoriquement, l'installateur Debian te propose d'utiliser grub2 à   la
place de grub.[…]



Euh, l’installateur (de Lenny) propose lilo et grub (pas
grub-pc/grub2).

Et si /boot est en RAID + LVM, vu que grub ne sait pas faire,
il installe lilo sans rien demander (en mode « pas expert  »).
C’est ce qu’il a dû essayer de faire. Sans réussi r. Peut-être à
cause du chiffrement ?

En tout cas, on peut toujours finir l’installation sans
programme de démarrage puis installer celui-ci ensuite (le
système n’est alors évidemment pas boutable mais on peut
démarrer depuis un CD, une clef, etc., en mode rescue p.ex. ou
en chroot pour l’installer). Et donc, là, choisir grub-pc (s ’il
sait faire RAID+LVM+chiffrement).
Sinon, repenser le démarrage : lilo et grub2 savent faire
RAID-1 + LVM, grub (v1) sait faire si /boot est hors LVM.

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Goldy
Le #19089671
Sylvain Sauvage a écrit :
’soir,

François Cerbelle, jeudi 9 avril 2009, 23:31:20 CEST
franck Dufau a écrit :
Bonjour,
Je souhaite installer un serveur personnel dont la configuration est la
suivante :


[...]



Nonobstant la présentation obscure de ce que tu veux faire, je
ne pige pas du tout l’intérêt de faire du LVM sur du RAID-0…





Le fait d'avoir une swap sur un raid0, ça me gêne pas outre mesure
personnellement, ou alors il faut que tu nous expliques un peu mieux ton
point de vu.


L’installation c’est bien passé jusqu’au moment ou lors de
l’installation de grub (en général c’est grub)
Le system m’informe qu’il est impossible d’installer lilo !?!
Je ne peux donc pas installer ni lilo ni grub qui est le loader par
défaut ! non ?
Bref comment rendre viable cette configuration ?
OU tout simplement…. Suis-je en train de demander l’impossible ???


Théoriquement, l'installateur Debian te propose d'utiliser grub2 à la
place de grub.[…]



Euh, l’installateur (de Lenny) propose lilo et grub (pas
grub-pc/grub2).



L'installateur de lenny propose grub2 en mode expert, il pose la
question de savoir si on veut l'utiliser malgré qu'il ne soit pas stable.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Sylvain Sauvage
Le #19089721
Goldy, vendredi 10 avril 2009, 01:56:48 CEST
[…]
> Nonobstant la présentation obscure de ce que tu veux faire, je
> ne pige pas du tout l’intérêt de faire du LVM sur du RAID-0…

Le fait d'avoir une swap sur un raid0, ça me gêne pas outre mes ure
personnellement, ou alors il faut que tu nous expliques un peu mieux ton
point de vu.



Ce n’est pas la partition d’échange sur du RAID-0 qu i me gêne,
c’est du RAID-0 sous du LVM. Dans LVM, un VG peut s’ét aler sur
plusieurs PV, en alternance (stripping) si on veut.
Donc quel intérêt de faire RAID-0+LVM là où le LVM su ffit ?

Ou alors c’est à cause du chiffrement ? Mais bon, j⠀™ai rien
capté au « schéma », non plus…

[…]
> Euh, l’installateur (de Lenny) propose lilo et grub (pas
> grub-pc/grub2).

L'installateur de lenny propose grub2 en mode expert, il pose la
question de savoir si on veut l'utiliser [bien] qu'il ne soit pas stable.



Oups, il semble bien que j’ai raté cette option (le menu et la
doc disent « grub » et je n’ai pas vu de pub/an nonce sur
l’utilisation du 2). Sinon, j’utilise l’installatio n « non
expert » ; elle fonctionne tellement bien ;o) (et même en
graphique cette année :oP ).

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Goldy
Le #19093421
Sylvain Sauvage a écrit :
Goldy, vendredi 10 avril 2009, 01:56:48 CEST
[…]
Nonobstant la présentation obscure de ce que tu veux faire, je
ne pige pas du tout l’intérêt de faire du LVM sur du RAID-0…


Le fait d'avoir une swap sur un raid0, ça me gêne pas outre mesure
personnellement, ou alors il faut que tu nous expliques un peu mieux ton
point de vu.



Ce n’est pas la partition d’échange sur du RAID-0 qui me gêne,
c’est du RAID-0 sous du LVM. Dans LVM, un VG peut s’étaler sur
plusieurs PV, en alternance (stripping) si on veut.
Donc quel intérêt de faire RAID-0+LVM là où le LVM suffit ?





Cette configuration de lvm n'est pas possible avec l'installateur (il me
semble, j'avoue n'avoir jamais utilisé lvm de cette façon, n'étant pas
très raid 0 dans l'absolu), donc l'utilisation du raid 0 + LVM est
probablement plus un choix pratique.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme