raid10 changement de configuration ?

Le
Grégoire COUTANT
Bonjour à tous,
N'étant pas un expert de la gestion du raid, j'en appelle à vos lumières.
J'ai créé un raid10 à l'installation d'une debian wheezy.
Régulièrement deux disques sortent du raid, voire quand ça reboote, je
vois un nouveau raid de créé (md127) sans savoir d'où ça vient.

Savez-vous ce que je peux regarder pour comprendre où ça pose pb et
comment faire pour obtenir un raid fonctionnel ?

root@serre:~# cat /proc/mdstat
Personalities : [raid10]
md127 : active (auto-read-only) raid10 sda1[4] sde1[5]
1953260544 blocks super 1.2 512K chunks 2 near-copies [4/2] [_U_U]

md0 : active raid10 sdc1[0] sdd1[2]
1953260544 blocks super 1.2 512K chunks 2 near-copies [4/2] [U_U_]

unused devices: <none>

Le listing des disques :

root@serre:~# fdisk -l

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util
fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
81 heads, 63 sectors/track, 382818 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x00000000

Device Boot Start End Blocks Id System
/dev/sda1 2048 1953525167 976761560 fd Linux raid
autodetect

WARNING: GPT (GUID Partition Table) detected on '/dev/sdc'! The util
fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sdc: 1000.2 GB, 1000204886016 bytes
78 heads, 63 sectors/track, 397542 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x00000000

Device Boot Start End Blocks Id System
/dev/sdc1 2048 1953525167 976761560 fd Linux raid
autodetect

Disk /dev/sdb: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders, total 234441648 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0000371c

Device Boot Start End Blocks Id System
/dev/sdb1 * 2048 224860159 112429056 83 Linux
/dev/sdb2 224862206 234440703 4789249 5 Extended
/dev/sdb5 224862208 234440703 4789248 82 Linux swap / Solaris

WARNING: GPT (GUID Partition Table) detected on '/dev/sdd'! The util
fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sdd: 1000.2 GB, 1000204886016 bytes
81 heads, 63 sectors/track, 382818 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x00000000

Device Boot Start End Blocks Id System
/dev/sdd1 2048 1953525167 976761560 fd Linux raid
autodetect

WARNING: GPT (GUID Partition Table) detected on '/dev/sde'! The util
fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sde: 1000.2 GB, 1000204886016 bytes
81 heads, 63 sectors/track, 382818 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x00000000

Device Boot Start End Blocks Id System
/dev/sde1 2048 1953525167 976761560 fd Linux raid
autodetect

Disk /dev/md0: 2000.1 GB, 2000138797056 bytes
2 heads, 4 sectors/track, 488315136 cylinders, total 3906521088 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 524288 bytes / 1048576 bytes
Disk identifier: 0x00000000

Disk /dev/md0 doesn't contain a valid partition table

Disk /dev/md127: 2000.1 GB, 2000138797056 bytes
2 heads, 4 sectors/track, 488315136 cylinders, total 3906521088 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 524288 bytes / 1048576 bytes
Disk identifier: 0x00000000

Disk /dev/md127 doesn't contain a valid partition table

Merci

Greg

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: https://lists.debian.org/5396BBDA.6040609@gmail.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
daniel huhardeaux
Le #26186772
Le 10/06/2014 10:03, Grégoire COUTANT a écrit :
Bonjour à tous,



Bonjour

[...]
Régulièrement deux disques sortent du raid, voire quand ça reboote, je
vois un nouveau raid de créé (md127) sans savoir d'où ça vient.



[...]

Un rapide coup d'oeil sur un site de recherche montre que md127 est un
device créé par mdadm lorsqu'il rencontre une erreur.

--
Daniel

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Grégoire COUTANT
Le #26186962
Bonjour,

Le 10/06/2014 10:20, daniel huhardeaux a écrit :
Un rapide coup d'oeil sur un site de recherche montre que md127 est un
device créé par mdadm lorsqu'il rencontre une erreur.



Merci, ça m'a mis sur une piste.
Je n'avais aucun array dans mdadm.conf
J'ai donc ajouté :

Dans /etc/mdadm/mdadm.conf

# definitions of existing MD arrays
ARRAY /dev/md0 level=raid10 metadata=1.2 num-devices=4
UUIDå17bca1:bdbcd117:227ee769:eb9ab3b6 name=serre:0

Dans /etc/fstab :
/dev/md0 /home ext4 defaults 0 2

Ensuite un cat /proc/mdstat :

Personalities : [raid10]
md0 : active raid10 sdc1[0] sdd1[2]
1953260544 blocks super 1.2 512K chunks 2 near-copies [4/2] [U_U_]
unused devices: <none>

J'ajoute donc les partitions qui ne sont pas dans le RAID, en espérant
qu'elles vont tenir :

mdadm --manage /dev/md0 --add /dev/sda1

cela donne :
Personalities : [raid10]
md0 : active raid10 sda1[4] sdc1[0] sdd1[2]
1953260544 blocks super 1.2 512K chunks 2 near-copies [4/2] [U_U_]
[>....................] recovery = 3.9% (38652672/976630272)
finish0.9min speed0928K/sec

Ca vous parait OK ?

Greg

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
daniel huhardeaux
Le #26186992
Le 10/06/2014 11:37, Grégoire COUTANT a écrit :
Bonjour,

Le 10/06/2014 10:20, daniel huhardeaux a écrit :
Un rapide coup d'oeil sur un site de recherche montre que md127 est un
device créé par mdadm lorsqu'il rencontre une erreur.



Merci, ça m'a mis sur une piste.
Je n'avais aucun array dans mdadm.conf
J'ai donc ajouté :

Dans /etc/mdadm/mdadm.conf

# definitions of existing MD arrays
ARRAY /dev/md0 level=raid10 metadata=1.2 num-devices=4
UUIDå17bca1:bdbcd117:227ee769:eb9ab3b6 name=serre:0

[...]




Ne pas oubler de reconstruire l'initramfs si nécessaire

--
Daniel

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Daniel Caillibaud
Le #26187002
Le 10/06/14 à 11:37, Grégoire COUTANT
GC> Bonjour,
GC>
GC> Le 10/06/2014 10:20, daniel huhardeaux a écrit :
GC> > Un rapide coup d'oeil sur un site de recherche montre que md127 est un
GC> > device créé par mdadm lorsqu'il rencontre une erreur.
GC>
GC> Merci, ça m'a mis sur une piste.
GC> Je n'avais aucun array dans mdadm.conf
GC> J'ai donc ajouté :
GC>
GC> Dans /etc/mdadm/mdadm.conf
GC>
GC> # definitions of existing MD arrays
GC> ARRAY /dev/md0 level=raid10 metadata=1.2 num-devices=4
GC> UUIDå17bca1:bdbcd117:227ee769:eb9ab3b6 name=serre:0
GC>
GC> Dans /etc/fstab :
GC> /dev/md0 /home ext4 defaults 0 2
GC>
GC> Ensuite un cat /proc/mdstat :
GC>
GC> Personalities : [raid10]
GC> md0 : active raid10 sdc1[0] sdd1[2]
GC> 1953260544 blocks super 1.2 512K chunks 2 near-copies [4/2] [U_U _]
GC> unused devices: <none>
GC>
GC> J'ajoute donc les partitions qui ne sont pas dans le RAID, en espéran t
GC> qu'elles vont tenir :
GC>
GC> mdadm --manage /dev/md0 --add /dev/sda1
GC>
GC> cela donne :
GC> Personalities : [raid10]
GC> md0 : active raid10 sda1[4] sdc1[0] sdd1[2]
GC> 1953260544 blocks super 1.2 512K chunks 2 near-copies [4/2] [U_U _]
GC> [>....................] recovery = 3.9% (38652672/976630272)
GC> finish0.9min speed0928K/sec
GC>
GC> Ca vous parait OK ?

Ça parait bizarre du raid10 sur 3 disques (il en faut 4), mais j'ai jamai s fait de raid10 et
pourrait pas vraiment t'aider.

Et c'est probablement mieux de le laisser finir sa reconstruction avant d'a jouter le 4e
disque.

(et pour lister tes partitions gpt, suis ses conseils, utilise parted -l à la place de fdisk
-l, ou gdisk si tu préfères).

--
Daniel

Le savant n'est pas l'homme qui fournit les vraies réponses,
c'est celui qui pose les vraies questions.
C. Lévi-Strauss

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Grégoire COUTANT
Le #26187022
Bonjour,

Le 10/06/2014 12:17, Daniel Caillibaud a écrit :
GC> Ca vous parait OK ?
Ça parait bizarre du raid10 sur 3 disques (il en faut 4), mais j'ai jamais fait de raid10 et
pourrait pas vraiment t'aider.
Et c'est probablement mieux de le laisser finir sa reconstruction avant d'ajouter le 4e
disque.



Oui c'est ce que je fais, j'ai lu qu'il fallait à priori ajouter les
disques un par un...
32% de sda, j'attend
J'ajouterai sde ensuite et après je rebooterai le serveur pour voir.

(et pour lister tes partitions gpt, suis ses conseils, utilise parted -l à la place de fdisk
-l, ou gdisk si tu préfères).



Oui ancien réflexe, tu as raison.

Merci

Greg

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Grégoire COUTANT
Le #26188212
Bonjour,
suite et j'espère fin.
Après synchro des deux disques restant, puis un redémarrage du serveur,
le RAID est en place.
J'espère qu'il va tenir :-)

# cat /proc/mdstat
Personalities : [raid10]
md0 : active raid10 sde1[5] sda1[4] sdc1[0] sdd1[2]
1953260544 blocks super 1.2 512K chunks 2 near-copies [4/4] [UUUU]

Merci pour votre aide

Grégoire

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Grégoire COUTANT
Le #26190592
Bonjour,
Suite et pas fin finalement.
Un reboot hard ce jour et voilà ce que donne le RAID :

:~# cat /proc/mdstat
Personalities : [raid10]
md0 : active raid10 sdb1[0] sdc1[2]
1953260544 blocks super 1.2 512K chunks 2 near-copies [4/2] [U_U_]

Je suis un peu perdu pour savoir où chercher.

Ce que je trouve étrange c'est que ce ne sont plus les mêmes partitions
dans le raid 10, on voit apparaitre sdb alors qu'avant il n'y avait que
sda / sdc / sdd / sde...

Grégoire

Le 11/06/2014 08:47, Grégoire COUTANT a écrit :
Bonjour,
suite et j'espère fin.
Après synchro des deux disques restant, puis un redémarrage du serveur,
le RAID est en place.
J'espère qu'il va tenir :-)

# cat /proc/mdstat
Personalities : [raid10]
md0 : active raid10 sde1[5] sda1[4] sdc1[0] sdd1[2]
1953260544 blocks super 1.2 512K chunks 2 near-copies [4/4] [UUUU]

Merci pour votre aide

Grégoire



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
daniel huhardeaux
Le #26190642
Le 12/06/2014 18:00, Grégoire COUTANT a écrit :
Bonjour,



Bonjour,

Suite et pas fin finalement.



Ce problème est différent de l'initial: md127 n'est pas présent, le
problème a donc été solutionné.


Un reboot hard ce jour et voilà ce que donne le RAID :

:~# cat /proc/mdstat
Personalities : [raid10]
md0 : active raid10 sdb1[0] sdc1[2]
1953260544 blocks super 1.2 512K chunks 2 near-copies [4/2] [U_U_]

Je suis un peu perdu pour savoir où chercher.

Ce que je trouve étrange c'est que ce ne sont plus les mêmes
partitions dans le raid 10, on voit apparaitre sdb alors qu'avant il
n'y avait que sda / sdc / sdd / sde...



Combien de disques y a t'il dans le serveur? mdadm.conf est il toujours
bon ? Le renommage des disques ne se fait pas seul, un coup d'oeil dans
dmesg devrait apporter des informations


Grégoire

Le 11/06/2014 08:47, Grégoire COUTANT a écrit :
Bonjour,
suite et j'espère fin.
Après synchro des deux disques restant, puis un redémarrage du serveur,
le RAID est en place.
J'espère qu'il va tenir :-)

# cat /proc/mdstat
Personalities : [raid10]
md0 : active raid10 sde1[5] sda1[4] sdc1[0] sdd1[2]
1953260544 blocks super 1.2 512K chunks 2 near-copies [4/4]
[UUUU]

Merci pour votre aide

Grégoire






--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Grégoire COUTANT
Le #26191812
Bonjour,

Le 12/06/2014 18:31, daniel huhardeaux a écrit :
Combien de disques y a t'il dans le serveur?



Il y a toujours les 5 disques

:~# fdisk -l

Disk /dev/sda: 120.0 GB, 120034123776 bytes
[...]
Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
[...]
Disk /dev/sdc: 1000.2 GB, 1000204886016 bytes
[...]
Disk /dev/md0: 2000.1 GB, 2000138797056 bytes
[...]
Disk /dev/sdd: 1000.2 GB, 1000204886016 bytes
[...]
Disk /dev/sde: 1000.2 GB, 1000204886016 bytes
[...]

mdadm.conf est il toujours
bon ?



Oui les modifs effectuées sont toujours présentes.

Le renommage des disques ne se fait pas seul, un coup d'oeil dans
dmesg devrait apporter des informations



C'est sûrement ce que je me suis dit également, les disques semblent
changer de nommage au boot.
Voilà ce que me dit dmesg, je ne suis pas un expert, j'ai extrait les
lignes correspondant au montage des disques et du RAID.
Ce que je comprend c'est que les disques HGST sont connectés en SATA et
que les disques WD sont connectés en SCSI.
Le raid essaie de monter les disques et n'y arrive pas car les disques
SCSI ne sont pas encore montés ?
Vous comprenez ça comme moi ?

:~# dmesg

[ 1.744044] ata6: SATA link down (SStatus 0 SControl 300)
[ 1.744064] ata5: SATA link down (SStatus 0 SControl 300)
[ 1.744084] ata1: SATA link down (SStatus 0 SControl 300)
[ 1.744106] ata2: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[ 1.744128] ata4: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 1.744145] ata3: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 1.744917] ata2.00: ATA-9: Samsung SSD 840 Series, DXT08B0Q, max
UDMA/133
[ 1.744933] ata2.00: 234441648 sectors, multi 16: LBA48 NCQ (depth
31/32), AA
[ 1.745196] ata2.00: configured for UDMA/133
[ 1.745263] scsi: waiting for bus probes to complete ...
[ 1.745315] ata4.00: ATA-8: HGST HTS721010A9E630, JB0OA3B0, max UDMA/133
[ 1.745319] ata4.00: 1953525168 sectors, multi 16: LBA48 NCQ (depth
31/32), AA
[ 1.745418] ata3.00: ATA-8: HGST HTS721010A9E630, JB0OA3B0, max UDMA/133
[ 1.745438] ata3.00: 1953525168 sectors, multi 16: LBA48 NCQ (depth
31/32), AA
[ 1.746777] ata4.00: configured for UDMA/133
[ 1.746949] ata3.00: configured for UDMA/133
[ 1.756012] usb 1-1: new high-speed USB device number 2 using ehci_hcd
[ 1.792161] scsi 2:0:0:0: Direct-Access ATA Samsung SSD 840
DXT0 PQ: 0 ANSI: 5
[ 1.792557] scsi 3:0:0:0: Direct-Access ATA HGST HTS721010A9
JB0O PQ: 0 ANSI: 5
[ 1.792909] scsi 4:0:0:0: Direct-Access ATA HGST HTS721010A9
JB0O PQ: 0 ANSI: 5
[ 1.797059] sd 2:0:0:0: [sda] 234441648 512-byte logical blocks: (120
GB/111 GiB)
[ 1.797087] sd 3:0:0:0: [sdb] 1953525168 512-byte logical blocks:
(1.00 TB/931 GiB)
[ 1.797090] sd 3:0:0:0: [sdb] 4096-byte physical blocks
[ 1.797126] sd 4:0:0:0: [sdc] 1953525168 512-byte logical blocks:
(1.00 TB/931 GiB)
[ 1.797128] sd 4:0:0:0: [sdc] 4096-byte physical blocks
[ 1.797146] sd 3:0:0:0: [sdb] Write Protect is off
[ 1.797150] sd 2:0:0:0: [sda] Write Protect is off
[ 1.797153] sd 2:0:0:0: [sda] Mode Sense: 00 3a 00 00
[ 1.797156] sd 3:0:0:0: [sdb] Mode Sense: 00 3a 00 00
[ 1.797171] sd 2:0:0:0: [sda] Write cache: enabled, read cache:
enabled, doesn't support DPO or FUA
[ 1.797174] sd 3:0:0:0: [sdb] Write cache: enabled, read cache:
enabled, doesn't support DPO or FUA
[ 1.797178] sd 4:0:0:0: [sdc] Write Protect is off
[ 1.797181] sd 4:0:0:0: [sdc] Mode Sense: 00 3a 00 00
[ 1.797198] sd 4:0:0:0: [sdc] Write cache: enabled, read cache:
enabled, doesn't support DPO or FUA
[ 1.797902] sda: sda1 sda2 < sda5 >
[ 1.798244] sd 2:0:0:0: [sda] Attached SCSI disk
[ 1.813472] sd 2:0:0:0: Attached scsi generic sg0 type 0
[ 1.813522] sd 3:0:0:0: Attached scsi generic sg1 type 0
[ 1.813568] sd 4:0:0:0: Attached scsi generic sg2 type 0

[...]

[ 2.057259] sdc: sdc1
[ 2.057857] sd 4:0:0:0: [sdc] Attached SCSI disk
[ 2.067727] sdb: sdb1
[ 2.068379] sd 3:0:0:0: [sdb] Attached SCSI disk

[...]

[ 2.427055] md: md0 stopped.
[ 2.427583] md: bind<sdc1>
[ 2.427731] md: bind<sdb1>
[ 2.428796] md: raid10 personality registered for level 10
[ 2.428997] bio: create slab <bio-1> at 1
[ 2.429065] md/raid10:md0: active with 2 out of 4 devices
[ 2.429084] md0: detected capacity change from 0 to 2000138797056
[ 2.434495] md0: unknown partition table

[...]

[ 4.529901] sas: phy-0:0 added to port-0:0, phy_mask:0x1
(5fcfffff00000001)
[ 4.529912] sas: DOING DISCOVERY on port 0, pid:227
[ 4.546219] EXT4-fs (md0): mounted filesystem with ordered data mode.
Opts: (null)
[ 4.714535] sas: Enter sas_scsi_recover_host
[ 4.714544] ata7: sas eh calling libata port error handler
[ 4.714557] sas: sas_ata_hard_reset: Found ATA device.
[ 4.715195] ata7.00: ATA-9: WDC WD10JPVX-08JC3T2, 03.01A03, max UDMA/133
[ 4.715202] ata7.00: 1953525168 sectors, multi 0: LBA48 NCQ (depth 31/32)
[ 4.715918] ata7.00: configured for UDMA/133
[ 4.715929] sas: --- Exit sas_scsi_recover_host
[ 4.729225] scsi 0:0:0:0: Direct-Access ATA WDC WD10JPVX-08J
03.0 PQ: 0 ANSI: 5
[ 4.729530] sd 0:0:0:0: Attached scsi generic sg3 type 0
[ 4.729544] sd 0:0:0:0: [sdd] 1953525168 512-byte logical blocks:
(1.00 TB/931 GiB)
[ 4.729550] sd 0:0:0:0: [sdd] 4096-byte physical blocks
[ 4.729600] sas: DONE DISCOVERY on port 0, pid:227, result:0
[ 4.729722] sd 0:0:0:0: [sdd] Write Protect is off
[ 4.729731] sd 0:0:0:0: [sdd] Mode Sense: 00 3a 00 00
[ 4.729791] sd 0:0:0:0: [sdd] Write cache: enabled, read cache:
enabled, doesn't support DPO or FUA
[ 4.754634] sdd: sdd1
[ 4.755223] sd 0:0:0:0: [sdd] Attached SCSI disk
[ 4.947395] sas: phy-0:1 added to port-0:1, phy_mask:0x2
(5fcfffff00000002)
[ 4.947414] sas: DOING DISCOVERY on port 1, pid:226
[ 5.136103] sas: Enter sas_scsi_recover_host
[ 5.136111] ata7: sas eh calling libata port error handler
[ 5.136126] ata8: sas eh calling libata port error handler
[ 5.136135] sas: sas_ata_hard_reset: Found ATA device.
[ 5.136771] ata8.00: ATA-9: WDC WD10JPVX-08JC3T2, 03.01A03, max UDMA/133
[ 5.136777] ata8.00: 1953525168 sectors, multi 0: LBA48 NCQ (depth 31/32)
[ 5.137630] ata8.00: configured for UDMA/133
[ 5.137642] sas: --- Exit sas_scsi_recover_host
[ 5.137865] scsi 0:0:1:0: Direct-Access ATA WDC WD10JPVX-08J
03.0 PQ: 0 ANSI: 5
[ 5.138096] sd 0:0:1:0: [sde] 1953525168 512-byte logical blocks:
(1.00 TB/931 GiB)
[ 5.138100] sd 0:0:1:0: [sde] 4096-byte physical blocks
[ 5.138159] sd 0:0:1:0: Attached scsi generic sg4 type 0
[ 5.138189] sd 0:0:1:0: [sde] Write Protect is off
[ 5.138193] sd 0:0:1:0: [sde] Mode Sense: 00 3a 00 00
[ 5.138223] sd 0:0:1:0: [sde] Write cache: enabled, read cache:
enabled, doesn't support DPO or FUA
[ 5.138287] sas: DONE DISCOVERY on port 1, pid:226, result:0
[ 5.161051] sde: sde1
[ 5.161803] sd 0:0:1:0: [sde] Attached SCSI disk

Soit je dois les ajouter après au raid ?
Pourquoi les disques changent de label ?

Grégoire

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
daniel huhardeaux
Le #26191912
Le 13/06/2014 11:40, Grégoire COUTANT a écrit :
Bonjour,

Le 12/06/2014 18:31, daniel huhardeaux a écrit :
Combien de disques y a t'il dans le serveur?



Il y a toujours les 5 disques

:~# fdisk -l

Disk /dev/sda: 120.0 GB, 120034123776 bytes
[...]
Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
[...]
Disk /dev/sdc: 1000.2 GB, 1000204886016 bytes
[...]
Disk /dev/md0: 2000.1 GB, 2000138797056 bytes
[...]
Disk /dev/sdd: 1000.2 GB, 1000204886016 bytes
[...]
Disk /dev/sde: 1000.2 GB, 1000204886016 bytes
[...]

mdadm.conf est il toujours
bon ?



Oui les modifs effectuées sont toujours présentes.

Le renommage des disques ne se fait pas seul, un coup d'oeil dans
dmesg devrait apporter des informations



C'est sûrement ce que je me suis dit également, les disques semblent
changer de nommage au boot.
Voilà ce que me dit dmesg, je ne suis pas un expert, j'ai extrait les
lignes correspondant au montage des disques et du RAID.
Ce que je comprend c'est que les disques HGST sont connectés en SATA
et que les disques WD sont connectés en SCSI.
[...]



Les contrôleurs sont ils intégrés à la carte mère ou y a t'il une carte
additionnelle pour l'un d'eux? Dans ce dernier cas, tester en déplacant
la carte contrôleur dans un autre slot.

--
Daniel

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Publicité
Poster une réponse
Anonyme