Re : Re : Ethernet non-configurable

Le
pingouin osmolateur
--0-1658918953-1217938479=:3686
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: quoted-printable

Est-ce que tu pourrais faire un #dmesg | grep eth0 afin de voir si ta=
carte est reconnu au démarrage Quelle version de debian ? quel=
le version du kernel ? Normalement le module devrait etre celui la =
http://kernel.xc.net/html/linux-2.6.18/frv/NE2K_PCI #lsmod | grep ne2k=
-pc afin de voir si le module est lancé sinon il faut que tu le=
charges #modprobe ne2k-pc Ensuite tu pourras reconfigurer ta carte=
. -- Message d'origine - De : kaliderus ka <kaliderus=
@gmail.com> À : debian-user-french@lists.debian.org Envoyé le=
: Mardi, 5 Août 2008, 14h02mn 43s Objet : Re: Re : Ethernet non-con=
figurable Salut, Malheureusement rien de bien intéressant :=
ethtool eth0 Settings for eth0: No data available La carte est =
assez vieille et rien n'est paramétrable à ce niveau. Au passa=
ge, j'ai aussi fait une reconfiguration de tous les paquets et une reinstal=
lation du noyau, et j'ai toujours le même comportement, c'est un vrai =
mystère. A bientôt Le 5 août 2008 13:37, pingou=
in osmolateur <pingouin_osmolateur@yahoo.fr> a écrit : Bonjour =
Que te renvoie la commande suivant lorsque le cable de ta freebox est br=
anché sur ta carte Realtek ? #ethtool eth0 A+ -- =
Message d'origine - De : kaliderus ka <kaliderus@gmail.com> À :=
debian-user-french@lists.debian.org Envoyé le : Mardi, 5 Août =
2008, 10h19mn 13s Objet : Ethernet non-configurable Bonjour,=
J'ai une machine qui fait d'un côté serveur-firewall avec ipta=
bles (eth0 en DHCP, type Realtek Semiconductor Co., Ltd. RTL-8029(AS)) et d=
e l'autre partage de connection internet pour la famille (eth1, adresse ip =
fixe en 192.168.0.XXX, type 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev =
78)). Jusqu'à il y a environ 1 semaine tout fonctionnait parfaitemen=
t. Depuis, pour une raison que je n'explique pas, l'interface eth0 ne per=
met plus d'accès via free. J'ai supprimé toutes les règle=
s iptables en les mettant toutes à ACCEPT, puis En modifiant /et=
c/network/interfaces j'ai testé eth1 (en changant les cables) et le se=
rveur de free attribue bien une adresse à la carte. En testant "eth0=
" avec une autre carte exactement du même type, toujours pas d'attribu=
tion d'adresse ip. J'ai supposé un soucis sur un port de la carte m=
ère, donc j'ai déplacé eth0 sur un autre port et j'ai toujo=
urs le même comportement. En googlant un chouilla, j'ai découve=
rt en partie le fonctionnement d'udev et j'ai supprimé les lignes rela=
tives aux interfaces dans /etc/udev/rules.d/z25_persistent-net.rules. Apr=
ès plusieurs redémarrages et en branchant le cable "internet" rel=
atif sur la Realtek, toujours le même comportement, eth0 n'est pas con=
figurable par DHCP, et la carte 3Com fonctionne parfaitement pour l'accÃ=
¨s internet Un coup de ifconfig permet bien de configurer la Realtek av=
ec une adresse ip prise au hasard du style 192.168.0.yyy. Un ping direct =
sur la Realtek renvoit bien une réponse. Un ping sur une autre machi=
ne de mon réseau local ne renvoie rien. ifup eth0 renvoit toujours l=
e même message : bla bla Listening on LPF/eth0/00:04:75:c1:9c:=
45 Sending on LPF/eth0/00:04:75:c1:9c:45 Sending on Socket/fallback=
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7 etc etc =
No DHCPOFFERS received. No working leases in persistent database - sle=
eping. lsmod présente bien les modules requis pour le fonctionnement=
des cartes. lspci me permet bien de voir les 2 cartes présentes. =
Là je colle, c'est comme si quelquepart dans la couche ip quelque chos=
e empêchait le passage des paquets spécifiquement sur le type de =
carte Realtek. Si vous avec une idée de début de piste ce serai=
t super Merci d'avance. _______________________________=
______________________________________________ Envoyez avec Yahoo! Mail.=
Une boite mail plus intelligente http://mail.yahoo.fr
--0-1658918953-1217938479=:3686
Content-Type: text/html; charset=utf-8
Content-Transfer-Encoding: quoted-printable

<html><head><style type="text/css"><!-- DIV {margin:0px;} --></style></he=
ad><body><div style="font-family:times new roman, new york, times, serif;=
font-size:12pt"><div>Est-ce que tu pourrais faire un <br>#dmesg | grep eth0=
<br>afin de voir si ta carte est reconnu au démarrage<br><br>Quelle v=
ersion de debian ?<br>quelle version du kernel ?<br><br>Normalement le modu=
le devrait etre celui la <br>http://kernel.xc.net/html/linux-2.6.18/frv/NE2=
K_PCI<br><br>#lsmod | grep ne2k-pc <br>afin de voir si le module est lanc=
é<br><br>sinon il faut que tu le charges <br>#modprobe ne2k-pc<br><br>=
Ensuite tu pourras reconfigurer ta carte.<br><br></div><div style="font-f=
amily: times new roman,new york,times,serif; font-size: 12pt;"><br><div sty=
le="font-family: times new roman,new york,times,serif; font-size: 12pt;">=
-- Message d'origine -<br>De : kaliderus ka &lt;kaliderus@gmail.com&g=
t;<br>À : debian-user-french@lists.debian.org<br>Envoyé le : Mard=
i, 5 Août 2008,
14h02mn 43s<br>Objet&nbsp;: Re: Re : Ethernet non-configurable<br><br><div=
dir="ltr">Salut,<br>Malheureusement rien de bien intéressant :<br>e=
thtool eth0<br>Settings for eth0:<br>No data available<br><br>La carte est =
assez vieille et rien n'est paramétrable&nbsp; à ce niveau.<br>Au=
passage, j'ai aussi fait une reconfiguration de tous les paquets et une re=
installation du noyau, et j'ai toujours le même comportement, c'est un=
vrai mystère.<br><br>A bientôt<br><br><div class="gmail_quote"=
>Le 5 août 2008 13:37, pingouin osmolateur <span dir="ltr">&lt;<a re=
l="nofollow" ymailto="mailto:pingouin_osmolateur@yahoo.fr" target="_b=
lank" href="mailto:pingouin_osmolateur@yahoo.fr">pingouin_osmolateur@yaho=
o.fr</a>&gt;</span> a écrit :<br><blockquote class="gmail_quote" sty=
le="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex;=
padding-left: 1ex;"><div><div style="font-family: times new roman,new yo=
rk,times,serif; font-size:
12pt;"><div>Bonjour <br>Que te renvoie la commande suivant lorsque le cabl=
e de ta freebox est branché sur ta carte Realtek ?<br>#ethtool eth0<br=
><br>A+<br></div><div style="font-family: times new roman,new york,times,=
serif; font-size: 12pt;"><br><div style="font-family: times new roman,new=
york,times,serif; font-size: 12pt;">-- Message d'origine -<br>De : k=
aliderus ka &lt;<a rel="nofollow" ymailto="mailto:kaliderus@gmail.com" =
target="_blank" href="mailto:kaliderus@gmail.com">kaliderus@gmail.com</=
a>&gt;<br> À : <a rel="nofollow" ymailto="mailto:debian-user-fre=
nch@lists.debian.org" target="_blank" href="mailto:debian-user-french@l=
ists.debian.org">debian-user-french@lists.debian.org</a><br>Envoyé le =
: Mardi, 5 Août 2008, 10h19mn 13s<br>Objet&nbsp;: Ethernet non-configu=
rable<div><div></div><div class="Wj3C7c"><br><br><div dir="ltr">Bonjour=
,<br>J'ai une machine qui fait d'un côté serveur-firewall avec ip=
tables (eth0 en DHCP, type Realtek Semiconductor Co., Ltd. RTL-8029(AS)) et=
de l'autre partage de connection internet pour la famille (eth1, adresse i=
p fixe en 192.168.0.XXX, type 3Com Corporation 3c905C-TX/TX-M [Tornado] =
(rev 78)).<br> Jusqu'à il y a environ 1 semaine tout fonctionnait pa=
rfaitement.<br>Depuis, pour une raison que je n'explique pas, l'interface e=
th0 ne permet plus d'accès via free.<br>J'ai supprimé&nbsp; toute=
s les règles iptables en les mettant toutes à ACCEPT, puis <br=
> En modifiant /etc/network/interfaces j'ai testé eth1 (en changa=
nt les cables) et le serveur de free attribue bien une adresse à la ca=
rte.<br>En testant "eth0" avec une autre carte exactement du même type=
, toujours pas d'attribution d'adresse ip.<br> J'ai supposé un so=
ucis sur un port de la carte mère, donc j'ai déplacé eth0 su=
r un autre port et j'ai&nbsp; toujours le même comportement.<br>En goo=
glant un chouilla, j'ai découvert en partie le fonctionnement d'udev e=
t j'ai supprimé les lignes relatives aux interfaces dans /etc/udev/rul=
es.d/z25_persistent-net.rules.<br> Après plusieurs redémarra=
ges et en branchant le cable "internet" relatif sur la Realtek, toujours le=
même comportement, eth0 n'est pas configurable par DHCP, et la carte =
3Com fonctionne parfaitement pour l'accès internet<br> Un coup de=
ifconfig permet bien de configurer la Realtek avec une adresse ip prise au=
hasard du style 192.168.0.yyy.<br>Un ping direct sur la Realtek renvoit bi=
en une réponse.<br>Un ping sur une autre machine de mon réseau lo=
cal ne renvoie rien.<br> ifup eth0 renvoit toujours le même messa=
ge :<br>bla bla <br>Listening on LPF/eth0/00:04:75:c1:9c:45<br>Sending o=
n&nbsp;&nbsp; LPF/eth0/00:04:75:c1:9c:45<br>Sending on&nbsp;&nbsp; Socket/f=
allback<br>DHCPDISCOVER on eth0 to <a rel="nofollow" target="_blank" h=
ref="http://255.255.255.255">255.255.255.255</a> port 67 interval 7<br>=
etc etc <br>No DHCPOFFERS received.<br>No working leases in persis=
tent database - sleeping.<br>lsmod présente bien les modules requis po=
ur le fonctionnement des cartes.<br>lspci me permet bien de voir les 2 cart=
es présentes.<br> Là je colle, c'est comme si quelquepart da=
ns la couche ip quelque chose empêchait le passage des paquets spÃ=
©cifiquement sur le type de carte Realtek.<br>Si vous avec une idée =
de début de piste ce serait super <br> Merci d'avance.<br></div><=
/div></div></div></div></div></div></blockquote></div><br></div></div></div=
></div><br> <hr size="1"> Envoyé avec <a href="ht=
tp://us.rd.yahoo.com/mailuk/taglines/isp/control/*http://us.rd.yahoo.com/ev=
t=52423/*http://fr.docs.yahoo.com/mail/overview/index.html">Yahoo! Mail</=
a>.<br>Une boite mail plus intelligente. </a></body></html>
--0-1658918953-1217938479=:3686--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
kaliderus
Le #16487611
J'ai déjà effectuer cette démarche de vérification du chargement du
module, et tout est bien présent,
il est même possible d'attribuer une ip locale fixe à la carte et de la
pinger (même je ne suis pas certain que le ping sur la machine transite
par les couches réseau)
Sauf que dès que je veux avoir accès au réseau (local ou internet),
impossible de sortir.
A la prochaine

pingouin osmolateur a écrit :
Est-ce que tu pourrais faire un
#dmesg | grep eth0
afin de voir si ta carte est reconnu au démarrage

Quelle version de debian ?
quelle version du kernel ?

Normalement le module devrait etre celui la
http://kernel.xc.net/html/linux-2.6.18/frv/NE2K_PCI

#lsmod | grep ne2k-pc
afin de voir si le module est lancé

sinon il faut que tu le charges
#modprobe ne2k-pc

Ensuite tu pourras reconfigurer ta carte.


----- Message d'origine ----
De : kaliderus ka À :
Envoyé le : Mardi, 5 Août 2008, 14h02mn 43s
Objet : Re: Re : Ethernet non-configurable

Salut,
Malheureusement rien de bien intéressant :
ethtool eth0
Settings for eth0:
No data available

La carte est assez vieille et rien n'est paramétrable à ce niveau.
Au passage, j'ai aussi fait une reconfiguration de tous les paquets et
une reinstallation du noyau, et j'ai toujours le même comportement,
c'est un vrai mystère.

A bientôt

Le 5 août 2008 13:37, pingouin osmolateur
écrit :

Bonjour
Que te renvoie la commande suivant lorsque le cable de ta freebox
est branché sur ta carte Realtek ?
#ethtool eth0

A+

----- Message d'origine ----
De : kaliderus ka À :
Envoyé le : Mardi, 5 Août 2008, 10h19mn 13s
Objet : Ethernet non-configurable


Bonjour,
J'ai une machine qui fait d'un côté serveur-firewall avec iptables
(eth0 en DHCP, type Realtek Semiconductor Co., Ltd. RTL-8029(AS))
et de l'autre partage de connection internet pour la famille
(eth1, adresse ip fixe en 192.168.0.XXX, type 3Com Corporation
3c905C-TX/TX-M [Tornado] (rev 78)).
Jusqu'à il y a environ 1 semaine tout fonctionnait parfaitement.
Depuis, pour une raison que je n'explique pas, l'interface eth0 ne
permet plus d'accès via free.
J'ai supprimé toutes les règles iptables en les mettant toutes à
ACCEPT, puis ...
En modifiant /etc/network/interfaces j'ai testé eth1 (en changant
les cables) et le serveur de free attribue bien une adresse à la
carte.
En testant "eth0" avec une autre carte exactement du même type,
toujours pas d'attribution d'adresse ip.
J'ai supposé un soucis sur un port de la carte mère, donc j'ai
déplacé eth0 sur un autre port et j'ai toujours le même comportement.
En googlant un chouilla, j'ai découvert en partie le
fonctionnement d'udev et j'ai supprimé les lignes relatives aux
interfaces dans /etc/udev/rules.d/z25_persistent-net.rules.
Après plusieurs redémarrages et en branchant le cable "internet"
relatif sur la Realtek, toujours le même comportement, eth0 n'est
pas configurable par DHCP, et la carte 3Com fonctionne
parfaitement pour l'accès internet
Un coup de ifconfig permet bien de configurer la Realtek avec une
adresse ip prise au hasard du style 192.168.0.yyy.
Un ping direct sur la Realtek renvoit bien une réponse.
Un ping sur une autre machine de mon réseau local ne renvoie rien.
ifup eth0 renvoit toujours le même message :
bla bla ...
Listening on LPF/eth0/00:04:75:c1:9c:45
Sending on LPF/eth0/00:04:75:c1:9c:45
Sending on Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
etc etc ...
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
lsmod présente bien les modules requis pour le fonctionnement des
cartes.
lspci me permet bien de voir les 2 cartes présentes.
Là je colle, c'est comme si quelquepart dans la couche ip quelque
chose empêchait le passage des paquets spécifiquement sur le type
de carte Realtek.
Si vous avec une idée de début de piste ce serait super ...
Merci d'avance.



------------------------------------------------------------------------
Envoyé avec Yahoo! Mail
Une boite mail plus intelligente.



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme