recherche une cellue qui CONTIENT xxx

Le
Olivier B
Voici un exemple concret de 2 tableaux
Tableau Alpha = colonnes A et B
Tableau Beta = colonnes D et E

|A | B | C | D | E
|
1| xxx | code1 | | bla zzz | formule qui renvoie le code |
2| yyy | code2 | | bla yyy bla | formule qui renvoie le code |
3| zzz | code3 | | xxx bla | formule qui renvoie le code |
4| | | |bla xxx bla | formule qui renvoie le code |
5| | | |bla xxx | formule qui renvoie le code
|
6| | | | yyy bla | formule qui renvoie le code
|


Je souhaite que la formule ou le code vba se comporte comme la formule
recherchev, à savoir :
Je prend une valeur de la colonne D (Tableau Beta)
je recherche dans la matrice composée des colonnes A et B (Tableau Alpha)

Lorsque le sujet (colonne A) est contenu dans la valeur de la colonne D, le
code correspondant de la colonne B est renvoyé.


Merci beaucoup du temps que vous m'accorderez. Essayez, si possible de
détailler un minimum vos proposition de formules car pour moi lorsque l'on me
dit formule trouve ou equiv et index, j'ai du mal.
Appliquez la formule à partir du tableau exemple et là je vous comprendrais
!!!

MERCI ENCORE

--
olivier
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #4274561
Bonjour,

=SI(ESTERREUR(EQUIV(D1;aa;0));"";INDEX(bb;EQUIV(D1;aa;0)))
Regarde ici:
http://cjoint.com/?eeoU3PhlJg
--
Salutations
JJ


"Olivier B" écrit dans le message de news:

Voici un exemple concret de 2 tableaux
Tableau Alpha = colonnes A et B
Tableau Beta = colonnes D et E

|A | B | C | D | E
|
1| xxx | code1 | | bla zzz | formule qui renvoie le code |
2| yyy | code2 | | bla yyy bla | formule qui renvoie le code |
3| zzz | code3 | | xxx bla | formule qui renvoie le code |
4| | | |bla xxx bla | formule qui renvoie le code
|
5| | | |bla xxx | formule qui renvoie le code
|
6| | | | yyy bla | formule qui renvoie le code
|


Je souhaite que la formule ou le code vba se comporte comme la formule
recherchev, à savoir :
Je prend une valeur de la colonne D (Tableau Beta)
je recherche dans la matrice composée des colonnes A et B (Tableau Alpha)

Lorsque le sujet (colonne A) est contenu dans la valeur de la colonne D,
le
code correspondant de la colonne B est renvoyé.


Merci beaucoup du temps que vous m'accorderez. Essayez, si possible de
détailler un minimum vos proposition de formules car pour moi lorsque l'on
me
dit formule trouve ou equiv et index, j'ai du mal....
Appliquez la formule à partir du tableau exemple et là je vous
comprendrais
!!!

MERCI ENCORE

--
olivier


Olivier B
Le #4274491
Malheureusement Jacky, tu n'a pas compris que le contenu de la colonne D
contient également autre chose que le code lui même comme je l'avais déjà
mentionné dans le post explicatif.

Même en ajoutant des * aux codes cela ne fonctionne pas.

Merci quand même de tes efforts.
--
olivier



Bonjour,

=SI(ESTERREUR(EQUIV(D1;aa;0));"";INDEX(bb;EQUIV(D1;aa;0)))
Regarde ici:
http://cjoint.com/?eeoU3PhlJg
--
Salutations
JJ


"Olivier B" écrit dans le message de news:

Voici un exemple concret de 2 tableaux
Tableau Alpha = colonnes A et B
Tableau Beta = colonnes D et E

|A | B | C | D | E
|
1| xxx | code1 | | bla zzz | formule qui renvoie le code |
2| yyy | code2 | | bla yyy bla | formule qui renvoie le code |
3| zzz | code3 | | xxx bla | formule qui renvoie le code |
4| | | |bla xxx bla | formule qui renvoie le code
|
5| | | |bla xxx | formule qui renvoie le code
|
6| | | | yyy bla | formule qui renvoie le code
|


Je souhaite que la formule ou le code vba se comporte comme la formule
recherchev, à savoir :
Je prend une valeur de la colonne D (Tableau Beta)
je recherche dans la matrice composée des colonnes A et B (Tableau Alpha)

Lorsque le sujet (colonne A) est contenu dans la valeur de la colonne D,
le
code correspondant de la colonne B est renvoyé.


Merci beaucoup du temps que vous m'accorderez. Essayez, si possible de
détailler un minimum vos proposition de formules car pour moi lorsque l'on
me
dit formule trouve ou equiv et index, j'ai du mal....
Appliquez la formule à partir du tableau exemple et là je vous
comprendrais
!!!

MERCI ENCORE

--
olivier







Olivier B
Le #4274361
La réponse a été trouvée par JB

Bonjour,

Function ChercheCode(champ, code, element)
ChercheCode = ""
For i = 1 To champ.Count
If InStr(element, champ(i)) > 0 Then ChercheCode = code(i)
Next i
End Function

=cherchecode(A2:A6;B2:B6;D2)

http://cjoint.com/?eerbzFSsVU

JB

--
olivier



Voici un exemple concret de 2 tableaux
Tableau Alpha = colonnes A et B
Tableau Beta = colonnes D et E

|A | B | C | D | E
|
1| xxx | code1 | | bla zzz | formule qui renvoie le code |
2| yyy | code2 | | bla yyy bla | formule qui renvoie le code |
3| zzz | code3 | | xxx bla | formule qui renvoie le code |
4| | | |bla xxx bla | formule qui renvoie le code |
5| | | |bla xxx | formule qui renvoie le code
|
6| | | | yyy bla | formule qui renvoie le code
|


Je souhaite que la formule ou le code vba se comporte comme la formule
recherchev, à savoir :
Je prend une valeur de la colonne D (Tableau Beta)
je recherche dans la matrice composée des colonnes A et B (Tableau Alpha)

Lorsque le sujet (colonne A) est contenu dans la valeur de la colonne D, le
code correspondant de la colonne B est renvoyé.


Merci beaucoup du temps que vous m'accorderez. Essayez, si possible de
détailler un minimum vos proposition de formules car pour moi lorsque l'on me
dit formule trouve ou equiv et index, j'ai du mal....
Appliquez la formule à partir du tableau exemple et là je vous comprendrais
!!!

MERCI ENCORE

--
olivier


Publicité
Poster une réponse
Anonyme