Recherche

Le
Jacquouille
Bonjour,

Dans une recherche, j'utilise ceci: =GAUCHE(A20;CHERCHE(" ";A20;1))
Qui fonctionne si A20 contient plusieurs mots avec un espace (ex:Tilleul à
larges feuilles).
Mais ne fonctionne pas si A20 ne contient qu'un seul mot (Tilleul) car il
n'y a pas d'espace après le mot Tilleul.. -(

Comment puis-je bricoler cette formule pour qu'elle fonctionne bien, si A20
contient un ou plusieurs mots?

Mille mercis et bon WE

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #24907642
Hello la haut ;o)

Une.....

=SI(ESTERREUR(CHERCHE(" ";A20));A20;GAUCHE(A20;CHERCHE(" ";A20;1)-1))

--
Salutations
JJ


"Jacquouille" 508b9ba9$0$3104$
Bonjour,

Dans une recherche, j'utilise ceci: =GAUCHE(A20;CHERCHE(" ";A20;1))
Qui fonctionne si A20 contient plusieurs mots avec un espace (ex:Tilleul à larges feuilles).
Mais ne fonctionne pas si A20 ne contient qu'un seul mot (Tilleul) car il n'y a pas d'espace après le mot
Tilleul..... -(

Comment puis-je bricoler cette formule pour qu'elle fonctionne bien, si A20 contient un ou plusieurs mots?

Mille mercis et bon WE

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
DanielCo
Le #24907982
Bonjour,
Si tu as XL2007 ou postérieur :
=SIERREUR(GAUCHE(A20;CHERCHE(" ";A20;1)-1);A20)
Cordialement.
Daniel


Bonjour,

Dans une recherche, j'utilise ceci: =GAUCHE(A20;CHERCHE(" ";A20;1))
Qui fonctionne si A20 contient plusieurs mots avec un espace (ex:Tilleul à
larges feuilles).
Mais ne fonctionne pas si A20 ne contient qu'un seul mot (Tilleul) car il n'y
a pas d'espace après le mot Tilleul..... -(

Comment puis-je bricoler cette formule pour qu'elle fonctionne bien, si A20
contient un ou plusieurs mots?

Mille mercis et bon WE

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
Jacquouille
Le #24908242
Merci Daniel, mais je me suis arrêté à 2003.
Peut-être pour le prochain PC ? ....
Merci et bon WE



Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"DanielCo" a écrit dans le message de groupe de discussion :
k6gdhs$k4g$

Bonjour,
Si tu as XL2007 ou postérieur :
=SIERREUR(GAUCHE(A20;CHERCHE(" ";A20;1)-1);A20)
Cordialement.
Daniel


Bonjour,

Dans une recherche, j'utilise ceci: =GAUCHE(A20;CHERCHE(" ";A20;1))
Qui fonctionne si A20 contient plusieurs mots avec un espace (ex:Tilleul à
larges feuilles).
Mais ne fonctionne pas si A20 ne contient qu'un seul mot (Tilleul) car il
n'y a pas d'espace après le mot Tilleul..... -(

Comment puis-je bricoler cette formule pour qu'elle fonctionne bien, si
A20 contient un ou plusieurs mots?

Mille mercis et bon WE

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
Jacquouille
Le #24908232
Ah, ce si-là, je l'avais oublié. Merdum!
Merci de me l'avoir remis en neurone.
Bon WE chez toi.


Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"Jacky" a écrit dans le message de groupe de discussion :
k6g8kr$8fc$

Hello la haut ;o)

Une.....

=SI(ESTERREUR(CHERCHE(" ";A20));A20;GAUCHE(A20;CHERCHE(" ";A20;1)-1))

--
Salutations
JJ


"Jacquouille" 508b9ba9$0$3104$
Bonjour,

Dans une recherche, j'utilise ceci: =GAUCHE(A20;CHERCHE(" ";A20;1))
Qui fonctionne si A20 contient plusieurs mots avec un espace (ex:Tilleul à
larges feuilles).
Mais ne fonctionne pas si A20 ne contient qu'un seul mot (Tilleul) car il
n'y a pas d'espace après le mot Tilleul..... -(

Comment puis-je bricoler cette formule pour qu'elle fonctionne bien, si
A20 contient un ou plusieurs mots?

Mille mercis et bon WE

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
Jacquouille
Le #24908932
Re

Cette formule me recherche (trouve) le bon texte (Tilleul), même si j'ai
"Tilleul à larges feuilles".
Cela, c'est OK.
Ce qui ne va pas , c'est que dans mon "tablo" de recherche, j'ai aussi,
parfois, des noms à rallonge, tels que "Marronnier d'Inde, ou roue ou de
Bauman). Tous ceux-ci sont dans la même famille.....
Donc, =RECHERCHEV(a20;tablo;3) déconne s'il trouve Marronnier d'Inde au lieu
de Marronnier.

Je mets le doc en annexe. Voir onglet "Base", cel A30 et B30. C'est B3O
qui déconne. Il doit me donner "Hippocastaneacées" qu'il doit trouver dans
l'onglet "Liste par nom", lignes 146,147 ou 148.

http://cjoint.com/?BJBrPLg2zIE

Grand merci

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"Jacky" a écrit dans le message de groupe de discussion :
k6g8kr$8fc$

Hello la haut ;o)

Une.....

=SI(ESTERREUR(CHERCHE(" ";A20));A20;GAUCHE(A20;CHERCHE(" ";A20;1)-1))

--
Salutations
JJ


"Jacquouille" 508b9ba9$0$3104$
Bonjour,

Dans une recherche, j'utilise ceci: =GAUCHE(A20;CHERCHE(" ";A20;1))
Qui fonctionne si A20 contient plusieurs mots avec un espace (ex:Tilleul à
larges feuilles).
Mais ne fonctionne pas si A20 ne contient qu'un seul mot (Tilleul) car il
n'y a pas d'espace après le mot Tilleul..... -(

Comment puis-je bricoler cette formule pour qu'elle fonctionne bien, si
A20 contient un ou plusieurs mots?

Mille mercis et bon WE

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
Jacky
Le #24909302
RE..
Essaie comme ceci

en B30
ÞCALER(tablo;EQUIV(A30;GAUCHE(nom;NBCAR(A30));0);2)
Validation Matricielle
--
Salutations
JJ


"Jacquouille" 508c00ef$0$3115$
Re

Cette formule me recherche (trouve) le bon texte (Tilleul), même si j'ai "Tilleul à larges feuilles".
Cela, c'est OK.
Ce qui ne va pas , c'est que dans mon "tablo" de recherche, j'ai aussi, parfois, des noms à rallonge, tels
que "Marronnier d'Inde, ou roue ou de Bauman). Tous ceux-ci sont dans la même famille.....
Donc, =RECHERCHEV(a20;tablo;3) déconne s'il trouve Marronnier d'Inde au lieu de Marronnier.

Je mets le doc en annexe. Voir onglet "Base", cel A30 et B30. C'est B3O qui déconne. Il doit me donner
"Hippocastaneacées" qu'il doit trouver dans l'onglet "Liste par nom", lignes 146,147 ou 148.

http://cjoint.com/?BJBrPLg2zIE

Grand merci

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"Jacky" a écrit dans le message de groupe de discussion : k6g8kr$8fc$

Hello la haut ;o)

Une.....

=SI(ESTERREUR(CHERCHE(" ";A20));A20;GAUCHE(A20;CHERCHE(" ";A20;1)-1))

--
Salutations
JJ


"Jacquouille" 508b9ba9$0$3104$
Bonjour,

Dans une recherche, j'utilise ceci: =GAUCHE(A20;CHERCHE(" ";A20;1))
Qui fonctionne si A20 contient plusieurs mots avec un espace (ex:Tilleul à larges feuilles).
Mais ne fonctionne pas si A20 ne contient qu'un seul mot (Tilleul) car il n'y a pas d'espace après le mot
Tilleul..... -(

Comment puis-je bricoler cette formule pour qu'elle fonctionne bien, si A20 contient un ou plusieurs mots?

Mille mercis et bon WE

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."



Jacquouille
Le #24909732
Re
Tout va à merveille, sauf B6 qui me donne une erreur.
Si je ne mets que "Aulne" en A6, c'est OK. Mais pas avec Alne noir --->
#N/A
Pas comprendre ?????
Mais, un grand merci
Bon WE

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"Jacky" a écrit dans le message de groupe de discussion :
k6h6f9$jj7$

RE..
Essaie comme ceci

en B30
ÞCALER(tablo;EQUIV(A30;GAUCHE(nom;NBCAR(A30));0);2)
Validation Matricielle
--
Salutations
JJ


"Jacquouille" 508c00ef$0$3115$
Re

Cette formule me recherche (trouve) le bon texte (Tilleul), même si j'ai
"Tilleul à larges feuilles".
Cela, c'est OK.
Ce qui ne va pas , c'est que dans mon "tablo" de recherche, j'ai aussi,
parfois, des noms à rallonge, tels que "Marronnier d'Inde, ou roue ou de
Bauman). Tous ceux-ci sont dans la même famille.....
Donc, =RECHERCHEV(a20;tablo;3) déconne s'il trouve Marronnier d'Inde au
lieu de Marronnier.

Je mets le doc en annexe. Voir onglet "Base", cel A30 et B30. C'est B3O
qui déconne. Il doit me donner "Hippocastaneacées" qu'il doit trouver dans
l'onglet "Liste par nom", lignes 146,147 ou 148.

http://cjoint.com/?BJBrPLg2zIE

Grand merci

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"Jacky" a écrit dans le message de groupe de discussion :
k6g8kr$8fc$

Hello la haut ;o)

Une.....

=SI(ESTERREUR(CHERCHE(" ";A20));A20;GAUCHE(A20;CHERCHE(" ";A20;1)-1))

--
Salutations
JJ


"Jacquouille" 508b9ba9$0$3104$
Bonjour,

Dans une recherche, j'utilise ceci: =GAUCHE(A20;CHERCHE(" ";A20;1))
Qui fonctionne si A20 contient plusieurs mots avec un espace (ex:Tilleul
à larges feuilles).
Mais ne fonctionne pas si A20 ne contient qu'un seul mot (Tilleul) car il
n'y a pas d'espace après le mot Tilleul..... -(

Comment puis-je bricoler cette formule pour qu'elle fonctionne bien, si
A20 contient un ou plusieurs mots?

Mille mercis et bon WE

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."



Jacky
Le #24910212
Si je ne mets que "Aulne" en A6, c'est OK. Mais pas avec Alne noir --->


Cela doit être parce qu'il n'y a PAS de "Alne noir" pas plus que de "Aulne noir " dans la liste
Par contre , il y a un "Aulne blanc"
Il a du déteindre au lavage :o))
;o))

--
Salutations
JJ


"Jacquouille" 508c3396$0$3115$
Re
Tout va à merveille, sauf B6 qui me donne une erreur.
Si je ne mets que "Aulne" en A6, c'est OK. Mais pas avec Alne noir ---> #N/A
Pas comprendre ?????
Mais, un grand merci
Bon WE

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"Jacky" a écrit dans le message de groupe de discussion : k6h6f9$jj7$

RE..
Essaie comme ceci

en B30
ÞCALER(tablo;EQUIV(A30;GAUCHE(nom;NBCAR(A30));0);2)
Validation Matricielle
--
Salutations
JJ


"Jacquouille" 508c00ef$0$3115$
Re

Cette formule me recherche (trouve) le bon texte (Tilleul), même si j'ai "Tilleul à larges feuilles".
Cela, c'est OK.
Ce qui ne va pas , c'est que dans mon "tablo" de recherche, j'ai aussi, parfois, des noms à rallonge, tels
que "Marronnier d'Inde, ou roue ou de Bauman). Tous ceux-ci sont dans la même famille.....
Donc, =RECHERCHEV(a20;tablo;3) déconne s'il trouve Marronnier d'Inde au lieu de Marronnier.

Je mets le doc en annexe. Voir onglet "Base", cel A30 et B30. C'est B3O qui déconne. Il doit me donner
"Hippocastaneacées" qu'il doit trouver dans l'onglet "Liste par nom", lignes 146,147 ou 148.

http://cjoint.com/?BJBrPLg2zIE

Grand merci

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"Jacky" a écrit dans le message de groupe de discussion : k6g8kr$8fc$

Hello la haut ;o)

Une.....

=SI(ESTERREUR(CHERCHE(" ";A20));A20;GAUCHE(A20;CHERCHE(" ";A20;1)-1))

--
Salutations
JJ


"Jacquouille" 508b9ba9$0$3104$
Bonjour,

Dans une recherche, j'utilise ceci: =GAUCHE(A20;CHERCHE(" ";A20;1))
Qui fonctionne si A20 contient plusieurs mots avec un espace (ex:Tilleul à larges feuilles).
Mais ne fonctionne pas si A20 ne contient qu'un seul mot (Tilleul) car il n'y a pas d'espace après le mot
Tilleul..... -(

Comment puis-je bricoler cette formule pour qu'elle fonctionne bien, si A20 contient un ou plusieurs mots?

Mille mercis et bon WE

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."






Jacquouille
Le #24911052
Il s'agit, bien évidemment, d'un lapsus claviae. (Comme l'aurait écrit
Monseigneur)
Aulne seul fonctionne, mais aulne noir ne fonctionne pas.
Il le devrait. Mais, bon 1 sur 50 qui ne va pas, on laisse
Merci et bonne fin de WE.



Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"Jacky" a écrit dans le message de groupe de discussion :
k6hrib$66f$

Si je ne mets que "Aulne" en A6, c'est OK. Mais pas avec Alne noir --->


Cela doit être parce qu'il n'y a PAS de "Alne noir" pas plus que de "Aulne
noir " dans la liste
Par contre , il y a un "Aulne blanc"
Il a du déteindre au lavage :o))
;o))

--
Salutations
JJ


"Jacquouille" 508c3396$0$3115$
Re
Tout va à merveille, sauf B6 qui me donne une erreur.
Si je ne mets que "Aulne" en A6, c'est OK. Mais pas avec Alne noir --->
#N/A
Pas comprendre ?????
Mais, un grand merci
Bon WE

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"Jacky" a écrit dans le message de groupe de discussion :
k6h6f9$jj7$

RE..
Essaie comme ceci

en B30
ÞCALER(tablo;EQUIV(A30;GAUCHE(nom;NBCAR(A30));0);2)
Validation Matricielle
--
Salutations
JJ


"Jacquouille" 508c00ef$0$3115$
Re

Cette formule me recherche (trouve) le bon texte (Tilleul), même si j'ai
"Tilleul à larges feuilles".
Cela, c'est OK.
Ce qui ne va pas , c'est que dans mon "tablo" de recherche, j'ai aussi,
parfois, des noms à rallonge, tels que "Marronnier d'Inde, ou roue ou de
Bauman). Tous ceux-ci sont dans la même famille.....
Donc, =RECHERCHEV(a20;tablo;3) déconne s'il trouve Marronnier d'Inde au
lieu de Marronnier.

Je mets le doc en annexe. Voir onglet "Base", cel A30 et B30. C'est B3O
qui déconne. Il doit me donner "Hippocastaneacées" qu'il doit trouver
dans l'onglet "Liste par nom", lignes 146,147 ou 148.

http://cjoint.com/?BJBrPLg2zIE

Grand merci

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"Jacky" a écrit dans le message de groupe de discussion :
k6g8kr$8fc$

Hello la haut ;o)

Une.....

=SI(ESTERREUR(CHERCHE(" ";A20));A20;GAUCHE(A20;CHERCHE(" ";A20;1)-1))

--
Salutations
JJ


"Jacquouille" 508b9ba9$0$3104$
Bonjour,

Dans une recherche, j'utilise ceci: =GAUCHE(A20;CHERCHE(" ";A20;1))
Qui fonctionne si A20 contient plusieurs mots avec un espace (ex:Tilleul
à larges feuilles).
Mais ne fonctionne pas si A20 ne contient qu'un seul mot (Tilleul) car
il n'y a pas d'espace après le mot Tilleul..... -(

Comment puis-je bricoler cette formule pour qu'elle fonctionne bien, si
A20 contient un ou plusieurs mots?

Mille mercis et bon WE

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."






Jacky
Le #24911082
Re...
Sans vouloir te vexer.
Je ne suis pas d'accord avec cette affirmation
...mais aulne noir ne fonctionne pas. Il le devrait.


Moi, je ne vois pas "aulne noir " dans ta liste

Et encore moins avec cela
Mais, bon 1 sur 50 qui ne va pas


Tous DOIVENT fonctionner.

--
Salutations
JJ


"Jacquouille" 508d16cc$0$3117$
Il s'agit, bien évidemment, d'un lapsus claviae. (Comme l'aurait écrit Monseigneur)
Aulne seul fonctionne, mais aulne noir ne fonctionne pas.
Il le devrait. Mais, bon 1 sur 50 qui ne va pas, on laisse
Merci et bonne fin de WE.



Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"Jacky" a écrit dans le message de groupe de discussion : k6hrib$66f$

Si je ne mets que "Aulne" en A6, c'est OK. Mais pas avec Alne noir --->


Cela doit être parce qu'il n'y a PAS de "Alne noir" pas plus que de "Aulne noir " dans la liste
Par contre , il y a un "Aulne blanc"
Il a du déteindre au lavage :o))
;o))

--
Salutations
JJ


"Jacquouille" 508c3396$0$3115$
Re
Tout va à merveille, sauf B6 qui me donne une erreur.
Si je ne mets que "Aulne" en A6, c'est OK. Mais pas avec Alne noir ---> #N/A
Pas comprendre ?????
Mais, un grand merci
Bon WE

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"Jacky" a écrit dans le message de groupe de discussion : k6h6f9$jj7$

RE..
Essaie comme ceci

en B30
ÞCALER(tablo;EQUIV(A30;GAUCHE(nom;NBCAR(A30));0);2)
Validation Matricielle
--
Salutations
JJ


"Jacquouille" 508c00ef$0$3115$
Re

Cette formule me recherche (trouve) le bon texte (Tilleul), même si j'ai "Tilleul à larges feuilles".
Cela, c'est OK.
Ce qui ne va pas , c'est que dans mon "tablo" de recherche, j'ai aussi, parfois, des noms à rallonge, tels
que "Marronnier d'Inde, ou roue ou de Bauman). Tous ceux-ci sont dans la même famille.....
Donc, =RECHERCHEV(a20;tablo;3) déconne s'il trouve Marronnier d'Inde au lieu de Marronnier.

Je mets le doc en annexe. Voir onglet "Base", cel A30 et B30. C'est B3O qui déconne. Il doit me donner
"Hippocastaneacées" qu'il doit trouver dans l'onglet "Liste par nom", lignes 146,147 ou 148.

http://cjoint.com/?BJBrPLg2zIE

Grand merci

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"Jacky" a écrit dans le message de groupe de discussion : k6g8kr$8fc$

Hello la haut ;o)

Une.....

=SI(ESTERREUR(CHERCHE(" ";A20));A20;GAUCHE(A20;CHERCHE(" ";A20;1)-1))

--
Salutations
JJ


"Jacquouille" 508b9ba9$0$3104$
Bonjour,

Dans une recherche, j'utilise ceci: =GAUCHE(A20;CHERCHE(" ";A20;1))
Qui fonctionne si A20 contient plusieurs mots avec un espace (ex:Tilleul à larges feuilles).
Mais ne fonctionne pas si A20 ne contient qu'un seul mot (Tilleul) car il n'y a pas d'espace après le mot
Tilleul..... -(

Comment puis-je bricoler cette formule pour qu'elle fonctionne bien, si A20 contient un ou plusieurs
mots?

Mille mercis et bon WE

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."









Publicité
Poster une réponse
Anonyme