Recherche un premier JourSem quelques jours après une date donnée

Le
AndréBdR
J'ai vu récemment ici une super solution matricielle pour la recherche du premier lundi (ou autre)
qui suit de quelques jours une date donnée.
Mais je ne l'ai pas retrouvée.
Comme le matriciel n'est pas mon fort, j'ai bidouillé une solution dans mes compétences qui m'a un
peu fait ramer hier, premier grand jour de grand froid.
A tout hasard, je la mets ci-dessous, même si elle existe déjà quelque part (je n'ai pas cherché):
* en A1 la date référence, genre 16/12/2009
* en B1 le nombre de jours à ajouter, et à partir duquel je cherche le premier lundi, ou mardi etc
: genre 188
* en C1 le jour de semaine recherché: 1 pour lundi, 2 pour mardi, 7 pour dimanche
* en D1 la formule suivante
=TEXTE(A1+B1+(JOURSEM(A1+B1;2)<C1)*C1-(JOURSEM(A1+B1;2)<C1)*(JOURSEM(A1+B1;2))+(JOURSEM(A1+B1;2)>Á)*(C1+7)-(JOURSEM(A1+B1;2)>Á)*(JOURSEM(A1+B1;2));"jjjj
jj mmmm aaaa")
Que cette journée vous soit joyeuse.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Caetera
Le #20787451
"AndréBdR" 4b2a2fe0$0$931$
J'ai vu récemment ici une super solution matricielle pour la recherche du
premier lundi (ou autre) qui suit de quelques jours une date donnée.
Mais je ne l'ai pas retrouvée.
Comme le matriciel n'est pas mon fort, j'ai bidouillé une solution dans mes
compétences qui m'a un peu fait ramer hier, premier grand jour de grand froid.
A tout hasard, je la mets ci-dessous, même si elle existe déjà quelque part
(je n'ai pas cherché):
* en A1 la date référence, genre 16/12/2009
* en B1 le nombre de jours à ajouter, et à partir duquel je cherche le premier
lundi, ou mardi etc ...: genre 188
* en C1 le jour de semaine recherché: 1 pour lundi, 2 pour mardi, ... 7 pour
dimanche
* en D1 la formule suivante
=TEXTE(A1+B1+(JOURSEM(A1+B1;2)<C1)*C1-(JOURSEM(A1+B1;2)<C1)*(JOURSEM(A1+B1;2))+(JOURSEM(A1+B1;2)>Á)*(C1+7)-(JOURSEM(A1+B1;2)>Á)*(JOURSEM(A1+B1;2));"jjjj
jj mmmm aaaa")



*******************

Avec ton exemple, pas matricielle et le résultat est une date :

±+A2-JOURSEM(A2+B1-C1-1)+7

Etc
AndréBdR
Le #20787941
Merci.
Compris.
Chapeau.

"Caetera"
"AndréBdR" 4b2a2fe0$0$931$
J'ai vu récemment ici une super solution matricielle pour la recherche du premier lundi (ou
autre) qui suit de quelques jours une date donnée.
Mais je ne l'ai pas retrouvée.
Comme le matriciel n'est pas mon fort, j'ai bidouillé une solution dans mes compétences qui m'a
un peu fait ramer hier, premier grand jour de grand froid.
A tout hasard, je la mets ci-dessous, même si elle existe déjà quelque part (je n'ai pas
cherché):
* en A1 la date référence, genre 16/12/2009
* en B1 le nombre de jours à ajouter, et à partir duquel je cherche le premier lundi, ou mardi
etc ...: genre 188
* en C1 le jour de semaine recherché: 1 pour lundi, 2 pour mardi, ... 7 pour dimanche
* en D1 la formule suivante
=TEXTE(A1+B1+(JOURSEM(A1+B1;2)<C1)*C1-(JOURSEM(A1+B1;2)<C1)*(JOURSEM(A1+B1;2))+(JOURSEM(A1+B1;2)>Á)*(C1+7)-(JOURSEM(A1+B1;2)>Á)*(JOURSEM(A1+B1;2));"jjjj
jj mmmm aaaa")



*******************

Avec ton exemple, pas matricielle et le résultat est une date :

±+A2-JOURSEM(A2+B1-C1-1)+7

Etc




AndréBdR
Le #20788411
Après vérification je reviens un peu en arrière.
Est-il possible d'adapter ta formule pour que, comme dans la mienne, lorsque A1+B1 tombe un
vendredi, on aille bien chercher le premier vendredi suivant, et non pas rester dans celui où on
est déjà qui n'est donc pas à venir?
Merci d'avance.

"Caetera"
"AndréBdR" 4b2a2fe0$0$931$
J'ai vu récemment ici une super solution matricielle pour la recherche du premier lundi (ou
autre) qui suit de quelques jours une date donnée.
Mais je ne l'ai pas retrouvée.
Comme le matriciel n'est pas mon fort, j'ai bidouillé une solution dans mes compétences qui m'a
un peu fait ramer hier, premier grand jour de grand froid.
A tout hasard, je la mets ci-dessous, même si elle existe déjà quelque part (je n'ai pas
cherché):
* en A1 la date référence, genre 16/12/2009
* en B1 le nombre de jours à ajouter, et à partir duquel je cherche le premier lundi, ou mardi
etc ...: genre 188
* en C1 le jour de semaine recherché: 1 pour lundi, 2 pour mardi, ... 7 pour dimanche
* en D1 la formule suivante
=TEXTE(A1+B1+(JOURSEM(A1+B1;2)<C1)*C1-(JOURSEM(A1+B1;2)<C1)*(JOURSEM(A1+B1;2))+(JOURSEM(A1+B1;2)>Á)*(C1+7)-(JOURSEM(A1+B1;2)>Á)*(JOURSEM(A1+B1;2));"jjjj
jj mmmm aaaa")



*******************

Avec ton exemple, pas matricielle et le résultat est une date :

±+A2-JOURSEM(A2+B1-C1-1)+7

Etc




Caetera
Le #20788871
"AndréBdR" 4b2a588a$0$939$
Après vérification je reviens un peu en arrière.
Est-il possible d'adapter ta formule pour que, comme dans la mienne, lorsque
A1+B1 tombe un vendredi, on aille bien chercher le premier vendredi suivant,
et non pas rester dans celui où on est déjà qui n'est donc pas à venir?



****************

±+A1-JOURSEM(A1+B1-C1)+8

Etc
AndréBdR
Le #20789181
C'est super parfait.
Mille mercis.

"Caetera"
"AndréBdR" 4b2a588a$0$939$
Après vérification je reviens un peu en arrière.
Est-il possible d'adapter ta formule pour que, comme dans la mienne, lorsque A1+B1 tombe un
vendredi, on aille bien chercher le premier vendredi suivant, et non pas rester dans celui où on
est déjà qui n'est donc pas à venir?



****************

±+A1-JOURSEM(A1+B1-C1)+8

Etc




Publicité
Poster une réponse
Anonyme