Recherche de valeurs dans multi-sélection

Le
Tatane
Bonjour à tous,

Je cherche à déterminer la dernière valeur dans une multisélection:
J'ai fai ceci:
dans une cellule: =SI(MIN(B4;D4;F4;H4;J4;L4;N4;P4)>3;"R2";"")
et dans une autre: =SI(MIN(B4;D4;F4;H4;J4;L4;N4;P4)<2;"R1";"")

mais le souci vient de MIN et MAX que je n'arrive pas à changer pour trouver
non pas la + petite ou la + grande valeur mais la DERNIERE valeur. Et
éventuellement le tout dans la même formule.

Si vous pouviez m'aider, je vous en remercie d'avance.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel
Le #4320711
Bonjour.
Peux-tu donner un exemple ? Qu'appelles-tu "dernière valeur" ?
Cordialement.
Daniel
"Tatane"
Bonjour à tous,

Je cherche à déterminer la dernière valeur dans une multisélection:
J'ai fai ceci:
dans une cellule: =SI(MIN(B4;D4;F4;H4;J4;L4;N4;P4)>3;"R2";"")
et dans une autre: =SI(MIN(B4;D4;F4;H4;J4;L4;N4;P4)<2;"R1";"")

mais le souci vient de MIN et MAX que je n'arrive pas à changer pour
trouver
non pas la + petite ou la + grande valeur mais la DERNIERE valeur. Et
éventuellement le tout dans la même formule.

Si vous pouviez m'aider, je vous en remercie d'avance.


Tatane
Le #4320691
Bonjour Daniel,

Plutôt qu'un long discours.... bla bla...
Voici mon fichier http://cjoint.com/?dyqrzCTX04

En fait, je souhaite trouver, dans ma formule au dernier chiffre de la
sélection multiple (dans le fichier valeurs en gras noir) par exemple pour la
1ère ligne la valeur cherchée doit être 63, mais si j'ajoute une valeur en N2
c'est cette dernière qui sera valeur de référence pour mon ">3" et "<2"
et ainsi de suite ...



Bonjour.
Peux-tu donner un exemple ? Qu'appelles-tu "dernière valeur" ?
Cordialement.
Daniel
"Tatane"
Bonjour à tous,

Je cherche à déterminer la dernière valeur dans une multisélection:
J'ai fai ceci:
dans une cellule: =SI(MIN(B4;D4;F4;H4;J4;L4;N4;P4)>3;"R2";"")
et dans une autre: =SI(MIN(B4;D4;F4;H4;J4;L4;N4;P4)<2;"R1";"")

mais le souci vient de MIN et MAX que je n'arrive pas à changer pour
trouver
non pas la + petite ou la + grande valeur mais la DERNIERE valeur. Et
éventuellement le tout dans la même formule.

Si vous pouviez m'aider, je vous en remercie d'avance.







h2so4
Le #4320671
bonjour,

je ne suis pas sur d'avoir compris malgré l'exemple.

tu veux rechercher la valeur la plus récente en fonction de la date dans
l'entête de colonne et utiliser cette valeur pour remplacer le 33 et 32 dans
ta formule en colonnes R et S ?

Est-ce cela ?

--

h2so4
play triogical at http://www.triogical.com
"Tatane" news:
Bonjour Daniel,

Plutôt qu'un long discours.... bla bla...
Voici mon fichier http://cjoint.com/?dyqrzCTX04

En fait, je souhaite trouver, dans ma formule au dernier chiffre de la
sélection multiple (dans le fichier valeurs en gras noir) par exemple pour
la
1ère ligne la valeur cherchée doit être 63, mais si j'ajoute une valeur en
N2
c'est cette dernière qui sera valeur de référence pour mon ">3" et
"<2"
et ainsi de suite ...



Bonjour.
Peux-tu donner un exemple ? Qu'appelles-tu "dernière valeur" ?
Cordialement.
Daniel
"Tatane" news:

Bonjour à tous,

Je cherche à déterminer la dernière valeur dans une multisélection:
J'ai fai ceci:
dans une cellule: =SI(MIN(B4;D4;F4;H4;J4;L4;N4;P4)>3;"R2";"")
et dans une autre: =SI(MIN(B4;D4;F4;H4;J4;L4;N4;P4)<2;"R1";"")

mais le souci vient de MIN et MAX que je n'arrive pas à changer pour
trouver
non pas la + petite ou la + grande valeur mais la DERNIERE valeur. Et
éventuellement le tout dans la même formule.

Si vous pouviez m'aider, je vous en remercie d'avance.









Tatane
Le #4320641
Bonjour,

Non c'est presque ça, ce n'est en fonction de la date mais simplement la
dernière valeur entrée manuellement le plus à droite (en noir gras)(les
valeurs en rouge ou bleu ne sont pas concernées) :

Si la dernière valeur (entrée manuellement) est SUP ou = à 33 cela met R2
dans la colonne R et INF ou = à 32 c'est R1 qui s'affiche dans la colonne S.
Ou le tout dans une même cellule par ligne (cela serait pas mal !).



bonjour,

je ne suis pas sur d'avoir compris malgré l'exemple.

tu veux rechercher la valeur la plus récente en fonction de la date dans
l'entête de colonne et utiliser cette valeur pour remplacer le 33 et 32 dans
ta formule en colonnes R et S ?

Est-ce cela ?

--

h2so4
play triogical at http://www.triogical.com
"Tatane" news:
Bonjour Daniel,

Plutôt qu'un long discours.... bla bla...
Voici mon fichier http://cjoint.com/?dyqrzCTX04

En fait, je souhaite trouver, dans ma formule au dernier chiffre de la
sélection multiple (dans le fichier valeurs en gras noir) par exemple pour
la
1ère ligne la valeur cherchée doit être 63, mais si j'ajoute une valeur en
N2
c'est cette dernière qui sera valeur de référence pour mon ">3" et
"<2"
et ainsi de suite ...



Bonjour.
Peux-tu donner un exemple ? Qu'appelles-tu "dernière valeur" ?
Cordialement.
Daniel
"Tatane" news:

Bonjour à tous,

Je cherche à déterminer la dernière valeur dans une multisélection:
J'ai fai ceci:
dans une cellule: =SI(MIN(B4;D4;F4;H4;J4;L4;N4;P4)>3;"R2";"")
et dans une autre: =SI(MIN(B4;D4;F4;H4;J4;L4;N4;P4)<2;"R1";"")

mais le souci vient de MIN et MAX que je n'arrive pas à changer pour
trouver
non pas la + petite ou la + grande valeur mais la DERNIERE valeur. Et
éventuellement le tout dans la même formule.

Si vous pouviez m'aider, je vous en remercie d'avance.














Jacky
Le #4320531
Bonsoir,

En Vba peut-être:
Ton tableau modifié
http://cjoint.com/?dysA6MKQ5V
'-----------
Private Sub Worksheet_Change(ByVal Target As Range)
If Not Intersect([plage], Target) Is Nothing Then
Range("R" & Target.Row) = ""
For i = 2 To 17 Step 2
If Cells(Target.Row, i) = "" Then Exit For
Next
If Cells(Target.Row, i - 2) >= 33 Then Range("R" & Target.Row) = "R2"
If Cells(Target.Row, i - 2) <= 32 Then Range("R" & Target.Row) = "R1"
End If
End Sub
'-----------

--
Salutations
JJ


"Tatane"
Bonjour,

Non c'est presque ça, ce n'est en fonction de la date mais simplement la
dernière valeur entrée manuellement le plus à droite (en noir gras)(les
valeurs en rouge ou bleu ne sont pas concernées) :

Si la dernière valeur (entrée manuellement) est SUP ou = à 33 cela met R2
dans la colonne R et INF ou = à 32 c'est R1 qui s'affiche dans la colonne
S.
Ou le tout dans une même cellule par ligne (cela serait pas mal !).



bonjour,

je ne suis pas sur d'avoir compris malgré l'exemple.

tu veux rechercher la valeur la plus récente en fonction de la date dans
l'entête de colonne et utiliser cette valeur pour remplacer le 33 et 32
dans
ta formule en colonnes R et S ?

Est-ce cela ?

--

h2so4
play triogical at http://www.triogical.com
"Tatane" news:
Bonjour Daniel,

Plutôt qu'un long discours.... bla bla...
Voici mon fichier http://cjoint.com/?dyqrzCTX04

En fait, je souhaite trouver, dans ma formule au dernier chiffre de la
sélection multiple (dans le fichier valeurs en gras noir) par exemple
pour
la
1ère ligne la valeur cherchée doit être 63, mais si j'ajoute une valeur
en
N2
c'est cette dernière qui sera valeur de référence pour mon ">3" et
"<2"
et ainsi de suite ...



Bonjour.
Peux-tu donner un exemple ? Qu'appelles-tu "dernière valeur" ?
Cordialement.
Daniel
"Tatane" news:

Bonjour à tous,

Je cherche à déterminer la dernière valeur dans une multisélection:
J'ai fai ceci:
dans une cellule: =SI(MIN(B4;D4;F4;H4;J4;L4;N4;P4)>3;"R2";"")
et dans une autre: =SI(MIN(B4;D4;F4;H4;J4;L4;N4;P4)<2;"R1";"")

mais le souci vient de MIN et MAX que je n'arrive pas à changer pour
trouver
non pas la + petite ou la + grande valeur mais la DERNIERE valeur.
Et
éventuellement le tout dans la même formule.

Si vous pouviez m'aider, je vous en remercie d'avance.
















Tatane
Le #4320481
Merci beaucoup Jacky,

Ta solution est parfaite pour résoudre mon problème.

J'étais en train de chercher aussi via le VBA mais comme je suis novice,
j'étais très loin de la (ta) solution.

Bon WE à tous.


Bonsoir,

En Vba peut-être:
Ton tableau modifié
http://cjoint.com/?dysA6MKQ5V
'-----------
Private Sub Worksheet_Change(ByVal Target As Range)
If Not Intersect([plage], Target) Is Nothing Then
Range("R" & Target.Row) = ""
For i = 2 To 17 Step 2
If Cells(Target.Row, i) = "" Then Exit For
Next
If Cells(Target.Row, i - 2) >= 33 Then Range("R" & Target.Row) = "R2"
If Cells(Target.Row, i - 2) <= 32 Then Range("R" & Target.Row) = "R1"
End If
End Sub
'-----------

--
Salutations
JJ


"Tatane"
Bonjour,

Non c'est presque ça, ce n'est en fonction de la date mais simplement la
dernière valeur entrée manuellement le plus à droite (en noir gras)(les
valeurs en rouge ou bleu ne sont pas concernées) :

Si la dernière valeur (entrée manuellement) est SUP ou = à 33 cela met R2
dans la colonne R et INF ou = à 32 c'est R1 qui s'affiche dans la colonne
S.
Ou le tout dans une même cellule par ligne (cela serait pas mal !).



bonjour,

je ne suis pas sur d'avoir compris malgré l'exemple.

tu veux rechercher la valeur la plus récente en fonction de la date dans
l'entête de colonne et utiliser cette valeur pour remplacer le 33 et 32
dans
ta formule en colonnes R et S ?

Est-ce cela ?

--

h2so4
play triogical at http://www.triogical.com
"Tatane" news:
Bonjour Daniel,

Plutôt qu'un long discours.... bla bla...
Voici mon fichier http://cjoint.com/?dyqrzCTX04

En fait, je souhaite trouver, dans ma formule au dernier chiffre de la
sélection multiple (dans le fichier valeurs en gras noir) par exemple
pour
la
1ère ligne la valeur cherchée doit être 63, mais si j'ajoute une valeur
en
N2
c'est cette dernière qui sera valeur de référence pour mon ">3" et
"<2"
et ainsi de suite ...



Bonjour.
Peux-tu donner un exemple ? Qu'appelles-tu "dernière valeur" ?
Cordialement.
Daniel
"Tatane" news:

Bonjour à tous,

Je cherche à déterminer la dernière valeur dans une multisélection:
J'ai fai ceci:
dans une cellule: =SI(MIN(B4;D4;F4;H4;J4;L4;N4;P4)>3;"R2";"")
et dans une autre: =SI(MIN(B4;D4;F4;H4;J4;L4;N4;P4)<2;"R1";"")

mais le souci vient de MIN et MAX que je n'arrive pas à changer pour
trouver
non pas la + petite ou la + grande valeur mais la DERNIERE valeur.
Et
éventuellement le tout dans la même formule.

Si vous pouviez m'aider, je vous en remercie d'avance.





















Jacky
Le #4320431
Re...
Rajoute quand même un :
On Error Resume Next
après Next
au cas ou les cellules sont effacées jusqu'a la colonne B
--
Salutations
JJ


"Tatane"
Merci beaucoup Jacky,

Ta solution est parfaite pour résoudre mon problème.

J'étais en train de chercher aussi via le VBA mais comme je suis novice,
j'étais très loin de la (ta) solution.

Bon WE à tous.


Bonsoir,

En Vba peut-être:
Ton tableau modifié
http://cjoint.com/?dysA6MKQ5V
'-----------
Private Sub Worksheet_Change(ByVal Target As Range)
If Not Intersect([plage], Target) Is Nothing Then
Range("R" & Target.Row) = ""
For i = 2 To 17 Step 2
If Cells(Target.Row, i) = "" Then Exit For
Next
If Cells(Target.Row, i - 2) >= 33 Then Range("R" & Target.Row) = "R2"
If Cells(Target.Row, i - 2) <= 32 Then Range("R" & Target.Row) = "R1"
End If
End Sub
'-----------

--
Salutations
JJ


"Tatane" news:

Bonjour,

Non c'est presque ça, ce n'est en fonction de la date mais simplement
la
dernière valeur entrée manuellement le plus à droite (en noir gras)(les
valeurs en rouge ou bleu ne sont pas concernées) :

Si la dernière valeur (entrée manuellement) est SUP ou = à 33 cela met
R2
dans la colonne R et INF ou = à 32 c'est R1 qui s'affiche dans la
colonne
S.
Ou le tout dans une même cellule par ligne (cela serait pas mal !).



bonjour,

je ne suis pas sur d'avoir compris malgré l'exemple.

tu veux rechercher la valeur la plus récente en fonction de la date
dans
l'entête de colonne et utiliser cette valeur pour remplacer le 33 et
32
dans
ta formule en colonnes R et S ?

Est-ce cela ?

--

h2so4
play triogical at http://www.triogical.com
"Tatane" news:
Bonjour Daniel,

Plutôt qu'un long discours.... bla bla...
Voici mon fichier http://cjoint.com/?dyqrzCTX04

En fait, je souhaite trouver, dans ma formule au dernier chiffre de
la
sélection multiple (dans le fichier valeurs en gras noir) par
exemple
pour
la
1ère ligne la valeur cherchée doit être 63, mais si j'ajoute une
valeur
en
N2
c'est cette dernière qui sera valeur de référence pour mon ">3" et
"<2"
et ainsi de suite ...



Bonjour.
Peux-tu donner un exemple ? Qu'appelles-tu "dernière valeur" ?
Cordialement.
Daniel
"Tatane" de
news:

Bonjour à tous,

Je cherche à déterminer la dernière valeur dans une
multisélection:
J'ai fai ceci:
dans une cellule:
=SI(MIN(B4;D4;F4;H4;J4;L4;N4;P4)>3;"R2";"")
et dans une autre: =SI(MIN(B4;D4;F4;H4;J4;L4;N4;P4)<2;"R1";"")

mais le souci vient de MIN et MAX que je n'arrive pas à changer
pour
trouver
non pas la + petite ou la + grande valeur mais la DERNIERE
valeur.
Et
éventuellement le tout dans la même formule.

Si vous pouviez m'aider, je vous en remercie d'avance.























Tatane
Le #4320381
Merci pour la précision.


Re...
Rajoute quand même un :
On Error Resume Next
après Next
au cas ou les cellules sont effacées jusqu'a la colonne B
--
Salutations
JJ


"Tatane"
Merci beaucoup Jacky,

Ta solution est parfaite pour résoudre mon problème.

J'étais en train de chercher aussi via le VBA mais comme je suis novice,
j'étais très loin de la (ta) solution.

Bon WE à tous.


Bonsoir,

En Vba peut-être:
Ton tableau modifié
http://cjoint.com/?dysA6MKQ5V
'-----------
Private Sub Worksheet_Change(ByVal Target As Range)
If Not Intersect([plage], Target) Is Nothing Then
Range("R" & Target.Row) = ""
For i = 2 To 17 Step 2
If Cells(Target.Row, i) = "" Then Exit For
Next
If Cells(Target.Row, i - 2) >= 33 Then Range("R" & Target.Row) = "R2"
If Cells(Target.Row, i - 2) <= 32 Then Range("R" & Target.Row) = "R1"
End If
End Sub
'-----------

--
Salutations
JJ


"Tatane" news:

Bonjour,

Non c'est presque ça, ce n'est en fonction de la date mais simplement
la
dernière valeur entrée manuellement le plus à droite (en noir gras)(les
valeurs en rouge ou bleu ne sont pas concernées) :

Si la dernière valeur (entrée manuellement) est SUP ou = à 33 cela met
R2
dans la colonne R et INF ou = à 32 c'est R1 qui s'affiche dans la
colonne
S.
Ou le tout dans une même cellule par ligne (cela serait pas mal !).



bonjour,

je ne suis pas sur d'avoir compris malgré l'exemple.

tu veux rechercher la valeur la plus récente en fonction de la date
dans
l'entête de colonne et utiliser cette valeur pour remplacer le 33 et
32
dans
ta formule en colonnes R et S ?

Est-ce cela ?

--

h2so4
play triogical at http://www.triogical.com
"Tatane" news:
Bonjour Daniel,

Plutôt qu'un long discours.... bla bla...
Voici mon fichier http://cjoint.com/?dyqrzCTX04

En fait, je souhaite trouver, dans ma formule au dernier chiffre de
la
sélection multiple (dans le fichier valeurs en gras noir) par
exemple
pour
la
1ère ligne la valeur cherchée doit être 63, mais si j'ajoute une
valeur
en
N2
c'est cette dernière qui sera valeur de référence pour mon ">3" et
"<2"
et ainsi de suite ...



Bonjour.
Peux-tu donner un exemple ? Qu'appelles-tu "dernière valeur" ?
Cordialement.
Daniel
"Tatane" de
news:

Bonjour à tous,

Je cherche à déterminer la dernière valeur dans une
multisélection:
J'ai fai ceci:
dans une cellule:
=SI(MIN(B4;D4;F4;H4;J4;L4;N4;P4)>3;"R2";"")
et dans une autre: =SI(MIN(B4;D4;F4;H4;J4;L4;N4;P4)<2;"R1";"")

mais le souci vient de MIN et MAX que je n'arrive pas à changer
pour
trouver
non pas la + petite ou la + grande valeur mais la DERNIERE
valeur.
Et
éventuellement le tout dans la même formule.

Si vous pouviez m'aider, je vous en remercie d'avance.




























Clochard
Le #4320341
Bonjour,

N'y a-t-il pas une formule qui n'est pas en VBA avec laquelle on peut
obtenir le même résultat

--
Clochard
Aimerais bien savoir....
Merci!



Merci beaucoup Jacky,

Ta solution est parfaite pour résoudre mon problème.

J'étais en train de chercher aussi via le VBA mais comme je suis novice,
j'étais très loin de la (ta) solution.

Bon WE à tous.


Bonsoir,

En Vba peut-être:
Ton tableau modifié
http://cjoint.com/?dysA6MKQ5V
'-----------
Private Sub Worksheet_Change(ByVal Target As Range)
If Not Intersect([plage], Target) Is Nothing Then
Range("R" & Target.Row) = ""
For i = 2 To 17 Step 2
If Cells(Target.Row, i) = "" Then Exit For
Next
If Cells(Target.Row, i - 2) >= 33 Then Range("R" & Target.Row) = "R2"
If Cells(Target.Row, i - 2) <= 32 Then Range("R" & Target.Row) = "R1"
End If
End Sub
'-----------

--
Salutations
JJ


"Tatane"
Bonjour,

Non c'est presque ça, ce n'est en fonction de la date mais simplement la
dernière valeur entrée manuellement le plus à droite (en noir gras)(les
valeurs en rouge ou bleu ne sont pas concernées) :

Si la dernière valeur (entrée manuellement) est SUP ou = à 33 cela met R2
dans la colonne R et INF ou = à 32 c'est R1 qui s'affiche dans la colonne
S.
Ou le tout dans une même cellule par ligne (cela serait pas mal !).



bonjour,

je ne suis pas sur d'avoir compris malgré l'exemple.

tu veux rechercher la valeur la plus récente en fonction de la date dans
l'entête de colonne et utiliser cette valeur pour remplacer le 33 et 32
dans
ta formule en colonnes R et S ?

Est-ce cela ?

--

h2so4
play triogical at http://www.triogical.com
"Tatane" news:
Bonjour Daniel,

Plutôt qu'un long discours.... bla bla...
Voici mon fichier http://cjoint.com/?dyqrzCTX04

En fait, je souhaite trouver, dans ma formule au dernier chiffre de la
sélection multiple (dans le fichier valeurs en gras noir) par exemple
pour
la
1ère ligne la valeur cherchée doit être 63, mais si j'ajoute une valeur
en
N2
c'est cette dernière qui sera valeur de référence pour mon ">3" et
"<2"
et ainsi de suite ...



Bonjour.
Peux-tu donner un exemple ? Qu'appelles-tu "dernière valeur" ?
Cordialement.
Daniel
"Tatane" news:

Bonjour à tous,

Je cherche à déterminer la dernière valeur dans une multisélection:
J'ai fai ceci:
dans une cellule: =SI(MIN(B4;D4;F4;H4;J4;L4;N4;P4)>3;"R2";"")
et dans une autre: =SI(MIN(B4;D4;F4;H4;J4;L4;N4;P4)<2;"R1";"")

mais le souci vient de MIN et MAX que je n'arrive pas à changer pour
trouver
non pas la + petite ou la + grande valeur mais la DERNIERE valeur.
Et
éventuellement le tout dans la même formule.

Si vous pouviez m'aider, je vous en remercie d'avance.























AV
Le #4320191
Si la dernière valeur (entrée manuellement) est SUP ou = à 33 cela met R2
dans la colonne R et INF ou = à 32 c'est R1 qui s'affiche dans la colonne S.
Ou le tout dans une même cellule par ligne (cela serait pas mal !).


L'exemple que tu as fourni ( http://cjoint.com/?dyqrzCTX04 ) ne correspond pas à
ces résultats attendus....
Pour obtenir, par formule, "R1" si la dernière valeur entrée est >= à 33 et "R2"
dans le cas contraire
En cellule R2 et recopie >> R7 :
Formule matricielle à valider par ctrl+maj+Entrée

=SI(INDEX(B2:Q2;MAX(SI((MOD(COLONNE(B2:Q2);2)=0)*(B2:Q2<>"");COLONNE(B2:Q2)-1;"")))>3;"R2";"R1")

AV

Publicité
Poster une réponse
Anonyme