recherche vertical sur un classeur.

Le
marc
Bonjour,
je cherche une formule qui dirais : recherche la valeur XXXX dans colonne A
de toutes les feuilles du fichier "boubou" et rapporter la sommes des valeurs
de la colonne D,

merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
dre
Le #4509021
Bonjour,

Au choix :
=SOMME.SI(boubou!A:A;"XXXX";boubou!D:D)
=SOMMEPROD((boubou!A:A="XXXX")*boubou!D:D)

dré



Bonjour,
je cherche une formule qui dirais : recherche la valeur XXXX dans colonne A
de toutes les feuilles du fichier "boubou" et rapporter la sommes des valeurs
de la colonne D,

merci


dre
Le #4508991
Re,

J'avais mal lu la question : "de toutes les feuilles du fichier boubou".
Les formules proposées ne font la somme que de la feuille boubou.

Je ne connais pas de formule qui puisse le faire, sans connaître le nom de
la première et de la dernière feuille du fichier.

dré






Bonjour,

Au choix :
=SOMME.SI(boubou!A:A;"XXXX";boubou!D:D)
=SOMMEPROD((boubou!A:A="XXXX")*boubou!D:D)

dré



Bonjour,
je cherche une formule qui dirais : recherche la valeur XXXX dans colonne A
de toutes les feuilles du fichier "boubou" et rapporter la sommes des valeurs
de la colonne D,

merci




Boisgontier
Le #4508971
Bonjour,

En D1: le critère xxx
En G2:G6 les noms des onglets:

=SOMMEPROD(SOMME.SI(INDIRECT(G2:G6&"!A1:A12");$D$1;INDIRECT(G2:G6&"!D1:D12")))

http://boisgontierjacques.free.fr/fichiers/Matriciel/Somme3DConditionnel5.xls

JB

"marc"
Bonjour,
je cherche une formule qui dirais : recherche la valeur XXXX dans colonne
A
de toutes les feuilles du fichier "boubou" et rapporter la sommes des
valeurs
de la colonne D,

merci


marc
Le #4508851
merci, c'est pas mal, mais cela implique de rajoutter les onglets a chaque
nouvelle creation?



Bonjour,

En D1: le critère xxx
En G2:G6 les noms des onglets:

=SOMMEPROD(SOMME.SI(INDIRECT(G2:G6&"!A1:A12");$D$1;INDIRECT(G2:G6&"!D1:D12")))

http://boisgontierjacques.free.fr/fichiers/Matriciel/Somme3DConditionnel5.xls

JB

"marc"
Bonjour,
je cherche une formule qui dirais : recherche la valeur XXXX dans colonne
A
de toutes les feuilles du fichier "boubou" et rapporter la sommes des
valeurs
de la colonne D,

merci







Boisgontier
Le #4508801
Si les onglets ont un nom générique feuil1,feuil2,...

=SOMMEPROD(SOMME.SI(INDIRECT("feuil"&LIGNE(INDIRECT("1:5"))&"!A1:A12");$D$1;INDIRECT("feuil"&LIGNE(INDIRECT("1:5"))&"!B1:B12")))

JB
"marc"
merci, c'est pas mal, mais cela implique de rajoutter les onglets a chaque
nouvelle creation?



Bonjour,

En D1: le critère xxx
En G2:G6 les noms des onglets:

=SOMMEPROD(SOMME.SI(INDIRECT(G2:G6&"!A1:A12");$D$1;INDIRECT(G2:G6&"!D1:D12")))

http://boisgontierjacques.free.fr/fichiers/Matriciel/Somme3DConditionnel5.xls

JB

"marc"
Bonjour,
je cherche une formule qui dirais : recherche la valeur XXXX dans
colonne
A
de toutes les feuilles du fichier "boubou" et rapporter la sommes des
valeurs
de la colonne D,

merci









marc
Le #4508761
merci,
non les nom ne sont pas generiques, pas grave je rajouterais le nom des
nouvelles feuilles a chaque fois et modifierais la formule (plus genant) pour
elargir la zone avec les noms des feuilles.
encore merci



Si les onglets ont un nom générique feuil1,feuil2,...

=SOMMEPROD(SOMME.SI(INDIRECT("feuil"&LIGNE(INDIRECT("1:5"))&"!A1:A12");$D$1;INDIRECT("feuil"&LIGNE(INDIRECT("1:5"))&"!B1:B12")))

JB
"marc"
merci, c'est pas mal, mais cela implique de rajoutter les onglets a chaque
nouvelle creation?



Bonjour,

En D1: le critère xxx
En G2:G6 les noms des onglets:

=SOMMEPROD(SOMME.SI(INDIRECT(G2:G6&"!A1:A12");$D$1;INDIRECT(G2:G6&"!D1:D12")))

http://boisgontierjacques.free.fr/fichiers/Matriciel/Somme3DConditionnel5.xls

JB

"marc"
Bonjour,
je cherche une formule qui dirais : recherche la valeur XXXX dans
colonne
A
de toutes les feuilles du fichier "boubou" et rapporter la sommes des
valeurs
de la colonne D,

merci














Boisgontier
Le #4508701
Voir solution:

http://boisgontierjacques.free.fr/fichiers/Matriciel/Somme3DConditionnel5B.xls

JB


"marc"
merci,
non les nom ne sont pas generiques, pas grave je rajouterais le nom des
nouvelles feuilles a chaque fois et modifierais la formule (plus genant)
pour
elargir la zone avec les noms des feuilles.
encore merci



Si les onglets ont un nom générique feuil1,feuil2,...

=SOMMEPROD(SOMME.SI(INDIRECT("feuil"&LIGNE(INDIRECT("1:5"))&"!A1:A12");$D$1;INDIRECT("feuil"&LIGNE(INDIRECT("1:5"))&"!B1:B12")))

JB
"marc"
merci, c'est pas mal, mais cela implique de rajoutter les onglets a
chaque
nouvelle creation?



Bonjour,

En D1: le critère xxx
En G2:G6 les noms des onglets:

=SOMMEPROD(SOMME.SI(INDIRECT(G2:G6&"!A1:A12");$D$1;INDIRECT(G2:G6&"!D1:D12")))

http://boisgontierjacques.free.fr/fichiers/Matriciel/Somme3DConditionnel5.xls

JB

"marc" news:

Bonjour,
je cherche une formule qui dirais : recherche la valeur XXXX dans
colonne
A
de toutes les feuilles du fichier "boubou" et rapporter la sommes
des
valeurs
de la colonne D,

merci
















marc
Le #4508561
Bonsoir,
MErci pour ce lien, mais j'ai un pb en corrigeant les noms des feuilles par
la formule donnee il me demande de choisir le classeur et la feuille au quel
ca s'applique?.
je m'y remet demain, si vous avez des infos n'hesitez pas.
sinceres salutations
MArk


Voir solution:

http://boisgontierjacques.free.fr/fichiers/Matriciel/Somme3DConditionnel5B.xls

JB


"marc"
merci,
non les nom ne sont pas generiques, pas grave je rajouterais le nom des
nouvelles feuilles a chaque fois et modifierais la formule (plus genant)
pour
elargir la zone avec les noms des feuilles.
encore merci



Si les onglets ont un nom générique feuil1,feuil2,...

=SOMMEPROD(SOMME.SI(INDIRECT("feuil"&LIGNE(INDIRECT("1:5"))&"!A1:A12");$D$1;INDIRECT("feuil"&LIGNE(INDIRECT("1:5"))&"!B1:B12")))

JB
"marc"
merci, c'est pas mal, mais cela implique de rajoutter les onglets a
chaque
nouvelle creation?



Bonjour,

En D1: le critère xxx
En G2:G6 les noms des onglets:

=SOMMEPROD(SOMME.SI(INDIRECT(G2:G6&"!A1:A12");$D$1;INDIRECT(G2:G6&"!D1:D12")))

http://boisgontierjacques.free.fr/fichiers/Matriciel/Somme3DConditionnel5.xls

JB

"marc" news:

Bonjour,
je cherche une formule qui dirais : recherche la valeur XXXX dans
colonne
A
de toutes les feuilles du fichier "boubou" et rapporter la sommes
des
valeurs
de la colonne D,

merci





















Publicité
Poster une réponse
Anonyme