rechercher remplacer

Le
Misange
Hello,

Avant que je ne me lance dans un machin en VBA, est ce que vous
connaissez une méthode pour rechercher truc?bidule dans une formule de
la feuille pour le remplacer par machin?bidule en conservant la valeur de ?

Le problème : j'ai besoin de modifier des formules qui ont un élément
commun à modifier mais un élément variable (une référence semi relative)
à conserver
je dois remplacer =Si(S$1*1<Útemodif.
par
=Si(mois(S$1*1)<mois(datemodif).

sachant que donc dans la colonne R ca sera si(R$1

merci de vos idées :-)
--
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #5332931
Bonjour.
Passe en référence L1C1.
Tu dois alors remplacer :
=SI(L1C*1<Útemodif)
par :
=SI(MOIS(L1C*1)<MOIS(datemodif)
quelle que soit la cellule.
Cordialement.
Daniel
"Misange"
Hello,

Avant que je ne me lance dans un machin en VBA, est ce que vous connaissez
une méthode pour rechercher truc?bidule dans une formule de la feuille
pour le remplacer par machin?bidule en conservant la valeur de ?

Le problème : j'ai besoin de modifier des formules qui ont un élément
commun à modifier mais un élément variable (une référence semi relative) à
conserver
je dois remplacer =Si(S$1*1<Útemodif....
par
=Si(mois(S$1*1)<mois(datemodif)....

sachant que donc dans la colonne R ca sera si(R$1...

merci de vos idées :-)
--
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net


Misange
Le #5332901
super astucieux ! j'ai bien fait de poser la question. Je n'utilise
absolument jamais les références L1C1 et je n'ai donc jamais le réflexe
d'y penser. Mille mercis Daniel, tu m'évites de me prendre la tête.

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Bonjour.
Passe en référence L1C1.
Tu dois alors remplacer :
=SI(L1C*1<Útemodif)
par :
=SI(MOIS(L1C*1)<MOIS(datemodif)
quelle que soit la cellule.
Cordialement.
Daniel
"Misange"
Hello,

Avant que je ne me lance dans un machin en VBA, est ce que vous connaissez
une méthode pour rechercher truc?bidule dans une formule de la feuille
pour le remplacer par machin?bidule en conservant la valeur de ?

Le problème : j'ai besoin de modifier des formules qui ont un élément
commun à modifier mais un élément variable (une référence semi relative) à
conserver
je dois remplacer =Si(S$1*1<Útemodif....
par
=Si(mois(S$1*1)<mois(datemodif)....

sachant que donc dans la colonne R ca sera si(R$1...

merci de vos idées :-)
--
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net






Publicité
Poster une réponse
Anonyme