RECHERCHEV

Le
thomas
Bonjour,

La fonction RECHERCHEV() permet de récupérer une valeur dans une colonne
d'un tableau en fonction de la valeur de la 1ère colonne

Existe-t-il une fonction qui fasse la même chose avec plusieurs critères
(par exemple valeur de la 1ère et de la 2ème colonne)

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Papyjac
Le #6749071
Bonjour Thomas,

Soit tu optes pour les matricielles, en commençant par des cas simples,
Soit tu concaténes les 2 premières colonnes par une formule, puis effectues
la recherche avec RECHERCHEV (si cette colonne calculée est en tête) ou avec
EQUIV (si la colonne calculée se situe après)


--
P a p y j a c


"thomas" <nomail> a écrit dans le message de
news:
Bonjour,

La fonction RECHERCHEV() permet de récupérer une valeur dans une colonne
d'un tableau en fonction de la valeur de la 1ère colonne

Existe-t-il une fonction qui fasse la même chose avec plusieurs critères
(par exemple valeur de la 1ère et de la 2ème colonne)

Merci




Tatanka
Le #6749451
Salut Thomas,

Peut-être quelque chose du genre :

En supposant que ton tableau est situé en A1:C5 et que tu veuilles
récupérer sur une colonne les valeurs de la colonne 3 correspondantes
aux valeurs 1, 3 et 5 de la colonne 1 :

1) Sélectionne trois cellules adjacentes dans une même colonne,
2) Entre cette formule dans la cellule active :
=RECHERCHEV({1;3;5};A1:C5;3;0)
et valide par Ctrl+Maj+Entrée.


Serge




"thomas" <nomail> a écrit dans le message de news:

Bonjour,

La fonction RECHERCHEV() permet de récupérer une valeur dans une colonne
d'un tableau en fonction de la valeur de la 1ère colonne

Existe-t-il une fonction qui fasse la même chose avec plusieurs critères
(par exemple valeur de la 1ère et de la 2ème colonne)

Merci



JB
Le #6749441
Bonjour,


Equiv 2 conditions:
=INDEX(C2:C100;EQUIV(1;(A2:A100â)*(B2:B100ò);0))
Valider avec Maj+Ctrl+Entrée

http://boisgontierjacques.free.fr/fichiers/Matriciel/Equiv2conditions.xls

JB


On 1 juin, 03:22, "thomas" <nomail> wrote:
Bonjour,

La fonction RECHERCHEV() permet de récupérer une valeur dans une colon ne
d'un tableau en fonction de la valeur de la 1ère colonne

Existe-t-il une fonction qui fasse la même chose avec plusieurs critèr es
(par exemple valeur de la 1ère et de la 2ème colonne)

Merci


Laurent
Le #6751851
Salut,

dans ce cas, tu peux utiliser les fonctions bases de données bdlire,
bdsomme, etc...

bdlire ne retourne une valeur que si une seule valeur correspond à tes
critères de recherche.

Pour reproduire le comportement de RECHERCHEV, tu peux imbriques plusieurs
fonctions de la façon suivante:
1. Supposons que tu aies la matrice suivante en A1:C5, et que tu recherche
la valeur dans la 3ème colonne, pour laquelle, laquelle la valeur dans les
colonnes 1 et 2 est "ok":

ok incorrect pas pertinent
cd incorrect pas pertinent
ok ok resultat
cd incorrect pas pertinent
ok ok resultat 2

2. Tu peux utiliser la fonction matricielle suivante:
{=INDEX(A1:C5;EQUIV(VRAI;SI((A1:A5="ok")*(B1:B5="ok")=1;VRAI);0);3)}

Il s'agit ici d'une fonction matricielle/ fonction tableau. Pour qu'elle
fonctionne, il te faut valider son entrée avec la combinaison ctrl+shift+
entrée. Si tu ne fais pas cela, la formule retourne "#na".

Evidemment, si applique cette méthode sur un grand nombre de colonnes, avec
un grand nombre de lignes, le temps de calcul commence à être perceptible.

"thomas" wrote:

Bonjour,

La fonction RECHERCHEV() permet de récupérer une valeur dans une colonne
d'un tableau en fonction de la valeur de la 1ère colonne

Existe-t-il une fonction qui fasse la même chose avec plusieurs critères
(par exemple valeur de la 1ère et de la 2ème colonne)

Merci




Tatanka
Le #6754201
Ridicule ma proposition !
Ça m'apprendra à suivre des cours de lecture rapide
avec un p'tit verre dans l'nez.

Serge



"Tatanka" QHr0k.99892$
Salut Thomas,

Peut-être quelque chose du genre :

En supposant que ton tableau est situé en A1:C5 et que tu veuilles
récupérer sur une colonne les valeurs de la colonne 3 correspondantes
aux valeurs 1, 3 et 5 de la colonne 1 :

1) Sélectionne trois cellules adjacentes dans une même colonne,
2) Entre cette formule dans la cellule active :
=RECHERCHEV({1;3;5};A1:C5;3;0)
et valide par Ctrl+Maj+Entrée.


Serge




"thomas" <nomail> a écrit dans le message de news:

Bonjour,

La fonction RECHERCHEV() permet de récupérer une valeur dans une colonne
d'un tableau en fonction de la valeur de la 1ère colonne

Existe-t-il une fonction qui fasse la même chose avec plusieurs critères
(par exemple valeur de la 1ère et de la 2ème colonne)

Merci







Publicité
Poster une réponse
Anonyme