RECHERCHEV

Le
pascallerudulier
Bonjour tout le monde,

J'utilise "recherchev(..)" et obtiens ce que je veux a l'exception
du contenu de cellules qui ne sont pas exactement celles contenues
dans la plage testees.
Ex:
=recherche('cellule';'plage';numero colonne; vrai ou faux)
si le contenu de la 'cellule' correspond, exactement, a une des
cellules de la 'plage' testee alors on obtient le contenu de la
cellule de la 'colonne' voulue.

Maintenant, et c'est la mon probleme, comment s'y prendre si la
cellule de plage testee contient plus que la cellule recherchee?
Ex:
cellule = XXXXX plage avec la cellule en question =
xxxxxxXXXXXxxxxxx (XXXX et xxxxXXXXXxxxxx etant des chaines de
caracteres).

Est-ce qu'il faut s'y prendre avec la fonction ou doit-on se coller de
la macro?
C'est un probleme classique je pense, si quelqu'un la deja resolu
soyez gentil d'indiquer ici comment.

Merci d'avance et bon weekend a tous,

Pascal
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
LSteph
Le #19398721
Bonjour,

supposons que tu cherches un "clou" dans une "boite à clous"

=RECHERCHEV("*clou*";$a$3:$b$5;2;0)


ce qui donnerait avec une formule préférable (dans ce cas) à recherchev

=INDEX($B$3:$B$5;EQUIV("*clou*";$A$3:$A$5;0))


si clou est dans une cellule F1 servant de base à la recherche

=INDEX($B$3:$B$5;EQUIV("*"&F1&"*";$A$3:$A$5;0))

ou encore


=RECHERCHEV("*"&F1&"*";$a$3:$b$5;2;0)


--
lSteph

a écrit :
Bonjour tout le monde,

J'utilise "recherchev(..)" et obtiens ce que je veux a l'exception
du contenu de cellules qui ne sont pas exactement celles contenues
dans la plage testees.
Ex:
=recherche('cellule';'plage';numero colonne; vrai ou faux)
si le contenu de la 'cellule' correspond, exactement, a une des
cellules de la 'plage' testee alors on obtient le contenu de la
cellule de la 'colonne' voulue.

Maintenant, et c'est la mon probleme, comment s'y prendre si la
cellule de plage testee contient plus que la cellule recherchee?
Ex:
cellule = XXXXX plage avec la cellule en question > xxxxxxXXXXXxxxxxx (XXXX et xxxxXXXXXxxxxx etant des chaines de
caracteres).

Est-ce qu'il faut s'y prendre avec la fonction ou doit-on se coller de
la macro?
C'est un probleme classique je pense, si quelqu'un la deja resolu
soyez gentil d'indiquer ici comment.

Merci d'avance et bon weekend a tous,

Pascal





lapin
Le #19401921
Merci LSteph pour la reponse, c'est tres exactement ce que je voulais.

Bonne soiree,

Pascal

On 24 mai, 11:54, LSteph
Bonjour,

supposons que tu cherches un "clou" dans une "boite à clous"

=RECHERCHEV("*clou*";$a$3:$b$5;2;0)

ce qui donnerait avec une formule préférable (dans ce cas) à recher chev

=INDEX($B$3:$B$5;EQUIV("*clou*";$A$3:$A$5;0))

si clou est dans une cellule F1 servant de base à la recherche

=INDEX($B$3:$B$5;EQUIV("*"&F1&"*";$A$3:$A$5;0))

ou encore

=RECHERCHEV("*"&F1&"*";$a$3:$b$5;2;0)

--
lSteph

a écrit :

> Bonjour tout le monde,

>     J'utilise "recherchev(..)" et obtiens ce que je veux a l'except ion
> du contenu de cellules qui ne sont pas exactement celles contenues
> dans la plage testees.
> Ex:
> =recherche('cellule';'plage';numero colonne; vrai ou faux)
> si le contenu de la 'cellule' correspond, exactement, a une des
> cellules de la 'plage' testee alors on obtient le contenu de la
> cellule de la 'colonne' voulue.

> Maintenant, et c'est la mon probleme, comment s'y prendre si la
> cellule de plage testee contient plus que la cellule recherchee?
> Ex:
> cellule = XXXXX    plage avec la cellule en question =
> xxxxxxXXXXXxxxxxx   (XXXX et xxxxXXXXXxxxxx etant des chaines de
> caracteres).

> Est-ce qu'il faut s'y prendre avec la fonction ou doit-on se coller de
> la macro?
> C'est un probleme classique je pense, si quelqu'un la deja resolu
> soyez gentil d'indiquer ici comment.

> Merci d'avance et bon weekend a tous,

> Pascal


Publicité
Poster une réponse
Anonyme