RECHERCHEV et #N/A

Le
J
Bonjour à tous
J'ai la formule suivante qui me cherche la valeur de AD2 dans P12:P57,
resultat=RECHERCHEV(AD2;P12:P57;1;FAUX)
ce qui m'apparaît bien fonctionner.

Mai pour éviter les #N/A que j'ai de temps en temps, j'ai tenté en vain:
Si(resultat=#N/A;"n'y a pas";resultat)

Evidemment cela ne va pas.
Comment dois-je faire, siouplait?

Merci d'avance
cordialement
J@@
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #19742871
Bon{j,s}o{u,i}r J@@,
=si(estna(RECHERCHEV(AD2;P12:P57;1;FAUX));"n'y a
pas";RECHERCHEV(AD2;P12:P57;1;FAUX))
devrait pouvoir convenir
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"J@@" news:
Bonjour à tous
J'ai la formule suivante qui me cherche la valeur de AD2 dans P12:P57,
resultat=RECHERCHEV(AD2;P12:P57;1;FAUX)
ce qui m'apparaît bien fonctionner.

Mai pour éviter les #N/A que j'ai de temps en temps, j'ai tenté en vain:
Si(resultat=#N/A;"n'y a pas";resultat)

Evidemment cela ne va pas.
Comment dois-je faire, siouplait?

Merci d'avance
cordialement
J@@


J
Le #19742861
Re bonjour, re à tous.

En cherchant dans le fond du jardin, j'ai trouvé une fonction perso made
by LL (citée par Pierre Fauconnier).
Bon pour une seule occurrence, c'est un peu lourd, mais cela fonctionne,
encore que le GETV() ne m'a pas donné le résultat souhaité. Voici ce qui
roule:
=SI(ESTNA(SETV(RECHERCHEV(maValeur;maTable;maCol;FAUX)));"texte de
remplacement N#A";RECHERCHEV(maValeur;maTable;maCol;FAUX))

Si quelqu'un a une autre réflexion ?
Encore merci.

'-------------------------
Dim V
'fonction de LL
Function SETV(param)
V = param
SETV = param
End Function

Function GETV()
GETV = V
End Function
'--------------------------

dans cellules :
=SI(ESTNA(SETV(RECHERCHEV(maValeur;maTable;maCol;FAUX)));"texte de
remplacement N#A";GETV())

--------------------------

J@@ a écrit :
Bonjour à tous
J'ai la formule suivante qui me cherche la valeur de AD2 dans P12:P57,
resultat=RECHERCHEV(AD2;P12:P57;1;FAUX)
ce qui m'apparaît bien fonctionner.

Mai pour éviter les #N/A que j'ai de temps en temps, j'ai tenté en vain:
Si(resultat=#N/A;"n'y a pas";resultat)

Evidemment cela ne va pas.
Comment dois-je faire, siouplait?

Merci d'avance
cordialement
J@@


J
Le #19743041
Bonjour (nuit ici) Pierre
et merci
cela fonctionne très bien
:-)
amicalement
@+
J@@


Philippe.R a écrit :
Bon{j,s}o{u,i}r J@@,
=si(estna(RECHERCHEV(AD2;P12:P57;1;FAUX));"n'y a
pas";RECHERCHEV(AD2;P12:P57;1;FAUX))
devrait pouvoir convenir


Publicité
Poster une réponse
Anonyme